Subject: Re: [Linux] Re: request of touch screen driver on Assabet SA1110 dev bd

From: [email-masked]
Date: Fri, 1 Sep 2000 13:14:13 +0800

Dear Greg, Nicolas,

Thank for your prompt response.

Nicola, I only find the patch (2.4.0-test6-rmk2-np1) from netwinder.org instead
of (2.4.0-test6-rmk5-np2) as you said.
Can I use this patch as I want to use touchscreen (UCB1200 in StrongARM) in
Assabet board. If not, how/where can I get the latest patch?

Luckily, I also find the touchscreen driver in drivers/char/ucb1200_ts.c.
Therefore, I try to make device node by the following command:

mount -o loop -t ext2 ramdisk /mnt
mknod /mnt/ts c 11 0
umount /mnt
cat ramdisk | gzip -v9 >ramdisk.gz

and then download the zImage and ramdisk.gz by using angelboot utility.

However, I got the similar error as before (with different error number, error 2
in previous test).

Error 19 opening touch panel
Cannot initialize mouse

>From the information in ftp://microwindows/pub/ads/readme.txt, I try 190,34 as
major, minor number for the ts device.
The test show the same result as before.

Please advise what I am doing wrong.

-------------------------------------------------------------------------------------------------------------------------------------------
On the same time, I am going to port FLTK on top of Microwindowst in Assabet
board.
I find the following error when making the fltk:
(I'd change the corresponding  MICROWINFOLDER in makeinclude.in for my working
environment.)

fl_scroll_area.cxx: In function `void fl_scroll(int, int, int, int, int, int,
void (*)(void *, int, int, int, int), void *)':
fl_scroll_area.cxx:89: implicit declaration of function `int printf(...)'
make[1]: *** [fl_scroll_area.o] Error 1
make[1]: *** No rule to make target `../lib/libfltk.a', needed by `fluid'.
Stop.
make[1]: *** No rule to make target `../lib/libfltk.a', needed by `valuators'.
Stop.
make: *** [all] Error 2

The patch I am using is microwindows-0.88pre10.tar.gz with
fltk-nanox-pre6.tar.gz.
The same result as I am using microwindows-0.88pre9.tar.gz with
fltk-nanox-pre5.tar.gz.

-------------------------------------------------------------------------------------------------------------------------------------------

I download ramdisk from  ftp://microwindows/pub/ads and try if I can use touch
screen by using it (I find /dev/ts).
Unluckily, the OS seem hang up in boot up sequence (maybe just before Linux
login : message display).
I am going to see the files under /bin in ramdisk. I find that they are file for
PDP-11 executable not stripped.
I think they should be StrongARM ELF file. Am I doing wrong this time?
On the other hand, I find the usage of ramdisk approaches to 99%. There are no
extra space for me to copy test program to it.
How can I increase the size for ramdisk?

Thanks,
Bona Fide,
Eric Wong,
VTech Informations Ltd.
[email-masked]

[email-masked] on 08/31/2000 08:02:28

To:   ERIC WONG/PD/HKG_MMC/VTECH

cc:   [email-masked]
      [email-masked]
      [email-masked]
Subject:  [Linux] Re: request of touch screen driver on Assabet SA1110 dev bd

On Wed, 30 Aug 2000 [email-masked] wrote:

> Nano-X and demo programs are successfully built up.
> However, I got the following error when running the demo.sh:
>
> Error 2 opening touch panel
> Cannot initialize mouse
>
>
>
> Then I try to make xconfig again without choosing Mouse drivers in Options and
> run make clean; make.
> I am exciting to see most demos can run, especially I can play mine on
> Microwindows! Great and cool! Don't you agree?
>
>
> Now, I can run the demo, several demo program ,eg. mclock, mdemo can show on
LCD
>  display.
> But I cannot use keyboard, mouse or touch screen to control them.
> Could you give me some advice for this phenomenon.

With my latest patch (2.4.0-test6-rmk5-np2), you'll find the following
touchscreen driver: drivers/char/ucb1200_ts.c.

The comment in the file says:

/*
 * SA11x0 + UCB1x00 Touch Screen Driver Version 0.2
 * Put together by Tak-Shing Chan <[email-masked]>
...
 * INSTRUCTIONS
 * To use this driver, simply ``mknod /dev/h3600_ts c 11 0'' and
 * use it as if it were an iPAQ.  TODO: iPAQ-compatible IOCTL's.
 */

Nicolas

_______________________________________________
Linux mailing list
[email-masked]
http://handhelds.org/mailman/listinfo/linux

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: "Greg Haerr" <[email-masked]>
Date: Fri, 1 Sep 2000 09:18:03 -0600

: On the same time, I am going to port FLTK on top of Microwindowst in Assabet
: board.
: The patch I am using is microwindows-0.88pre10.tar.gz with
: fltk-nanox-pre6.tar.gz.

The most current FLTK sources are now in the ViewML
project CVS.  Tarballs for the recent sources are at
ftp://ftp.viewml.com/pub/viewml/dep

The ViewML Project is currently heavily involved enhancing
FLTK for Microwindows and the browser.

These sources require the latest patch to Microwindows 0.88:
ftp://microwindows.org/pub/microwindows/microwindows-0.88patch1.tar.gz

Regards,

Greg

---

From: "Greg Haerr" <[email-masked]>
Date: Fri, 1 Sep 2000 09:18:03 -0600

Regards,

Greg

---

From: Nicolas Pitre <[email-masked]>
Date: Fri, 1 Sep 2000 16:11:46 -0400 (EDT)

> of (2.4.0-test6-rmk5-np2) as you said.

I just checked and 2.4.0-test6-rmk5-np2 is still there.

Nicolas

---

From: Nicolas Pitre <[email-masked]>
Date: Fri, 1 Sep 2000 16:11:46 -0400 (EDT)

Nicolas