Subject: recompiled loadmap / troubles with boot.map magic /RiscPC / DEBian 2.2r0 Potato

From: "efred" <[email-masked]>
Date: Sat, 2 Sep 2000 23:44:55 +0200

Hi there,
I recently installed the latest debian release on a SA-RiscPC. It works
really fine (nearly everything from kernel recompilation to vnc access
...I've just a paging handler request bugging in xdm & a couple of other
things -mainly mouse & keyboard screwed up). I used the original debian
disks images and it worked nearly the first time without problems.

I re-compiled the loadmap program so that I can boot the RPC directly into
debian (from the ARM Linux original sources distribution, e.g version
1.6.0).
It compiles fine, executes and says it wrote  a 512 bytes bootsector from
boot.conf.

When booting with Russell's bootloader for riscos, it complains about
invalid /boot/boot.map magic.

When turning on debug option ., it says boot.map fits in a 1024 bytes block,
it reads two or more bytes and stops with that error.

I've one IDE disc partionned as follow:

hda1 is ADFS
hda2 is Linux Table
hda3 is swap (64Mb)
hda4 is / (1.3Gb +)
hda5 is /home (3.2Gb +)

Any idea ? The boot loader needs special partionning ? the 2.2r0 debian
install is not compatible with that technique?

Thanks in advance

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: "Lund, Daniel" <[email-masked]>
Date: Sun, 03 Sep 2000 11:53:33 +0100

In article <[email-masked]>,
   efred <[email-masked]> wrote:
>
> ...I've just a paging handler request bugging in xdm
got that here. i think its that the kernel doesnt support frame buffering.
i may be wrong but please let me know if you find out.

> invalid /boot/boot.map magic.
i got that, so i used !Linux with kernel argument specifying root. Then it
worked fine. Although i cant get it to take 2 arguments ie a video
one. In linloader try --root=/dev/hda4. This may get around it.

-- 
Daniel Lund
Physics Dep. IC London SW7 3BZ
[email-masked]

---

From: "Lund, Daniel" <[email-masked]>
Date: Sun, 03 Sep 2000 11:53:33 +0100

---

From: Peter Naulls <[email-masked]>
Date: Sun, 03 Sep 2000 13:07:33 +0100

In message <[email-masked]>

> one. In linloader try --root=/dev/hda4. This may get around it.

Use double quotes, e.g.:

ATAFS::Plop.$.ARMLinux.!Linux -bootkernel ATAFS::Plop.$.ARMLinux.DebianBoot.zImage -args "root=/dev/hdb2 ide0=0"

-- 
------------------------------------------------------------------------
 Peter Naulls - [email-masked]
 Homepage - http://free.prohosting.com/~chocky/
 Java for RISC OS and ARM - http://free.prohosting.com/~chocky/java/
 Debian Linux on RiscPCs - http://www.erble.freeserve.co.uk/
------------------------------------------------------------------------

---

From: Peter Naulls <[email-masked]>
Date: Sun, 03 Sep 2000 13:07:33 +0100

Use double quotes, e.g.:

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Sun, 3 Sep 2000 16:32:22 +0100 (BST)

> one. In linloader try --root=/dev/hda4. This may get around it.

But you missed the one most important step - reporting the problem.
Can all of you who have experienced this problem please give details
as to exactly what your setup is (ie, what /dev/hd* files are what
on your hard disk, what version of RISC OS) and /etc/boot.conf files
please?
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |            http://www.arm.linux.org.uk/            /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Sun, 3 Sep 2000 16:32:22 +0100 (BST)

---

From: "efred" <[email-masked]>
Date: Sun, 3 Sep 2000 19:15:51 +0200

> on your hard disk, what version of RISC OS) and /etc/boot.conf files
of course ! here it comes:

SA-110 (buggy version) RiscPC -32Mb ram -6.4Gb ide -I-cubed Ethernet A
RiscOS 3.7
!linux bootloader 3.36 alpha

ide disc partitionning:

/dev/hda1 filecore, 74 MB
/dev/hda2 linux table
/dev/hda3 linux swap, 65MB
/dev/hda4 linux native, 2169MB, mounted on /
/dev/hda5 linux native, 3842MB, mounted on /home

Misc. details : IscaFS is unable to mount these partitions (don't know
why,maybe because of the swap position), and the filecore can only be read
from linux, writes fail with "permission denied".

/dev/root is a  link to /dev/hda4

Boot.conf:

kernel{
 name = "2.2.16-rmk2";
 path = "/vmlinuz";
 root = "/dev/hda4";
 flags = readonly;
};

riscos {
 name = "Risc OS";
};

I hope this helps...

---

From: "efred" <[email-masked]>
Date: Sun, 3 Sep 2000 19:15:51 +0200

ide disc partitionning:

Boot.conf:

kernel{
 name = "2.2.16-rmk2";
 path = "/vmlinuz";
 root = "/dev/hda4";
 flags = readonly;
};

riscos {
 name = "Risc OS";
};

I hope this helps...

---

From: "efred" <[email-masked]>
Date: Sun, 3 Sep 2000 19:31:52 +0200

complements to the  boot.map bug report , log of !Linux -debug :

reading blocks 0x0 -> 0x1
/boot/boot.map is 1024 bytes (block size 1024) long
Reading blocks 0x1B083 -> 0x1B084
Error: invalid /boot/boot.map magic - aborting

 !Linux crashes with -debug option when passing the kernel by hand.

The loadmap version used is : loadmap version 1.6.0
it has been recompiled.

the system is a debian 2.2r0 arm with a 2.2.16-rmk2 kernel.

I hope this helps too.

---

From: "efred" <[email-masked]>
Date: Sun, 3 Sep 2000 19:31:52 +0200

I hope this helps too.