Subject: Compile arm linux-2.4.0-test4 error

From: "cschiu" <[email-masked]>
Date: Wed, 2 Aug 2000 16:55:52 +0800

Hello all,

I compiled linux kernel target on arm7
The kernel version is linux-2.4.0-test4 with patch-2.4.0-test4-rmk1
The System type I choose is "RiscPC" and "Support ARM710"
The following is compiling error:
Could somebody point out where is the problem ?
How can I fix this problem?

make -C  arch/arm/kernel
make[1]: Entering directory `/home/kevin/linux/arch/arm/kernel'
arm-linux-gcc -D__ASSEMBLY__ -D__KERNEL__ -I/home/kevin/linux/include -Wa,-E
B -m
no-fpu -mapcs-32 -marmv3m  -c -o entry-armv.o entry-armv.S
entry-armv.S: Assembler messages:
entry-armv.S:747: Error: address offset too large
entry-armv.S:749: Error: Invalid constant
entry-common.S:31: Error: address offset too large
entry-common.S:32: Error: address offset too large
entry-common.S:97: Error: address offset too large
entry-armv.S:817: Error: address offset too large
entry-armv.S:818: Error: address offset too large
entry-armv.S:819: Error: address offset too large
make[1]: *** [entry-armv.o] Error 1
make[1]: Leaving directory `/home/kevin/linux/arch/arm/kernel'
make: *** [_dir_arch/arm/kernel] Error 2

Regards,
Kevin

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Xavier DEBREUIL <[email-masked]>
Date: Wed, 02 Aug 2000 11:30:21 +0200

you are using -EB option : it means you are compiling for a big endian target.
the file arch/arm.../lib/extract_.perl does not produce the right addresses in
that mode 
the following changes should help you :
#	return substr($num, 6, 2).substr($num, 4, 2).substr ($num, 2, 2).substr ($num,
0, 2);
	return substr($num, 0, 2).substr($num, 2, 2).substr ($num, 4, 2).substr ($num,
6, 2);

Xavier

---

From: Philip Blundell <[email-masked]>
Date: Wed, 02 Aug 2000 19:42:41 +0100

>arm-linux-gcc -D__ASSEMBLY__ -D__KERNEL__ -I/home/kevin/linux/include -Wa,-E

You have somehow ended up with big-endian compilation.  Do you genuinely have 
a big endian RiscPC?

p.

---

From: Xavier DEBREUIL <[email-masked]>
Date: Thu, 03 Aug 2000 10:08:40 +0200

Xavier