Subject: request of touch screen driver on Assabet SA1110 dev bd

From: [email-masked]
Date: Wed, 30 Aug 2000 12:21:16 +0800

Dear Sirs,

I am conducting eBook project in VTech (Hong Kong) by using SA1110/SA1111 (
Assabet) development board.
I'd like to use embedded Linux to act as our development platform.
I am much fascinating when I see a penguin on LCD display when I successfully
build up the kernel.
I much keen on linux world since then and like to put embedded linux into
practice and let it become product in the near future.

I am using the following toolchains and configuration under SuSE Linux 6.4.

Build utility
=========
binutils-2.10

Compiler & Lib
============
arm-linux-binutils-2.10-1.src.rpm
arm-linux-gcc-2.95.2-1.src.rpm
arm-linux-gcc-preglibc-2.95.2-1.src.rpm
arm-linux-glibc-2.1.3-1.src.rpm

Kernel Sources
=============
arm-linux-kernel-src-2.4.0.test4.np1-1.src.rpm

Host: Linux i586
Target: arm-linux

Last week, I download the Microwindows (microwindows-0.88pre11.tar.gz)
and start to port it to arm-linux by the following command.

make xconfig   (choose Linux (ARM), Options-> Mouse drivers=Touch screen,
Keyboard drivers=TTY)
make clean
make

Nano-X and demo programs are successfully built up.
However, I got the following error when running the demo.sh:

Error 2 opening touch panel
Cannot initialize mouse

Then I try to make xconfig again without choosing Mouse drivers in Options and
run make clean; make.
I am exciting to see most demos can run, especially I can play mine on
Microwindows! Great and cool! Don't you agree?

Now, I can run the demo, several demo program ,eg. mclock, mdemo can show on LCD
 display.
But I cannot use keyboard, mouse or touch screen to control them.
Could you give me some advice for this phenomenon.
Should I require /dev/ts kernel driver (char special 190,34) to use ADS touch
screen?
Please advise how/where or any channel/contact vendor list I can get this device
driver?

--------------------------------------------------------------------------------------------------------------------------------------

By the way, I want to use gdb to remote debug an arm-based system since I am
novice for that.
Could you tell me how to do it or give me some hints to search related
information about using gdb to remote debug an arm-based system?
By the way, when may I find any driver development kit for Linux?

Your prompt advise and help will be greatly appreciated.

Thank in advance.

Eric Wong,
VTech Informations Ltd.
[email-masked]

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Nicolas Pitre <[email-masked]>
Date: Wed, 30 Aug 2000 20:02:28 -0400 (EDT)

> Could you give me some advice for this phenomenon.

With my latest patch (2.4.0-test6-rmk5-np2), you'll find the following
touchscreen driver: drivers/char/ucb1200_ts.c.

The comment in the file says:

/*
 * SA11x0 + UCB1x00 Touch Screen Driver Version 0.2
 * Put together by Tak-Shing Chan <[email-masked]>
...
 * INSTRUCTIONS
 * To use this driver, simply ``mknod /dev/h3600_ts c 11 0'' and
 * use it as if it were an iPAQ.  TODO: iPAQ-compatible IOCTL's.
 */

Nicolas

---

From: Nicolas Pitre <[email-masked]>
Date: Wed, 30 Aug 2000 20:02:28 -0400 (EDT)

/*

Nicolas