Subject: Re: EEPro100 NICs and EBSA285.

From: [email-masked]
Date: Mon, 17 Jul 2000 10:47:12 +0100

What has changed in the 2.4.x kernel to fix the dma cache coherency problems. Do
you know when this will be a stable kernel. We have  ported  the 82559 driver
adding the DMA writebacks and invalidates which generally works but we still see
some infrequent transmit problems.

Gerry

From: Nicolas Pitre@nico on 07/12/2000 08:51 PM

To:   Jacob Strauss@[email-masked]@SMTP@EXCHANGE
cc:   linux-arm@[email-masked]@SMTP@EXCHANGE

Subject:  Re: EEPro100 NICs and EBSA285.

You need to add all the cache coherency handling into the driver for it to
work properly with ARM processors.

If you'd use a 2.4.x kernel, everything is already done for you.

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: David Rusling <[email-masked]>
Date: Mon, 17 Jul 2000 11:52:25 +0100

All,

    I'm trying to get Microwindows running on our prospector platform.
When I  build the keyboard into it, it fails for want of opening /dev/tty.
My reading of the code is that that _should_ work, but it fails 'cos
current has no tty at this point.   How?   init has a tty, the shell inherits
it.  Do I need to have logged in (via tinylogin) - at the moment my
rc script just starts a shell...

Dave

----------------------------------------------------------------------
David A Rusling   Consulting Engineer
    ARM Limited
    Liberty House,
    Moorbridge Road,
    Maidenhead, SL6 8LT

    Tel: UK-(0)1628-427754
    Fax: UK-(0)1628-780551
    e-mail: [email-masked]
----------------------------------------------------------------------

---

From: Matthew Wilcox <[email-masked]>
Date: Mon, 17 Jul 2000 10:22:41 -0400

> What has changed in the 2.4.x kernel to fix the dma cache coherency problems. Do

it's all described in Documentation/DMA-mapping.txt

-- 
Revolutions do not have corporate support.