Subject: Oops on a EP7211

From: "Dinakar Guniguntala" <[email-masked]>
Date: Fri, 21 Jul 2000 21:22:46 IST

Hello,

I am trying to get a 2.2.1 kernel with the latest patch from
Ben Williamson cb26-benw3 (and other requisite patches) to boot
through a serial port (COM1) on an EP7211 board when I get the
following Oops

I can see that we are in the do_rs7211_bh of the serial_7211
driver called from do_bottom_half.  I have already made the changes
to proc-arm6,7.S for TLB flushing of EP7211.  Are there any other
changes that need to be done

Thanks for any inputs

Dino

PS: Sorry for the long post

boot no options
Linux version 2.2.1-rmk2-cb23 (root@orange) (gcc version egcs-2.91.66
19990325/philb (egcs-1.1.2 release)) #13 Fri Jul 21 18:43:57 IST 2000
initrd: start 0xc1713000, size 968537 -> start c0f13000, end 0xc0fff759
NetWinder Floating Point Emulator V0.94.1 (c) 1998 Corel Computer Corp.
c0122f04-c1000000
memzero
alloc_init_page [ mem c0126400, virt 00000000 -> phys c0125400 ]: D
c0034000 := c00fd6c8
alloc_init_page [ mem c0126800, virt 00000000 -> phys c0125400 ]: P
c0126400
setup_pagetables
flush_tlb_all
paging_init
trap_init
init_IRQ
sched_init
time_init (0)
parse_options:
parse_options (0xc014ebf0)
rs_power: state = 1
console_init (67, 0xc014ebf0)
init_modules (68)
prof_shift (69)
cpsr = 0x60000013 (70)
SR1 0x00000904 MR1 0x00001200
SR2 0x00001004 MR2 0x00000000
sti (73, 0xc014ebf0)
kmem_cache_init (0xc014ebf0)
sti
Calibrating delay loop... 68.61 BogoMIPS
calibrate_delay
Memory: 14096k/16M available (768k code, 224k reserved, 344k data, 4k init)
POSIX conformance testing by UNIFIX
&<6>Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Unix domain sockets 1.0 for Linux NET4.0.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
Starting kswapd v 1.5
Power: PCMCIA 3300 mV
²rs_power: state = 1
rs_power: state = 1
alized:  16 RAM disks of 4096K size
RAMDISK: Compressed image found at block 0
EXT2-fs warning: mounting unchecked fs, running e2fsck is recommended
VFS: Mounted root (ext2 filesystem).
Freeing unused kernel memory: 4k init
Enabling Transmits on Line 0
Line 0 opened
Bad mode in prefetch abort handler detected: mode SVC_32
Internal error: Oops: 0
CPU: 0
pc : [<03a24008>]    lr : [<c00c86fc>]
sp : c015fe60  ip : c015fea8  fp : c015febc
r10: c003820c  r9 : c0108b60  r8 : c0108ce0
r7 : c0117a00  r6 : c0117a04  r5 : 00000001  r4 : c01078c8
r3 : 03a24009  r2 : 00000000  r1 : 00000001  r0 : 00000000
Flags: nzCv  IRQs on  FIQs on  Mode SVC_32  Segment kernel
INTSR1 0x00000b04 INTMR1 0x00003200
INTSR2 0x00001004 INTMR2 0x00002000
INTSR3 0x00002000 INTMR3 0x00002000
Control: 017D  Table: C003401D  DAC: 0000001D
Process kflushd (pid: 2, stackpage=c015f000)
Stack:
c015fe80:
c00c86fc 03a24008
c015fea0: 20000013 ffffffff 00000001 c0117a5c  c015fed8 c015fec0 c004e95c 
c00c86d4
c015fec0: 00000000 00000000 0000000c c015ff08  c015fedc c003ac50 c004e8dc 
00000180
c015fee0: c015ff0c 00003007 c015ff54 00000001  c00b8fbc 60000013 ffffffff 
c015ff9c
c015ff00: c015ff0c c003a060 c003ab34 00000000  00000000 00000000 60000013 
00000100
c015ff20: c0f11aa0 00000001 0000002a 00000002  c011cb10 c003820c c015ff9c 
c0111974
c015ff40: c015ff54 00000001 c00b8fbc 60000013  ffffffff deeb7397 c0f11ab8 
c011cba0
c015ff60: 00000004 00000000 00000000 0000001e  00000001 00000001 c015ffd4 
00000000

c015ff80: 00000001 00000400 00000001 00000100  c015ffc4 c015ffa0 c00b9170 
c00b88f4
c015ffa0: c0f11d40 00000f90 00000002 00000010  c0100bac 00000008 c015fffc 
c015ffc8
c015ffc0: c00639b0 c00b8ff8 00000000 00000003  00000008 c0f11aa0 00000000 
c00fd6c4
c015ffe0: c01226bc c00fd6c8 c00fd8ec 41807202  c0f0ffe4 c0160000 c0039bd8 
c0063820
Backtrace:
Function entered at [<c00c86c4>] from [<c004e95c>]
  r5 = c0117a5c       ^do_rs7211_bh     ^do_bottom_half
  r4 = 00000001
Function entered at [<c004e8cc>] from [<c003ac50>]
  r6 = 0000000c
  r5 = 00000000
  r4 = 00000000
Function entered at [<c003ab24>] from [<c003a060>]
  r9 = ffffffff
  r8 = 60000013
  r7 = c00b8fbc
  r6 = 00000001
  r5 = c015ff54
  r4 = 00003007
Function entered at [<c00b88e4>] from [<c00b9170>]
  r9 = 00000100
  r8 = 00000001
  r7 = 00000400
  r6 = 00000001
  r5 = 00000000
  r4 = c015ffd4
Function entered at [<c00b8fe8>] from [<c00639b0>]
  r9 = 00000008
  r8 = c0100bac
  r7 = 00000010
  r6 = 00000002
  r5 = 00000f90
  r4 = c0f11d40
Function entered at [<c0063810>] from [<c0039bd8>]
  r9 = 41807202
  r8 = c00fd8ec
  r7 = c00fd6c8
  r6 = c01226bc
  r5 = c00fd6c4
  r4 = 00000000
Function entered at [<c00eabf8>] from [<60000013>]
Code: pc not in code space
________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Sat, 22 Jul 2000 08:49:26 +0100 (BST)

> I am trying to get a 2.2.1 kernel with the latest patch from

About 18 months of work has happened since this kernel was released.
It is known to be buggy, and by this time I guess that very few people
can remember what the problems were.

> changes that need to be done

Looks like its jumping off to somewhere silly 0x38 bytes into
do_rs7211_bh.  Apart from that, I can't comment what the problem
may be.  You'll have to look at the assembly code of that function
to diagnose where its supposed to be jumping to.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |            http://www.arm.linux.org.uk/            /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |