Subject: Compiling uclinux for arm7

From: "Jooyeon Cho" <[email-masked]>
Date: Fri, 28 Jul 2000 16:31:45 KST

Hi

Is there anybody who are willing to help me compiling uclinux kernel?
arm system is aplio-trio and arm cpu is arm6/7.
Final error message is as follows.

make[1]: Entering directory `/data/uclinux/cross/linux/arch/armnommu/boot'
make[2]: Entering directory 
`/data/uclinux/cross/linux/arch/armnommu/boot/compressed'
./xtract /data/uclinux/cross/linux/linux | gzip -9 | ./piggyback > piggy.o
Non-GCC header of 'system'
compressed size 20
arm-uclinux-ld -Ttext 0x2000 -o linux head.o misc.o  piggy.o
piggy.o: file not recognized: file format not recognized
make[2]: [linux] Error 1

Thanks in advance.

Regards
Joe
________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Fri, 28 Jul 2000 10:31:19 +0100 (BST)

> piggy.o: file not recognized: file format not recognized

Looks like something has gone spectacularly wrong here -
piggy.o is only 20 bytes, and therefore not a valid ELF file.  I'd
guess that ./xtract doesn't know about ELF (which is why we don't use
it in the mainstream kernels anymore, but prefer to use objcopy and
ld magic).

I guess tha the armnommu people need to fix that up when using ELF.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |            http://www.arm.linux.org.uk/            /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |

---

From: "Vadim Lebedev" <[email-masked]>
Date: Fri, 28 Jul 2000 12:36:32 +0200

I've just added followig chaptre to the ucLinux/ARM FAQ  at
http://aplionet.aplio.fr/uclinux

5.	How does the system boot?
The boot process for AEB target of ucLinux is uses bootrecod stored at
adress 0x4040 in the flash memory and assumes that the flash contains
FTL formatted disk image starting somewhere afterx 0xffff
The boot recod contains boot items. Each boot item contains the list of
sectors on FTL volume which decribes the file to load into ram , program
start address and some optioanl data.  The first boot items so decribes the
linux_boot program (the sorce of the program is in AplioTRIO/common/ftl
directory) .  linux_boot is compiled to be position indepnedent.
So the IPL code (which is activated upon reset at address 0x0000) loads the
linux_boot program into ram and gives it the control. The linux_boot loads
in turn loads the file
Described by the second boot item (BTW the file can be gzip-compressed in
this case it is uzipped during load) prepares the command line for the
kernel and jumps to the
kernel start address.
In the AplioTRIO/common/ftl  directory resides a source of the simpl.y
makeboot utility which given name of the linux_boot and kerenl files
prepares the bootrecord and
Optionally writes it to the specified address in the flash.

One more thing:  when make command is run to build the kernel  by default it
builds 3 files:
·	linux – elf emage of the kernel,
·	linux.bin – absolute image of the kernel
·	linux.bin.gz – copressed version of above

Enjoy
-----------------------------------------
Vadim Lebedev
Chief Software Engineer
Aplio SA.
mail:[email-masked]
http://www.aplio.com
------------------------------------------
|-----Original Message-----
|From: [email-masked]
|[mailto:[email-masked]]On Behalf Of Jooyeon Cho
|Sent: vendredi 28 juillet 2000 09:32
|To: [email-masked]
|Subject: Compiling uclinux for arm7
|
|
|Hi
|
|Is there anybody who are willing to help me compiling uclinux kernel?
|arm system is aplio-trio and arm cpu is arm6/7.
|Final error message is as follows.
|
|make[1]: Entering directory `/data/uclinux/cross/linux/arch/armnommu/boot'
|make[2]: Entering directory
|`/data/uclinux/cross/linux/arch/armnommu/boot/compressed'
|./xtract /data/uclinux/cross/linux/linux | gzip -9 | ./piggyback > piggy.o
|Non-GCC header of 'system'
|compressed size 20
|arm-uclinux-ld -Ttext 0x2000 -o linux head.o misc.o  piggy.o
|piggy.o: file not recognized: file format not recognized
|make[2]: [linux] Error 1
|
|Thanks in advance.
|
|Regards
|Joe
|________________________________________________________________________
|Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com
|
|
|unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
|++        Please use [email-masked] for
|        ++
|++                        kernel-related discussions.
|        ++
|