Subject: RE: Spurious characters after kernel boot on Intel dev. board

From: Jeff Sutherland <[email-masked]>
Date: Fri, 14 Jul 2000 14:20:40 -0400

MN)" wrote:
> 
> > VFS: Mounted root (ext2 filesystem).
> > IN%M.ve.Kzr.&3..boJr; 68k init
> > IN%M.Ent..Jr;.&asc*+b....
> > S
> >    .Jr;.6.*j....9:. sysl:#
> > S
> >    .Jr;...R4..seK*... i.+"
> > 
> > Li......o:.root
> > [rz..ZM[7../rz.ls ..
> > l.Zd.S7..de....2..    e...2..    var....2..   usr....2..   
> l.kL.nl.n        bi....2..    rz...2..   r....2...
> 
> You're using 2.4.0-test2-ac1-rmk2-np3, aren't you? =)
> 
> (I thought I was losing it yesterday when both my Assabet and 
> Neponset started to do this.)
> 
> Back out to -np1; -np3 has some fairly substantial changes in 
> the serial character driver which may require some
> sorting.
> 
> -jd

I was going to suggest checking inittab on the ramdisk to see what the
gettys are doing.  Looks like something is fooling around with the serial
port settings when the tty's are starting up.  BTW my -np3 works fine except
for that problem Nico mentioned with keyboard escape sequences and the like
where two characters are sent back to back in quick succession.  No trouble
with output, though, and this is at 115200, n, 8, 1.  I need to track this
one down as we use serial I/O pretty extensively.

//Jeff

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: John G Dorsey <[email-masked]>
Date: Fri, 14 Jul 2000 08:50:43 -0400

Jeff Sutherland wrote:

> No trouble

That's interesting, because it looks to me as though -np3 cannot actually
implement that configuration (it doesn't believe in the "n").

The enclosed patch assumes that PARODD (or rather, its absence) does not imply
PARENB. It fixes the output strangeness on my Assabet and Assabet+Neponset.

-jd

---

From: Nicolas Pitre <[email-masked]>
Date: Fri, 14 Jul 2000 16:35:18 -0400 (EDT)

> implement that configuration (it doesn't believe in the "n").

Oops... That's surely my fault.  

What's strange is that the output isn't garbled for me nor Jeff.  Only
today I received two reports of the serial port being broken but I still
can't make it to garble my output.

> PARENB. It fixes the output strangeness on my Assabet and Assabet+Neponset.

Thanks!
Now only the receive overflow has to be found... or maybe it's the same
problem?  ;-)  I'll try to confirm that tonight.

Nicolas

---

From: Nicolas Pitre <[email-masked]>
Date: Sat, 15 Jul 2000 22:07:21 -0400 (EDT)

> PARENB. It fixes the output strangeness on my Assabet and Assabet+Neponset.

... and it fixes the more-than-two-characters-received problem too.  
The serial driver is fully working again.  Nice catch John!

My next patch should be less buggy than the two latest ones...  ;)

Nicolas