Subject: BLOB : download ramdisk ?

From: "¹éº´±â" <[email-masked]>
Date: Tue, 06 Jun 2000 05:27:18 KST

Hello.....

I have a SA1100 brutus board and blob..
Now I downloaded kernel successfully  at blob> prompt using 
"uuencode zImage zImage > /dev/ttyS0".

But I don't know how can I download ramdisk image .
When I tried like download kernel , It failed.

I have nothing to see except "starting kernel ...." when I booted without ramdisk.

Thank you.

==================================================
[email-masked] 
==================================================
No. 1 우리 인터넷, Daum
평생 쓰는 무료 E-mail 주소 한메일넷
지구촌 한글 검색서비스 Daum FIREBALL
http://www.daum.net

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: [email-masked] (Erik Mouw)
Date: Tue, 13 Jun 2000 06:13:38 +0200 (CEST)

> I have nothing to see except "starting kernel ...." when I booted without ramdisk.

Sorry for my late reaction, but I'm actually on vaction now and I was
able to grab a terminal with an internet connection. If you answer
this message, don't expect me to answer it soon.

The ramdisk download is similar to the kernel download: you have to use
download a compressed ramdisk to the target board using uuencode. You can
get a working ramdisk at the LART site, or you can use Nicolas Pitre's
ramdisk (available at ftp://ftp.netwinder.org/users/n/nico/).

Remember that blob and the kernel have to agree on the location of
the ramdisk. The standard blob distribution is actually tailor made
for the LART, so it puts the ramdisk at a place where a SA1100-LART
kernel expects it to be. I don't know if that is the same location
that an SA1100-Brutus kernel expects it. If not, you'll have to change
blob or the kernel.

Erik

-- 
J.A.K. (Erik) Mouw, Information and Communication Theory Group, Department
of Electrical Engineering, Faculty of Information Technology and Systems,
Delft University of Technology, PO BOX 5031,  2600 GA Delft, The Netherlands
Phone: +31-15-2783635  Fax: +31-15-2781843  Email: [email-masked]
WWW: http://www-ict.its.tudelft.nl/~erik/