Subject: Re: FIQ support on ARM-Linux

From: Kong Gang Feng <[email-masked]>
Date: Tue, 20 Jun 2000 20:11:32 +0900

Hi,

If I am not wrong, FIQ is never used in ARM-linux.

Kong
At 07:37 PM 6/20/00 +0530, umesh wrote:
>Hi,
>
>Is there any support for FIQ on ARM-Linux?
>I know that IRQs are supported and I can put my IRQ handler in proper
>place.
>But I am not able to do this for FIQ. Has anybody done this? If yes,
>how?
>
>I apologize if this is not the right mailing list to ask this
>question.....
>
>Umesh Puranik
>
>
>unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
>++        Please use [email-masked] for           ++
>++                        kernel-related discussions.                      ++
>
>

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Philip Blundell <[email-masked]>
Date: Sat, 24 Jun 2000 17:12:28 +0100

>If I am not wrong, FIQ is never used in ARM-linux.

As it happens, you are wrong.  But the kernel doesn't give you a lot of help 
to use FIQs; you have to do most of the work yourself.  See arch/arm/kernel/
fiq.c for some example stuff, though it may not suit your needs.  Really, it 
all depends what you want to do.

p.