Subject: SA1100(Brutus) : /proc/cpuinfo problems..

From: "¹éº´±â" <[email-masked]>
Date: Fri, 30 Jun 2000 14:16:31 KST

Hi all...

I have a Brutus(sa1100) board and Linux-2.2.13 with rmk2 patch. 
The kernel made by binutils-2.9.1.0.19a , egcs-1.1.2, glibc-2.1
It was loaded using BLOB, running good.

When I tried to see cpuinfo from /proc, It gives me under info.
Could someone give me a directions ?

Thank you.
ByungGi Baek.

--------------------------------------------------------------------
[root@Linux /proc]$more cpuinfo
Unable to handle kernel paging request at virtual address 001acacc
memmap = D81B4000, pgd = c0db4000
*pgd = 00000000, *pmd = 00000000
Internal error: Oops: 2
CPU: 0
pc : [<c000fed8>]    lr : [<c00acacc>]
sp : c0df7f44  ip : c00c5d84  fp : 00000000
r10: 40104f28  r9 : c0efcf34  r8 : 00000400
r7 : 00000000  r6 : c00b00dc  r5 : d7b74124  r4 : 04bd78a3
r3 : 90040000  r2 : 01844f90  r1 : 05c949c4  r0 : c0d56000
Flags: Nzcv  IRQs on  FIQs on  Mode SVC_32  Segment user
Control: D81B517D  Table: D81B517D  DAC: 00000015
Process more (pid: 75, stackpage=c0df7000)       
Stack:
c0df7f20:                                               c00acacc c000fed8 80000013
c0df7f40: ffffffff 00000009 c0efcf20 ffffffea  c0d43650 00000007 00000000 c00574a0
c0df7f60: c00577c4 00000400 c0d56000 40016000  00000000 c0efcf20 ffffffea 00000000
c0df7f80: 00000400 40016000 00000000 c00312c4  00000003 00000022 0207b7f8 c000d1a8
c0df7fa0: 00000003 c0df6000 c0df7ff4 00000001  c000d020 0207b7f8 00000003 40016000
c0df7fc0: 00000400 0207b7f8 0207b7f8 0207b7f8  00000000 0207b7f8 02001ec4 00000001
c0df7fe0: 40104f28 bffffc88 400af830 bffffc7c  4006c97c 400af834 20000010 00000003
Backtrace: no frame pointer
Code: e59fe064 e59c3000 (e79e1103) e1a028a2 e58d2004
Killed                

==================================================
[email-masked] 
ByungGi Baek.

==================================================
No. 1 우리 인터넷, Daum
평생 쓰는 무료 E-mail 주소 한메일넷
지구촌 한글 검색서비스 Daum FIREBALL
http://www.daum.net

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Fri, 30 Jun 2000 09:56:25 +0100 (BST)

> Could someone give me a directions ?

1. Compile the kernel up with a frame pointer
2. Re-run it and cause the problem
3. Lookup each number in [< >] up in your System.map
4. Email the information obtained in 2 and 3 to the list.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |            http://www.arm.linux.org.uk/            /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |