Subject: Re: FIQ support on ARM-Linux

From: "Jacky Lam" <[email-masked]>
Date: Wed, 21 Jun 2000 12:32:29 +0800

I also have this trouble before while I am trying to implement some drivers
using FIQ. It seems that the overhead of FIQ is too large and called so
freqently that the kenrel cannot handle it.

Jacky Lam

-----Original Message-----
From: Kong Gang Feng <[email-masked]>
To: umesh <[email-masked]>; [email-masked]
<[email-masked]>
Cc: [email-masked] <[email-masked]>
Date: Wednesday, June 21, 2000 9:17 AM
Subject: Re: FIQ support on ARM-Linux

>Hi,
>
>If I am not wrong, FIQ is never used in ARM-linux.
>
>Kong
>At 07:37 PM 6/20/00 +0530, umesh wrote:
>>Hi,
>>
>>Is there any support for FIQ on ARM-Linux?
>>I know that IRQs are supported and I can put my IRQ handler in proper
>>place.
>>But I am not able to do this for FIQ. Has anybody done this? If yes,
>>how?
>>
>>I apologize if this is not the right mailing list to ask this
>>question.....
>>
>>Umesh Puranik
>>
>>
>>unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
>>++        Please use [email-masked] for
++
>>++                        kernel-related discussions.
++
>>
>>
>
>unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
>++        Please use [email-masked] for
++
>++                        kernel-related discussions.
++

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: "Hugo Fiennes" <[email-masked]>
Date: Wed, 28 Jun 2000 16:08:30 +0100

> freqently that the kenrel cannot handle it.

I assume you mean the IRQ overhead is too large?

We use FIQs in various empeg units, both for sound buffer filling (on the
Cirrus 7212) and things like USB/consumer IR. It all works fine, you just
have to make sure the source is enabled & unmasked & the registers are setup
correctly.

The acorn floppy driver is a good example of fiq usage - if you've not done
fiq code before it's worth reading the ARM architecture ref manual about fiq
code so you're aware of the restrictions/things to look out for.

Hugo
empeg