Subject: [RE]Re: SA1100(Brutus) : /proc/cpuinfo problems..

From: "¹éº´±â" <[email-masked]>
Date: Fri, 30 Jun 2000 20:24:13 KST

Thanks....
I attached more informations

Backtrace:
Function entered at [<c00100d4>] from [<c0059038>]
  r5 = 00000000
  r4 = 00000007
Function entered at [<c0058f78>] from [<c005938c>]
Function entered at [<c0059290>] from [<c0032028>]
  r9 = 00000000
  r8 = 40016000
  r7 = 00000400
  r6 = 00000000
  r5 = ffffffea
  r4 = c06f8800
Function entered at [<c0031f0c>] from [<c000d0c0>]
  r9 = 00000001
  r8 = c0df3ff4
  r7 = c0df2000
  r6 = 00000003
  r5 = c000d248
  r4 = 0207b7f8
Code: e59fe064 e59c3000 (e79e1103) e1a028a2 e58d2004
Killed    

and System.map :
c000d0c0 t fast_syscall_return
c000d0c4 t slow_syscall_return                                                  

c000fd80 T setup_arch
c00100d4 T get_cpuinfo                                                          

c0031f0c T sys_read
c003203c T sys_write                                                            

c0058f78 t get_root_array
c00590d4 t process_unauthorized
c0059200 t get_process_array
c0059290 t array_read
c00594c4 t arraylong_read                                                       

---------> 받은 메일 내용 <----------
>From : Russell King - ARM Linux Admin <[email-masked]>
>>백병기 writes:
>>> When I tried to see cpuinfo from /proc, It gives me under info.
>>> Could someone give me a directions ?
>>
>>1. Compile the kernel up with a frame pointer
>>2. Re-run it and cause the problem
>>3. Lookup each number in [< >] up in your System.map
>>4. Email the information obtained in 2 and 3 to the list.
>>   _____
>>  |_____| ------------------------------------------------- ---+---+-
>>  |   |        Russell King       [email-masked]      --- ---
>>  | | | |            http://www.arm.linux.org.uk/            /  /  |
>>  | +-+-+                                                     --- -+-
>>  /   |               THE developer of ARM Linux              |+| /|\
>> /  | | |                                                     ---  |
>>    +-+-+ -------------------------------------------------  /\\\  |
>>
<hr>

==================================================
[email-masked] 
ByungGi Baek.

==================================================
No. 1 우리 인터넷, Daum
평생 쓰는 무료 E-mail 주소 한메일넷
지구촌 한글 검색서비스 Daum FIREBALL
http://www.daum.net

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Fri, 30 Jun 2000 14:38:36 +0100 (BST)

Ok, it looks like "machine_type" contains value 0x90040000, which is an
illegal machine type number (especially when used as an index into an
array).

The question is how is this number getting past the checks in
arch/arm/kernel/head-armv.S?  It explicitly traps out of range values
for this variable.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |            http://www.arm.linux.org.uk/            /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |