Subject: Re: Brutus:serial console config(no angel) ....???

From: "Dan" <[email-masked]>
Date: Thu, 8 Jun 2000 13:07:25 -0600

During the kernel initialization and execution of
the inittab, we found that the console speed was
changed several times. This caused hyperterminal
and the host's UART to lose sync on the serial
link.

In the serial_sa1100 ?? code there is a function
for changing the speed of the serial port. I hacked
it up so that all requests resulted in one
speed being set. Like Henry Ford's first cars --
you can have any color you want as long as its black.
You can have any speed you want as long as its 9600 --
all requests resulted in the speed being set to 9600.

This hack allowed us to monitor the kernel initialization
progress through all the speed changes.

Maybe there is something there but its coming out
at the wrong baud rate ????

Just a thought!

--------------------------------
Bye!
Dan McDonald
The Late Night Software Shop 
Sign up today for your Free E-mail at: http://www.canoe.ca/CanoeMail 

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Nicolas Pitre <[email-masked]>
Date: Fri, 9 Jun 2000 09:05:20 -0400 (EDT)

> and the host's UART to lose sync on the serial

The serial console is still missing some bits to prevent that to happen.
The code is marked with a "fixme" comment for someone with extra time to
fix it.

Nicolas