Subject: gcc-2.95.2 compile error

From: Sanggyu Nam <[email-masked]>
Date: Fri, 26 May 2000 10:39:04 +0900

I'm using gcc-2.95.2.tar.gz with gcc-2.95.2-diff-991022.gz.
After make binutils-2.9.5.0.42 with no patch, I tried command 'make
LANGUAGES="c"' but below errors are shown.

./libgcc2.c:41: stdlib.h: there's no file
./libgcc2.c:42: unistd.h: tehre's no file
make[3]: Leaving directory `/devel/arm/assabet/gcc-2.95.2/gcc'
make[2]: *** [stmp-multilib-sub] Error 2
make[2]: Leaving directory `/devel/arm/assabet/gcc-2.95.2/gcc'
make[1]: *** [stmp-multilib] Error 1
make[1]: Leaving directory `/devel/arm/assabet/gcc-2.95.2/gcc'
make: *** [all-gcc] Error 2

If I use '-i' option to disregard errors, libgcc.a is made but it's not
correct. So it caused another error when compile glibc-2.1.3.
ehwn compile egcs-1.1.2 has not generated any error like this.
How can I solve this?

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Mathias Teikari <[email-masked]>
Date: Fri, 26 May 2000 08:59:41 +0200

Looks like you haven't got the libc headers for arm targets up to date. Try the
following..

In file: gcc-2.95.2/gcc/config/arm/t-linux, add -Dinhibit_libc and
-D__gthr_posix_h to the line that starts with TARGET_LIBGCC2_CFLAGS.

That line should now look like this:
TARGET_LIBGCC2_CFLAGS = -fomit-frame-pointer -fPIC -Dinhibit_linc
-D__gthr_posix_h

Re-run configure with extra parameter --disable-threads

After you have built your glibc you can go back and rebuild the complete
compiler as usual!

    - Mathias

--
 +---------------------------------------------------------+      .--.
 | Mathias Teikari           [email-masked]    |     |o_o |
 | Ba. Sc. EE.               Office Ph: +41 (0)31 376 2030 |     |:_/ |
 | SW Development Engineer   Mobile Ph: +41 (0)76 541 9449 |    //   \ \
 | Telscom AG                Sandrainstr. 17, CH-3007 Bern |   (|     | )
 |                                                         |  /'\_   _/`\
 +---------------- http://www.telscom.ch ------------------+  \___)=(___/

---

From: "Sanggyu Nam" <[email-masked]>
Date: Fri, 26 May 2000 16:07:30 +0900

Thank you for answering.
Just before you reply, I saw the thing about this error at arm linux site. And I tried as you mentioned.
but there's another error has occured,

the error is like this;

checking if compiler cc1obj has been built... no
libobjc: directory not empty

I used command 'make LANGUAGES="c"'

-----Original Message-----
From: mathiast [mailto:mathiast]On Behalf Of Mathias Teikari
Sent: Friday, May 26, 2000 4:00 PM
To: Sanggyu Nam
Cc: [email-masked]
Subject: Re: gcc-2.95.2 compile error

    - Mathias

§²æìr¸›yºÊ‡îžË›±ÊâmébžìZ®kh™¨èÚ&¢ø®»êìyÛ¾øù^jÇ®±ébžìZ®i®w¥–+-±ªæ–)îÆŠàºGè¯ï¾úG«ékzVy×b±Ë¬²*'³ï