Subject: Re: Can't compile a 2.2.14 kernel

From: Peter Köllner <[email-masked]>
Date: Mon, 1 May 2000 16:45:42 +0200 (MET DST)

Erik Mouw wrote:
> Yes, see http://www.lart.tudelft.nl/lartware/compile-tools/ for all
> necessary components. Follow Chris Rutter's description (link on the same
> page), and it will work straight out of the box.

i am downloading the binaries now after building from the sources failed.
i got binutils 2.9.5.0.31 and gcc-2.95.2 as well as all patches i could get my 
hands on. then i built on a i668-pc-linux-gnu host with target=arm-linux.
the compilation in gcc failed with assembler errors from 
./xgcc crtstuff.c with -DCRT_BEGIN and -DCRT_END: "out of range branch".
it looks like the compiler wrongly uses bl subroutine jumps if static 
functions are just a bit too far. to test that, i changed the order of 
functions in that file, and the compilation succeeded.
then i tried to compile something else and got lots of the same error.
so what patch would i need to get rid of that?

-- 
CANBOX Communications GmbH  - Peter Koellner - [email-masked]
voicemail & fax via www.smartvia.de:      +49-441-80066-5042
phone +49 231 5865139                     mobile  +49 177 6490606
make[3]: Entering directory `/usr/local/src/gcc-2.95.2/gcc'
/usr/local/src/gcc-2.95.2/gcc/xgcc -B/usr/local/src/gcc-2.95.2/gcc/ -B/usr/local/arm-linux/bin/ -I/usr/local/arm-linux/include -DCROSS_COMPILE -DIN_GCC     -g -O2 -I./include  -I. -I. -I./config -I./../include  -g0 \
  -finhibit-size-directive -fno-inline-functions -fno-exceptions  \
  -c ./crtstuff.c -DCRT_BEGIN -o tcrtbegin.o
/tmp/ccWHlbLq.s: Assembler messages:
/tmp/ccWHlbLq.s:61: Error: out of range branch
make[3]: *** [tcrtbegin.o] Error 1
make[3]: Leaving directory `/usr/local/src/gcc-2.95.2/gcc'
mv: tcrtbegin.o: No such file or directory
make[3]: Entering directory `/usr/local/src/gcc-2.95.2/gcc'
/usr/local/src/gcc-2.95.2/gcc/xgcc -B/usr/local/src/gcc-2.95.2/gcc/ -B/usr/local/arm-linux/bin/ -I/usr/local/arm-linux/include -DCROSS_COMPILE -DIN_GCC     -g -O2 -I./include  -I. -I. -I./config -I./../include  -g0 \
  -finhibit-size-directive -fno-inline-functions -fno-exceptions  \
  -c ./crtstuff.c -DCRT_END -o tcrtend.o
/tmp/ccWMenxf.s: Assembler messages:
/tmp/ccWMenxf.s:37: Error: out of range branch
make[3]: *** [tcrtend.o] Error 1
make[3]: Leaving directory `/usr/local/src/gcc-2.95.2/gcc'
mv: tcrtend.o: No such file or directory
make[2]: *** [stmp-multilib-sub] Error 1
make[2]: Leaving directory `/usr/local/src/gcc-2.95.2/gcc'
make[1]: *** [stmp-multilib] Error 1
make[1]: Leaving directory `/usr/local/src/gcc-2.95.2/gcc'
make: *** [all-gcc] Error 2

---

From: Erik Mouw <[email-masked]>
Date: Mon May 01 16:58:12 +0200 (MDT) 2000

> i got binutils 2.9.5.0.31 and gcc-2.95.2 as well as all patches i could get my 
                 ^^^^^^^^^^
That's a known bug. Don't use binutils-2.9.5.0.31.

Erik

-- 
In theory, practice and theory are the same, but in practice they 
are different -- Larry McVoy

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++