Subject: RE: undefined instruction problem

From: "Naik, Uday" <[email-masked]>
Date: Wed, 3 May 2000 21:31:34 -0700

After putting some printk's in the traps.c code, and printing out the
vm_area_struct's, it looks like the addresses where the undefined 
instructions are happening are in ld-2.1.2.so and libc-2.1.2.so. 

I looked at the ramdisk (ramdisk_img.gz from nico's site). The ld-2.1.2.so
and libc-2.1.2.so seem much smaller than the one's in my tools chain.
Have they been specially built for a small footprint ??

Any help would be highly appreciated. 

Also what is the format of the page table directory. If I print out memory 
at current->mm->pgd_t what is the format of the entries I should expect to
see.

Thanks

Uday

P.S: I only used the footbridge uart code as a sample and modified it for my
uart. It just seemed like a cleaner piece of code to work with.

---

All opinions expressed are mine and do not reflect those of my employer.

-----Original Message-----
From: Russell King - ARM Linux Admin [mailto:[email-masked]]
Sent: Tuesday, May 02, 2000 11:08 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: undefined instruction problem

Naik, Uday writes:
> Any ideas on how to debug this ?? It looks like the 
> page table for the process is messed up. 

How did you diagnose this?

> I have tried to keep my ixp1200 port very very close
> to the SA1100 port. One thing I did have to do was to
> replace the serial driver with a serial driver modified
> from 21285 which seemed a lot cleaner. Otherwise, I 
> would get to the /sbin/init and just hang.

The 21285 northbridge serial driver is not a drop-in replacement for
the SA1100 serial driver.  Do you have a 21285 chip in this system?

PS, this really belongs on [email-masked],
as per the footer line on every message on this (linux-arm) list.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |            http://www.arm.linux.org.uk/            /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Nicolas Pitre <[email-masked]>
Date: Thu, 4 May 2000 16:08:50 -0400 (EDT)

> Have they been specially built for a small footprint ??

No.  Only stripped.

Nicolas