Subject: XWindow

From: "Alan Chong" <[email-masked]>
Date: Tue, 4 May 2004 09:28:01 +0800

Hi !!! Has anyone ever include XWindow codes into the kernel ???
I am given the task of doing it but don't know where to start.
Any advice is very much appreciated.

Thanks in advance

Alan Chong

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Philip Blundell <[email-masked]>
Date: Thu, 04 May 2000 09:02:59 +0100

>Hi !!! Has anyone ever include XWindow codes into the kernel ???

I don't think so.  Why do you want to do this?

p.

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Thu, 4 May 2000 08:57:32 +0100 (BST)

> Any advice is very much appreciated.

You're asking about integrating the X server code into the kernel?  That
would cause many problems.  For instance, any memory that the kernel allocates
can not be swapped out.  Since X tends to use a lot of memory, this would
mean that you could easily use a large unswappable chunk of memory.

Also, there is a security issue here - you could easily launch a denial-of-
service attack against that by causing the X server to allocate more and more
memory until the machine has no more memory available to allocate.

It's also against the traditional unix philosophy as well.

Why do you want to do such a strange thing?
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |            http://www.arm.linux.org.uk/            /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |

---

From: [email-masked] (Jim Gettys)
Date: Thu, 4 May 2000 10:51:09 -0700 (PDT)

Probably for the reason it got tried in the first place 13
years ago: a pointy haired manager thought it was a good
idea....
				- Jim

--
Jim Gettys
Technology and Corporate Development
Compaq Computer Corporation
[email-masked]