Subject: RE: cross gdb & debugging agent

From: Jungjun Kim <[email-masked]>
Date: Wed, 24 May 2000 09:08:18 +0900

First you need to have debugging agent on target board.
I'm using ANGEL as a debugging agent, and the origianl source of ANGEL can be
found in ARM SDT.
Maybe you need to port ANGEL if you want to use it as a debugging agent.
There are some documents about porting in ARM site.
Once you get ANGEL for your target board, gdb can be connect to target board
using serial port.
   (gdb) target rdi /dev/ttyS0

And I was told that it is not difficult to implement gdb original remote
protocol.
Anyway, once you get a debugging agent for your board, you can connect to
target board and you can download linux image on the board.

Jungjun Kim

> hello,
> 
> I have downloaded the gdb 5.0 version and installed it on my Linux PC. The
> board had the ARM debugger running on it. I have also compiled the
> arm linux 2.3.99 kernel. How do I download this image into the board using
> the gdb??
> 
> Thanks,
> -lavu sridhar
> 
> On Mon, 22 May 2000, Jungjun Kim wrote:
> 
> >Hello,
> >
> >First, i'm not using ARM SDT, I'm just using GDB.
> >With GDB, you need to have ARM debugging agent running on target board.
> >If you are using ARM SDT, please check tool configuration or ask about it ARM
> >Ltd, because I don't know much about it.
> >

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Lavu Sridhar <[email-masked]>
Date: Wed, 24 May 2000 13:54:31 +0530 (IST)

Thank you for the info. I have the ANGEL Debugger running on the board.
Next I tried the command u specified: but it says undefined target
commmand rdi. Next I tried the command: target remote /dev/ttyS0 , but I
get the message saying could not open connectoin with the remote target.

What is the solution to the problem?

Regards,
Lavu Sridhar