Subject: glibc-2.1.3 compile error

From: Sanggyu Nam <[email-masked]>
Date: Thu, 25 May 2000 20:08:40 +0900

I'm trying to make tool-chain for arm-linux but I've got the problem
that compile glibc-2.1.3.

Here's thing I'm using.

binutils-2.9.5.0.42
gcc-2.95.2
glibc-2.1.3
linux-2.3.99-pre8

When compile glibc-2.1.3, below messages are shown.

../libc.so.6: undefined reference to `__ashldi3'
../libc.so.6: undefined reference to `__divdi3'
../libc.so.6: undefined reference to `__umoddi3'
../libc.so.6: undefined reference to `__udivdi3'
../libc.so.6: undefined reference to `__lshrdi3'
../libc.so.6: undefined reference to `__moddi3'
../libc.so.6: undefined reference to `__muldi3'
collect2: ld returned 1 exit status
make[1]: *** [makedb] Error 1
make[1]: Leaving directory `/devel/arm/assabet/glibc-2.1.3/db2'
make: *** [db2/others] Error 2

Please teach me the solution.
Someone said me that this error will be solved by using
binutils-2.9.5.0.22. But it cannot be solve this.
How can I compile glibc-2.1.3?

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Scott Bambrough <[email-masked]>
Date: Thu, 25 May 2000 12:24:12 -0400

All these functions can be found in libgcc.a.  This comes with the compiler.  Is
your compiler installed correctly?

Scott

-- 
Scott Bambrough - Software Engineer
REBEL.COM    http://www.rebel.com
NetWinder    http://www.netwinder.org