Subject: Re: GDB baudrate

From: Jungjun Kim <[email-masked]>
Date: Wed, 17 May 2000 11:07:29 +0900

Hello,

The GDB 4.18 has some problems in serial implementation in ANGEL.
Expecially, it doesn't support high baudrate( like 57600, 119200)
I recommend to use GDB 4.95.x instead of fixing it.

The download site is ftp://sourceware.cygnus.com/pub/gdb/snaphots .
To compile GDB 4.95.1 with angel support, you have to change your gdb/Makefile
and execute "configure --target=arm-linux --prefix=/somewhere"  in the
gdb/rdi-share directory.

Add two files ( remote-rdi.o , rdi-share/libangelsd.a ) in Makefile. I don't
know why these two files are not included.

609: DEPFILES = $(TDEPFILES) $(XDEPFILES) $(SER_HARDWIRE) $(NATDEPFILES) \
610:      $(REMOTE_OBS) $(SIM_OBS) $(CONFIG_OBS) remote-rdi.o

783: gdb$(EXEEXT): main.o libgdb.a $(ADD_DEPS) $(CDEPS) $(TDEPLIBS)
rdi-share/libangsd.a

The serial device file GDB uses is /dev/ttySx,
But I like to use serial port via /dev/cua0, so I modified source code for that
to use /dev/cua0 .
Try to use /dev/ttyS1 instead of /dev/cau1.

Related source files are as follows.

gdb/rdi-share/unixcomm.c
gdb/rdi-share/serdrv.c

Regards,

> >From [email-masked]  Wed May 17 10:33:09 2000

> 
> Dear Mr.Jungjun Kim
> 
>   I found your message on the mail-list,I use Intel Assabate develop board too, when it communicates with the host through COM1,the protocol is Angle, use the command "target rdi /DEV/cau1",but when it connected, the display connected speed only at 9600. I use the command "target rdi /dev/cua1 57600", it said "can not found the device /DEV/cau1 57600",Is the some error on my operations?
> 
> BTW:where can I download the GDB 4.95.1? I can not find it at "sourceware.cysgnu.com".
> 
> My host OS :Redhat Linux 6.0
> Host : Pentium II 400, 64MB memory
> The GDB version:4.18 compile "configure -target=arm-linux-elf"
> 
> Thanks
> Best regards
> 
>  Sui Litao

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: "Chagas, Jason" <[email-masked]>
Date: Mon, 22 May 2000 17:14:22 -0700

Take a look into the attached patch for clues on how to get GDB to support
multiple baud rates.

I hope you'll find it useful.

Jason

----------------------

Index: targetselection.itb
===================================================================
RCS file: /cvs/cvsfiles/devo/gdb/gdbtk/library/targetselection.itb,v
retrieving revision 1.1
diff -p -r1.1 targetselection.itb
*** targetselection.itb 2000/02/04 13:52:34     1.1
--- targetselection.itb 2000/04/20 20:57:16
*************** body TargetSelection::init_target_db {}
*** 123,129 ****
    # ARM Remote
    set gdb_target(rdp,pretty-name) "ARM Remote/Serial"
    set gdb_target(rdp,defbaud) "9600"
!   set gdb_target(rdp,baud-rates) {9600}
    set gdb_target(rdp,cmd) "rdp com1"
    set gdb_target(rdp,runlist) {1 1 0 1}
    set gdb_target(rdp,after_attaching) {}
--- 123,129 ----
    # ARM Remote
    set gdb_target(rdp,pretty-name) "ARM Remote/Serial"
    set gdb_target(rdp,defbaud) "9600"
!   set gdb_target(rdp,baud-rates) {9600 19200 38400 57600}
    set gdb_target(rdp,cmd) "rdp com1"
    set gdb_target(rdp,runlist) {1 1 0 1}
    set gdb_target(rdp,after_attaching) {}