Subject: arm-linux ELF format problem

From: Umesh Puranik <[email-masked]>
Date: Mon, 15 May 2000 22:05:21 +0530

I am trying to build a gcc cross-compiler for ARM/Linux on
a PC (Pentium III).
When I try to compile a simple c program (hello.c),
I get an error message:
ld: unsupported emulation format elf32arm

I am using the following sources to build the compiler:
binutils-2.9.5.0.41
gcc-2.95.2
linux kernel 2.2.2

I am not able to build the libraries using glibc-2.1.2 for
the same reason as above.

Could anybody tell what is going wrong? Or do I need to use
any patches?

Umesh

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Scott Bambrough <[email-masked]>
Date: Mon, 15 May 2000 12:45:17 -0400

The answer can be found here:

http://www.netwinder.org/~scottb/notes/Binutils-Notes-2.html#ss2.2

-- 
Scott Bambrough - Software Engineer
REBEL.COM    http://www.rebel.com
NetWinder    http://www.netwinder.org