Subject: LCD backlight on Assabet BD problem

From: Sun-Gi Hong <[email-masked]>
Date: Tue, 23 May 2000 16:50:19 +0900

Greetings,

Now I am trying to turn on the LCD backlight on Assabet board, however,
I don't know how to achieve this.

In /video/sa1100fb.c, there is a function of
sa1100fb_enable_lcd_controller (), and it contains the following
routines.

                if (machine_is_assabet()) {
#ifdef CONFIG_SA1100_ASSABET
                        BCR_set(BCR_LCD_ON);
#endif
                } else if (machine_is_penny()) {
#ifdef CONFIG_SA1100_PENNY
                        FpgaLcdCS1 = 0x0FF;     /* LCD Backlight to 100%

*/
                        FpgaPortI  |= LCD_ON;   /* Turn on LCD Backlight

*/
#endif
                } else if (machine_is_tifon()) {
                        GPCR = GPIO_GPIO(24);   /* cycle on/off-switch
*/
                        udelay(150);
                        GPSR = GPIO_GPIO(24);   /* turn on display */

As you can see, LCD backlight seems to work in the case of PENNY, but
Assabet does not. (Am I right?) What can I do for turning on LCD
backlight? Any ideas?

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: John G Dorsey <[email-masked]>
Date: Tue, 23 May 2000 12:21:41 -0400

> I don't know how to achieve this.

Toggling the backlight GPIO line won't do much on Assabet unless you've
added a power supply to your board. Sections 4.6.2.1 and 4.6.2.4 of the
Assabet user's guide both note the absence of backlight power on the design.

-jd