Subject: Re: LCD backlight on Assabet BD problem

From: [email-masked]
Date: Tue, 23 May 2000 16:04:47 -0400

Unless you obtain an AC inverter for the frontlight on the Assabet, enabling the
frontlight in software will do nothing.

After doing a bit of research (and calling intel)  i was able to find a vendor
for the inverter..

Endicott Research        (www.ergpower.com)
2601 Wayne Street
Endicott, New York 13760
607-754-9187
fax 607-754-9255

I was able to find out that they do have an inverter that supports the Sharp
LQ039Q2DS54, but every time i try to contact the engineer, he is not at his
desk!?!?  I will try again today, and see if i can get more info.. pricing..
etc..

-Nick

Sun-Gi Hong <[email-masked]> on 05/23/2000 03:50:19 AM

To:   [email-masked]
cc:    (bcc: Nicholas Mistry/USER/US/LHS)

Subject:  LCD backlight on Assabet BD problem

Greetings,

Now I am trying to turn on the LCD backlight on Assabet board, however,
I don't know how to achieve this.

In /video/sa1100fb.c, there is a function of
sa1100fb_enable_lcd_controller (), and it contains the following
routines.

                if (machine_is_assabet()) {
#ifdef CONFIG_SA1100_ASSABET
                        BCR_set(BCR_LCD_ON);
#endif
                } else if (machine_is_penny()) {
#ifdef CONFIG_SA1100_PENNY
                        FpgaLcdCS1 = 0x0FF;     /* LCD Backlight to 100%

*/
                        FpgaPortI  |= LCD_ON;   /* Turn on LCD Backlight

*/
#endif
                } else if (machine_is_tifon()) {
                        GPCR = GPIO_GPIO(24);   /* cycle on/off-switch
*/
                        udelay(150);
                        GPSR = GPIO_GPIO(24);   /* turn on display */

As you can see, LCD backlight seems to work in the case of PENNY, but
Assabet does not. (Am I right?) What can I do for turning on LCD
backlight? Any ideas?

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: [email-masked]
Date: Tue, 23 May 2000 23:34:47 -0400

After speaking with an engineer @ ergpower I have the part needed to power the
frontlight on the Sharp LQ039Q2DS54 Display.

The part # is 8m122375
its an 8m Class DC to AC inverter

The cost per unit is $29 each, for a qty of less than 10..  there is a minimum
order amount of $100.   And a lead time of 4 weeks..

-Nick

[email-masked] on 05/23/2000 04:04:47 PM

To:   Sun-Gi Hong <[email-masked]>
cc:   [email-masked] (bcc: Nicholas Mistry/USER/US/LHS)

Subject:  Re: LCD backlight on Assabet BD problem

-Nick

Greetings,

*/

*/
#endif