Subject: undefined instruction problem

From: "Naik, Uday" <[email-masked]>
Date: Tue, 2 May 2000 17:43:09 -0700

On my ixp1200 system (sa1100 + ...), I am now
running linux-2.3.99-pre3 with the patches 
2.3.99-pre3-rmk3 and pre3-rmk3-np2. 

It does fine until the /sbin/init is run. I am using the
ramdisk from nico's site. I get a number of 
pc: undefined instruction always at the addresses
0x4004be04 and 0x400105b4. I tried replacing the 
/sbin/init with just bash. I see the bash prompt,
but get the same undefined instructions at the same
addresses. I wrote a small infinite loop hello world
program, and that seems to work fine. 

Any ideas on how to debug this ?? It looks like the 
page table for the process is messed up. 

I have tried to keep my ixp1200 port very very close
to the SA1100 port. One thing I did have to do was to
replace the serial driver with a serial driver modified
from 21285 which seemed a lot cleaner. Otherwise, I 
would get to the /sbin/init and just hang.

Thanks

uday

---

All opinions expressed are mine and do not reflect those of my employer.

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Wed, 3 May 2000 07:07:37 +0100 (BST)

> page table for the process is messed up. 

How did you diagnose this?

> would get to the /sbin/init and just hang.

The 21285 northbridge serial driver is not a drop-in replacement for
the SA1100 serial driver.  Do you have a 21285 chip in this system?

PS, this really belongs on [email-masked],
as per the footer line on every message on this (linux-arm) list.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |            http://www.arm.linux.org.uk/            /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |