Subject: RE: cross gdb & debugging agent

From: Jungjun Kim <[email-masked]>
Date: Thu, 25 May 2000 08:54:23 +0900

Oops,

You need to change the following lines of gdb/Makefile

    783 gdb$(EXEEXT): main.o libgdb.a $(ADD_DEPS) $(CDEPS) $(TDEPLIBS)
rdi-share/libangsd.a
    784     rm -f gdb$(EXEEXT)
    785     $(HLDENV) $(CC_LD) $(INTERNAL_LDFLAGS) $(WIN32LDAPP) -o gdb$(EXEEXT) main.o libgdb.a $(TDEPLIBS) $(TUI_LIBRARY) $(CLIBS) $(LOADLIBES) rdi-share/libangsd.a  

Jungjun Kim

> I have made the chages in the Makefile in gdb directory. After that in
> directory rdi-share i executed the following commands: 
> 
> ./configure
> make 
> 
> And when i gave the instruction target rdi /dev/ttyS0 in gdb, it is still
> saying that it cannot recognize the rdi command.
> 
> regards,
> -lavu sridhar
> 
> On Wed, 24 May 2000, Jungjun Kim wrote:
> 
> >The reason why this happens is that gdb5.0 doesn't include RDI stuffs.
> >You need to change gdb/Makefile as follows,
> >
> >for gdb/Makefile
> >
> >    609 DEPFILES = $(TDEPFILES) $(XDEPFILES) $(SER_HARDWIRE) $(NATDEPFILES) \
> >    610        $(REMOTE_OBS) $(SIM_OBS) $(CONFIG_OBS) remote-rdi.o
> >
> >    783 gdb$(EXEEXT): main.o libgdb.a rdi-share/libangsd.a $(ADD_DEPS) $(CDEPS)
> >$(TDEPLIBS)
> >
> >and change directory to gdb/rdi-share, make configuration, and run 'make',
> >then you get libangsd.a library.
> >
> >I don't know why they don't include this target .
> >
> >Jungjun Kim
> >
> >> Thank you for the info. I have the ANGEL Debugger running on the board.
> >> Next I tried the command u specified: but it says undefined target
> >> commmand rdi. Next I tried the command: target remote /dev/ttyS0 , but I
> >> get the message saying could not open connectoin with the remote target.
> >> 
> >> What is the solution to the problem?
> >> 
> >> Regards,
> >> Lavu Sridhar
> >>

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Lavu Sridhar <[email-masked]>
Date: Thu, 25 May 2000 11:13:31 +0530 (IST)

Hello again, I have done :
 	
	1) ./configure in gdb-5.0/
	2) changes in the Makefile in gdb-5.0/gdb/
	3) ./configure in gdb-5.0/gdb/rdi-share/
	4) make in gdb-5.0/gdb/rdi-share/
	5) make in gdb-5.0/

In the last step I have got the following error message saying that
udefined reference to some functions.

libgdb.a(remote-rdi.o): In function `arm_rdi_resume':
/home/arm/gdb-5.0/gdb/remote-rdi.c:495: undefined reference to
`arm_get_next_pc'libgdb.a(remote-rdi.o): In function
`arm_rdi_insert_breakpoint':
/home/arm/gdb-5.0/gdb/remote-rdi.c:768: undefined reference to
`arm_pc_is_thumb'/home/arm/gdb-5.0/gdb/remote-rdi.c:768: undefined
reference to `arm_pc_is_thumb$collect2: ld returned 1 exit status
make[1]: *** [gdb] Error 1

Have I got the sequence of steps right? 

Regards,
Lavu Sridhar	

-----------------------------------------------------------------------

---

From: Vikas Datta <[email-masked]>
Date: Thu, 25 May 2000 15:36:27 +0530 (IST)

Hello,

I have built the kernel using bin-utils-2.95.2- and linux-2.3.99
Using gdb5.0 , i have tried :

target rdi /dev/ttyS0
load zImage

it says that this is not an executable.....
I had enabled the Kernel Support for ELF binaries while making the
kernel....am i using the wrong format? which format shd i use for the
download ?

I am using the Cirrus Logic 7500FE Development board with 16MB RAM and no
Flash SIMM, debugging through COMM1 port.

regards,
vikas datta