Subject: shared library problem?

From: Chris Blazie <[email-masked]>
Date: Mon, 15 May 2000 16:18:10 -0400 (EDT)

I am unable to run dynamically-linked applications on the
2.3.99-pre3 kernel I have running on our development board.  I can run
bash as init if bash is statically linked, but executing any other
application (such as ls) fails as shown below.  It looks like a problem
loading shared libraries.  Any ideas?

Thanks,
Chris

Linux version 2.3.99-pre3-rmk3-np2 (root@cassius) (gcc version 2.95.2
20000212 (re0
Architecture: Blazie Engineering Sherman
On node 0 totalpages: 16384
zone(0): 16384 pages.
zone(1): 0 pages.
zone(2): 0 pages.
On node 1 totalpages: 16384
zone(0): 16384 pages.
zone(1): 0 pages.
zone(2): 0 pages.
Calibrating delay loop... 124.52 BogoMIPS   
Memory: 64MB 64MB = 128MB total
Memory: 124616KB available (596K code, 414K data, 8K init)
Buffer-cache hash table entries: 8192 (order: 3, 32768 bytes)
Page-cache hash table entries: 32768 (order: 5, 131072 bytes)
POSIX conformance testing by UNIFIX
Linux NET4.0 for Linux 2.3
Based upon Swansea University Computer Society NET3.039
Starting kswapd v1.6
SA1100 serial driver version 1.2
ttyS0 on SA1100 UART3 (irq 17)
ttyS1 on SA1100 UART1 (irq 15)
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
RAMDISK: Compressed image found at block 0
NetWinder Floating Point Emulator V0.95 (c) 1998-1999 Rebel.com
VFS: Mounted root (ext2 filesystem).
Freeing unused kernel memory: 8k init   
bash# ls
ls: memory violation at pc=0x4000d040, lr=0x40003f60 (bad
address=0x4011aa54, code)
init (1): undefined instruction: pc=400cdb3c
init (1): undefined instruction: pc=400cdb3c
init (1): undefined instruction: pc=400cdb3c
init (1): undefined instruction: pc=400cdb3c
init (1): undefined instruction: pc=400cdb3c
init (1): undefined instruction: pc=400cdb3c
init (1): undefined instruction: pc=400cdb3c
init (1): undefined instruction: pc=400cdb3c
init (1): undefined instruction: pc=400cdb3c
init (1): undefined instruction: pc=400cdb3c
[1] init: obsolete system call 00ffbfd8.
[1] init: obsolete system call 00ffbe34.
[1] init: obsolete system call 00ffbc90.
[1] init: obsolete system call 00ffbc0c.
[1] init: obsolete system call 00ffbaec.

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Philip Blundell <[email-masked]>
Date: Mon, 15 May 2000 23:03:40 +0100

>loading shared libraries.  Any ideas?

Seems that you have some problem with your memory management.  I doubt it's 
related to shared libraries directly.

>address=0x4011aa54, code)

I suspect this is a bogus trap, though without knowing the `code' value it's 
hard to say for sure.

>init (1): undefined instruction: pc=400cdb3c

... and things just go completely ga-ga from that point on.

p.