Subject: Re: XWindow

From: "Alan Chong" <[email-masked]>
Date: Tue, 4 May 2004 16:37:00 +0800

I was given the task to run X on brutus board. Wonder where are all the x
window system source code located ???

With regards

-----Original Message-----
From: Philip Blundell <[email-masked]>
To: Alan Chong <[email-masked]>
Cc: armLinux <[email-masked]>
Date: Thursday, May 04, 2000 4:04 PM
Subject: Re: XWindow

>In message <001401c43177$0a700800$a412420a@Nicodemus>, "Alan Chong" writes:
>>Hi !!! Has anyone ever include XWindow codes into the kernel ???
>
>I don't think so.  Why do you want to do this?
>
>p.
>
>
>
>

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Philip Blundell <[email-masked]>
Date: Thu, 04 May 2000 09:40:52 +0100

>window system source code located ???

You don't need to put X into the kernel to run it on Brutus.  You just need to 
install the X packages from (say) Debian, and find a copy of the XF86_FBDev 
server.

p.

---

From: [email-masked] (Jim Gettys)
Date: Thu, 4 May 2000 08:29:43 -0700 (PDT)

Yes.  It has been tried once.  I told the guilty parties they were crazy,
but they tried anyway.  As I expected, disaster ensued.

It has been proven to be a very bad idea.  X in the kernel is a BIG mistake.

The CPU is the same speed in the kernel as in a user process: you gain
nothing, and generate major problems (e.g. memory management).

X already runs on Arm just fine: (on Itsy, and another device we have).

XFree86 4.0a (the current development snapshot available to members of 
the XFree86 project) will cross compile out of the box on the fbdev driver.  
I sent some patches in on 4.0 to aid in cross compiling that are in 4.0a.

Size of the executable is about 600Kbytes (700K with symbols): Keith 
Packard's new frame buffer code is MUCH smaller than the code that has 
been used in the past.

To join the XFree86 project, see their web site at www.xfree86.org.
				- Jim Gettys

> Sender: [email-masked]
> From: "Alan Chong" <[email-masked]>
> Date: 	Tue, 4 May 2004 16:37:00 +0800
> To: "Philip Blundell" <[email-masked]>
> Cc: "armLinux" <[email-masked]>
> Subject: Re: XWindow
> -----

--
Jim Gettys
Technology and Corporate Development
Compaq Computer Corporation
[email-masked]