Subject: RE: Cross-compiling libc5 to arm-linux

From: Jeff Sutherland <[email-masked]>
Date: Wed, 3 May 2000 13:43:07 -0400

> In message <[email-masked]>, Nandana writes:
> >Has anybody tried to cross-compile  libc5 library ( not glibc ) on to
> >linux-arm flatform.
> >Is it possible at all.
> 
> Not without some porting effort.  I think this would be a 
> waste of time.  You 
> would do better to invest your work in reducing the footprint 
> of glibc if this 
> is important to you.
> 
> p.

Agreed.  BTW, for those interested in minimizing file sizes, I've found that
many of the Makefiles in the GNU sources run gcc with the -g switch
(debugging) turned on.  If you have no need to debug library routines or are
preparing production releases, be sure to turn this off.  It will make a
dramatic difference in the size of your executables.

//Jeff

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Nicolas Pitre <[email-masked]>
Date: Wed, 3 May 2000 15:02:47 -0400 (EDT)

> dramatic difference in the size of your executables.

Alternately you can 'strip' the resulting libraries which is probably
simpler to do.

Nicolas

---

From: Rod Stewart <[email-masked]>
Date: Wed, 3 May 2000 16:06:27 -0400 (EDT)

> dramatic difference in the size of your executables.

And if space is a really tight, you can build a non-versioned glibc.  Not
certain how much space this will save, but it should get you a few bytes
:)

-Rms