Subject: RE: booting kernel on SA1110

From: Jeff Sutherland <[email-masked]>
Date: Thu, 27 Apr 2000 16:49:42 -0400

> 	I'm using an uncompressed Image and loading to C0008000.
> 
> > Another possibility: If the Icache has not been enabled up 
> to now, turning
> > on the buffers and the Icache initiates an 8 word burst 
> transfer on the
> > memory buss.  If the memory timing is not set correctly, 
> especially when
> > using SDRAMs on the SA1110, or there are other signal 
> integrity issues, this
> > is a good time for things to blow up.  How do I know this???
> 
> 	Is it possible to test for this by NOT enabling the 
> Icache at this
> point in head-armv.S?  Or will that blow up for other reasons?
> 
> Thanks,
> Chris

Try inserting some debug code: Turn the Icache on without turning on the mmu
or enabling the buffers and see if you can still get output.  Then try
turning on the MMU but do not enable write buffer and Dcache*.  If you can't
survive turning on just the Icache with MMU off then don't waste time
fooling around with the MMU code because it's most likely you have a
hardware problem, or a software inspired hardware problem (bad hardware
setup in your bootloader).

//Jeff

*Consult the SA1110 manual or other suitable reference for legal
combinations of write buffer, data cache, and MMU bits (hint: there aren't
many...)

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: "Meng, David" <[email-masked]>
Date: Thu, 27 Apr 2000 17:47:42 -0700

>	I'm trying to get a kernel to boot on an SA1110 platform
>(development board with 64mb SDRAM).  I set up the memory configurations
>in mm/mm-sa1100.c and kernel/arch.c.  I pass architecture number 0x10 from
>the bootloader but it never gets out of head-armv.S.  I traced the problem
>to the instruction turning on the MMU:

>mcr     p15, 0, r0, c1, c0

>	At this point r0 = 0xc000517d; mmu, write buffer, and all caches
>on.  Is all of that really supposed to happen here?  Or is r0 getting
>incorrectly set in __create_page_tables?

If the error is undefined instuction, the reason is that the ARM is in the
user mode.  This coprocessor instruction is supposed to be used in
supervisor mode.
David Meng
____________________________________________________________
This is my personal opinion and not related to my employer.

---

From: Jeff Sutherland <[email-masked]>
Date: Fri, 28 Apr 2000 09:14:18 -0400

> On Thu, 27 Apr 2000, Jeff Sutherland wrote:
> 
> > issue with these fast low power processors.  Even on the 
> Intel Assabet
> > (SA1110 development platform) about 132MHz is all the 
> faster this thing will
> > run reliably day in and day out.  At faster speeds we 
> experience occasional
> > random lockups.  Happens to WindowsCE, too, so it's not just a Linux
> > thing...
> 
> Didn't happen to me in Linux even at 200MHz, so maybe it's a WindowsCE
> thing...   :-)
> 
> 
> Nicolas

You have an AssabetPlus, I take it?  Check your SDRAMs: if they're Toshiba,
you've got the Plus.  Samsung parts are on the older version.  Once I get
networking up and running I may try to push the speed limit up :)

//Jeff

---

From: George France <[email-masked]>
Date: Fri, 28 Apr 2000 11:52:33 -0400

I have compression in my boot loader for NetBSD, even though it is not
necessary for Linux. Maybe these people are doing the same.

--George

Russell King - ARM Linux Admin [mailto:[email-masked]] wrote:

What is the reason for having your own compression scheme built into your
boot loader?  It doesn't make sense when the kernel one is tried, tested
and proved to work.

Please explain why you thought it was a good idea.

---

From: George France <[email-masked]>
Date: Fri, 28 Apr 2000 11:53:55 -0400

Hello David;

Are you doing this big or little edian?

--George

-----Original Message-----
From: Meng, David [mailto:[email-masked]]
Sent: Thursday, April 27, 2000 8:48 PM
To: 'Chris Blazie'; [email-masked]
Subject: RE: booting kernel on SA1110

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for
++
++                        kernel-related discussions.
++

---

From: "Meng, David" <[email-masked]>
Date: Fri, 28 Apr 2000 16:29:28 -0700

Hi George:
I am doing little endian first.  I will do it in big endian.
Regards.
David

-----Original Message-----
From: George France [mailto:[email-masked]]
Sent: Friday, April 28, 2000 8:54 AM
To: 'Meng, David'; 'Chris Blazie'; [email-masked]
Subject: RE: booting kernel on SA1110

Hello David;

--George