Subject: boot from flash!!

From: "green" <[email-masked]>
Date: Sat, 11 Mar 2000 11:09:05 +0800

Dear all,
I want to boot my SA1100 mm-board from flash.
Can I use bios.1.0.6 ?? 
Becasue It seems to be made for EBSA-285.
What step should I do?? 
Thanks!!
================================================

                                   ^^ green in Lab.       ncku,Taiwan

---

From: Nicolas Pitre <[email-masked]>
Date: Sat, 11 Mar 2000 12:07:43 -0500 (EST)

> I want to boot my SA1100 mm-board from flash.

No.

For a SA1100 system, look at BLOB instead.

Nicolas

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Changho Seo <[email-masked]>
Date: Sun, 12 Mar 2000 18:18:36 +0900

> For a SA1100 system, look at BLOB instead.

What is BLOB?

---

From: Erik Mouw <[email-masked]>
Date: Sun, 12 Mar 2000 14:27:46 +0100 (MET)

>> For a SA1100 system, look at BLOB instead.

BLOB is the bootloader Jan-Derk Bakker and I wrote for the LART (see
signature). Adam Wiggins ported (read: changed one or two constants) it to
PLEB. Have a look at:

  http://www-ict.its.tudelft.nl/~erik/open-source/blob/

Erik

-- 
LART. 250 MIPS under one Watt.
http://www-ict.its.tudelft.nl/~erik/open-source/LART/

---

From: Chester <[email-masked]>
Date: Mon, 13 Mar 2000 11:55:24 +0800 (CST)

>   http://www-ict.its.tudelft.nl/~erik/open-source/blob/
	Go it!
	It can boot sa1100,but anybody have experiece on sa-1110 to
	use blob.
	
	BTW,how many choise when i want to boot from flash??
	blob,angelboot,...or something else.

	Thanks.
	
						Chester

---

From: Erik Mouw <[email-masked]>
Date: Mon, 13 Mar 2000 14:12:34 +0100 (MET)

On Mon, 13 Mar 2000 11:55:24 +0800 (CST), Chester wrote:
>> ... Have a look at:

Yes, we have experience with blob on LART, and Adam Wiggins has experience
with blob on PLEB.

>     blob,angelboot,...or something else.

I think that's all there is. Or write your own bootloader, but in that
case you'd better use blob as a starting point.

Erik

-- 
There was a point to this story, but it has temporarily escaped the
croniclers mind. -- Douglas Adams, The Hitch Hikers Guide to the Galaxy

---

From: Erik Mouw <[email-masked]>
Date: Tue, 14 Mar 2000 10:08:29 +0100 (MET)

> Yes, we have experience with blob on LART, and Adam Wiggins has experience

Oops! I hate to followup my own messages, but JDB told me to have another
look at the CPU model. Sorry for the bad information.

No, AFAIK nobody has experience using blob on a SA1110. It can't be too
difficult, though. The SA1110 is just an SA1100 with a different memory
controller and some silicon bugs fixed.

Erik %-)

-- 
Mar 14 10:07:58 linux kernel: lp0 printer error
Mar 14 10:07:58 linux kernel: lp0 on fire
  -- Linux kernel log