Subject: An error on building cross gcc

From: Changho Seo <[email-masked]>
Date: Tue, 14 Mar 2000 02:31:57 +0900

> Hi everyone..
>
> I tried to build a cross compiler on a Red Hat 6.1 (i686) system for
> strong arm target with binutils-2.9.5.0.27 and gcc-2.95.1.
>
> But I failed with following error message.
>
> configure --target=arm-linux --with-cpu=strongarm1100
> ...
>
> make [LANGUAGE=c]
> ...
>
> *************************************************************************
> rm -f tmplibgcc1.a libgcc1.S
> cp ./config/arm/lib1funcs.asm libgcc1.S
> for name in _udivsi3 _divsi3 _umodsi3 _modsi3 _dvmd_lnx; \
> do \
>   echo ${name}; \
>   /usr/local/src/gcc-2.95.1/gcc/xgcc -B/usr/local/src/gcc-2.95.1/gcc/
> -B/usr/local/arm-linux/bin/ -I/usr/local/arm-linux/include -O2  -DCROSS_COMPILE
> -DIN_GCC     -g -O2 -I./include  -fomit-frame-pointer -fPIC -g0
> -DHAVE_GTHR_DEFAULT -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED   -I. -I. -I./config
> -I./../include -c -DL${name} libgcc1.S; \
>   if [ $? -eq 0 ] ; then true; else exit 1; fi; \
>   mv libgcc1.o ${name}.o; \
>   arm-linux-ar rc tmplibgcc1.a ${name}.o; \
>   rm -f ${name}.o; \
> done
> _udivsi3
> _divsi3
> _umodsi3
> _modsi3
> _dvmd_lnx
> libgcc1.S:438: asm/unistd.h: can't find such a file or directory
> make[1]: *** [libgcc1-asm.a] Error 1
> make[1]: Leaving directory `/usr/local/src/gcc-2.95.1/gcc'
> make: *** [all-gcc] Error 2
> *************************************************************************
>
> Please help me. Thank you.
>
> Changho
>
> mailto:[email-masked]

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Erik Mouw <[email-masked]>
Date: Tue, 14 Mar 2000 09:52:24 +0100 (MET)

>> strong arm target with binutils-2.9.5.0.27 and gcc-2.95.1.

Please use gcc-2.95.2. It's the latest stable release.

>> libgcc1.S:438: asm/unistd.h: can't find such a file or directory

You forgot to install the linux kernel headers, or you did install them
but forgot to run "make config; make dep" in the kernel tree.

Erik

-- 
There was a point to this story, but it has temporarily escaped the
croniclers mind. -- Douglas Adams, The Hitch Hikers Guide to the Galaxy