Subject: Kernel can't find the ramdisk!!

From: "green" <[email-masked]>
Date: Mon, 6 Mar 2000 19:40:41 +0800

Hi all,

      The first question, I use angelboot to upload the kernel and 
ramdisk from nico ftp site to SA1100 multimedia development 
board. The minicom show the kernel panic "can't find ramdisk 
at start 0".

     And I upload the kernel and ramdisk to the board. I can't see
any the result on the minicom application. What kernel configure
should I choose? I use the kernel-2.2.12 with patch-2.2.12-rmk1
and diff-2.2.12-rmk1-np13, compiled with egcs-1.1.2.

    The second, nico use the kernel based on Linux 2.2.13 with patch
2.2.13-rmk and diff-2.2.13-rmk2-np14, compiled with egcs-1.1.1.
But I can't find the patch file for egcs-1.1.1. Where can I find it?
Or can I use egcs-1.1.2 to compile it??

Your advice is high appreciate!!
                                                                                            green

---

From: "ªü­õ" <[email-masked]>
Date: Mon, 6 Mar 2000 20:59:49 +0800

>and diff-2.2.12-rmk1-np13, compiled with egcs-1.1.2.

	diff-2.2.12-rmk1-np13 does not work on my Brutus, either.

	You can try diff-2.2.12-rmk1-np12.

-----------------------------------------------
Murphy Chen (陳正哲)
Design Engineer
Internet Embedded System Department
Computer & Communications Research Laboratories
Industrial Technology Research Institute
-----------------------------------------------

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Nicolas Pitre <[email-masked]>
Date: Mon, 6 Mar 2000 09:26:46 -0500 (EST)

> and diff-2.2.12-rmk1-np13, compiled with egcs-1.1.2.

Please try diff-2.2.14-rmk3-np15.  2.2.12-rmk1-np13 is broken.  Also see
Documentation/arm/SA1100/Brutus for the address where your ramdisk image
must be loaded.  It may have changed at that time.

> Or can I use egcs-1.1.2 to compile it??

egcs-1.1.2 should be fine.  Otherwise use gcc-2.95.x with 2.3.x kernels.

Nicolas