Subject: 主旨: Re: undefined reference to `__libc_global_ctors'

From: [email-masked]
Date: 4 Mar 2000 16:21:32 -0800

> >  After I successfully built binutils, gcc, and linux kernel,
> >  however, I encountered
> >
> >  " ../elf/ld-linux.so.2: undefined reference to `__libc_global_ctors' "
> >
> >  error messgae when I am building glibc for ARM!!
> 
> Get glibc 2.1.3.

  Thanks!! It now can be normally built.

  However, could you tell me why this error occurs??
  And if I meet the similar error again, what I can do
  to solve it?? Chagne another version of glibc or ...??

  Have a nice day!

  kirk

_______________________________________________________________
http://www.SINA.com - #1 Destination Site for Chinese Worldwide

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Philip Blundell <[email-masked]>
Date: Sun, 05 Mar 2000 09:30:31 +0000

>  However, could you tell me why this error occurs??

It's an incompatibility between the version of binutils you are using and 
older libcs.

p.