Subject: virt->phys mapping question

From: [email-masked]
Date: Fri, 10 Mar 2000 12:10:25

Hi,
Forgive me if this is a bit off-topic.
( I did skim the archives and could'nt
find what I wanted). Sorry again, if 
this is a beginner-ish question.

I want virt to phys page mappings for two 
flash banks (8Meg each) (the banks are
not physically adjacant) on an ep7211 based 
board.
Tried a loop of alloc_init_page() at PAGESIZE
increaments in setup_pagetables(). This works
for a limited number of mappings (but not
for the entire 2*8Meg).

Also what does alloc_init_section() do?

Thanks & Rgds,
Sreekrishnan V

 -------------------------------------------------------------------------------
Get a free mail address from http://www.indiainfo.com

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Fri, 10 Mar 2000 20:59:59 +0000 (GMT)

> for a limited number of mappings (but not

Don't do this.

> Also what does alloc_init_section() do?

Don't use that either.

Add an entry to the mapping tables ("MAPPING" in 2.2, or the io_desc
in 2.3).  The routines that scan these tables will then sort out the
page or section mappings as appropriate to achieve your required mapping
at the least cost to the TLB.

PS, this is a kernel question.  Please post such questions to the
linux-arm-kernel mailing list, details are on the web site.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |            http://www.arm.linux.org.uk/            /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |