Subject: Re: Can't complete build of ELF Glibc 2.1.2

From: [email-masked] (Steve Dicks)
Date: Sun, 06 Feb 2000 22:09:53 GMT

On Mon, 24 Jan 2000 09:43:08 +0000, [email-masked] said:

> In message <[email-masked]>, Steve Dicks writes:
> >I'm trying to produce an ELF version of glibc 2.1.2 (having sucessfully
> >built an ELF version of GCC) however I'm running out of memory during
> >some links. I think I need a static-linked version of ld for a.out systems
> >- is there one somewhere that I can grab, or do I have a different problem?
>
> I think Chris Rutter had a binary at one point.  You might find it easier to 
> install the Debian development packages which would give you native ELF tools,
> rather than trying to bootstrap them yourself.
>
Sorry to appear thick, but how do I do that? I can't find a copy of dpkg (which
I presume I need to install in .deb files) and I can't find how to upgrade my copy
of RPM either. I seem to need elf support for all the latest binaries, and most
of the available RPMs and SRPMs are in the later (RPM 2.5) format. Is there something
completely obvious that I'm missing here?

-- 
Steve Dicks - Starswan Systems Ltd
Hertfordshire's premier one-man Systems Consultancy

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: [email-masked]
Date: Sun, 6 Feb 2000 23:02:16 -0500

On Sun, Feb 06, 2000 at 10:09:53PM +0000, Steve Dicks wrote:
> Sorry to appear thick, but how do I do that? I can't find a copy of
> dpkg (which I presume I need to install in .deb files) and I can't find
> how to upgrade my copy of RPM either. I seem to need elf support for
> all the latest binaries, and most of the available RPMs and SRPMs are
> in the later (RPM 2.5) format. Is there something completely obvious
> that I'm missing here?

you can find dpkg on ftp.debian.org.  source is in
/debian/dists/potato/main/source/base/dpkg_1.6.7.tar.gz
binary is in /debian/dists/sid/main/binary-arm/base/dpkg_1.6.4.deb

you can unpack .deb archives with standard unix tools in fact.  they're
ar archives containing tars.