Subject: patching gcc

From: Philip Hall <[email-masked]>
Date: Fri, 11 Feb 2000 11:00:57 -0500

I am attempting to install gcc-2.95.2 on a netwinder.
I tried to patch it with
gcc-2.95.2-diff-991022
and several things happen.
1. all of the patches for ChangeLog fail.
all the patches for configure fail.

and patch doesn't seem to be able to find the files that need patching
so I must type int he names by hand when prompted.
What should be patch command be?
i use patch <../gcc-2.95.2-diff-991022 while in
the top level of gcc-2.95.2

what should I do about the failing hunks for configure?
Someone suggested i run autoconfig to rebuild configure, but
this only resulted in a zero length configure.

Thanks for any and all help.

phil

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Erik Mouw <[email-masked]>
Date: Fri, 11 Feb 2000 18:35:05 +0100 (MET)

> and several things happen.

Take Phil's newer gcc-2.95.3 patch, according to Phil it applies cleanly
against gcc-2.95.2.

> 1. all of the patches for ChangeLog fail.

Not important.

> all the patches for configure fail.

Hmm, strange. You do have patch 2.5? (use "patch -v" to find out)

> so I must type int he names by hand when prompted.

The files for gcc/cp/parse.[ch] are only in the full source. They are for
the C++ front-end. If you just have gcc-core, it's OK that they fail.

> the top level of gcc-2.95.2

It should be:

  tar zxvf gcc-2.95.2-core.tar.gz
  cd gcc-2.95.2
  patch -p0 < ../gcc-2.95.2-diff-991022

> what should I do about the failing hunks for configure?

They shouldn't fail. 

> this only resulted in a zero length configure.

It's autoconf, not autoconfig. You need a reasonably new autoconf version
(2.13 is the latest, AFAIK).

> Thanks for any and all help.

I'll check if I can get gcc-2.95.2 compiled on my Netwinder.

Erik

-- 
He had an odd feeling of being like a man in the act of adultery who
is surprised when the woman's husband wanders into the room, changes
his trousers, passes a few idle remarks about the weather and leaves
again. -- Douglas Adams, The Hitch Hikers Guide to the Galaxy

---

From: "Steven J. Hill" <[email-masked]>
Date: Fri, 11 Feb 2000 11:12:29 -0500

> Thanks for any and all help.
I had the same problem, so I created a new patch that works identically
to Phil's original patch. Give this a try, it should work great.

-Steve

---

From: Philip Blundell <[email-masked]>
Date: Fri, 11 Feb 2000 18:33:09 +0000

>the top level of gcc-2.95.2

You probably need to use -p0.

>this only resulted in a zero length configure.

Only run autoconf in a directory where there was actually a failed patch to 
`configure' -- ie gcc-2.95.2/gcc, but not gcc-2.95.2 itself.  The comments at 
the top of the latter configure file should explain why.

p.

---

From: Scott Bambrough <[email-masked]>
Date: Fri, 11 Feb 2000 17:32:10 -0500

> I am attempting to install gcc-2.95.2 on a netwinder.

I have made available my .rpms for gcc-2.95.2 at 

ftp://ftp.netwinder.org/user/s/scottb/current

They require use of binutils 2.9.5, which can be found in the same place.

I've been using this compiler for ~8 weeks now, and Rod has rebuilt the entire
build 15 distribution with it.  It seems solid.  If you can wait until Monday I
intend to update them with a set of updated patches.  Mine are somewhat
different than Phils.  For the inquisitive, who look in the SRPM, I have three
patches, the third is mostly equivalent to Phil's.  I still need to add the
scheduling fix from Jeff Law (the very last patch in Phil's latest diff).

Scott

-- 
Scott Bambrough - Software Engineer
REBEL.COM    http://www.rebel.com
NetWinder    http://www.netwinder.org