Subject: Cross-compiling XFree86 for ARM

From: "Saju Thomas" <[email-masked]>
Date: Fri, 04 Feb 2000 04:09:11 -0800

Hi,

I am facing problems in cross-compiling XFree86 for ARM Architecture. I followed the following steps:

1. Downloaded XFree86-3.3.3.1-36nw10.src.rpm and installed.
2. Extracted files from x333src-1.tgz (I want to build XServer only)
3. Applied the patch 3.3.3-3.3.3.1.diff
4. Applied the patch XFree86-3.3.3-sparc.patch
5. Applied the patch XFree86-3.3.3.1-arm.patch
6. Made changes in config files in xc/config/cf directory
to build XF86_Mono server only.
Now the problem is:

I am able to compile all necessary directories for X86_Mono Server except xc/program/Xserver/hw/xfree86/vga2/
In this directory, I am getting errors while handling .s files. I used cpp and arm-linux-as from arm tools to create *.i files and *.o files respectively from *.s files.
While using arm-linux-as, we get the error messages saying
that instructions in *.i files are not valid instuctions. I also varified that the instructions in *.i files are i386 instructions (which are created by cpp), not ARM instructions and thus the error.
We can see in XFree86-3.3.3.1-arm.patch that nothing is modified in any of the .s files by applying this patch.

Could any one help me to over come this error, please ???

Thanks in advance
Saju.
______________________________________________________________________
Get Visto.com!  Private groups, event calendars, email, and much more.  
Visto.com. Life on the Dot.
Check it out @ http://www.visto.com/info

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Philip Blundell <[email-masked]>
Date: Fri, 04 Feb 2000 12:29:42 +0000

>In this directory, I am getting errors while handling .s files. I used cpp and
> arm-linux-as from arm tools to create *.i files and *.o files respectively fr
>om *.s files.

You can't use the .S files for ARM.  You need to use the generic C 
implementation.

p.

---

From: Rod Stewart <[email-masked]>
Date: Fri, 4 Feb 2000 09:41:23 -0500 (EST)

> 1. Downloaded XFree86-3.3.3.1-36nw10.src.rpm and installed.

Just a note:  This version of XFree86 is very much NetWinder specific. The
only X server which we (Rebel.com) use reliably is XF86_SVGA.  I'm not
certain about the other ones (XF68_FBDev is broken, I believe).  You might
get further using the Debian version, I believe someone is "actively"
working on it.

> to build XF86_Mono server only.

As well I think you need to apply most/some of the other patches, as they
are needed to fix/address some issues.

Good luck,

-Rms