Subject: Building a cross compiler

From: Eric Engstrom <[email-masked]>
Date: Tue, 1 Feb 2000 22:02:20 -0800 (PST)

I'm trying to build a cross-compiler from x86 Linux to Arm Linux. However,
make dies with the error:

configure: error: installation or configuration problem: C compiler cannot
create executables.

First, I build binutils-2.9.1.0.25 (there seems to be no patches for
anything newer than 2.9.1.0.19a):

	cd binutils-2.9.1.0.25
	./configure --target=arm-linux --prefix=/usr/local
	make
	make install

	[/usr/local/arm-linux is created.]

I set up linux kernel 2.2.13, patch it with patch-2.2.13-rmk1.gz and
linux-2.2.13rmk1-cvs991228.diff.gz, config it (make xconfig), and make
dep. Then, I set the asm and linux links in /usr/local/arm-linux/include.

	tar -xyf linux-2.2.13.tar.bz2
	cd linux
	patch -p1 < ../patch-2.2.13.rmk1
	patch -p1 < ../linux-2.2.13rmk1-cvs991228.diff
	vi Makefile
		[change line: ARCH := $(shell ... to ARCH = arm]
	make mrproper
	make xconfig
		[select Footbridge, save & exit]
	make dep
	cd /usr/local/arm-linux
	mkdir include; cd include
	ln -s /usr/local/src/linux/include/asm-arm asm
	ln -s /usr/local/src/linux/include/linux linux

So far, so good. I then try to configure and build gcc as a cross
compiler, in /usr/local/src:

	tar -xyf egcs-1.1.2.tar.bz2
	cd egcs-1.1.2
	patch -p1 < ../egcs-1.1.2-arm-diff-990325
	cd ..
	mkdir egcs-build; cd egcs-build
	../egcs-1.1.2/configure --target=arm-linux --prefix=/usr/local
	make LANGUAGES="c" cross

	[make dies]

Any ideas?

Eric

Eric Engstrom, Computer Science, Cal Poly, SLO
[email-masked]
http://www.csc.calpoly.edu/~eengstro

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
This is a backup list for [email-masked], and the subscription
list is regularly synchronised.

---

From: Philip Blundell <[email-masked]>
Date: Wed, 02 Feb 2000 09:40:53 +0000

>configure: error: installation or configuration problem: C compiler cannot

In the target libiberty, right?  Check the mailing list archives, this has 
been discussed many times before.

>	../egcs-1.1.2/configure --target=arm-linux --prefix=/usr/local

Not that it's the cause of your problem, but you probably want to use gcc-2.95 
rather than egcs-1.1. 

p.