Subject: bios.bin problem

From: "¹éº´±â" <[email-masked]>
Date: Thu, 24 Feb 2000 19:57:33 KST

Hi all..

I have an ebsa285 with no angel.
I want to boot with bios-1.06.
My environments :
    binutils - 2.9.5.0.27(no patch)
    gcc - 2.95.1
    libc - 2.1.2
    PREFIX - arm-linux

I successfully install the tool-chain and make bios.elf.
 
My question is about arm-linux-objcopy.
I made a bios.bin to write bootrom using  "arm-linux-objcopy bios.elf bios.bin".
Then I wrote bios.bin at bootrom with rom writer.
But I can't boot , Nothing is coming in serial.
I don't know why bios.elf is same as bios.bin.......
 
Is there any other program to convert bios.elf to bios.bin which can be written at bootrom with ROMwriter?
 
Thank you.
 
ByungGi Baek.

==================================================
[email-masked] 
==================================================
No. 1 우리 인터넷, 다음
평생 쓰는 무료 E-mail 주소 한메일넷
지구촌 한글 검색서비스 Daum FIREBALL
http://www.daum.net

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Erik Mouw <[email-masked]>
Date: Thu, 24 Feb 2000 13:10:31 +0100 (MET)

> I don't know why bios.elf is same as bios.bin.......

Because objcopy defaults to ELF if you don't specify the output format you
want. In BLOB[1], we use:

  arm-linux-objcopy -O binary -R .note -R .comment -S bios.elf bios.bin

Objcopy supports many other formats; use "info objcopy" to find out.

Erik

[1] Boot Loader OBject, the LART bootloader, see
    http://www-ict.its.tudelft.nl/~erik/open-source/blob/

-- 
LART. 250 MIPS under one Watt.
http://www-ict.its.tudelft.nl/~erik/open-source/LART/

---

From: Nicolas Pitre <[email-masked]>
Date: Thu, 24 Feb 2000 10:21:45 -0500 (EST)

> I don't know why bios.elf is same as bios.bin.......

First, if you want to flash the bios at the beginning of your bootrom,
define the following in the Makefile:

	TEXTADDR        =0x41000080

Then issueing the 'make' command will finish with the 

	mkaif bios.elf bios

invocation.  The 'mkaif' tool is already included with the bios sources.
You should then flash the resulting "bios" file. That's all.

You can't use objcopy to convert ELF to binary here since .text and .data
section aren't quite contigous and objcopy'ing bios.elf to binary format
will create a +/- 1GB file !

Nicolas