Subject: GDB and ANGEL.

From: "Steven J. Hill" <[email-masked]>
Date: Wed, 02 Feb 2000 22:02:32 -0500

Greetings.

I have searched through the archives and found only one mention of using
GDB and ANGEL for kernel debugging. It appears that it is not possible to
utilize GDB and ANGEL for this purpose. The only other way mentioned was
to buy an ICE and use 'printk'. Surely there has to be a better method than
this? Does anyone have a better methodology? Thanks in advance.

-Steve

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: George France <[email-masked]>
Date: Thu, 3 Feb 2000 11:57:05 -0500

Hello Steve;

First get gdb-4.18, it supports the ARM architecture.  It contains a file
called remote-rdi.c that can be incorporated into your system for remote
kernel debugging.  If you have further questions you will need the experts
from the gdb mailing lists.

--George

George France,      [email-masked]
Cambridge Research Laboratory, Compaq Computer Corporation
One Kendall Square, Building 700     MS: CRL
Cambridge, MA 02139 USA

-----Original Message-----
From: Steven J. Hill [mailto:[email-masked]]
Sent: Wednesday, February 02, 2000 10:03 PM
To: [email-masked]
Subject: GDB and ANGEL.

Greetings.

-Steve

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for
++
++                        kernel-related discussions.
++