Subject: RE: How to config gdb-4.18 to debug ARM code ?

From: George France <[email-masked]>
Date: Fri, 11 Feb 2000 10:27:40 -0500

Hello Kevin;
 
Ptrace was not implemented in the ARM kernel.  So you probably need to patch
your kernel.  You will have to write your own ptrace code or I will send you
my Strong-ARM ptrace patch for linux 2.2.14 and you can make any
modifications you need from that point.  After you patch your kernel then.
 
1) You could run gdbserver on your ARM system.
 
2) You could write a gdb stub program for the ARM processor.
 
3)  Some ARM architecures can use the gdb programs remote-rdi.c or
remote-dp.c. It just depends on your system.

Good Luck in your efforts,

--George
George France,      [email-masked] 
Cambridge Research Laboratory, Compaq Computer Corporation 
One Kendall Square, Building 700     MS: CRL 
Cambridge, MA 02139 USA 

-----Original Message-----[George France] ;l 
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, February 10, 2000 8:28 PM
To: linux-arm
Subject: How to config gdb-4.18 to debug ARM code ?

Hello all ,
 
I got gdb-4.18 ,but I don't how to configure and make gdb-4.18 and then I
could debug my ARM code.
My host is i586 ,
My target is arm.
 
Regards,
Kevin.

---

From: Scott Bambrough <[email-masked]>
Date: Fri, 11 Feb 2000 17:14:40 -0500

>From Kevin:
> could debug my ARM code.  My host is i586, My target is arm.

>From Georgd France:      
 
>    remote-dp.c. It just depends on your system.

I don't understand what is going on here.  Ptrace is implemented in the ARM
kernel, at least as early as has been since 2.0.31.  It is certainly in the 2.2
kernels, cause I use it in GDB.  There have been bugs in the ptrace
implementation, but these have been identified and fixed.  It should work fine.

The GDB in CVS at sourceware.cygnus.com has support for ARM Linux, and a variety
of embedded platforms.  I've never configured for any of the embedded stuff
however.  The released 4.18 code has no support for ARM Linux however, you need
to get it from the CVS tree.

What kind of ARM target are you interested in?

Scott

-- 
Scott Bambrough - Software Engineer
REBEL.COM    http://www.rebel.com
NetWinder    http://www.netwinder.org

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++