Subject: Configuring GDB - PC host EBSA285 target

From: "Paul Robertson" <[email-masked]>
Date: Mon, 29 Nov 1999 16:29:38 -0000

I'd like to use GDB for cross-debugging Linux applications on EBSA-285.

What "stub" is needed/recommended for the target?
Are there any guidelines on the net for configuring and building the GDB host. The host is a PC (x86)

Thanks,

Paul Robertson
LocSoft Limited
"The key to your embedded solutions"
www.locsoft.com
Phone +44 (0) 1793 432557 
Fax     +44 (0) 1793 432727

---

From: Gaixia Zhang <[email-masked]>
Date: Mon, 29 Nov 1999 19:44:32 -0600

On the target side, the debugging stub these three subroutines:
set_debug_traps;
handle_exception; breakpoint.

You need to provide:
    int getDebugChar();
    void putDebugChar(int);
    void exceptionHandler (int exception_number, void
*exception_address);
    void flush_i_cache();
    void *memset(void *, int, int).

You can check
ftp://ftp.netwinder.org/users/s/scottb/public_html/gdb/gdb_toc.html
for more info,

I am still wondering if there is someone really using gdb stub for
kernel/module
debugging on ARM?

Best wishes,
Gaixia

>Are there any guidelines on the net for configuring and building the
GDB host.
>The host is a PC (x86)

__________________________________________
NetZero - Defenders of the Free World
Get your FREE Internet Access and Email at
http://www.netzero.net/download/index.html

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++