Subject: BIOS: only crt0.S + kernel from flash (w/o pci stuff)

From: Gaixia Zhang <[email-masked]>
Date: Tue, 02 Nov 1999 19:43:33 -0600

Hi, I make a small modification to Russell's loader.
Right before
    bl    SYMBOL_NAME(start_main)
do
    memcpy fetching kernel from flash
    zero param page
    r0=0, r1=4
    jump to kernel
I got "Uncompressing Linuix ... done", "Now booting the
kernel", then hangs,

The difference I can see is that that Russell has cli() before
pci_init(), and sti() before boot_kernel(), and he fills in
param page. Should I see more message comes out on
the serial port?

The problem is I can write to UART (4200 0000) right
before the line turning on MMU, but right after the line,
I can't write to UART (fe00 0000). Should I?

Thank you very much for your help,
Gaixia

__________________________________________
NetZero - Defenders of the Free World
Get your FREE Internet Access and Email at
http://www.netzero.net/download/index.html
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Wed, 3 Nov 1999 15:36:08 +0000 (GMT)

> param page. Should I see more message comes out on

Beware - the sti() and cli() refer to the state of the I-bit in
the StrongARM, which is the reverse of the meaning in the x86 code.

> I can't write to UART (fe00 0000). Should I?

Yes you should.  This tends to indicate that it's not making it
into the code after the MMU switch.  I trust that you're using
a recent 2.2 or 2.3 kernel?
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.linux.org.uk/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]