Subject: ELF to AIF utility

From: "Paul Robertson" <[email-masked]>
Date: Fri, 12 Nov 1999 10:27:23 -0000

Hi,

I have a utility (part of Russell King's bios 1.05) called mkaif, which converts ARM-ELF binaries to ARM Image Format.
If I try to use it on an uncompressed Linux kernel it fails after the first section "Missing data section!"

How do I determine if this is a problem with the ELF header or with mkaif ?

Is there an alternative to mkaif ?

Paul Robertson
LocSoft Limited
"The key to your embedded solutions"
www.locsoft.com
Phone +44 (0) 1793 432557 
Fax     +44 (0) 1793 432727

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Fri, 12 Nov 1999 12:44:45 +0000 (GMT)

Paul Robertson writes:
> I have a utility (part of Russell King's bios 1.05) called mkaif, which
> converts ARM-ELF binaries to ARM Image Format.

mkaif was only designed to be used with the resulting image from the bios,
however, if someone does fix it to work with the kernel, please feed back
the changes to me.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.linux.org.uk/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Philip Blundell <[email-masked]>
Date: Fri, 12 Nov 1999 20:26:30 +0000

>How do I determine if this is a problem with the ELF header or with

Objdump will show you the ELF headers.

>Is there an alternative to mkaif ?

Depends what you want it for.  `objcopy -O binary' might do the trick.

p.