Subject: Angelboot trouble

From: "Per Borgentun (Pilotfish)" <[email-masked]>
Date: Wed, 24 Nov 1999 18:03:31 +0100

Hello,

I'm trying to download the test programs that are available on 
Intels developer site and have some trouble with angelboot.

Downloading the programs to our Brutus card with Arm SDT 2.10
works fine.

Downloading with Angelboot does not work at all.
I include a verbose output of angelboot. 
i dowloaded angelboot from ftp://ftp.netwinder.org/users/n/nico/
and are running RedHat 5.2 on a PII host machine.

Any help/hints would be appreciated.

//Per B
[email-masked]

---8<----SNIP---8<----------

#> angelboot/angelboot -v -f angelboot/opts.axf bounce.axf

serial device   = /dev/ttyS0
serial options  = 9600 8N1
baud rate       = 9600
image file      = bounce.axf
image size      = 0x00000000
image offset    = 0x00000000
base address    = 0x00008000
entry address   = 0xc0008000
r0              = 00000000
r1              = 00000000
r2              = 00000000
r3              = 00000000
other image file        = (null)
other image size        = 0x00000000
other base address      = 0x00000000
Negotiating...([2d] bytes in reply message)
Issuing 'ping'...([1c] bytes in reply message)
Issue reset...([20] bytes in reply message)
([4dd3] bytes in reply message)
Initialising execution environment.
Error: Received wrong # bytes (-19668) when expecting packet.Downloading
image size 0x30c4 to 0x8000
Error: Received wrong # bytes (-19668) when expecting packet..Error:
Received wrong # bytes (-19668) when expecting packet..Error: Received
wrong # bytes (-19668) when expecting packet..Error: Received wrong #
bytes (-19668) when expecting packet..Error: Received wrong # bytes
(-19668) when expecting packet..Error: Received wrong # bytes (-19668)
when expecting packet..Error: Received wrong # bytes (-19668) when
expecting packet..

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
++        Please use [email-masked] for           ++
++                        kernel-related discussions.                      ++

---

From: Per Borgentun <[email-masked]>
Date: Thu, 25 Nov 1999 16:18:32 +0100

> Downloading with Angelboot does not work at all.

  Well after increasing the MAXBUF size in angel_io.c to 1024 
  I was able to download the bounce.axf program but none of the 
  other test programs (tick.axf or keyboard.axf among others)
  They download ok but doesn't seem to start running.
  The only difference I can see is that bounce is smaller than
  16 kB and all the other are bigger than 16 kB but that shouln't
  be any problem or ?
  Have anyone experienced this before ?

 I include the opts file that I'm using.
 
//Per Borgentun  -  [email-masked]

---8<-- angelboot opts-file  
base  0xc0008000
entry 0xc0008000
device /dev/ttyS0
options "9600 8N1"
baud 9600

---

From: Per Borgentun <[email-masked]>
Date: Fri, 26 Nov 1999 16:28:15 +0100

Hello again,
after two days of trying to download linux with angelboot
I am stuck. The only program I am able to download is 'bounce.axf',
none of the other test programs wants to run after they have been 
downloaded (the led display still shows 3).

All test programs have successfully been downloaded with
ARM SDT 2.10 running WinNT.

Can someone please send me a 'stty < /dev/ttyS0' and a 
'setserial -a /dev/ttyS0' output after they
successfully have downloaded a program to the brutus board.
so that I can see thet it isnt't my serial port that has
wrong setup.

How (if possible) can I download the ramdisk-image with the
ARM SDT debugger, I have been able to download the linux
'Image' file (uncompressed) but it doesn't like the 
ramdisk file, and how do I specify the address to put the
ramdisk ? 

Thank you.

---

From: Vasant Ramasubramanian <[email-masked]>
Date: Fri, 26 Nov 1999 19:24:55 -0600 (CST)

> downloaded (the led display still shows 3).

This maybe a bit obvious, but are you sure the swtiches on Brutus are set
properly? There is a mistake in the Intel documentation and swtich 14
should be NO DOT (DRAM). Note on a clean reset, the numeric LED display
shouldn't display anything.

Which ramdisk image are you using? The perfered one for Brutus I belive is
the one from Zsolt Kiraly. If you don't have this, I can send a working
ramdisk.gz & 2.2.12 kernel with sound and video support for Brutus; 
Nicolas P. has compiled a nice patch & script that makes compiling the
kernel for Brutus much easier (all the correct default options are choosen
and such by the script). Use the np12 patch, the np13 doesn't seem to
work (yet). 

> so that I can see thet it isnt't my serial port that has

After bootstrapping my kernel and loading the ramdisk this is what I got.

stty on cua0 gave me:

speed 115200 baud; line = 0;
min = 32; time = 1;
ignbrk -brkint -icrnl ixoff -imaxbel
-opost
-isig -icanon -echo -echoe -echok

setserial gave me
 Line 0, UART: 16550A, Port: 0x03f8, IRQ: 4
	Baud_base: 115200, close_delay: 50, divisor: 0
	closing_wait: 3000, closing_wait2: infinte
	Flags: spd_normal skip_test

My Angelboot opts file is:

base 0x8000
entry 0xc0008020
device /dev/ttyS0
options "9600 8N1" 
baud 115200
otherfile ramdisk.gz
otherbase 0x800000 

My go script is:
#!/bin/sh

#arm-linuxaout-strip linux/vmlinux

angelboot/angelboot -f opts /home/dfer/armbuild/linux/arch/arm/boot/zImage

I used the Intel document for setting up my Brutus board for Linux

developer.intel.com/design/strong (application notes, Linux on the SA-1100
platform).

There was a mistake in setting up glibc I believe but it's correct for the
rest...

I can send my Angelboot program / my working Linux kernel / working
ramdisk.gz image if need be.

Check :
ftp://ssdl-redstone.stanford.edu/pub/ramdisk.gz for the Ramdisk image
that's I'm using / works well...

> ramdisk file, and how do I specify the address to put the

If you find out, I'd like to know too.

Good luck and make sure Brutus doesn't betray you too =).

Vasant.