Subject: question on gcc-2.95.1 build

From: "Marc D. Bumble" <[email-masked]>
Date: Mon, 13 Sep 1999 11:13:52 -0400

Hi,

Any help would be greatly appreciated.  

In a  build attempt of a  i686 to arm-linux  gcc-2.95.1 cross compiler, I  get a
build with pretty much no errors or warnings, except at the end when I get:

checking whether the C compiler (/usr/local/arm-linux/src/gcc-2.95.1/arm-objdir/gcc/xgcc \
	 -B/usr/local/arm-linux/src/gcc-2.95.1/arm-objdir/gcc/ \
	 -B/usr/local/arm-linux/arm-linux/bin/ -g -O2 ) works... no

Is this error significant  in a cross-compiler?  I'm not sure.  Can anyone tell me what
I'm doing incorrectly?  There is an abbreviated build description below.

When I go on to attempt the glibc build, that fails, but I'm not sure if I have a
problem with  the gcc  compiler or whether  my problems  lie in the  glibc build
itself.

The only spurious warnings I get when compiling gcc are of the nature:

    ../../gcc/config/arm/arm.c: In function `arm_override_options':
    ../../gcc/config/arm/arm.c:285: warning: assignment discards `const' \
				    from pointer target type

or :

   cc1plus: warning: -g with -fomit-frame-pointer may not give sensible debugging

other than that, no problems and it compiles.

I first built binutils-2.9.4.0.6 with:

      ../configure --target=arm-linux --prefix=/usr/local/arm-linux
      gmake > build.log 2>&1
      gmake install > install.log 2>&1

Then I  installed kernel headers  for linux-2.2.12 with  patch patch-2.2.12-rmk1
and    created    links    for     the    include    header    files    to    my
/usr/local/arm-linux/include.

Next, I compiled gcc-2.95.1 with:

      export LD_LIBRARY_PATH=/usr/local/arm-linux/lib
      export LD_RUN_PATH=/usr/local/arm-linux/lib
      ../configure --target=arm-linux --prefix=/usr/local/arm-linux -v > config.log 2>&1
      gmake LANGUAGES="c" > build.log 2>&1

At the end it of the compilation, I get:

gmake[2]: Leaving directory `/usr/local/arm-linux/src/gcc-2.95.1/arm-objdir/gcc'
Configuring in arm-linux/libiberty
loading cache ./config.cache
checking host system type... arm-unknown-linux-gnu
checking build system type... i686-pc-linux-gnu
checking for arm-linux-ar... arm-linux-ar
checking for arm-linux-ranlib... arm-linux-ranlib
checking for gcc... /usr/local/arm-linux/src/gcc-2.95.1/arm-objdir/gcc/xgcc -B/usr/local/arm-linux/src/gcc-2.95.1/arm-objdir/gcc/ -B/usr/local/arm-linux/arm-linux/bin/
checking whether we are using GNU C... yes
checking whether /usr/local/arm-linux/src/gcc-2.95.1/arm-objdir/gcc/xgcc -B/usr/local/arm-linux/src/gcc-2.95.1/arm-objdir/gcc/ -B/usr/local/arm-linux/arm-linux/bin/ accepts -g... yes
checking for POSIXized ISC... no
checking for a BSD compatible install... /bin/sh /usr/local/arm-linux/src/gcc-2.95.1/install-sh -c
xhost-mkfrag is unchanged
checking how to run the C preprocessor... /lib/cpp
checking for sys/file.h... yes
checking for sys/param.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for unistd.h... yes
checking for strings.h... yes
checking for sys/time.h... yes
checking for sys/resource.h... yes
checking for sys/wait.h that is POSIX.1 compatible... no
checking whether the C compiler (/usr/local/arm-linux/src/gcc-2.95.1/arm-objdir/gcc/xgcc -B/usr/local/arm-linux/src/gcc-2.95.1/arm-objdir/gcc/ -B/usr/local/arm-linux/arm-linux/bin/ -g -O2 ) works... no
configure: error: installation or configuration problem: C compiler cannot create executables.
gmake[2]: Entering directory `/usr/local/arm-linux/src/gcc-2.95.1/arm-objdir/arm-linux/libio'
test x"no" != xyes ||\
  /usr/local/arm-linux/src/gcc-2.95.1/arm-objdir/gcc/xgcc -B/usr/local/arm-linux/src/gcc-2.95.1/arm-objdir/gcc/ -B/usr/local/arm-linux/arm-linux/bin/ -c -g -O2 -I. -I../../../libio -D_IO_MTSAFE_IO  ../../../libio/iogetline.c -o pic/iogetline.o
/usr/local/arm-linux/src/gcc-2.95.1/arm-objdir/gcc/xgcc -B/usr/local/arm-linux/src/gcc-2.95.1/arm-objdir/gcc/ -B/usr/local/arm-linux/arm-linux/bin/ -c -g -O2 -I. -I../../../libio -D_IO_MTSAFE_IO ../../../libio/iogetline.c
In file included from ../../../libio/iogetline.c:26:
../../../libio/libioP.h:30: errno.h: No such file or directory
In file included from ../../../libio/iolibio.h:1,
                 from ../../../libio/libioP.h:47,
                 from ../../../libio/iogetline.c:26:
../../../libio/libio.h:30: _G_config.h: No such file or directory
../../../libio/iogetline.c:27: string.h: No such file or directory
gmake[2]: *** [iogetline.o] Error 1
gmake[2]: Leaving directory `/usr/local/arm-linux/src/gcc-2.95.1/arm-objdir/arm-linux/libio'
gmake[1]: *** [all-target-libio] Error 2
gmake[1]: Leaving directory `/usr/local/arm-linux/src/gcc-2.95.1/arm-objdir'
gmake: *** [cross] Error 2

Thanks for any assistance,

marc

-- 

/++++++++++++++++++++++++++++++++++++++/

Marc Bumble	phone:	 (617) 796-2540
		fax:	 (617) 965-8342

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Mon, 13 Sep 1999 19:19:26 +0100

>	 -B/usr/local/arm-linux/arm-linux/bin/ -g -O2 ) works... no

That is expected; you haven't yet installed the target C runtime library.

>When I go on to attempt the glibc build, that fails,

What problem do you have here?

>   cc1plus: warning: -g with -fomit-frame-pointer may not give sensible debugg

You can ignore both of these, they are harmless.

p.