Subject: building Arm-linux kernel

From: [email-masked]
Date: Fri, 10 Sep 1999 11:23:29 +0800

Hello,

I wonder if anyone could help me with this building error.

While doing: make zImage, I encounter Make errors. 
In file: fault-common.c, it state that many variables are defined but not
used. And ended with Make error messages. 

I followed the procedure on the Intel strongarm website [to build the arm
linux kernel]
for my brutus board. 

Would appreciate if you could let me know whether this is serious and how to 
overcome this.

- jessica

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: [email-masked]
Date: Fri, 10 Sep 1999 13:12:46 +0800

Sorry; But to add to my previous mail. T
These are the versions of sources I use:

1)
binutils_2_9_1_0_19a_orig_tar
binutils-2_9_1_0_19a-arm-diff-981230

2)
egcs-1_1_1_tar
egcs-1_1_2-arm-diff-990325

3)
glibc-2_1_tar
glibc-crypt-2_0_109_tar
glibc-linuxthreads-2_1_tar

4)
linux-2_2_10_tar
patch-2_2_10-rmk2
diff-2_2_10-rmk2-np11

I had errors building while patching egcs-1_1_2-arm-diff-990325.
gcc/config.rej file exist but the error message gave [ignored] note.
I use egcs-1_1_2-arm-diff-990325 because I couldn't find the 
egcs-1_1_1-arm-diff-xxxxxx version !

Hope this helps. Any idea what went wrong ?

- jessica

---

From: Nicolas Pitre <[email-masked]>
Date: Fri, 10 Sep 1999 10:11:33 -0400 (EDT)

> These are the versions of sources I use:
[...]
> diff-2_2_10-rmk2-np11

For the np11 patch, there is a cut'n paste mistake I left there
unfortunately.  In arch/arm/mm/fault-common.c line 155, there is a printk
with its string truncated.  You must put a closing quote at the end of the
line.

I'll be releasing another diff soon.  But in the mean time, fixing the
above error should do.

Also issueing a "make brutus_config" prior to all other make commands will
help you a lot to have a good kernel configuration.

Nicolas