Subject: ARMLinux and SCSI interface

From: Marco Suzzi <[email-masked]>
Date: Fri, 10 Sep 1999 01:15:47 +0000

Hi,
I would like to install ARMLinux on my RiscPC.
I read Paul Vigay's guide, other guides and FAQs and I hope
I understood them well (my English is not good) but I had
few problems.

My hardware is:

RiscPC 700 + StrongARM 40Mb RAM 2 Mb VRAM 
Acorn IDE controller + 1.6 Gb HD + CD-ROM 4x
Eesox 'fast' SCSI-2 interface + 4Gb HD
Acorn 586 card second processor.

I would like to install ARMLinux on 4GB SCSI HD.
First I used Eesox's !SDirector to create partitions but every 
partition becames a RISCOS (od DOSFS) drive on the icon bar ...

Second I tried Partition Manager 1.11 to partition but it can only see
partitions made before and pressing MENU button on it, "New ..." field
is always disabled (I can't add a new partition).

Then I thought to load ARMLinux from root & supplemental disks and 
use fdisk to partition HD but here I surprised.

I run !LinuxBoot to load kernel rpc-2.0.36-1999.05.29 then root disk 
root-rpc-1999.05.29 and supplemental disk supplemental-1999.05.29.

Loading messages shows ...

<...>
Probing expansion cards
0:   [0064:008C] 'Fast' SCSI-2 Interface card
<...>
scsi : 0  hosts.
scsi : detected total.
<...>

In "Hardware configuration" I choose [ADD],
  in "Hardware type" I select "SCSI adapters" and [NEXT],
    in "SCSI drivers" I choose "EESOX SCSI" and [TRY],
      in "Module options" I choose "Specify options" and [OK],
        in "Module parameters" I set "Termination" field to "term=0"
        and no value in "Miscellaneous options" and [OK]

Then machine hang and I have to reset.

OK, this is my story.
can anybody suggest me how solve this problem ?

Thanks,
-- 
Marco Suzzi
[email-masked]

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Fri, 10 Sep 1999 07:09:51 +0100 (BST)

> is always disabled (I can't add a new partition).

Have you tried the latest alpha partition manager? (can be found
on ftp://ftp.arm.linux.org.uk:/pub/armlinux/testing/).  Have you
tried creating a partition using !SDirector, and then using the
partition manager?

> Then machine hang and I have to reset.

Can you describe your SCSI card, and which kernel version you are
using (both normal x.x.xx and date as well).
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.linux.org.uk/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]