Subject: Re: question on gcc-2.95.1 build

From: "Marc D. Bumble" <[email-masked]>
Date: Mon, 13 Sep 1999 16:04:49 -0400

Hi Philip,
>> "Philip" == Philip Blundell <[email-masked]> writes:

  >> When I go on to attempt the glibc build, that fails,

  > What problem do you have here?

Thanks  for the  reply,  and thanks  in advance  for  any assistance  with the  glibc
problem.  i  believe you have  answered two very  significant questions for  me.  Its
nice to  know my compiler is  basically okay, and  my problem is apparently  with the
glibc build.

At the moment,  my glibc build is  seeking the ld.so.map file in  my build directory,
but it isn't there:

/usr/local/arm-linux/arm-linux/bin/ld: cannot open linker script file \
	/usr/local/arm-linux/src/glibc-2.1.2/arm-objdir/ld.so.map: No \
	such file or directory

In the build compilation context, it looks like:

cd /usr/local/arm-linux/src/glibc-2.1.2/arm-objdir && /usr/local/arm-linux/arm-linux/bin/ar cruv libc_pic.a `cat csu/stamp.os assert/stamp.os ctype/stamp.os db/stamp.os db2/stamp.os locale/stamp.os intl/stamp.os catgets/stamp.os math/stamp.os setjmp/stamp.os signal/stamp.os stdlib/stamp.os stdio-common/stamp.os libio/stamp.os malloc/stamp.os string/stamp.os wcsmbs/stamp.os time/stamp.os dirent/stamp.os grp/stamp.os pwd/stamp.os posix/stamp.os io/stamp.os termios/stamp.os resource/stamp.os misc/stamp.os socket/stamp.os sysvipc/stamp.os gmon/stamp.os gnulib/stamp.os iconv/stamp.os iconvdata/stamp.os wctype/stamp.os manual/stamp.os shadow/stamp.os md5-crypt/stamp.os po/stamp.os argp/stamp.os crypt/stamp.os linuxthreads/stamp.os resolv/stamp.os nss/stamp.os localedata/stamp.os timezone/stamp.os rt/stamp.os debug/stamp.os inet/stamp.os hesiod/stamp.os sunrpc/stamp.os nis/stamp.os nscd/stamp.os streams/stamp.os login/stamp.os elf/stamp.os stamp.os`
a - csu/init-first.os
a - csu/libc-start.os
a - csu/set-init.os
a - csu/sysdep.os
a - csu/version.os

lots more a - */*.os

a - elf/dl-symbol.os
a - elf/dl-addr.os
a - elf/dl-profstub.os
a - elf/dl-origin.os
: /usr/local/arm-linux/src/glibc-2.1.2/arm-objdir/libc_pic.a
arm-linux-gcc -B/usr/local/arm-linux/bin/   -nostdlib -nostartfiles -r -o /usr/local/arm-linux/src/glibc-2.1.2/arm-objdir/elf/librtld.os '-Wl,-(' /usr/local/arm-linux/src/glibc-2.1.2/arm-objdir/elf/dl-allobjs.os /usr/local/arm-linux/src/glibc-2.1.2/arm-objdir/libc_pic.a -lgcc '-Wl,-)'
arm-linux-gcc: file path prefix `/usr/local/arm-linux/bin/' never used
arm-linux-gcc -B/usr/local/arm-linux/bin/   -nostdlib -nostartfiles -shared -o /usr/local/arm-linux/src/glibc-2.1.2/arm-objdir/elf/ld.so  \
	  /usr/local/arm-linux/src/glibc-2.1.2/arm-objdir/elf/librtld.os		\
	  -Wl,--version-script=/usr/local/arm-linux/src/glibc-2.1.2/arm-objdir/ld.so.map -Wl,-soname=ld-linux.so.2
/usr/local/arm-linux/arm-linux/bin/ld: cannot open linker script file /usr/local/arm-linux/src/glibc-2.1.2/arm-objdir/ld.so.map: No such file or directory
collect2: ld returned 1 exit status
arm-linux-gcc: file path prefix `/usr/local/arm-linux/bin/' never used
gmake[2]: *** [/usr/local/arm-linux/src/glibc-2.1.2/arm-objdir/elf/ld.so] Error 1
gmake[2]: Leaving directory `/usr/local/arm-linux/src/glibc-2.1.2/elf'
gmake[1]: *** [elf/subdir_lib] Error 2
gmake[1]: Leaving directory `/usr/local/arm-linux/src/glibc-2.1.2'
gmake: *** [all] Error 2

marc

-- 

/++++++++++++++++++++++++++++++++++++++/

Marc Bumble	phone:	 (617) 796-2540
		fax:	 (617) 965-8342

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Mon, 13 Sep 1999 21:18:13 +0100

>At the moment,  my glibc build is  seeking the ld.so.map file in  my build 
>directory, but it isn't there:
>

A similar problem has been reported by some people on other platforms, but I 
don't think anybody has worked out the cause (or a cure) yet.  The best guess 
so far seems to be that it might be due to a buggy version of awk or some 
other tool.  It seems to have occurred suddenly in glibc 2.1.2, so you could 
try going back to 2.1.1 and see if that works any better.  Alternatively I 
think you will have to investigate the Makefiles and try to figure out why the 
*.map files are not being correctly built.

p.