Subject: gdb-stub for EBSA285

From: Gaixia Zhang <[email-masked]>
Date: Wed, 29 Sep 1999 18:55:31 -0500

Hi, Thank you all for your help recently. Have a question
about gdb-stub for EBSA285:

To do kernel/module debugging, Except "always printk",
Is there a gdb-stub for EBSA285 available for us to
download?

Is it possible to use Angel ARM romote debugger to do
do kernel/module debugging? It just seems stranget to me,
anybody ever tried to use it?

Thanks again,
Gaixai Zhang

________________________________________________________
NetZero - We believe in a FREE Internet.  Shouldn't you?
Get your FREE Internet Access and Email at
http://www.netzero.net/download/index.html
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: David Rusling <[email-masked]>
Date: Thu, 30 Sep 1999 09:14:25 +0100

Gaixai,

> about gdb-stub for EBSA285:

I must admit to never having used it.

> anybody ever tried to use it?

No, it is not possible to use Angel - it runs with a different address
map and is not transparent enough.   The ARM kernel work that I'm doing
is (mostly) on ARM720/920 and I'm using Multi-ICE and printk().

--
----------------------------------------------------------------------
David A Rusling   Consulting Engineer
    ARM Limited
    Liberty House,
    Moorbridge Road,
    Maidenhead, SL6 8LT

    Tel: UK-(0)1628-427754
    Fax: UK-(0)1628-780551
    e-mail: [email-masked]
----------------------------------------------------------------------