Subject: Problems configuring gcc-2.95 (was: RE: This time it's gcc...)

From: "Vater, Thomas" <[email-masked]>
Date: Thu, 5 Aug 1999 08:20:05 +0200

> Post a transcript of the actual commands you type and the 
> error messages; 
> without that it's hard to guess what might be wrong.  As I 
> said to Jan-Uwe, 
> you must configure at the top level, not in the gcc subdirectory.

Ok then, here's what I did (actually not much):

1. extracted gcc-2.95.tar.gz from gnu.org
2. cd gcc-2.95
3. applied your patch with: patch -p0 < ../gcc-2.95-diff-990730 
	(reports some Hunk #x succeeded at xxxxx, no rejects)
4. ./configure arm-linux --prefix=/arm-tools 

This reported the following:

Created "Makefile" in /usr/src/gcc-2.95 using "mt-frag"
Cannot find the GNU C library minor version number.

The machine I'm running on is a RISC PC with a stock ARM Linux installation
from ftp.arm.linux.org.uk and a home-made 2.0.35 kernel.
I might add that I compiled and installed binutils (2.9.1.0.22 I think, not
sure) successfully into /arm-tools before.

Any help and suggestions are greatly welcome.
Thanks.

Thomas

> 
> p.
> 
> 
> unsubscribe: body of `unsubscribe linux-arm' to 
> [email-masked]
> 
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Thu, 05 Aug 1999 10:48:07 +0100

>Cannot find the GNU C library minor version number.

Ugh.  The problem is that you are configuring as a native compiler, but you 
don't actually have a working native environment yet.  Try configuring 
initially as an arm-linuxaout - arm-linux cross and see if that helps any.

Alternatively you could install from a binary distribution for bootstrap 
purposes.

p.