Subject: Where is host?

From: "J.Bland" <[email-masked]>
Date: Tue, 17 Aug 1999 16:58:34 +0000

Dear all,

     The standard distribution doesn't appear to have the host command and a
user on my machine would like this but I can't find the source on any search
engine or in any obvious places like inetutils etc.

     Anyone know where host is hiding?
     
     Cheers,
            John
            
-- 
 John Bland                            Webmaster and Ph.D. Research Student,
 M.Phys (Hons) Grad.Inst.P              Condensed Matter Physics Department,
 [email-masked]                               The University of Liverpool
 http://www.sliced.uk.eu.org/~shrike  http://www.liv.ac.uk/~olmsg01/physics/
"We're young, rich and full of sugar! What do we do now?" - Simpsons
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Paul Koning <[email-masked]>
Date: Tue, 17 Aug 1999 14:23:08 -0400

>>>>> "J" == J Bland <[email-masked]> writes:

> Dear all, The standard distribution doesn't appear to have the
> host command and a user on my machine would like this but I can't
> find the source on any search engine or in any obvious places like
> inetutils etc.
>

ftp://ftp.nikhef.nl/pub/network/host.tar.Z

	paul

---

From: "J.Bland" <[email-masked]>
Date: Tue, 17 Aug 1999 19:33:46 +0000

> ftp://ftp.nikhef.nl/pub/network/host.tar.Z

Thanks, but it doesn't want to link the *.o files as it can't find the
-lresolv library. Where do I get this?

John

---

From: Paul Koning <[email-masked]>
Date: Tue, 17 Aug 1999 15:05:06 -0400

>> > Dear all, The standard distribution doesn't appear to have the >
 >> > find the source on any search engine or in any obvious places
 >> like > inetutils etc.  > > Anyone know where host is hiding?
 >> 

 J> Thanks, but it doesn't want to link the *.o files as it can't find
 J> the -lresolv library. Where do I get this?

I have one in /lib and another in /usr/lib, not sure why.  rpm says
the former is from glibc and the latter from glibc-devel.  That's on a 
RedHat 5.2 system.  If you have 5.2 or later you should have at least
glibc, I'm puzzled that it wouldn't be found...

	paul

---

From: "J.Bland" <[email-masked]>
Date: Tue, 17 Aug 1999 20:21:05 +0000

> glibc, I'm puzzled that it wouldn't be found...

I have the normal ARMLinux install, 'mangled' RedHat 3.0.3 .

John.

---

From: Philip Blundell <[email-masked]>
Date: Mon, 23 Aug 1999 23:02:53 +0100

>-lresolv library. Where do I get this?

It's supplied with newer versions of libc, or you could probably get the bind 
source and use the library that comes with that.

p.