Subject: error : storage size isn't known ?

From: Jan-Uwe Finck <[email-masked]>
Date: Wed, 11 Aug 1999 14:22:16 +0200

After getting over my last problems, the next one was not wide away :
Again trying to compile gcc-2.95 (what else :-(),the next thing I bump into is :

make[1]: Entering directory `/usr/src/gcc-2.95/libiberty'
test x"no" != xyes || \
gcc -c -DHAVE_CONFIG_H -g -O2 -I. -I./../include   mkstemps.c -o
pic/mkstemps.o
gcc -c -DHAVE_CONFIG_H -g -O2 -I. -I./../include  mkstemps.c
In file included from /usr/include/sys/types.h:4,
                 from /usr/include/fcntl.h:27,
		 from mkstemps.c:31:
/usr/include/linux/types.h:15: warning: empty declaration
mkstemps.c: In function `mkstemps':
mkstemps.c:72: storage size of `tv' isn't known
make[1]: *** [mkstemps.o] Error 1
make[1]: Leaving directory `/usr/src/gcc-2.95/libiberty'
make: *** [all-libiberty] Error 2

The relevant lines of mkstemps.c look like this :

#ifdef HAVE_GETTIMEOFDAY
  struct timeval tv;
#endif
  
but timeval doesn't seem to be defined somewhere, althoug I could
find it in time.h..

This leaves me completely helpless again..

Still 2.0.36aout, binutils 2.9.1.0.25 installed, and on my long,stony way to
build a new toolchain.. ;-)

-- 
CU	
	Jan-Uwe
-------------------------------------------------
PGP-Public-Key on Request.
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Wed, 11 Aug 1999 16:56:11 +0100

>but timeval doesn't seem to be defined somewhere, althoug I could

It should be in some of your libc's header files.  If not then it sounds like 
you have a broken C library installation.

p.