Subject: Kernel patching..

From: Jan-Uwe Finck <[email-masked]>
Date: Mon, 2 Aug 1999 13:37:08 +0200

Hmm..

after failing to patch 2.2.10, I wonder if I have to use all the three
patches or just the latest, I assume only the latest, right ?

Sorry, I think I should be more clear :
Patching itself with only the latest patch works normally, no mistkae,
even make dep && make clean gives no rumours..
but the Kernel-compiling itself stops immediately with the following
error : 

[root@riscy linux]# make zImage
gcc -Wall -Wstrict-prototypes -O2  -o scripts/split-include
scripts/split-include.c
scripts/split-include include/linux/autoconf.h include/config
gcc -D__KERNEL__ -I/usr/src/linux/include  -m6 -Wall
-Wstrict-prototypes -O2  -pipe  -c -o init/main.o init/main.c
init/main.c:400: section attributes are not supported for this target
init/main.c:539: section attributes are not supported for this target
init/main.c:867: section attributes are not supported for this target
make: *** [init/main.o] Error 1
 
Any ideas ?
I suppose the solution is simple, but have mercy.. :-)

-- 
CU	
	Jan-Uwe
-------------------------------------------------
PGP-Public-Key on Request.
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Mon, 02 Aug 1999 12:56:00 +0100

>I suppose the solution is simple, but have mercy.. :-)

Sounds like you might be trying to use an old a.out compiler.  What does `gcc 
-v' say?

p.

---

From: Jan-Uwe Finck <[email-masked]>
Date: Mon, 2 Aug 1999 16:42:32 +0200

> Sounds like you might be trying to use an old a.out compiler.  What does `gcc 

Once again my mistake..always give _any_ useful information to the
others.. :-)

It's gcc version 2.7.2.2 !

Just from the standard installation from the ftp-server..
2.0.36 had no problems with this, so I thought I'll try 2.2.10..

This is too old, right ? Do I have to build a new toolchain ? I suppose
so..

---

From: Alex Holden <[email-masked]>
Date: Mon, 2 Aug 1999 15:57:36 +0100 (GMT)

> init/main.c:400: section attributes are not supported for this target

What compiler and binutils are you using? Does it compile ordinary
programs okay? Have you tried turning off the "Split text into discardable
sections" kernel option?

--------------- Linux- the choice of a GNU generation. --------------
: Alex Holden (M1CJD)- Caver, Programmer, Land Rover nut, Radio Ham :

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Mon, 2 Aug 1999 15:51:35 +0100 (BST)

> 2.0.36 had no problems with this, so I thought I'll try 2.2.10..

Correct, 2.2.10 needs the new tool chain.

> This is too old, right ? Do I have to build a new toolchain ? I suppose

Correct again.  Yes.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.linux.org.uk/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Mon, 02 Aug 1999 16:03:53 +0100

In message <[email-masked]>, Alex 
>programs okay? Have you tried turning off the "Split text into discardable

That won't help; you still need sections for the exception handling stuff at 
least.

p.

---

From: Philip Blundell <[email-masked]>
Date: Mon, 02 Aug 1999 16:06:29 +0100

>It's gcc version 2.7.2.2 !
[...]
>This is too old, right ? Do I have to build a new toolchain ?

Got it in one.  You could try using the Debian binaries if you don't feel like 
compiling one yourself.

p.

---

From: Jan-Uwe Finck <[email-masked]>
Date: Mon, 2 Aug 1999 17:41:31 +0200

> In message <[email-masked]>, Alex 
Anyway, I'll try my luck with a new toolchain.

I'll be back crying for help if it doesn't work.. :-)

Thanks for any comments !
-- 
CU	
	Jan-Uwe
-------------------------------------------------
PGP-Public-Key on Request.
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Mon, 2 Aug 1999 18:21:29 +0100 (BST)

Philip Blundell writes:
>...

That option does not affect the exception handling.
   _____

---

From: Philip Blundell <[email-masked]>
Date: Mon, 02 Aug 1999 22:21:20 +0100

>That option does not affect the exception handling.

Yup, that's why it won't help.  Actually there isn't all that much use for 
that option at all really - it would be better to teach the makefiles how to 
tell the difference between the versions of ld that work with the .init stuff 
and those that don't (which, as it happens, we have to do anyway for other 
reasons).  Leaving it up to the user to choose just means that people get it 
wrong.  

(Unless anyone can think of a reason why you'd want to not use .init other 
than it not working, at any rate.)

p.

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Mon, 2 Aug 1999 22:24:05 +0100 (BST)

> reasons).  Leaving it up to the user to choose just means that people get it 

I was thinking about disabling the option actually.  AFAIK from what you've
said, there are no versions which work correctly.  The last email I had
from you was something like "I don't forsee the need to fix it". ;(
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.linux.org.uk/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Ian Molton <[email-masked]>
Date: Mon, 07 Aug 1995 08:46:16 +0000 (GMT)

Can someone resub me to the list as [email-masked] ?

thx.

-- 
-Ian aka Spyro
Acorn Computers, the best in the world
http://www.users.zetnet.co.uk/hawk/
Aspie and proud of it.
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]