Subject: Problem building gcc-2.95 for arm-linux

From: Randall Sears <[email-masked]>
Date: Mon, 9 Aug 1999 08:59:53 -0500

Hello,

I am trying to build gcc-2.95 for arm-linux.  The build fails with the error:

	gcc-2.95/gcc/libgcc2.c:41 stdlib.h : No such file or directory

I've downloaded, patched and installed the arm kernel headers  (and built installed the binutils).  I've downloaded and applied the latest patch for gcc-2.95 from the netwinder/users/p/philb directory. I'm running "configure" with 
--target=arm-linux 
--prefix=/usr/local/arm-linux 
--with-headers=/usr/local/arm-linux/include.  

I using "make all" as the make target.

Any ideas on what I'm doing wrong?  

Thanks for any help.

Randall Sears

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Mon, 09 Aug 1999 17:39:39 +0100

>Any ideas on what I'm doing wrong?  

Nothing.  See Chris Rutter's toolchain guide for an explanation.

p.

---

From: Jan-Uwe Finck <[email-masked]>
Date: Tue, 10 Aug 1999 19:39:10 +0200

> I using "make all" as the make target.

I don't know if anybody answered this already, but you should use 
make LANGUAGES=c as far as I remember..
And if you have an aout-system, you should configure with
--host=arm-linuxaout .

And what does 'locate stdlib.h' say ? Is it anywhere on your system ?
-- 
CU	
	Jan-Uwe
-------------------------------------------------
PGP-Public-Key on Request.
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]