Subject: This time it's gcc... :-(

From: Jan-Uwe Finck <[email-masked]>
Date: Tue, 3 Aug 1999 19:15:09 +0200

I _hate_ to ask again..
Anyway, I fetched gcc-2.95, patched in /gcc-2.95/gcc , configured it
by ./configure arm-linux --prefix=/usr , and typed make LANGUAGES="c",
and the result is a bug after some Lines :

[root@riscy gcc]# make LANGUAGES="c"
gcc  -DIN_GCC     -g  -DHAVE_CONFIG_H  -o cccp cccp.o cexp.o intl.o
prefix.o version.o  mbchar.o  obstack.o
../libiberty/libiberty.a
gcc: ../libiberty/libiberty.a: No such file or directory
make: *** [cccp] Error 1

I checked it, the file is non-existent, but I couldn't manage to find
the appropiate line in the Makefile to comment it out or even look at
it.This means I'm stuck again.. (what a pain, but I want to build the
toolchain completely on my own..)

I'm sure the solution is simple again...

old Kernel 2.0.36, binutils-2.9.0.1.25 installed.
-- 
CU	
	Jan-Uwe
-------------------------------------------------
PGP-Public-Key on Request.
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: "Adam 'WeirdArms' Wiggins" <[email-masked]>
Date: Wed, 4 Aug 1999 17:46:35 +1000 (EST)

I had the same problem, I was in a rush (plane to catch) so I
didn't explore it.
	
	Cheers Adam

---

From: Philip Blundell <[email-masked]>
Date: Wed, 04 Aug 1999 09:52:35 +0100

>and the result is a bug after some Lines :

Don't do that, then - just configure and make at the top level.  The gcc 
subdirectory depends on other things such as libiberty that need to be built 
first.

p.