Subject: rpm - Data-type 9 not supported

From: Jan-Uwe Finck <[email-masked]>
Date: Tue, 24 Aug 1999 19:42:45 +0200

Hi,

when trying to install some .rpm-files I stumbled across the
error in the subject..

The current rpm-version is 2.3, but where do I get a version of rpm
able to handle data-type 9 , and < 3.0.6, 'cause I can't install that
due to it's data-type(which is 9 of course..:-(( )

Any idea anybody ?
-- 
CU	
	Jan-Uwe
-------------------------------------------------
PGP-Public-Key on Request.
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Rod Stewart <[email-masked]>
Date: Tue, 24 Aug 1999 13:51:11 -0400 (EDT)

> due to it's data-type(which is 9 of course..:-(( )

Use rpm2cpio if you are trying to get rpm upgraded...  Or get a copy of
the rpm source and compile it, for the first time:  ftp.rpm.org

The following might work, you might want to back up /var/lib/rpm first..
	cd /tmp
	rpm2cpio [ rpm  name ] | cpio -vid 
	./bin/rpm --rebuilddb 
	./bin/rpm -Uhv [ rpm name to upgrade]

-Rms