Subject: THUMB vs ARM

From: Claus Toendering <[email-masked]>
Date: Fri, 6 Aug 1999 12:10:57 +0200

I'm new to the ARM processor, so please bear with me if this question is
really stupid:

Does GCC support generation of both ARM and THUMB code? And if so, how does
one control which instruction set is generated?

--
Claus Tondering
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Fri, 06 Aug 1999 11:18:23 +0100

>one control which instruction set is generated?

Yes, but not currently as a run-time option.  You have to build two toolsets, 
one for ARM and one for Thumb.

Thumb is not currently supported very well under Linux; this is something I've 
been working on sporadically for a while but not completed yet.

p.