Subject: Installation problems

From: nik <[email-masked]>
Date: Mon, 19 Jul 1999 18:06:36 +0100

Ahhhhg, I hate installing ARMLinux.
I had a go last year but gave up - I am now trying again but have not got very
far at all.
I am having problems with !Partman.
Using version 1.11, when I click 'new' on the menu, nothing happens.
Using version 1.13, when I try to create a new partion an error box appears
saying '% may have gone wrong. Click continue to try to resume or Quit to stop
%0'
Using version 1.05, I am able to create the partitions perfectly, but when I
boot into Linux, it doesn't see them (ie it can see hda, but doesn't mention
hda1,hda2 etc) although it can see hdc, hdc1, hdc2, hdc3 which are the
partitions on a hard disk connected to my APDL IDE interface

Which version should I be using?
I am trying to put the partitions an a hard disk connected to the motherboard
IDE interface.

Nik

-- 
[email-masked]
http://www.cheddarcheese.de
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Mon, 19 Jul 1999 17:22:27 +0100 (BST)

> saying '% may have gone wrong. Click continue to try to resume or Quit to stop

This sounds like there's something wrong with MessageTrans - it shouldn't leave
the messages with '%' signs in them.

> hda1,hda2 etc)

Can you try the latest ALPHA partition manager?

> although it can see hdc, hdc1, hdc2, hdc3 which are the

Note that you can't use PartMan on APDL/ICS IDE interfaces (due to IDEFS problems).
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.linux.org.uk/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: nik <[email-masked]>
Date: Mon, 19 Jul 1999 21:12:56 +0100

In article <[email-masked]>,
   Russell King - ARM Linux Admin <[email-masked]> wrote:
> nik writes:
> > I am having problems with !Partman. Using version 1.11, when I click
> > 'new' on the menu, nothing happens. Using version 1.13, when I try to
> > create a new partion an error box appears saying '% may have gone wrong.
> > Click continue to try to resume or Quit to stop %0'

> This sounds like there's something wrong with MessageTrans - it shouldn't
> leave the messages with '%' signs in them.

> > Using version 1.05, I am able to create the partitions perfectly, but
> > when I boot into Linux, it doesn't see them (ie it can see hda, but
> > doesn't mention hda1,hda2 etc)

> Can you try the latest ALPHA partition manager?

Trying partman-1/13-alpha13-dev2/arc, is this the latest?
It works (sort of). I'm sure that I tried this one before and it didn't work.
Anyway, I can get it to work by telling it to look for ADFS Filecore/Linux
partitions.  I can set up the partitions correctly apart from Linux Table - it
wants to stay at 0k - is this OK?

> > although it can see hdc, hdc1, hdc2, hdc3 which are the partitions on a
> > hard disk connected to my APDL IDE interface

> Note that you can't use PartMan on APDL/ICS IDE interfaces (due to IDEFS

It still can't see the partitions on the drive (hda) connected to the internal
IDE interface.
Booting into Linux it says:
<snip out stuff not needed>
Icside detected ARCIN v6 on slot 0
hda:ST33232a, 3077mb w/128kB cache, CHS6253/16/63
hdc:Quantum Fireball SE6.4A 6149mb w/80kb cache, CHS13328/15/63
hdd:MATSHITA CR588, ATAPI CDROM drive
ide0 at 0x1f0-0x1f7, 0x3f6 on irq9
ide1 at 0x800d0800-0x800d0807, 0x800d08e0 on irq 32
floppy drive(s): fd0 is 1.44mb, fd1 is 1.44mb
FDC0 is post-1992 82077
scsi: 0 hosts
scsi: detected hosts
Partition Check
hda:[ics]
hdc:[ics]hdc1 hdc2 hdc3 hdc4

The hda disk drive is connected to the internal IDE interface.
The hdc is connected to the APDL card.
The Linux partitions are on he hda device, but somehow linux cannot recognise
them.
I have RISC OS partitions on the Quantum Fireball, and I am able to mount
these, but I cannont mount hda, hda1 etc

TTFN
Nik

---

From: Timothy Baldwin <[email-masked]>
Date: Fri, 23 Jul 1999 21:37:58 +0100

In message <[email-masked]>
            nik <[email-masked]> wrote:

[snip]

> It still can't see the partitions on the drive (hda) connected to
> the internal IDE interface.

[snip]

> hda:[ics]

There is there problem, hda contains an ICS partition table which Linux
is using in preference to the filecore/linux partition table. You need
to zero the first 1024 bytes of the disc, this can be done under linux
by:

dd block=1024 count=1 if=/dev/zero of=/dev/hda

[snip rest]

-- 
http://www.reinhouse.freeserve.co.uk/
  Please don't CC replies to me!!!
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]