Subject: newbe question: Tools

From: Mark Pulver <[email-masked]>
Date: Wed, 14 Jul 1999 08:30:44 +1000 (EST)

Sorry to ask question below the techinical level of this list.
I'm using a Brutus board trying to do an embedded application,
I'm not ready of linux yet, but in the future I will be.

Currently, I'm using the Arm SDK 2.5 evaulation version. Been
unwilling to pay US$4500 per copy for the full version, and finding
the debugger useless once you start running real time.
I want to start using the gnutools (also to get off the PC). 
I can not understand how (once I cross-compile and link my
application) to  load this into the board (flash) or debug
with angel/gdb. 
Having  only the evaulation version of Arm's toolkit, I don't
have angel source, so I don't know how to talk to it.

Any help, or pointers to FAQ much welcome.

Mark
Mark Pulver ([email-masked])
Senior Hardware Engineer (A Chip Designer)    _--_|\  "Get up on your bike ...
+61 - 2 - 9805 - 2965  (fax 9805-2929)       /      \  pedal on, pedal on,
Canon Information Systems Research Australia \_.--._/  pedal on" -- Luka Bloom
1 Thomas Holt Drive, North Ryde, N.S.W., 2113.     v   The Acoustic Motorbike

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Wed, 14 Jul 1999 09:34:19 +0100

>application) to  load this into the board (flash) or debug

GDB knows how to talk to Angel so you can just load the program in that way.  
Alternatively look on ftp.cam.org:/pub/users/nico for a utility called 
"angelboot" that can do the download.

p.