Subject: SA-1100 phone device

From: "Thomas Olausson" <[email-masked]>
Date: Wed, 14 Jul 1999 10:29:07 -0400

Greetings all, I'm new to list.
Trying to evaluate if Linux is installable on this little device:

I have a Internet TouchScreen Phone from Lucent.
It has a SA-1100 chip, an ethernet PCMCIA card, 
a touchscreen (possibly VGA), 16Mb ram, flash ram,
a keyboard.
The motherboard is probably lucent's own.

Right now it's running Inferno OS from them, what
I want to see if Linux could be run here, maybe
as a X-terminal.

Any suggestions?

It has limited memory capabilites, but I saw on the site
www.arm.uk.linux.org a couple of other smaller devices (itsy, empeg) , 
so it shouldn't be impossible.

Regards,
Thomas

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Wed, 14 Jul 1999 16:01:01 +0100

>Trying to evaluate if Linux is installable on this little device:

No reason why not.  16MB of RAM should be adequate.  Your main problem is 
likely to be actually getting the code into the device, assuming it currently 
boots from ROM or flash.

p.

---

From: Nicolas Pitre <[email-masked]>
Date: Wed, 14 Jul 1999 12:53:28 -0400 (EDT)

> The motherboard is probably lucent's own.

It is certainly doable, but it might require the flash to be replaced with
a custom bootloader + kernel code.  

> I want to see if Linux could be run here, maybe

Yes it's possible.

BTW: do you have a pointer on that product?

Nicolas Pitre, B. ing.
[email-masked]

---

From: "Dr. David Gilbert" <[email-masked]>
Date: Wed, 14 Jul 1999 18:06:33 +0100 (BST)

> The motherboard is probably lucent's own.

Hmm - it sounds like it would be do-able - there is a separate mail list
for SA1100 activities (sorry I can't remember it at the mo).

The main problems to solve are:

   1) How to get Linux into it (PCMCIA/ether etc)
   2) How to have a loader for Linux under Inferno
   3) How they've added the hardware onto the SA1100

I'm going to guess that (2) is the hard problem because (3) is probably
similar to most other SA1100 based devices.

Dave

P.S. What is Inferno like ?

/------------------------------------------------------------------\
| Dr. David Alan Gilbert | Work: [email-masked] (+44-161-286-2000)   |
| -------- G7FHJ --------|---------------------------------------- |
| Home: [email-masked]   http://www.treblig.demon.co.uk          |
\------------------------------------------------------------------/