Subject: Connection refused

From: [email-masked]
Date: Mon, 12 Jul 1999 13:56:36 +0100

Hello,

     I'm still working on the problem of my ramdisk ( see mail setup_initrd the
2/07/99 ) and haven't solved it yet . I'll let you know...
     Another question, I mean a problem ;-)
     I'm trying to have the network working on my brutus like-board / kernel
2.2.2. At the present time, I try ping and ftp on the local loop (127.0.0.1).
the "ping 127.0.0.1" works well, telling that all the transmitted packet are
received. But when I type "ifconfig" to display the status of lo, I have
something like:
     RX packets: 12 errors:0 dropped:0 overruns:0
     TX packets: 0 errors:1008 dropped:12 overruns:0
          It must be something wrong !

With ftp: I have inetd running ( ready to call "tcpd " and then "ftpd"). The
tcpdchk and tcpdmatch commands let me know that all seem to be OK for a ftp on
127.0.0.1 (access granted), but when trying "ftp 127.0.0.1", I have "ftp:
connect: Connection refused" . ???

Thanks for your help.
Arnaud

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Mon, 12 Jul 1999 17:11:27 +0100

>          It must be something wrong !

Your net-tools is old and broken.  Upgrade to the latest version (currently 
1.52) and this problem should go away.  This is mentioned in the kernel 
documentation, incidentally.

>connect: Connection refused" . ???

Does `netstat -a' show inetd listening for connections?

p.

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Mon, 12 Jul 1999 19:49:35 +0100 (BST)

[email-masked] writes:
> But when I type "ifconfig" to display the status of lo, I have
> something like:

Classic old nettools.  Please upgrade your nettools.

> connect: Connection refused" . ???

Do you get this immediately, or is there a delay?  What does netstat -a
tell you?  Is the ftp port listening for connections?
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.linux.org.uk/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Nicolas Pitre <[email-masked]>
Date: Mon, 12 Jul 1999 19:19:56 -0400 (EDT)

>           It must be something wrong !

Are you sure you have a net-tools distribution that is Linux 2.2.x aware?

Nicolas Pitre, B. ing.
[email-masked]