Subject: Re: ARMLinux installation stalled at Select RedHat RPM partition

From: Richard Atterer <[email-masked]>
Date: Tue, 06 Apr 1999 21:52:24 +0200

In article <[email-masked]>
    Keith Wright <[email-masked]> wrote:

['device hda3 does not appear to contain a RedHat installation tree']
> The frustration is slowly mounting but the enthusiasm is not yet gone.
> Is there any other possible cause for the inability to get
> past step 57????

I'm at a loss... almost!

I've had one more thought: Maybe you've somehow messed up the various
Linux partitions on your hard disc, making them overlap and/or go off
the end of the disc.

I believe the RedHat installer looks at the first few bytes of every RPM
file it sees. It will probably fail with this 'no installation tree'
message if you've accidentally overwritten some RPM file data while,
say, initialising your swap partition.

As it happens, I've got a 3GB drive which, like yours, is split into 2GB
ADFS and 1GB Linux. !PartMan displays the following:

  Disk size: 3078, 6253 Cylinders, 16 Heads,
  63 Sectors, Sector size: 512 bytes
  
  1        0  4082399  1993 MB Filecore
  2  4082400  4082401     1 KB Linux Table
  3  4082402  6236898  1052 MB Linux Native
  4  6236899  6303023    32 MB Linux Swap

If the partitions are OK, I can't think of anything else which might
cause the problem - sorry.

Cheers,

  Richard

-- 
  __   _
  |_) /|  Richard Atterer
  | \/¯|  http://www.in.tum.de/~atterer/                      raFS V1.15
  ¯ ´` ¯
PGP key fingerprint: C5 59 22 97 80 12 34 C6  6E CE 27 32 2A 44 2C 4A
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Keith Wright <[email-masked]>
Date: Tue, 06 Apr 1999 20:43:51 +0000

In message <[email-masked]> you wrote:

> On Tue, 30 Mar 1999, Keith Wright wrote:
> 
> > In message <[email-masked]> you wrote:
> > >snip<
> > 
> > > It should have worked with the Zip file, though. :-/
> > > You can check whether everything is where it should be at the end of
> > > step 49, just before the umount's:
> > > 
> > >   ls /hd             (should output "RedHat")
> > >   ls /hd/RedHat      (should output "RPMS")
> > >   ls /hd/RedHat/RPMS (should output all the RPM filenames)
> > > 
> > 
> > Waa Haa Haaaaaaaaa!!!!!!
> > I did the above suggestion and guess what...everything looks as tho 
> > it is where it is supposed to be :(
> 
> Beware - it's case sensitive - I fell for that one when I called the RPMS
> directory RPMs which seemed more logical to me but obviously not to
> RedHat!
> 
> There's also something 'base' which should be in RedHat/base.
> 
> hth
> 
> John Joyce
> 
Well, inspite of all the suggestions (thanks crew!) I am still
stuck!!! Everything appears to be where it should (thanks for
the suggestion Richard Atterer) and all is case typed correctly.

Cheers!
Keith Wright
aka Kriten_
Denmark
Western Australia

---

From: Keith Wright <[email-masked]>
Date: Wed, 07 Apr 1999 07:33:45 +0000

> cause the problem - sorry.

OK...here is the info displayed by !PartMan.

Disk size:  3078
cylinders:  6296
heads:       16
sector size: 512
sectors:     63

1.        0  4031999  1969MB  Filecore
2.  4032000  4032001     1kb  Linux table
3.  4032002  6243842  1080MB  Linux native
4.  6243843  6346367    50MB  Linux swap

They are a little different to your figures.
Does this mean I need to reformat?
Or just redo the linux partitions?
Or are they just fine and I have the mother of all installations?

-- 
Cheers!
Keith Wright
aka Kriten_
Denmark
Western Australia