Subject: RE: HELP: (was Problem building EBSA-285...)

From: Adam Radford <[email-masked]>
Date: Fri, 23 Apr 1999 15:35:28 -0700

Greg,

I had this problem as well.

The crt*.o files need to end up in
/usr/arm-linux/lib/gcc-lib/arm-linux/egcs-2.91.60
(or equivalent directory on your system).

Try:

 cp /work/glibc-2.1/csu/crt*.o
/usr/arm-linux/lib/gcc-lib/arm-linux/egcs-2.91.60

-Adam

> -----Original Message-----
> From:	Greg Johnson [SMTP:[email-masked]]
> Sent:	Thursday, April 22, 1999 4:07 PM
> To:	[email-masked]
> Subject:	Re: HELP: (was Problem building EBSA-285...)
> 
> Hi,
> 
> Thanks for the help. After taking Andrew Dachs advice and 
> configuring/compiling without the '--with-cpu=strongarm110' I was
> able to build glibc cross-compiled for the arm. Now I just need
> to figure out how to get the compiler and bin-tool to look in the
> correct directories when building executables. For some reason
> no matter what command line options I used, 'ld' can't find
> crt1.o and friends. The only way I have been able to compile
> hello world is to actually be in the lib directory where the
> files are. Seems that the default paths were not properly configured
> when I configured the compiler.
> 
> Regards
> 
> Greg.
> 
> -- 
> +----------------------------------------------------+
> | Do you want to know more?                          |
> |               --== Greg Johnson ==--               |
> | HW/SW Engineer      [email-masked] |
> | Canon   Information  Systems   Research  Australia |
> | 1 Thomas Holt Dr, North Ryde, NSW, 2113, Australia |
> | "I FLEXed my BISON and it went YACC!" - me.        |
> +----------------------------------------------------+
> unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Sat, 24 Apr 1999 11:24:14 +0100

>/usr/arm-linux/lib/gcc-lib/arm-linux/egcs-2.91.60

No, this isn't quite right.  

There are two groups of crt*.o files - the first lot (crtbegin.o, crtbeginS.o, 
crtend.o, crtendS.o) are generated as part of egcs and do indeed live in the 
directory you mentioned under gcc-lib.  But the rest (crt1.o, crti.o, crtn.o 
and a few more) which are the ones built as part of glibc, should live in 
$PREFIX/lib (eg /usr/lib) for a native compiler and $PREFIX/arm-linux/lib for 
a cross compiler.  If the linker can't find them there the chances are it was 
built with the wrong PREFIX setting.  `ld -verbose' might tell you where it's 
looking.

p.