Subject: cache

From: Dave Baukus <[email-masked]>
Date: Wed, 07 Apr 1999 16:40:56 -0500

A long time ago I turned the turned off the instruction caching, data caching
and write buffering on my ebsa285 because I had problems when these features
were enabled (not booting).

Well now its time to figure out the problem. I'm assuming the problem
is in my initialization of the hardware prior to entering head-armv.S.

The latest manifestation of the problem can be seen when the scsi adapter
and ethernet card are initialized:

-----
NET4: Unix domain sockets 1.0 for Linux NET4.0.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
Starting kswapd v 1.5 
ncr53c8xx: at PCI bus 0, device 8, function 0
Trying to vfree() nonexistent vm area (e1800000)
ncr53c8xx: 53c860 detected 
ncr53c860-0: rev=0x02, base=0x1000, io_port=0x0, irq=5
ncr53c860-0: NCR clock is 80074KHz, 80074KHz
ncr53c860-0: ID 7, Fast-20, Parity Checking
CACHE TEST FAILED: host wrote 1, ncr read 0.
CACHE TEST FAILED: ncr wrote 2, host read 1.
CACHE INCORRECTLY CONFIGURED.
ncr53c860-0: detaching...
Trying to vfree() nonexistent vm area (e1802000)
scsi : 0 hosts.
scsi : detected total.
3c59x.c:v0.99H 11/17/98 Donald Becker
http://cesdis.gsfc.nasa.gov/linux/drivers/vortex.html
eth0: 3Com 3c905B Cyclone 100baseTx at 0x1000,  00:10:4b:66:7a:ec, IRQ 8
  8K byte-wide RAM 5:3 Rx:Tx split, autoselect/Autonegotiate interface.
  MII transceiver found at address 24, status 786d.
  MII transceiver found at address 0, status 786d.
  Enabling bus-master transmits and whole-frame receives.
Sending BOOTP requests...........`
------

The bootp replys are never received by the adapter and the scsi card
complains about caching. These errors are not encountered if cacheing is
disabled.

Is there anybody running an ebsa285 that is willing to share their hardware
initialization ? If not that then any pointers/clues/advice will be apreciated.

--
Dave Baukus
	Inet Technologies Inc.
	[email-masked]
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Wed, 07 Apr 1999 23:11:33 +0100

>initialization ? If not that then any pointers/clues/advice will be apreciated

You will probably find that the instruction cache is harmless and it's the 
data cache that's causing the trouble.  What version of the kernel are you 
using?  The 3Com driver had cache coherency code added a month or so back.  I 
thought the 53c8xx driver was OK already but looking through it quickly I 
couldn't see any any code to deal with this.

p.