Subject: RE: HELP: (was Problem building EBSA-285...)

From: Andrew Dachs <[email-masked]>
Date: Mon, 19 Apr 1999 16:30:01 +0100

FWIW I had the same "unrecognised insn" error but it went away when I
rebuilt binutils/egcs without the --with-cpu=strongarm110 option.

The versions were:
binutils-2.9.1.0.19a (patched with binutils-2.9.1.0.19a-arm-diff-981230.gz)
egcs-1.1.2 (patched with egcs-1.1.2-arm-diff-990325.gz)

Part way through rebuilding glibc I got another error.  Make, in the ./elf
directory, reported that symbols could not be found in libgcc.a and that I
should run ranlib on it.  I did that by:
cd /home/arm/tools/lib/gcc-lib/arm-linux/egcs-2.91.66
arm-linux-ranlib libgcc.a

After that glibc built cleanly and installed.  I'm not able to test it on a
real system at the moment but I can compile a helloworld program and get
sensible looking code.

Andy

> -----Original Message-----
> From:	Philip Blundell [SMTP:[email-masked]]
> Sent:	Monday, April 19, 1999 9:51 AM
> To:	Greg Johnson
> Cc:	[email-masked]; [email-masked]
> Subject:	Re: HELP: (was Problem building EBSA-285...) 
> 
> >board. Has anyone had success cross compiling for the EBSA-285? The 
> >instructions I have been following seem to be for arm-linux
> >in general, rather than EBSA-285 Cross Compiler specific.
> 
> There is nothing special about the EBSA-285 that means you need a
> different 
> compiler.  All current machines running ARM GNU/Linux have a common ABI,
> aside 
> from the 26/32-bit division which is irrelevant here.
> 
> >> However, when I attempt to compile glibc I get the following
> >> internal compiler error (I have broken up to enormous compiler command
> line.
> 
> Can you try with egcs 1.1.2 and the latest patch from ftp.netwinder.org?
> I've 
> seen this bug before but I don't remember offhand what the exact status of
> it 
> is.  You could also try the trunk version if you feel brave.
> 
> p.
> 
> 
> unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Greg Johnson <[email-masked]>
Date: Fri, 23 Apr 1999 09:06:38 +1000 (EST)

Hi,

Thanks for the help. After taking Andrew Dachs advice and 
configuring/compiling without the '--with-cpu=strongarm110' I was
able to build glibc cross-compiled for the arm. Now I just need
to figure out how to get the compiler and bin-tool to look in the
correct directories when building executables. For some reason
no matter what command line options I used, 'ld' can't find
crt1.o and friends. The only way I have been able to compile
hello world is to actually be in the lib directory where the
files are. Seems that the default paths were not properly configured
when I configured the compiler.

Regards

Greg.

-- 
+----------------------------------------------------+
| Do you want to know more?                          |
|               --== Greg Johnson ==--               |
| HW/SW Engineer      [email-masked] |
| Canon   Information  Systems   Research  Australia |
| 1 Thomas Holt Dr, North Ryde, NSW, 2113, Australia |
| "I FLEXed my BISON and it went YACC!" - me.        |
+----------------------------------------------------+
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]