Subject: ARM w/o MMU

From: James Goodwin <[email-masked]>
Date: Sun, 25 Apr 1999 14:32:12 -0700 (PDT)

Hi,

We currently have an embedded O/S running on an ARM
based system-on-a-chip design. We are seriously
considering replacing the embedded O/S with Linux
(with some tweaks for the embedded world). Our main
concern is that our design does not contain a true
MMU (it's based on an ARM9TDMI core, w/o MMU).

Looking for feedback/comments/opinions on how
feasible it is to support Linux on an ARM CPU w/o a
true MMU.

Thanks much!
--James

_________________________________________________________
DO YOU YAHOO!?
Get your free @yahoo.com address at http://mail.yahoo.com

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Ormund Williams <[email-masked]>
Date: Mon, 26 Apr 1999 02:52:00 +0000

> feasible it is to support Linux on an ARM CPU w/o a
Hi James

I have begun to design a system based on the ARM7DI core without MMU and
was going to use Linux but the port I chose is uCLinux.
 see:-  http://ryeham.ee.ryerson.ca/uClinux
They already have a stable kernel running on some 68k chips (Dragonball,
ColdFire etc.).  These microcontrollers have no MMU.  

I haven't heard of anyone else trying to port uCLinux to ARM yet, so I
welcome your company.  I should have my hardware ready by the start of
June, currently I am learning to build cross compilers and develop a
working knowledge of the Linux kernel.  I recommend joining the uCLinux
mailing list.

--
Ormund

---

From: Mitch Davis <[email-masked]>
Date: Mon, 26 Apr 1999 13:35:32 +1000

>  see:-  http://ryeham.ee.ryerson.ca/uClinux

If this could be made to work, then it could be run on
the AEB-1:

  http://www.arm.com/Documentation/Overviews/AEB/index.html

Regards,

Mitch.
--
| mailto:[email-masked]       | Not the official view of: |
| mailto:[email-masked] | Australian Calculator Opn |
| Certified Linux Evangelist! | Hewlett Packard Australia |
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]