Subject: Tweak for ds2400 in philb's kernel

From: Chris Rutter <[email-masked]>
Date: Fri, 9 Apr 1999 03:28:16 +0100 (BST)

Anyone using the latest philb kernel patch and configuring for a RiscPC
will receive a link error in the final stage (an unresolved reference
to ds2400).  This is because arch/arm/kernel/setup.c assumes ds2400
for both the A5000 and RiscPC:

        if (machine_is_a5000() || machine_is_riscpc()) {
                /* Read the unique ID */
                ds2400_init();
        }

but ds2400.o is only pulled in for the A5000, in Makefile:

    O_OBJS_a5k        = dma-a5k.o iic.o fiq.o ds2400.o
    O_OBJS_rpc        = dma-rpc.o iic.o fiq.o

Not knowing anything relevant about the hardware, I'd suggest adding
ds2400.o into the RiscPC objects definition.

Patch for those that want it:

--- linux/arch/arm/kernel/Makefile~   Fri Apr  9 03:25:36 1999
+++ linux/arch/arm/kernel/Makefile    Fri Apr  9 03:18:51 1999
@@ -18,7 +18,7 @@

 O_OBJS_arc        = dma-arc.o iic.o fiq.o oldlatches.o
 O_OBJS_a5k        = dma-a5k.o iic.o fiq.o ds2400.o
-O_OBJS_rpc        = dma-rpc.o iic.o fiq.o
+O_OBJS_rpc        = dma-rpc.o iic.o fiq.o ds2400.o
 O_OBJS_ebsa110    = dma-dummy.o
 O_OBJS_footbridge = dma-footbridge.o $(ISA_DMA_OBJS) isa.o
 O_OBJS_nexuspci   = dma-dummy.o

-- 
Chris <[email-masked]>                         ( http://www.fluff.org/chris )

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Fri, 09 Apr 1999 10:13:01 +0100

>for both the A5000 and RiscPC:

Oops, you're right.  Yes, I think your fix is right.  Does the DS2400 driver 
actually work on the RiscPC -- what do you get in /proc/cpuinfo?

p.