Subject: Cross building bash

From: christophe leroy <[email-masked]>
Date: Tue, 02 Mar 1999 18:17:15 +0000

To build bash for arm from a i486,

untar bash (version 2)
./configure --target=linux-arm

Edit Makefile and replace

mksignames:     $(SUPPORT_SRC)mksignames.c
        $(CC) $(CCFLAGS) $(CPPFLAGS) -o $@ $(SUPPORT_SRC)mksignames.c   

by
           
mksignames:     $(SUPPORT_SRC)mksignames.c
        $(CC_FOR_BUILD) $(CCFLAGS) $(CPPFLAGS) -o $@
$(SUPPORT_SRC)mksignames.c              

then 

make CC=arm-linux-gcc CC_FOR_BUILD=gcc AR=arm-linux-ar
RANLIB=arm-linux-ranlib

Christophe
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Stefan Hanske <[email-masked]>
Date: Tue, 2 Mar 1999 20:10:03 +0100 (CET)

> unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

Does this bash binary work ??? I hade difficulties building bash natively
with glibc2 because of some trouble with (a)malloc() and free().

----------------------------------------------------------
|mailto: Stefan Hanske ([email-masked] |
|WWW : http://www.rzuser.uni-heidelberg.de/~shanske      |
|phone: I'm not silly                                    |
|--------------------------------------------------------|
| And don't forget to remember what you remembered not   |
| to forget to remember...				 |
----------------------------------------------------------

---

From: christophe leroy <[email-masked]>
Date: Wed, 03 Mar 1999 09:26:11 +0000

> with glibc2 because of some trouble with (a)malloc() and free().

I've no tools so I can't test very hard, but at least, I get
a prompt, and I'm able to do things like 
echo *
pwd
cd
.....

glibc is 2.1

Christophe