Subject: Some binary not working on RPC700

From: Hiroshi Ishii <[email-masked]>
Date: Tue, 02 Mar 1999 10:28:34 +0900

Hi, folks!

Anyone working correctly linux on RPC700?
I can boot on RPC700. Kernel version is 2.0.36.
But some binary not working. It is "insmod", "mount" ,
"gcc" . About "insmod" ,"mount",  memory violation occurred.
"gcc", occurred illegal instruction. Another binary , "ls",
"less" working good. 

Why?

-------------------------------
My environment ;
                             byte
libc.so.4.6.27  ....  766093
libm.so.4.6.27 ....  162756
ld.so               .... 131076

insmod    .....         17600
mount    ....          360448
gcc          .....       127146

----------------------------------
Funai Electric R & D Co.,LTD
                            　     -Hiroshi Ishii-
            ♪♪ rock'n roll♪♪
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Tue, 2 Mar 1999 08:28:39 +0000 (GMT)

> "gcc", occurred illegal instruction. Another binary , "ls",

Have you loaded the FP emulator?
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.linux.org.uk/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Stefan Hanske <[email-masked]>
Date: Tue, 2 Mar 1999 17:25:08 +0100 (CET)

> "gcc", occurred illegal instruction. Another binary , "ls",

The binaries are not working because fpem.o is not loaded. The link
/lib/modules/misc/fpem.o should point to fpem-4.07.o (or similar).
If this is OK and you have more than 16M of RAM installed, try adding
mem=16M to the command line parameters at bootup.
If it works now, you have to download/install the newer versions of
modutils-* from ftp.arm.uk.linux.org

----------------------------------------------------------
|mailto: Stefan Hanske ([email-masked] |
|WWW : http://www.rzuser.uni-heidelberg.de/~shanske      |
|phone: I'm not silly                                    |
|--------------------------------------------------------|
| And don't forget to remember what you remembered not   |
| to forget to remember...				 |
----------------------------------------------------------

---

From: Hiroshi Ishii <[email-masked]>
Date: Wed, 03 Mar 1999 13:51:48 +0900

On Tue, 2 Mar 1999 17:25:08 +0100 (CET)

> /lib/modules/misc/fpem.o should point to fpem-4.07.o (or similar).

I put it's modules. but "insmod" not working , so can't
load it. Or,  are there another way to load fpem?

> mem=16M to the command line parameters at bootup.

I try it. But same problem occurred.

Regards;

---

From: Russell King <[email-masked]>
Date: Wed, 3 Mar 1999 09:34:37 +0000 (GMT)

> load it. Or,  are there another way to load fpem?

Why is it not working?  What is the error message?  What command
are you issuing to load it?  What version and where did you get
this insmod from?  And any other relevent questions...

--
Russell King ([email-masked])