Subject: RE: Problems building ARM-Linux v2.0.35 for Brutus

From: "Chagas, Jason" <[email-masked]>
Date: Mon, 8 Mar 1999 17:13:30 -0800

Nico,

These are the setup and patch sets I used:

linux-2.0.35.tar.gz
patch-arm-2.0.35.gz
diff-brutus-2.0.35.8.gz

Note I'm also trying to build the kernel with the latest tools (w/ 'a.out'
Binutils 2.9.1.0.19a and Egcs 1.1.1). I can build the kernel but the
binaries "hang" at loading time.

Jason

	----------
	From:  Nicolas Pitre [SMTP:[email-masked]]
	Sent:  Friday, March 05, 1999 10:03 PM
	To:  Chagas, Jason
	Cc:  [email-masked]'
	Subject:  RE: Problems building ARM-Linux v2.0.35 for Brutus

	On Fri, 5 Mar 1999, Chagas, Jason wrote:

	> I tried what you suggested but the problem persists. I noticed
there is a
	> problem with script "~/scripts/Configure":
	> 
	> 
	> Support for SA1100/UCB-1200 audio (CONFIG_AUDIO_SA1100) [Y/m/n/?]
n
	> Support for SA1100/UCB-1200 mcp common code (CONFIG_MCP_SA1100)
[Y/m/n/?] n
	> scripts/Configure: [: missing `]'
	> 
	> 
	> Do you get the same error? Does it make any difference?

	Yes I get this one... But I don't know where it comes from and
didn't try
	to spot it since the overall configuration was OK for me anyway.  It
	should work for you too.

	> Like I said running "make dep" produces the same errors as I
described
	> before. So I ran "make -i dep"  (to ignore all the errors)
followed by "make
	> zImage". I got the following error messages back:
	> 
	> /home/chagas/linux-2.0.35/linux/include/linux/string.h:31:
warning:
	> conflicting
	> types for built-in function `memcpy'
	> /home/chagas/linux-2.0.35/linux/include/linux/string.h:34:
warning:
	> conflicting
	> types for built-in function `memcmp'
	> binfmt_aout.c: In function `do_load_aout_binary':
	> binfmt_aout.c:317: `SEGMENT_SIZE' undeclared (first use in this
function)
	> binfmt_aout.c:317: (Each undeclared identifier is reported only
once
	> binfmt_aout.c:317: for each function it appears in.)
	> make[2]: *** [binfmt_aout.o] Error 1
	> make[2]: Leaving directory `/home/chagas/linux-2.0.35/linux/fs'
	> make[1]: *** [first_rule] Error 2
	> make[1]: Leaving directory `/home/chagas/linux-2.0.35/linux/fs'
	> make: *** [linuxsubdirs] Error 2
	> 
	> Any ideas?

	I'm stumped.  You probably did something  wrong somewhere.....
	Could you state your exact setup and patch sets?

	Nicolas Pitre, B. ing.
	[email-masked]
	
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Nicolas Pitre <[email-masked]>
Date: Mon, 8 Mar 1999 20:50:07 -0500 (EST)

> These are the setup and patch sets I used:

You better use diff-brutus-2.0.35.9.gz instead of .8 ...  .9 will crash on
you under heavy load or even randomly.

> binaries "hang" at loading time.

What do you mean by "hang"?  Can you see some startup messages?

BTW: I never was able to build a correct a.out kernel with egcs-1.1.1 but
egcs-1.1.1-pre2 + PhilB patch dated 981223 (or around) worked for me.
With egcs-1.1.1 the kernel build but any user space app will segfault. 

Nicolas Pitre, B. ing.
[email-masked]