Subject: !linux -bootkernel problems

From: Allen Craig <[email-masked]>
Date: Mon, 15 Mar 1999 02:51:07 +1300 (BST)

I have 2 problems with regard to setting up armlinux for the first time

(1)
I have managed to get through Paul Vigays Instructions to the step (84)
where I reboot the system after all the installations - unfortunately at
this point I get the following :

partition check...
EXT2-fs warning = mounting unchecked fs running esfsck is recommended

VFS: mounted root (ext2 filesystem)
init version 2.64 booting

bad mode in prefetch abort handler detected : mode SVC-32

Internal error :0ops:0
cpu ..... etc etc

I will try to re-do it all from beginning again but has anyone any ideas
on what might be cause/fix ?

(2)
Additonally when I try and boot the kernel (right at the beginning when
attempting to configure linux etc) with my CD drive plugged in the
process sticks at

hdb : MATSHITA CD-584 atapi cd rom drive...

the CD/IDE share acorn interface..

to get it past here I have to de-configure cd, unplug power and data
leads....any ideas/fixes ?

Thanks for your help....sorry to mither again....

-- 
Allen Craig ... Hamilton New Zealand
    Using Acorn StrongArm RISC PC
ICQ 9948225    IRC#acorn .. Alkemyst

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Sun, 14 Mar 1999 16:37:45 +0000 (GMT)

> EXT2-fs warning = mounting unchecked fs running esfsck is recommended

You want to add 'ro' to the kernel arguments.

> bad mode in prefetch abort handler detected : mode SVC-32

Have you used the latest modutils on the FTP site (ftp.arm.linux.org.uk)?

> hdb : MATSHITA CD-584 atapi cd rom drive...

Oh, it's this old problem again, which we don't have a fix for.
I would like to get a CD drive which exhibits this problem here
so I can debug it.  I suspect it's another bad drive which
asserts it's interrupt line when asked to disable it.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.linux.org.uk/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]