Subject: Pb accessing flash memory on EBSA285

From: christophe leroy <[email-masked]>
Date: Wed, 03 Mar 1999 10:53:34 +0000

I've tried to access the flash using this prog:

fd=open("/dev/mem",O_RDWR);        
ptr=mmap(0,4*1024*1024,PROT_READ|PROT_WRITE,MAP_PRIVATE,fd,0xd8000000);            
printf("%x\n",*ptr);

I get a Bus error and message
do_wp_page: bogus page at address 40103000  (98000000)

What does it mean ?

christophe
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: christophe leroy <[email-masked]>
Date: Wed, 03 Mar 1999 14:08:49 +0000

> do_wp_page: bogus page at address 40103000  (98000000)

Ok, corrected with real address 0x41000000 instead of virtual one.
I'm able to read flash, but when I'm triing to write on it,
I get a Bus error and message
do_wp_page: bogus page at address 40103000  (01000000)

Does someone know what it means ?

christophe