Subject: DNARD

From: Nicky Kern <[email-masked]>
Date: Thu, 4 Mar 1999 13:51:00 +0100

Hi Folks,

I'm trying to set up linux for a DNARD (Digital Network Appliances
References Design -- what a beautiful name!). It is a network computer,
so I originally thougt it was an EBSA110.
But when I gave the hardware a closer look, it doesn't seem, that that
is the case. :-(
So my question: should linux run on a DNARD? If yes, how should I
configure the kernel? If not, is it possible to get it running on a
DNARD?

Here's the detailed hardware:
CPU: StrongARM SA110
Ethernet: Crystal Semiconductor CS8900 Ethernet Controller 
Busses on the board: 
	VL & ISA: National Semiconductor PT86C7x8 "Sequoia" Core Logic Chip Set 
		Includes an IDE port.
	PCI: VIA Technologies VT82C505 VL to PCI Bus Bridge 
		There are no onboard-components that use the PCI-bus, though.
Video: IGS Technology CyberPro 2010 Video Controller
	The Frame Buffer consists of 2MB of 256Kx16 EDO DRAMs.
Keyboard, Mouse, Floppy, RTC, UARTs, Infrared, Parallel:
	National Semiconductor PC87307VUL "Enhanced Sidewinder Lite"
Firmware: Firmworks (the same, that is used on some of Suns Sparcstations)
Audio: ESS Technology 1887 "AudioDrive Solution" 

Thanks anyone for any help!

Nicky

----------------------------------------------------------------------------
Verein der Informatikstudierenden
Nicky Kern
ETH Zentrum                                          IFW B29
Tel: 01/632 72 12                                    [email-masked]
----------------------------------------------------------------------------
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Fri, 05 Mar 1999 11:49:49 +0000

>configure the kernel? If not, is it possible to get it running on a

I don't believe Linux will run on a DNARD without some modifications.  It 
shouldn't be too hard to arrange, though.  Either the EBSA-110 or EBSA-285 
sources would be a reasonable starting point.

>Ethernet: Crystal Semiconductor CS8900 Ethernet Controller 

I'm not sure if there's a driver for this currently.  You may need to write 
one.

>	The Frame Buffer consists of 2MB of 256Kx16 EDO DRAMs.

This is probably compatible with the NetWinder graphics system - see the 
cyber2000fb driver.

>	National Semiconductor PC87307VUL "Enhanced Sidewinder Lite"

Presumably this is a standard ISA-style I/O device.

p.

---

From: Alan Cox <[email-masked]>
Date: Fri, 5 Mar 1999 12:57:26 +0000 (GMT)

> I'm not sure if there's a driver for this currently.  You may need to write 

There is, written by Russ Nelson.
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]