Subject: Re: EBSA-285 PCI-bus Driver Interface

From: Mark van Doesburg <[email-masked]>
Date: Sun, 7 Mar 1999 23:14:06 +0100

3 looks promising. Since my ESBA card is plugged into my Dell NT
	machine chassis, I'd like to be able to send/receive data via
	the PCI bus instead of via the  slow serial cable.

I can mail you the patches. On the host you need linux-2.2.2 and on the
EBSA-285 you need linux-2.2.2-rmk2. Both kernels must be patched. In
order to get this working you will need to reprogram the flash of the
EBSA-285 to work with the boot driver.

Let me know if you want the patches/drivers/utils and I'll mail them to
you (64kB)

greetings,

Mark.
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Paul Koning <[email-masked]>
Date: Mon, 8 Mar 1999 10:06:16 -0500

>>>>> "Mark" == Mark van Doesburg <[email-masked]> writes:

 >> 3 looks promising. Since my ESBA card is plugged into my Dell
 >> NT machine chassis, I'd like to be able to send/receive data
 >> via the PCI bus instead of via the slow serial cable.

 Mark> I can mail you the patches. ...

This looks like it would be useful to a number of us... Would it be
possible to find a home for these things on some suitable file server,
and post some links to it where they can be found?  It would be handy
if the ARM-Linux webpages could lead you to this work.

	paul

---

From: David Feustel <[email-masked]>
Date: Mon, 08 Mar 1999 10:32:22 -0500

Note that I'm looking for an NT-based (not Linux-based) PCI interface to the ESBA285.
How hard would it be to generate an NT PCI interface from the Linux PCI interface?

-- 
David Feustel
Fort Wayne, Indiana
219-483-1857

http://www.d-feustel.com

---

From: Alan Cox <[email-masked]>
Date: Mon, 8 Mar 1999 15:47:53 +0000 (GMT)

> How hard would it be to generate an NT PCI interface from the Linux PCI interface?

Probably fairly hard. NT drivers have to look like NTspeak, and unicode and
other horrors. Good luck - you'll need it
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Alan Cox <[email-masked]>
Date: Mon, 8 Mar 1999 15:49:46 +0000 (GMT)

Also on this subject I have chunks of the I2O Linux interface working, and
the I2O target port on the 285, even without a full heap of I2O crap on it
will make a nice message passing (eg network card) interface between
the host and the EBSA card. Probably only a days work to have a "pci0" ;)
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: christophe leroy <[email-masked]>
Date: Mon, 08 Mar 1999 16:43:07 +0000

> How hard would it be to generate an NT PCI interface from the Linux PCI interface?

It will be hard, as you have to develop a vxd in order
to acces the PCI bus, that you cannot directly access from
user land. 
I think the best thing you can do is put on a floppy a MSDOS, DOS4GW and
FMU.EXE you got on floppies shipped with the EBSA285 card.

Christophe