Subject: Pb compiling linux 2.2.1rmk2 + philb19990108

From: [email-masked]
Date: Tue, 9 Feb 1999 14:27:12 +0100

/usr/local/bin/arm-linux-ld -m elf32arm -T /usr/src/linux.2.2.1-
arm/arch/arm/vmlinux-armv.lds -e stext -Ttext 0xC0008000 
arch/arm/kernel/head-armv.o arch/arm/kernel/init_task.o init/main.o 
init/version.o \
--start-group \
arch/arm/kernel/kernel.o arch/arm/mm/mm.o kernel/kernel.o 
mm/mm.o fs/fs.o ipc/ipc.o \
fs/filesystems.a \
net/network.a \
drivers/block/block.a drivers/char/char.a drivers/misc/misc.a 
drivers/net/net.a drivers/pci/pci.a arch/arm/special/special.a 
arch/arm/nwfpe/math-emu.a \
arch/arm/lib/lib.a /usr/src/linux.2.2.1-arm/lib/lib.a `/usr/local/bin/arm-
linux-gcc -D__KERNEL__ -I/usr/src/linux.2.2.1-arm/include  -
mshort-load-bytes -march=armv4 -mtune=strongarm110 --print-
libgcc-file-name` \
	--end-group \
	-o vmlinux
drivers/char/char.a(misc.o): In function `misc_init':
misc.o(.text.init+0x38): undefined reference to 
`footbridge_watchdog_init'
misc.o(.text.init+0x38): relocation truncated to fit: R_ARM_PC24 
footbridge_watchdog_init
make: *** [vmlinux] Error 1

#
# Automatically generated by make menuconfig: don't edit
#
CONFIG_ARM=y

#
# System and processor type
#
# CONFIG_ARCH_ARC is not set
# CONFIG_ARCH_A5K is not set
# CONFIG_ARCH_RPC is not set
# CONFIG_ARCH_EBSA110 is not set
CONFIG_FOOTBRIDGE=y
CONFIG_HOST_FOOTBRIDGE=y
CONFIG_ADDIN_FOOTBRIDGE=y
CONFIG_ARCH_EBSA285=y
# CONFIG_CATS is not set
# CONFIG_ARCH_NETWINDER is not set
# CONFIG_ARCH_ACORN is not set
CONFIG_PCI=y
# CONFIG_ISA_DMA is not set
CONFIG_CPU_32=y
# CONFIG_CPU_26 is not set
CONFIG_CPU_ARMV4=y
CONFIG_TUNE_SA110=y

#
# Code maturity level options
#
CONFIG_EXPERIMENTAL=y
# CONFIG_ALIGNMENT_TRAP is not set
CONFIG_TEXT_SECTIONS=y

#
# Loadable module support
#
CONFIG_MODULES=y
# CONFIG_MODVERSIONS is not set
CONFIG_KMOD=y

#
# General setup
#
# CONFIG_NET is not set
CONFIG_SYSVIPC=y
# CONFIG_BSD_PROCESS_ACCT is not set
CONFIG_SYSCTL=y
CONFIG_NWFPE=y
# CONFIG_BINFMT_AOUT is not set
CONFIG_BINFMT_ELF=y
# CONFIG_BINFMT_MISC is not set
# CONFIG_PARPORT is not set
CONFIG_LEDS=y
CONFIG_LEDS_TIMER=y
CONFIG_LEDS_CPU=y

#
# Plug and Play support
#
# CONFIG_PNP is not set

#
# Block devices
#
# CONFIG_BLK_DEV_FD is not set
# CONFIG_BLK_DEV_IDE is not set
# CONFIG_BLK_DEV_HD_ONLY is not set
# CONFIG_BLK_DEV_LOOP is not set
# CONFIG_BLK_DEV_MD is not set
CONFIG_BLK_DEV_RAM=y
# CONFIG_BLK_DEV_INITRD is not set
# CONFIG_BLK_DEV_XD is not set
CONFIG_PARIDE_PARPORT=y
# CONFIG_PARIDE is not set
# CONFIG_BLK_DEV_HD is not set

#
# Character devices
#
# CONFIG_VT is not set
# CONFIG_SERIAL is not set
# CONFIG_SERIAL_EXTENDED is not set
CONFIG_SERIAL_NONSTANDARD=y
# CONFIG_ROCKETPORT is not set
# CONFIG_DIGIEPCA is not set
# CONFIG_DIGI is not set
# CONFIG_CYCLADES is not set
# CONFIG_STALDRV is not set
# CONFIG_RISCOM8 is not set
# CONFIG_SPECIALIX is not set
# CONFIG_ESPSERIAL is not set
# CONFIG_ISI is not set
CONFIG_SERIAL_21285=y
CONFIG_SERIAL_21285_CONSOLE=y
# CONFIG_UNIX98_PTYS is not set
# CONFIG_MOUSE is not set
# CONFIG_QIC02_TAPE is not set
CONFIG_WATCHDOG=y

#
# Watchdog Cards
#
# CONFIG_WATCHDOG_NOWAYOUT is not set
# CONFIG_WDT is not set
CONFIG_SOFT_WATCHDOG=y
# CONFIG_PCWATCHDOG is not set
# CONFIG_ACQUIRE_WDT is not set
CONFIG_21285_WATCHDOG=y
# CONFIG_21285_FLASH is not set
# CONFIG_NVRAM is not set
# CONFIG_RTC is not set

#
# Video For Linux
#
# CONFIG_VIDEO_DEV is not set

#
# Joystick support
#
# CONFIG_JOYSTICK is not set

#
# Ftape, the floppy tape device driver
#
# CONFIG_FTAPE is not set

#
# SCSI support
#
# CONFIG_SCSI is not set

#
# Sound
#
# CONFIG_SOUND is not set

#
# Filesystems
#
# CONFIG_QUOTA is not set
# CONFIG_AUTOFS_FS is not set
# CONFIG_ADFS_FS is not set
# CONFIG_AFFS_FS is not set
# CONFIG_HFS_FS is not set
# CONFIG_FAT_FS is not set
CONFIG_MSDOS_FS=m
# CONFIG_UMSDOS_FS is not set
CONFIG_VFAT_FS=m
# CONFIG_ISO9660_FS is not set
# CONFIG_JOLIET is not set
# CONFIG_MINIX_FS is not set
# CONFIG_NTFS_FS is not set
# CONFIG_HPFS_FS is not set
CONFIG_PROC_FS=y
# CONFIG_QNX4FS_FS is not set
CONFIG_ROMFS_FS=y
CONFIG_EXT2_FS=y
# CONFIG_SYSV_FS is not set
# CONFIG_UFS_FS is not set

#
# Partition Types
#
# CONFIG_OSF_PARTITION is not set
# CONFIG_MAC_PARTITION is not set
# CONFIG_MSDOS_PARTITION is not set
# CONFIG_SGI_PARTITION is not set
# CONFIG_SUN_PARTITION is not set
# CONFIG_AMIGA_PARTITION is not set
# CONFIG_ACORN_PARTITION is not set
# CONFIG_NLS is not set

#
# Kernel hacking
#
CONFIG_FRAME_POINTER=y
CONFIG_DEBUG_ERRORS=y
# CONFIG_DEBUG_USER is not set
# CONFIG_DEBUG_INFO is not set
CONFIG_MAGIC_SYSRQ=y
# CONFIG_ARTHUR is not set

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Wed, 10 Feb 1999 10:03:48 +0000

>`footbridge_watchdog_init'

My mistake.  Try the appended patch.

p.

--- linux/drivers/char/Makefile~	Mon Feb  8 11:49:51 1999
+++ linux/drivers/char/Makefile	Wed Feb 10 10:02:28 1999
@@ -469,6 +469,30 @@
   endif
 endif
 
+ifeq ($(CONFIG_21285_WATCHDOG),y)
+L_OBJS += wdog285.o
+else
+  ifeq ($(CONFIG_21285_WATCHDOG),m)
+  M_OBJS += wdog285.o
+  endif   
+endif
+
+ifeq ($(CONFIG_21285_FLASH),y)
+L_OBJS += flash285.o
+else
+  ifeq ($(CONFIG_21285_FLASH),m)
+  M_OBJS += flash285.o
+  endif   
+endif
+
+ifeq ($(CONFIG_VNC_FLASH),y)
+L_OBJS += nwflash.o
+else
+  ifeq ($(CONFIG_VNC_FLASH),m)
+  M_OBJS += nwflash.o
+  endif   
+endif
+
 include $(TOPDIR)/Rules.make
 
 fastdep: