Subject: Re: arm-linux lockup

From: [email-masked]
Date: Thu, 25 Feb 1999 16:50:11 +0000

>  Enabling bus-master transmits and whole-frame receives.
>PCI: master abort pc=C00A668C
>Sending RARP requests..... OK

I don't expect it's related to your problem but you might like to investigate 
that master abort message.  Those shouldn't happen in normal operation unless 
something is accessing nonexistent peripherals.

p.

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: christophe leroy <[email-masked]>
Date: Thu, 25 Feb 1999 17:40:02 +0000

Russell King wrote:
> 
> christophe leroy said:
> > On console I've got: Freeing unused kernel memory: 8k init
> > Then nothing.
> > EBSA285 responds to ping during kernel boot, but not anymore at this
> > point
> 
> It sounds like you're missing the FPEmulator.  Try configuring
> your kernel for NWFPE.
> 

I've got NWFPE in my kernel.

christophe

Linux version 2.2.1-rmk4 (root@dcs) (gcc version egcs-2.91.57 19980901
(egcs-1.1
 release)) #66 Thu Feb 25 14:53:33 1999
NetWinder Floating Point Emulator V0.94.1 (c) 1998 Corel Computer Corp.
Calibrating delay loop... 213.81 BogoMIPS
Memory: 15196k/16M available (804k code, 32k reserved, 344k data, 8k
init)
POSIX conformance testing by UNIFIX
PCI: Intel 21285 Footbridge revision 03
PCI: Probing PCI hardware
pci_scan_bus for bus 0
PCI: master abort pc=C00118AC
PCI: 00:38 [10b7/9055]
PCI: pci_scan_bus returning with max=00
pcibios_fixup_ebsa285: ve=10b7 id=9055
PCI: 00:38 [10b7/9055] on irq 22
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Unix domain sockets 1.0 for Linux NET4.0.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
Starting kswapd v 1.5
Footbridge Watchdog Timer: 0.01, timer margin: 60 sec
RAM disk driver initialized:  16 RAM disks of 4096K size
3c59x.c:v0.99H 11/17/98 Donald Becker
http://cesdis.gsfc.nasa.gov/linux/drivers/
vortex.html
eth0: 3Com 3c905B Cyclone 100baseTx at 0x400,  00:10:4b:4b:4c:7e, IRQ 22
  8K byte-wide RAM 5:3 Rx:Tx split, Autonegotiate interface.
  MII transceiver found at address 24, status 780d.
  Enabling bus-master transmits and whole-frame receives.
PCI: master abort pc=C00A668C
Sending RARP requests..... OK
IP-Config: Got RARP answer from 192.168.235.2, my address is
192.168.235.90
Looking up port of RPC 100003/2 on 192.168.235.2
Looking up port of RPC 100005/1 on 192.168.235.2
VFS: Mounted root (NFS filesystem) readonly.
Freeing unused kernel memory: 8k init
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: christophe leroy <[email-masked]>
Date: Thu, 25 Feb 1999 18:37:25 +0000

> something is accessing nonexistent peripherals.

this pc is inside pcnet32_probe1 function, so I think I dont have
to worry about it, as I've no pcnet32 card in my system at the moment.

christophe

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Thu, 25 Feb 1999 20:11:36 +0000 (GMT)

> something is accessing nonexistent peripherals.

You did configure with NWFPE didn't you?
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.linux.org.uk/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: christophe leroy <[email-masked]>
Date: Fri, 26 Feb 1999 10:48:59 +0000

> You did configure with NWFPE didn't you?

Yes, I did.

I'm trying to trace the problem.
In do_execve(), it never returns from the first copy_strings()

christophe

---

From: Russell King <[email-masked]>
Date: Fri, 26 Feb 1999 10:50:59 +0000 (GMT)

christophe leroy said:
> Oh, by adding printk()s to function copy strings, it goes
> further. I suspect that printk is not synchronous.
> Is there a way to be sure that a printk as be written to 
> the serial port before continuing.

printk is fully synchronous.
--
Russell King ([email-masked])

---

From: christophe leroy <[email-masked]>
Date: Fri, 26 Feb 1999 11:23:57 +0000

Christophe