Subject: 2.2.1-rmk4 buglet

From: Matthew Wilcox <[email-masked]>
Date: Tue, 23 Feb 1999 03:14:37 +0100

In include/asm-arm/arch-rpc/uncompress.h there is
#include "../arch/arm/drivers/char/font.h"

I can't find a file which looks anything like this, so I just deleted the
offending line.  However then I get

arm-linux-ld -m elf32arm -Ttext 0x10008000 -o vmlinux head.o misc.o /usr/src/linux-2.2-arm/arch/arm/lib/ll_char_wr.o piggy.o
/usr/src/linux-2.2-arm/arch/arm/lib/ll_char_wr.o(.text+0x8): undefined reference to `cmap_80'
make[2]: *** [vmlinux] Error 1
make[2]: Leaving directory `/usr/src/linux-2.2-arm/arch/arm/boot/compressed'

Grepping the source tree finds no references to this anywhere else.

Deleting the offending reference in arch/arm/lib/ll_char_wr.S produces a
kernel which builds.  I'll try booting it tomorrow...

For your convenience:

--- arch/arm/lib/ll_char_wr.S	Tue Feb 23 03:04:04 1999
+++ arch/arm/lib/ll_char_wr.S.old	Tue Feb 23 03:08:54 1999
@@ -25,6 +25,7 @@
 
 LC0:		.word	SYMBOL_NAME(bytes_per_char_h)
 		.word	SYMBOL_NAME(video_size_row)
+		.word	SYMBOL_NAME(cmap_80)
 		.word	SYMBOL_NAME(con_charconvtable)
 
 ENTRY(ll_write_char)
--- include/asm-arm/arch-rpc/uncompress.h~	Sat Feb  6 06:37:07 1999
+++ include/asm-arm/arch-rpc/uncompress.h	Tue Feb 23 02:17:15 1999
@@ -5,7 +5,6 @@
  */
 #define VIDMEM ((char *)SCREEN_START)
  
-#include "../arch/arm/drivers/char/font.h"
 #include <asm/hardware.h>
 #include <asm/io.h>

-- 
Matthew Wilcox <[email-masked]>
"I decry the current tendency to seek patents on algorithms.  There are
better ways to earn a living than to prevent other people from making use of
one's contributions to computer science."  -- Donald E. Knuth, TAoCP vol 3
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Tue, 23 Feb 1999 08:39:44 +0000 (GMT)

> kernel which builds.  I'll try booting it tomorrow...

Ok, I've fixed it to use the font defined in drivers/video/font_acorn_8x8.c
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.linux.org.uk/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |