Subject: Kernel upgrade problems

From: Andrew Tuson <[email-masked]>
Date: Mon, 08 Feb 1999 16:40:13 +0000

I am trying to upgrade from V2.0.35 off the Clan CD, to
V2.2.1, and have run into a problem.

I downloaded linux-2.2.1.tar.gz, and patch-2.2.1-19990128-1.gz,
and unarchived the linux file into /usr/src without any
apparent problems.  I then applied the ARMLinux patch from
the /usr/src/linux directory.  Part way through the execution
of the patch it stopped with

file to patch:

By ignoring that file, the patch proceeded and announced itself
to be successfull.

Make config does not work however, indicating that
script/split_include.c cannot find linux/types.h, linux/stat.h,
linux/errno.h and fcntl.h, and then gives the error:
make: *** [scripts_include] Error 1

This is my first upgrade and (I thought) it seemed to be going
well.  Any help would be gratefully received.

-- 
Andrew Tuson
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Andrew Tuson <[email-masked]>
Date: Mon, 08 Feb 1999 22:25:33 +0000

On 8 Feb Matthew Wilcox wrote:

> On Mon, Feb 08, 1999 at 04:40:13PM +0000, Andrew Tuson wrote:
> It's not the only problem you'll run into.  You'll need an ELF compiler &
> binutils & libc to compile a 2.2 kernel.  I'm trying to upgrade my own
> machine right now, and you can hear the problems I'm having.

Where from?

> > the /usr/src/linux directory.
> 
> -EINSUFFICIENTDATA
> 
> I can however guess that you're not using the correct options to patch
> - you should change into the /usr/src/linux directory and type `zcat
> /path/to/patch-2.2.1-19990128-1.gz | patch -p1'.

I used gzip -cd patch-2.2.1-19990128-1.gz | patch -p1 (from Chris
Sawers ARMLinux pages).

> Even with this correct, I do think you're going to have a lot more
> problems..
> 

Perhaps I would be better off waiting until the Debian CD is available.

-- 
Andrew Tuson