Subject: Re: getty

From: Russell King <[email-masked]>
Date: Thu, 11 Feb 1999 22:04:19 +0000 (GMT)

Dave Baukus said:
> I can not seem to get login/getty working. Any hints?
> 
> I've got linux 2.2.0 booting on an ebsa285 w/ the folowing "features"
> 	- mounting a root NFS file system. The file system image is titan-II-19990106.
> 	- The kernel is compiled w/ 
> 			CONFIG_SERIAL_21285=y
> 			CONFIG_SERIAL_21285_CONSOLE=y
> 	- The only way I was able to get the open of /dev/console to work
> 	was to:
> 		mknod syscons c 5 1
> 		ln -s syscons console

I don't think that this is 100% correct.  Please check the Documentation/devices.txt
for the correct special device settings for the console/tty devices.

> I get a login prompt but I can not get the tty to respond.
> I've tried various arguments at the end of the getty statement to no avail.

After you've hit a few keys on the terminal, can you cat /proc/interrupts and post
the results please?  It maybe that for some reason there are no serial receive
interrupts.

--
Russell King ([email-masked])
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Nicolas Pitre <[email-masked]>
Date: Thu, 11 Feb 1999 20:00:37 -0500 (EST)

> > I've got linux 2.2.0 booting on an ebsa285 w/ the folowing "features"
[...]
> > I've tried various arguments at the end of the getty statement to no avail.

I experienced the same problem with a SA1100 kernel.
I needed the following patch for serial input to work with
2.2.0-pre9.  Maybe it can help you.

--- original/arch/arm/drivers/char/tty_io.c     Wed Jan 20 23:23:31 1999
+++ linux/arch/arm/drivers/char/tty_io.c        Wed Jan 20 21:37:56 1999
@@ -1911,6 +1911,7 @@
        tty->flip.pty_sem = MUTEX;
        tty->tq_hangup.routine = do_tty_hangup;
        tty->tq_hangup.data = tty;
+       sema_init(&tty->atomic_read, 1);
 }

 /*

Nicolas Pitre, B. ing.
[email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Fri, 12 Feb 1999 14:16:44 +0000 (GMT)

> 2.2.0-pre9.  Maybe it can help you.

Ok, this'll be in my next patch release.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.linux.org.uk/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]