Subject: Re: Menuconfig problem

From: Philip Blundell <[email-masked]>
Date: Wed, 24 Feb 1999 12:59:55 +0000

>With philb kernels, It doesn't crash but it ALWAYS defines
>CONFIG_MSDOS_FS and CONFIG_VFAT_FS, even when CONFIG_FAT_FS is unset

Does it define them to M or Y?  If the former I suspect this is because 
menuconfig has a different idea about dep_tristate to the other config 
systems, and they need wrapping in a 'if [ $CONFIG_FAT_FS != "n" ]' type 
construct.

If the latter I've no idea.

p.

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: christophe leroy <[email-masked]>
Date: Wed, 24 Feb 1999 13:42:49 +0000

With rmk kernels, make menuconfig crashes when you enter Filesystem
Menu.
With philb kernels, It doesn't crash but it ALWAYS defines
CONFIG_MSDOS_FS and CONFIG_VFAT_FS, even when CONFIG_FAT_FS is unset

Christophe

---

From: christophe leroy <[email-masked]>
Date: Wed, 24 Feb 1999 14:30:41 +0000

> If the latter I've no idea.

#
# Filesystems
#
# CONFIG_QUOTA is not set
# CONFIG_AUTOFS_FS is not set
# CONFIG_ADFS_FS is not set
# CONFIG_AFFS_FS is not set
# CONFIG_HFS_FS is not set
# CONFIG_FAT_FS is not set
CONFIG_MSDOS_FS=y
# CONFIG_UMSDOS_FS is not set
CONFIG_VFAT_FS=y
# CONFIG_ISO9660_FS is not set

And we can't say that it is because FAT_FS has just been turned off
Before entering menuconfig Filesystem submenu, it was not set,
And I've just entered and exited Filesystem submenu, not played with
FAT_FS

christophe

---

From: Russell King <[email-masked]>
Date: Wed, 24 Feb 1999 15:05:41 +0000 (GMT)

> With rmk kernels, make menuconfig crashes when you enter Filesystem

I've fixed this in 2.2.2 (which should be out shortly).

--
Russell King ([email-masked])

---

From: Philip Blundell <[email-masked]>
Date: Thu, 25 Feb 1999 09:39:13 +0000

>I've found the problem. Here is a patch

Great.  Send it to Michael Chastain, his address is in the MAINTAINERS file.

p.

---

From: christophe leroy <[email-masked]>
Date: Thu, 25 Feb 1999 09:58:22 +0000

christophe

--- linux.2.2.1-arm/scripts/Menuconfig.org      Thu Feb 25 09:52:04 1999
+++ linux.2.2.1-arm/scripts/Menuconfig  Thu Feb 25 09:52:31 1999
@@ -190,7 +190,7 @@
        else if [ "$3" = "m" ]; then
            mod_bool "$1" "$2"
        else
-           define_bool "$2" "$n"
+           define_bool "$2" "n"
        fi; fi
 }
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]