Subject: RE: HELP - Egcs 1.1.1

From: "Chagas, Jason" <[email-masked]>
Date: Tue, 23 Feb 1999 04:40:30 -0800

Tim,

Did you find a solution for the problem you described? I followed
Christophe's instructions step by step and everything seemed to work fine
(after a few minor ajustments, that is) until I go back to finish building
'EGCS'. That's when it fails with the error:

checking whether the C compiler (/home/chagas/egcs/egcs-1.1.1/gcc/xgcc
-B/home/c
hagas/egcs/egcs-1.1.1/gcc/ -g -O2 ) works... no
configure: error: installation or configuration problem: C compiler cannot
create executables.
make: *** [configure-target-libiberty] Error 1

Note I tested 'xgcc' and seems to run ok:

#./xgcc -v
Reading specs from /usr/local/arm/lib/gcc-lib/arm-linux/egcs-2.91.60/specs
gcc version egcs-2.91.60 19990113/philb (egcs-1.1.1 release)

Am I missing something?

Jason

	----------
	From:  [email-masked]
[SMTP:[email-masked]]
	Sent:  Friday, February 19, 1999 3:38 AM
	To:  Tim Lindquist
	Cc:  [email-masked]
	Subject:  Re: HELP - Egcs 1.1.1

	Let me sum up stages and tell me where it fails, I'll help you

	- Compile and install binutils-1.9.1.0.19a
		./configure --target=arm-linux --prefix=where_you_want
		make
		make install
	- add where_you_want/bin in your PATH
	- Untar egcs, patch it, find . -name "*.rej"
	- enter egcs dir, then ./configure --target=arm-linux --
	prefix=wher_you_want_the_same
	- modify makefile to add -Dinhibit-libc in CFLAGS
	- make -i LANGUAGES=c
	- make -i LANGUAGES=c install

	compile glibc, with 
	prefix=/where_you_want_not_the_same_as_above
	make, make install

	go back in egcs,
	./configure --prefix=same_place_as_first_time --with-
	headers=/where_you_put_glibc/include --with-
	libs=/where_you_put_glibc/lib --target=arm-linux
	make LANGUAGES="c c++" 
	make LANGUAGES="c c++" install

	DONE

	Christophe

	> 
	> > I'm having problems building a cross compiler on solaris.
	> > When running  make, I get:
	> >
	> > checking whether the C compiler (arm-linux-gcc -g -O2 ) works...
no
	> > configure: error: installation or configuration problem: C
compiler
	> > cannot create executables.
	> > gmake: *** [configure-target-libiberty] Error 1
	> >
	> > Before I got to this stage, I had the egcs-1.1.1 source,
	> > and got 3 patch files for it that I applied consecutively:
	> >
	> > egcs-1.1.1-prerelease-2-arm-diff-981117.gz
	> > egcs-1.1.1-prerelease-2-arm-diff-981117-981124
	> > egcs-1.1.1-prerelease-2-arm-diff-981124-981125
	> >
	> > I got the following message during the final patch:
	> >
	> > patching file `gcc/f/intdoc.texi'
	> > Reversed (or previously applied) patch detected!  Assume -R? [y]
	> >
	> > I created an egcs-1.1.1-build dir, and from there ran:
	> >
	> >  ../egcs-1.1.1/configure --target=arm-linux
	> > --prefix=/home/elph/tjl/work/sw/armlinux/
	> >
	> > and then ran make.
	> >
	> > What am I doing wrong?
	> 

	unsubscribe: body of `unsubscribe linux-arm' to
[email-masked]
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Tue, 23 Feb 1999 13:10:53 +0000

>Note I tested 'xgcc' and seems to run ok:

Just running `xgcc' with no parameters doesn't test very much.  Try actually 
compiling a source file - "hello world" or something - and see what happens.

p.