Subject: Booting Linux on ebsa285

From: [email-masked]
Date: Tue, 16 Feb 1999 15:56:21 +0100

I've now got everything needed to download aif files on EBSA285 
Flash. Now, I'd like to know two things:
- Can put zImage in flash to be executed at 0x8000 and it will work, 
or is there other initialisations to be done before booting kernel. If 
so, where can I find such a "boot loader" ?
- Where can I find something to put aif header around zImage ?

- Is there a way to load a ramdisk appended at the end of kernel in 
flash, just like you do with a floppy on a PC x86 ?

Thanks 

Christophe

christophe
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Tue, 16 Feb 1999 15:07:05 +0000

>so, where can I find such a "boot loader" ?

Almost but not quite.  You need to load a couple of registers with magic 
numbers before calling the kernel.  Also you need to be in supervisor mode 
with the MMU off but this may well already be the case in your environment.
If you look in the archives for this mailing list you can probably find a bit 
of code I posted a while back for booting kernels on a CATS board where the 
situation is slightly similar.  (If you can't find it, mail me and I'll send 
it to you.)

p.

---

From: [email-masked]
Date: Tue, 16 Feb 1999 18:40:25 +0100

To:             	[email-masked]
Copies to:      	[email-masked]
Subject:        	Re: Booting Linux on ebsa285 
Date sent:      	Tue, 16 Feb 1999 15:07:05 +0000
From:           	Philip Blundell <[email-masked]>

> situation is slightly similar.  (If you can't find it, mail me and I'll send 

Thanks, but I can't find archives of this mailing list. All archives 
listed on www.arm.uk.linux.org have stopped since August 98

So if you can tell me where archives are or send me a copy of your 
tools, It would be nice

Christophe