Subject: make not working.

From: Sam Ellis <[email-masked]>
Date: Tue, 9 Feb 1999 15:56:24 +0000 (GMT)

Hi,

I'm using the 2.0.35 kernel on a RiscPC.
My problem is that make will not execute shell scripts. The shell scripts
are located in a bin directory, and work fine when run from the command
prompt. When run from a makefile, I always get the error 'cannot execute
binary file [Error 126]'.

A trivial example is when the makefile contains:

a:
	b

and the shell script (called b) contains:

echo

doing a 'make -d' gives:
  Putting child 0x00035C60 PID00445 on the chain.
  Live child 0x00035C60 PID445
  make: /usr/bin/make: cannot execute binary file
  Got a SIGCHLD; 1 unreaped children

Am I doing something really stupid, or is it make's fault?
Any help would be appreciated.

Sam Ellis.

Department of Electronics & Computer Science
University of Southampton

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Nicholas Clark <[email-masked]>
Date: Tue, 9 Feb 1999 16:15:30 +0000 (GMT)

> Am I doing something really stupid, or is it make's fault?

No.
try

make SHELL=/bin/zsh

and see if that helps.

> Any help would be appreciated.

1: Do your shell scripts start with a single :   ?
2: Does anyone know if bash 2 can cope with such shell scripts?
   (if so, another reason for suppling bash 2 in preference to 1.14)

Nick