Subject: arm-linux lockup

From: Andrew Thomas <[email-masked]>
Date: Thu, 25 Feb 1999 16:02:35 GMT

christophe leroy writes:
 > I've tried to execute the following init prog with my kernel that
 > now correctly boots:
 > 
 > #include <stdio.h>
 > #include <sys/time.h>
 > 
 > main()
 > {
 >         while (1) {
 >                 printf("Coucou les amis\n");
 >                 fflush(stdout);
 >                 sleep(1);
 >         }
 > }
 > 
 > On console I've got: Freeing unused kernel memory: 8k init
 > Then nothing.
 > EBSA285 responds to ping during kernel boot, but not anymore at this 
 > point
 > 
 > Compiled with crossbuild egcs-1.1b and glibc-2.0.112
 > Doesn't work better when statically linked

/dev/syscons is probably not there or not set up correctly,
you should see a message about no console during boot...

Dave Baukus <[email-masked]>

>		mknod syscons c 5 1
>		ln -s syscons console

suggested this sometime ago and it works for me (on an EBSA285..)

Andrew
	
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Thu, 25 Feb 1999 16:04:35 +0000

>EBSA285 responds to ping during kernel boot, but not anymore at this 

Have you turned on `debug user faults' in the kernel config?  It could be that 
your program is dying for some reason.  If init exits then the kernel will 
probably just lock up.

p.

---

From: christophe leroy <[email-masked]>
Date: Thu, 25 Feb 1999 16:27:40 +0000

#include <stdio.h>
#include <sys/time.h>

main()
{
        while (1) {

christophe

---

From: Andrew Thomas <[email-masked]>
Date: Thu, 25 Feb 1999 17:01:20 GMT

christophe leroy writes:
 > Andrew Thomas wrote:
 > I've got no message, and I've got a c 5 1 console and a c 5 1 syscons

If your running this by replacing /sbin/init then try fopening 
/dev/console etc...

Andrew

---

From: christophe leroy <[email-masked]>
Date: Thu, 25 Feb 1999 17:17:36 +0000

christophe

---

From: christophe leroy <[email-masked]>
Date: Thu, 25 Feb 1999 17:58:08 +0000

> your program is dying for some reason.  If init exits then the kernel will

I've now turned on debug user faults, but I get nothing more
on console.

Christophe

---

From: christophe leroy <[email-masked]>
Date: Thu, 25 Feb 1999 18:19:48 +0000

> If your running this by replacing /sbin/init then try fopening

Tried to explicitly open /dev/console and write to it:
nothing

Christophe

---

From: "Adam 'WeirdArms' Wiggins" <[email-masked]>
Date: Fri, 26 Feb 1999 12:37:26 +1100 (EST)

Does linux-arm reserve some of the virtual address space for the
kernel? If so how much and where?

	Cheers Adam

---

From: Russell King <[email-masked]>
Date: Fri, 26 Feb 1999 09:24:52 +0000 (GMT)

> kernel? If so how much and where?

linux-arm is the kernel, with any program that runs out of RAM,
it does reserve space for itself (otherwise how can it run?)
How much depends on the build size of the kernel, where is in
the systems RAM.

Could you please be more explicit?

--
Russell King ([email-masked])

---

From: christophe leroy <[email-masked]>
Date: Fri, 26 Feb 1999 09:29:49 +0000

> kernel? If so how much and where?

Yes, the same than i386
C0000000 to FFFFFFFF

christophe

---

From: Philip Blundell <[email-masked]>
Date: Fri, 26 Feb 1999 10:20:08 +0000

>kernel? If so how much and where?

Depends on exactly what you're thinking of.  Broadly, the page from 0-0xfff 
and the area from C0000000-FFFFFFFF are reserved for the kernel's use.  Of 
that, the area at C0000000-CFFFFFFF is used for direct-mapped RAM and 
everything above that is I/O.

1000-BFFFFFFF is available for user programs.

Mark van D.'s "co285" architecture changes this around somewhat, though.  He 
puts the kernel rather a lot lower down to get more space for PCI mappings.

p.