Subject: egcs 1.1.1 on Netwinder

From: Chris Blazie <[email-masked]>
Date: Tue, 5 Jan 1999 16:16:48 -0500 (EST)

I'm trying to install egcs 1.1.1 on a Netwinder.  I did the
following:

1)  Unpack egcs-1.1.1
2)  Apply latest patch (egcs-1.1.1-arm-diff-981227.gz)
3)  ./configure --prefix=/usr/local --target=arm-linuxaout --with-gnu
--with-cpu=strongarm110
4)  make "LANGUAGES=c c++"

and it bombs with:

gcc -DCROSS_COMPILE -DIN_GCC    -g -O2  -DHAVE_CONFIG_H     -I. -I.
-I./config \
-DPREFIX=\"/usr/local\" \
  -c `echo ./prefix.c | sed 's,^\./,,'`
In file included from config/arm/aout.h:259,
                 from config/arm/linux-aout.h:56,
                 from tm.h:2,
                 from config/arm/xm-arm.h:54,
                 from config/arm/xm-linux.h:22,
                 from config.h:2,
                 from prefix.c:66:
config/arm/arm.h:56: syntax error before `enum'
make[1]: *** [prefix.o] Error 1
make[1]: Leaving directory `/usr2/src/egcs-1.1.1/gcc'
make: *** [all-gcc] Error 2

	I tried altering the parameters to configure (specifying the
host/build machine, etc) but no luck.  Am I missing a patch here?

Thanks,

Chris

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Wed, 06 Jan 1999 15:59:04 +0100

>3)  ./configure --prefix=/usr/local --target=arm-linuxaout --with-gnu

Are you sure you want to target an a.out system?  You don't need --with-gnu by 
the way, it's the default for Linux.

>make: *** [all-gcc] Error 2

My guess is that config.h has something nasty in it, maybe because of a broken 
autoconf or something.  If there's nothing obvious there, run it through gcc 
-E and look at whatever comes immediately before that enum in the output.  
99% of the headers in config/arm are just #defines so it should be fairly 
obvious.

p.

---

From: Chris Blazie <[email-masked]>
Date: Wed, 6 Jan 1999 11:03:46 -0500 (EST)

> config/arm/arm.h:56: syntax error before `enum'

	Ok, this really was what it seemed.  In the file "auto-host.h" in
egcs-1.1.1/gcc the word "TOP" (line 106) is getting generated by
configure. I don't know why that would happen, but removing the line fixes
it.

Chris