Subject: RE: ARM-Linux on Brutus...

From: "Steve Kipisz (EUS)" <[email-masked]>
Date: Thu, 28 Jan 1999 05:57:55 -0600

I can't remember how I solved this problem.  I remembered having the
problem, I just can't remember how I solved it!  Here is my file:

/*
 * *** THIS FILE IS AUTOMATICALLY GENERATED.  DO NOT EDIT! ***
 */
unsigned long tss_memmap = 696;
#define __HAS_tss_memmap
unsigned long mm = 708;
#define __HAS_mm
unsigned long pgd = 4;
#define __HAS_pgd
unsigned long tss_save = 692;
#define __HAS_tss_save
unsigned long tss_fpesave = 552;
#define __HAS_tss_fpesave

Steve Kipisz

> -----Original Message-----
> From:	Chagas, Jason [SMTP:[email-masked]]
> Sent:	Thursday, January 28, 1999 2:04 AM
> To:	[email-masked]'
> Cc:	Chagas, Jason
> Subject:	ARM-Linux on Brutus...
> 
> I ran into a problem building the ARM-Linux version (v2.0.030) that runs
> on
> Brutus (downloaded from
> http://www.research.digital.com/wrl/itsy/linux/linux-brutus.html
> <http://www.research.digital.com/wrl/itsy/linux/linux-brutus.html> ). The
> file 'getconstants.c' fails to build because some variable names in
> 'getconstants.h' were not declared:
> 
> /*
>  * *** THIS FILE IS AUTOMATICALLY GENERATED.  DO NOT EDIT! ***
>  */
> unsigned long  = 696;
> #define __HAS_
> unsigned long  = 708;
> #define __HAS_
> unsigned long  = 4;
> #define __HAS_
> unsigned long  = 692;
> #define __HAS_
> unsigned long  = 552;
> #define __HAS_
> 
> 
> Apparently 'getconstants.h1' gets generated by
> '/arch/arm/lib/extractinfo.perl'... I've tried building it with both ELF
> and
> 'a.out' and experienced the same problem on both instances.
> 
> Can anyone tell me what I'm missing??
> 
> Thanks,
> 
> Jason
> unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Russell King <[email-masked]>
Date: Thu, 28 Jan 1999 17:24:50 +0000 (GMT)

> #define __HAS_tss_fpesave

It is not a good idea to send people this file!  There is a good
reason why it's automatically generated (and it's not to make the
build process harder).  The constants are highly kernel-version
dependent.

The problem is most likely going to be an incompatability between
the 'extractinfo.pl' perl script and your version of objdump.  When
using 2.0 kernel source, you either /must/ use the binutils-2.7 a.out
tools, /or/ fix 'extractinfo.pl' so that it can parse your binutils'
objdump output.
--
Russell King ([email-masked])