Subject: Configure.help

From: Philip Blundell <[email-masked]>
Date: Sun, 24 Jan 1999 15:16:40 +0100

The latest 2.2 kernel is missing help for these config options (plus many 
others not ARM related).  Anybody feel like writing any of them?

Include support for Intel EBSA285
CONFIG_ARCH_EBSA285
  No help for CONFIG_ARCH_EBSA285

Include support for Corel NetWinder
CONFIG_ARCH_NETWINDER
  No help for CONFIG_ARCH_NETWINDER

21285 serial port support
CONFIG_SERIAL_21285
  No help for CONFIG_SERIAL_21285

Console on 21285 serial port
CONFIG_SERIAL_21285_CONSOLE
  No help for CONFIG_SERIAL_21285_CONSOLE

DS1620 Thermometer support
CONFIG_DS1620
  No help for CONFIG_DS1620

VIDC 16-bit sound
CONFIG_SOUND_VIDC
  No help for CONFIG_SOUND_VIDC

Netwinder WaveArtist
CONFIG_SOUND_WAVEARTIST
  No help for CONFIG_SOUND_WAVEARTIST

WaveArtist I/O base
CONFIG_WAVEARTIST_BASE
  No help for CONFIG_WAVEARTIST_BASE

WaveArtist IRQ
CONFIG_WAVEARTIST_IRQ
  No help for CONFIG_WAVEARTIST_IRQ

WaveArtist DMA
CONFIG_WAVEARTIST_DMA
  No help for CONFIG_WAVEARTIST_DMA

WaveArtist second DMA
CONFIG_WAVEARTIST_DMA2
  No help for CONFIG_WAVEARTIST_DMA2

Cyber2000 support
CONFIG_FB_CYBER2000
  No help for CONFIG_FB_CYBER2000

Acorn console 8x8 font
CONFIG_FONT_ACORN_8x8
  No help for CONFIG_FONT_ACORN_8x8

MFM harddisk support
CONFIG_BLK_DEV_MFM
  No help for CONFIG_BLK_DEV_MFM

Old Archimedes floppy (1772) support
CONFIG_BLK_DEV_FD1772
  No help for CONFIG_BLK_DEV_FD1772

Autodetect hard drive geometry
CONFIG_BLK_DEV_MFM_AUTODETECT
  No help for CONFIG_BLK_DEV_MFM_AUTODETECT

Acorn partition support
CONFIG_ACORN_PARTITION
  No help for CONFIG_ACORN_PARTITION

Native filecore partition support
CONFIG_ACORN_PARTITION_ADFS
  No help for CONFIG_ACORN_PARTITION_ADFS

ICS partition support
CONFIG_ACORN_PARTITION_ICS
  No help for CONFIG_ACORN_PARTITION_ICS

PowerTec partition support
CONFIG_ACORN_PARTITION_POWERTEC
  No help for CONFIG_ACORN_PARTITION_POWERTEC

RISCiX partition support
CONFIG_ACORN_PARTITION_RISCIX
  No help for CONFIG_ACORN_PARTITION_RISCIX

Here's my contribution for CONFIG_DEBUG_INFO.

Include debugging information in kernel binary
CONFIG_DEBUG_INFO
  Say Y here to include source-level debugging information in the `vmlinux'
  binary image.  This is handy if you want to use gdb or addr2line to
  debug the kernel.  It has no impact on the in-memory footprint of the
  running kernel but it can increase the amount of time and disk space
  needed for compilation.  If in doubt say N.

p.

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Sun, 24 Jan 1999 17:44:04 +0000 (GMT)

> others not ARM related).  Anybody feel like writing any of them?

Anyone at all want to do these?  It's a nice easy task. ;)

>   needed for compilation.  If in doubt say N.

Ok, added.  Maybe I'll do a new patch tonight. (4 patches in one weekend.
Have I gone mad?)
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.linux.org.uk/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Mon, 25 Jan 1999 17:28:06 +0100

Hi Paul,

>I figured I'd try the 285 related ones but looking at the code (to
>figure out exactly what happens) leaves me puzzled.

Actually Dave Gilbert has already sent me entries for those two.  Thanks 
anyway.  I've appended a list of the ones that I think are still missing in my 
current tree.

>CONFIG_SERIAL_21285 and CONFIG_SERIAL_21285_CONSOLE are mentioned in
>arch/arm/drivers/tty_io.c and the latter also in
>arch/arm/drivers/serial_21285.c~.  Note the tilde.  Is that unfinished 
>work?  Turning on CONFIG_SERIAL_21285 causes a call to rs285_init to
>appear but I see that defined nowhere.

It should be in linux/drivers/char/serial_21285.c I think.  The ~ file is just 
a stray backup; Russell's patches aren't always completely clean in that 
respect.

p.

VIDC 16-bit sound
CONFIG_SOUND_VIDC

Netwinder WaveArtist
CONFIG_SOUND_WAVEARTIST

WaveArtist I/O base
CONFIG_WAVEARTIST_BASE

WaveArtist IRQ
CONFIG_WAVEARTIST_IRQ

WaveArtist DMA
CONFIG_WAVEARTIST_DMA

WaveArtist second DMA
CONFIG_WAVEARTIST_DMA2

Cyber2000 support
CONFIG_FB_CYBER2000

Acorn console 8x8 font
CONFIG_FONT_ACORN_8x8

Acorn partition support
CONFIG_ACORN_PARTITION

ICS partition support

RISCiX partition support

---

From: Paul Koning <[email-masked]>
Date: Mon, 25 Jan 1999 12:06:19 -0500

>>>>> "Philip" == Philip Blundell <[email-masked]> writes:

 Philip> The latest 2.2 kernel is missing help for these config
 Philip> options (plus many others not ARM related).  Anybody feel
 Philip> like writing any of them?

	paul

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Tue, 26 Jan 1999 20:29:53 +0000 (GMT)

> a stray backup; Russell's patches aren't always completely clean in that 

Strange, they're not in my latest tree, but they are in the release tree.
rm -rf can't be working.  I'll just try rm -rf / and see what happens... ;)

I'm sure if I find the time to do 2.2.0 they won't be there.

However, I'm now thinking about splitting the arch/arm/drivers/char stuff
out into one separate patch.  I'm not going to bother from this point on
maintaining this stuff (dispite IMHO it's far superiour to the FB console
in terms of speed).  If someone wants faster speed from their console,
they can look at my modifications to the original Linux console code to
speed it up by around a factor of 2 and do a similar optimisation to the
FB stuff.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.linux.org.uk/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]