Subject: ARCIN v6 trouble

From: Tom Lawton <[email-masked]>
Date: Wed, 06 Jan 1999 17:39:13 +0000

Hi,

 Having recently compiled a new 2.0.35 kernel with ARCIN support, I rebooted
and the bootup took quite some time due to problems with the card. Can anyone
explain them and tell me how to prevent them? The most obvious method I can
think of is to recompile without support but I'd prefer to use the drive if
possible.

 There was a long pause after the "unrecognised interrupt from backplane",
and after every "irq timeout".

 The card is one bought from APDL, marked "ARCIN v6B"
 
 Thanks,
 
 Tom

Console: colour A-series 128x96x256, 1 virtual console (max 63) Installed
expansion cards:
  0:      [003C:00AE] IDE & CDFS Expansion Card
  8:      [0053:00E4] ANT Ethernet (00:02:07:04:48:f0) Acorn Access / AUN (DCI4)

 [snip]
 
icside: detected ARCIN V6 in slot 0
hda: Seagate Technology 1275MB - ST31276A, 1221MB w/0kB Cache, CHS=2482/16/63
hde: Conner Peripherals 850MB - CFS850A, 812MB w/64kB Cache, CHS=1651/16/63
hdf: CD820E.0v1098300, ATAPI CDROM drive ide0 at 0x1f0-0x1f7,0x3f6 on irq 9
ide2 at 0x800d0c00-0x800d0c07,0x800d0ce0 on irq 32 Partition check:
 hda: [ADFS] hda1 [Linux] hda2 < hda3 hda4 >
 hde:<3>
Unrecognised interrupt from backplane

Interrupt lockup detected - disabling expansion card IRQs
Expansion card IRQ state:
  0: claimed, irqaddr = e0342290, irqmask = 1, status=FE
hde: irq timeout: status=0x50 { DriveReady SeekComplete }
hde: irq timeout: status=0x50 { DriveReady SeekComplete }
hde: irq timeout: status=0x50 { DriveReady SeekComplete }
hde: irq timeout: status=0x58 { DriveReady SeekComplete DataRequest }
ide2: reset: success
hde: irq timeout: status=0x50 { DriveReady SeekComplete }
hde: irq timeout: status=0x50 { DriveReady SeekComplete }
hde: irq timeout: status=0x50 { DriveReady SeekComplete }
hde: irq timeout: status=0x58 { DriveReady SeekComplete DataRequest }
ide2: reset: success
hde: irq timeout: status=0x50 { DriveReady SeekComplete }
end_request: I/O error, dev 21:00, sector 0
 unable to read boot sectors / partition sectors

 [the kernel then continued bootup successfully]

-- 

... Be a better psychiatrist and the world will beat a psychopath to your
door
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Fri, 8 Jan 1999 14:26:01 +0000 (GMT)

> Unrecognised interrupt from backplane

Oops, this means that the expansion card layer does not know where the
interrupt came from.

>   0: claimed, irqaddr = e0342290, irqmask = 1, status=FE

That's saying that the interrupt status register for card 0 is not
indicating that the card is not causing an interrupt.  I suspect that
the registers are not pointing at the correct place.

Which connector are your drives connected to?
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.linux.org.uk/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]