Subject: RE: Problems building an ARM development environment

From: "Chagas, Jason" <[email-masked]>
Date: Fri, 22 Jan 1999 11:30:38 -0800

Matt,

Thanks again for your prompt response. 

The build process now failed at a different spot. After reading the
instructions posted by Phil Blundell (at
http://www.tazenda.demon.co.uk/phil/arm-tools.html) I tried  running 'make
LANGUAGES="c" ' in the 'gcc' subdirectory (~/egcs-1.1.1/gcc). This is was
the error returned:

_udivsi3
_divsi3
_umodsi3
_modsi3
_dvmd_lnx
libgcc1.S:430: asm/unistd.h: No such file or directory
make: *** [libgcee1-arm.a] Error 1
#

If I run 'make cross' from the 'egcs-1.1.1' directory I get the same error.

Do you know how I can fix it?

Thanks,

Jason

	----------
	From:  Matthew Wilcox [SMTP:[email-masked]]
	Sent:  Friday, January 22, 1999 1:42 PM
	To:  Chagas, Jason
	Cc:  'Matthew Wilcox'; 'Philip Blundell';
[email-masked]'
	Subject:  Re: Problems building an ARM development environment

	On Fri, Jan 22, 1999 at 10:27:49AM -0800, Chagas, Jason wrote:
	> Mathew,
	> 
	> I was able to run the patch (#patch -p1 <
egcs-1.1.1-arm-diff-990113) and
	> 'configure' (./configure --target=arm-linux -prefix=/usr)
successfully.
	> However, 'make' failed with the following error messages:
	> 
	> In file included from ./objc/hash.c:31:
	> objc/runtime.h:31: stdio.h: No such file or directory
	> objc/runtime.h:31: ctype.h: No such file or directory
	> In file included from objc/runtime.h:38,
	>                  from ./objc/hash.c:31:
	> include/objc/objc-api.h:33 stdio.h: No such file or directory
	> make[1]: Leaving directory '/home/chagas/egcs/egcs-1.1.1/gcc'
	> make: *** [all-gcc] Error 2
	> #
	> 
	> Has anyone experienced this problem and/or knows how to fix it?

	You're building the Objective C compiler; this will almost certainly
not
	work.  According to INSTALL/BUILD, you should be typing `make cross'
	which will build only the C and C++ compilers.

	-- 
	Matthew Wilcox <[email-masked]>
	"I decry the current tendency to seek patents on algorithms.  There
are
	better ways to earn a living than to prevent other people from
making use of
	one's contributions to computer science."  -- Donald E. Knuth, TAoCP
vol 3

---

From: Matthew Wilcox <[email-masked]>
Date: Sat, 23 Jan 1999 14:07:13 +0100

> Do you know how I can fix it?

You need to tell it where the kernel headers are - I forget what the
directive for this is.

-- 
Matthew Wilcox <[email-masked]>
"I decry the current tendency to seek patents on algorithms.  There are
better ways to earn a living than to prevent other people from making use of
one's contributions to computer science."  -- Donald E. Knuth, TAoCP vol 3

---

From: Philip Blundell <[email-masked]>
Date: Sat, 23 Jan 1999 17:41:18 +0100

>You need to tell it where the kernel headers are - I forget what the

Either give the --with-headers option to configure, or just put the 
appropriate headers in $PREFIX/arm-linux/include (eg /usr/arm-linux/include/
asm and /usr/arm-linux/include/linux).  I recommend the latter personally.

p.