Subject: hd.c bitrot

From: Philip Blundell <[email-masked]>
Date: Sun, 17 Jan 1999 11:49:54 +0100

Here's a patch.  I guess not many people use it these days. :-)

p.

--- clean/linux/drivers/block/hd.c	Mon Jan 11 18:22:22 1999
+++ linux/drivers/block/hd.c	Sat Jan 16 18:48:33 1999
@@ -803,8 +791,12 @@
 	hd_ioctl,		/* ioctl */
 	NULL,			/* mmap */
 	hd_open,		/* open */
+	NULL,			/* flush */
 	hd_release,		/* release */
-	block_fsync		/* fsync */
+	block_fsync,		/* fsync */
+	NULL,			/* fasync */
+	NULL,			/* check_media_change */
+	NULL			/* revalidate */
 };
 
 __initfunc(int hd_init(void))

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Sun, 17 Jan 1999 13:04:31 +0100

>Do you really need these? I thought GCC always packed out empty structure
>entries like that automatically...

Yeah.  I put them in because hd.c actually does have a revalidate routine - it 
just turns out to be arranged slightly wrong at the moment.

And, duh, I meant to send that to linux-kernel not linux-arm.  For the ARM 
there is another problem if you've applied Russell's patch; you need something
like this too.

@@ -80,6 +73,8 @@
 static int reset;
 static int hd_error;
 
+#define SUBSECTOR(block) (CURRENT->current_nr_sectors > 0)
+
 /*
  *  This struct defines the HD's and their types.
  */

p.

---

From: Alex Holden <[email-masked]>
Date: Sun, 17 Jan 1999 12:39:07 +0000 (GMT)

--------------- Linux- the choice of a GNU generation. --------------
: Alex Holden (M1CJD)- Caver, Programmer, Land Rover nut, Radio Ham :