Subject: RE: Problems building an ARM development environment

From: "Chagas, Jason" <[email-masked]>
Date: Fri, 22 Jan 1999 10:27:49 -0800

Mathew,

I was able to run the patch (#patch -p1 < egcs-1.1.1-arm-diff-990113) and
'configure' (./configure --target=arm-linux -prefix=/usr) successfully.
However, 'make' failed with the following error messages:

In file included from ./objc/hash.c:31:
objc/runtime.h:31: stdio.h: No such file or directory
objc/runtime.h:31: ctype.h: No such file or directory
In file included from objc/runtime.h:38,
                 from ./objc/hash.c:31:
include/objc/objc-api.h:33 stdio.h: No such file or directory
make[1]: Leaving directory '/home/chagas/egcs/egcs-1.1.1/gcc'
make: *** [all-gcc] Error 2
#

Has anyone experienced this problem and/or knows how to fix it?

Thanks,

Jason

	----------
	From:  Matthew Wilcox [SMTP:[email-masked]]
	Sent:  Friday, January 22, 1999 12:16 PM
	To:  Chagas, Jason
	Cc:  'Philip Blundell'; [email-masked]'
	Subject:  Re: Problems building an ARM development environment

	Use the patch program.  In the egcs-1.1.1 directory, use
	patch -p1 < filename

	-- 
	Matthew Wilcox <[email-masked]>
	"I decry the current tendency to seek patents on algorithms.  There
are
	better ways to earn a living than to prevent other people from
making use of
	one's contributions to computer science."  -- Donald E. Knuth, TAoCP
vol 3

	On Fri, Jan 22, 1999 at 07:15:53AM -0800, Chagas, Jason wrote:
	> Phil,
	> 
	> Thanks for your prompt reply. However, I ran into trouble when
trying to
	> apply the ARM patch. These were the errors returned:
	> 
	> #./egcs-1.1.1-arm-diff-990113
	> ./egcs-1.1.1-arm-diff-990113: ---: command not found
	> ./egcs-1.1.1-arm-diff-990113: +++: command not found
	> ./egcs-1.1.1-arm-diff-990113: @@: command not found
	> ./egcs-1.1.1-arm-diff-990113: syntax error near unexpected token
	> '<[email-masked]>'
	> ./egcs-1.1.1-arm-diff-990113: ./egcs-1.1.1-arm-diff-990113: line
5:
	> '+1999-01-07 Philip Blundell <[email-masked]>'
	> #
	> 
	> I tried executing 'egcs-1.1.1-arm-diff-990113' both from the
'egcs-1.1.1'
	> subdirectory (where the EGCS code is located) and the directory it
was
	> branched from... I got the same errors on both instances. What is
the
	> appropriate method for applying the ARM patch??

---

From: Matthew Wilcox <[email-masked]>
Date: Fri, 22 Jan 1999 19:42:20 +0100

> Has anyone experienced this problem and/or knows how to fix it?

You're building the Objective C compiler; this will almost certainly not
work.  According to INSTALL/BUILD, you should be typing `make cross'
which will build only the C and C++ compilers.

-- 
Matthew Wilcox <[email-masked]>
"I decry the current tendency to seek patents on algorithms.  There are
better ways to earn a living than to prevent other people from making use of
one's contributions to computer science."  -- Donald E. Knuth, TAoCP vol 3