Subject: Problems compiling egcs 1.1b

From: Glenn Ramsey <[email-masked]>
Date: Tue, 15 Dec 1998 07:11:56 +1400

Hi,

I am trying to get a working ELF system going but am having
problems compiling egcs.  I have followed the recent threads
on this topic but couldn't find the answer to this problem.

I'm using binutils 2.9.1.0.15 (with the patch) and egcs 1.1b
(also with the patch) according to the instructions on Phil
Blundell's web page.

Binutils compiles OK. But if I install them then gcc breaks
and the configure script for egcs doesn't work.  This is
because ld 2.9.1 says it can't understand the format of a
file "crt0.o".  The original ld which works here is 2.4.1.

If I don't install the bunutils, I can configure egcs OK,
however "make LANGUAGES="c" doesn't work because part way
through ld (2.4.1) says: unrecognized emulation mode:
elf32arm.  ld 2.7 does the same.  ld 2.9.1 also doesn't work
but the message it gives is: cannot open crt1.o .  

What do I do now?

g
-- 
Glenn Ramsey
[email-masked]

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Mon, 14 Dec 1998 22:39:33 +0100

>but the message it gives is: cannot open crt1.o .  

Yeah, this is tricky.  The problem is that as soon as you install part of the 
toolchain you end up with an inconsistent state of affairs.  GCC, binutils and 
libc all need to be synchronised for things to work.

About the only way to solve it is to go through an intermediate state of 
having either ELF or a.out as a cross-compiler.  To be honest it would 
probably be easier to ask someone from the Debian or Red Hat camp if they 
could provide working binaries.  (If you're using a non-RiscPC StrongARM 
machine then it's easy; you can just install the NetWinder ones.)  Trying to 
build everything from source is possible but it's quite a long and painful 
process, especially if you haven't had much experience in this area before.

p.