Subject: ping binary(aout) is good working?

From: Hiroshi Ishii <[email-masked]>
Date: Mon, 05 Oct 1998 13:28:12 +0900

Hi!

  I try to "ping localhost" , in brutus-linux , but no
response. Stop at bellow state ;

	PING localhost (127.0.0.1) :56 data bytes

kernel version is 2.0.30. I got "ping" binary from armlinux
ftp site. Of course , I'm setting "TCP/IP networking" is
yes. And setting;

/sbin/ifconfig lo 127.0.0.1  
/sbin/route add -net 127.0.0.0 netmask 255.0.0.0 lo  

"ifconfig -a " showing;

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Bcast:127.255.255.255  Mask:255.0.0.0
          UP BROADCAST LOOPBACK RUNNING  MTU:3584  Metric:1
          RX packets:75 errors:0 dropped:0 overruns:0 frame:0
          TX packets:75 errors:0 dropped:0 overruns:0 carrier:0 coll:0

I think setup is complete. "Ping" is broken? or
brutus-linux has not implement TCP/IP yet?

--------------------------------------
Funai Electric Engineering Co.,LTD
                                     -Hiroshi Ishii
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Deborah Wallach <[email-masked]>
Date: Sun, 4 Oct 1998 21:56:14 -0700

I don't know why you're having problems.  brutus-linux definitely works
with tcp/ip (we run PPP), and the ping binary works fine.

			-Deborah Wallach

---

From: Phil Norman <[email-masked]>
Date: Mon, 05 Oct 1998 10:03:37 +0100

In message <[email-masked]>
          Hiroshi Ishii <[email-masked]> wrote:

>   I try to "ping localhost" , in brutus-linux , but no response. Stop at
> bellow state ;
> 

My network configuration (which is 4 lines of shell script, rather than the
huge number of config files and scripts used by redhat) doesn't bother
setting up a route to localhost.  The only localhost-related thing I have is:

ifconfig -e lo 127.0.0.1

And if I try to ping localhost, it works fine.  I don't know whether this
information is helpful, but my ifconfig line may be worth a try.

Good luck,
Phil

---

From: Philip Blundell <[email-masked]>
Date: Mon, 05 Oct 1998 13:52:10 +0100

>ifconfig -e lo 127.0.0.1

I don't think "-e" is an option that ifconfig understands - it'll just 
silently ignore it.

p.

---

From: Phil Norman <[email-masked]>
Date: Mon, 05 Oct 1998 14:08:15 +0100

In message <[email-masked]>

> I don't think "-e" is an option that ifconfig understands - it'll just 

Ah.  Well, this was stolen from my RiscOS setup (which uses BSD-based
things); it seemed to want it, so I assumed linux would too.  Well, it works
anyway ;-).

Cheers,
Phil

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Mon, 5 Oct 1998 19:50:07 +0100 (BST)

>           TX packets:75 errors:0 dropped:0 overruns:0 carrier:0 coll:0

What does the 'route' command show?  This looks ok, and it appears to
be sending/receiving the packets.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.uk.linux.org/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]