Subject: Angel v1.00 --> v1.02

From: Nicolas Pitre <[email-masked]>
Date: Tue, 1 Sep 1998 09:59:46 -0400 (EDT)

Hi!  This is a question to Angel experts...

In Brutus' Linux code, there is this at the beginning of head32.S :

@ need to enter SVC mode
#define angel_SWIreason_EnterSVC 0x17  /* from arm.h, in angel source */
#define angel_SWI_ARM       (0xEF123456 & 0xffffff)
                mov     r0, #angel_SWIreason_EnterSVC
                swi     #angel_SWI_ARM

@ turn off interrupts to prevent the angel from running
                mrs     r0, cpsr
                orr     r0, r0, #0xc0
                msr     cpsr, r0

This works with Angel 1.00 but doesn't with Angel 1.02.  It it because the
two defines must be changed for Angel 1.02?  If so, does someone knows
what they should be?

Thanks!

Nicolas Pitre, B. ing.
[email-masked]

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Hiroshi Ishii <[email-masked]>
Date: Wed, 02 Sep 1998 10:00:25 +0900

On Tue, 1 Sep 1998 09:59:46 -0400 (EDT)

> two defines must be changed for Angel 1.02?  If so, does someone knows

I think it seems to good two defines you
pointed out.

--------------------------------------
Funai Electric Engineering Co.,LTD
                                     -Hiroshi Ishii
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]