Subject: crash on startup of Linux

From: Sander van der Wal <[email-masked]>
Date: Sun, 20 Sep 1998 09:57:38 +0200

Hi

I'm trying to install arm linux from the Acorn CDRom, following the 
instructions as given by Paul Vigay. I've installed it on my second 
ide disc (a 2.1 GB one). Everything went ok up to step 82 of Paul's
instructions, because the kernel crashed with the messages below (hope
I copied them right)

Partition check
  hda: [ADFS] hda1
  hdb: [ADFS] hdb1 [Linux] hdb2 <hdb3 hdb4>
EXT2-fs warning: mounting unchecked fs, running e2fsck recommended
INIT: version 2.64 booting
Bad mode in prefetch abort handler detected: mode SVC_32
Internal error: Oops: 0
CPU 0
pc: [<c40188a0>]
lr: [<c2805254>]
sp:  c1ec92c4    ip: c1ec9f1c   fp: c1ec9f18
r10: 00000000    r9: 0001d000   r8: 00019f80
r7:  0000007a    r6: c1ec8098   r5: 00000000   r4: c1ff49f8
r3:  00000001    r2: c2805000   r1: 00000000   r0: c280af6c
flags: nZCv  IRQs on  FIQs on   Mode SVC_32
Process insmod <pid: 9, stackpage=c1ec9000>
Stack:
backtrace:
Function entered at [<c2805240>] from [<c001af98>]
Function entered at [<c001ace0>] from [<c000e634>]
  r9=c1ec9fb8
  r8=00018000
  r7=0001d000
  r6=c0106170
  r5=00006094
  r4=03fffd8c
Function entered at [<c000e578>] from [<c000a0d4>]
  r8=c1ec9ff4
  r7=00900080
  r6=00000080
  r5=c1eca018
  r4=00019f80
Code: pc not in code space

I'm using a StrongArm in a RPC600.

Thank you for your time.

-- 
Sander

These systems people never changed. They could work miracles, but at the
same time they claimed perfectly reasonable requests were impossible.

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Sun, 20 Sep 1998 09:28:52 +0100 (BST)

Sander van der Wal writes:
>...

This problem is covered on the FAQ.  Please see the 3rd question in the
'Booting / Rebooting problems' section.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.uk.linux.org/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |