Subject: Re: Booting kernel V2.1.108

From: Russell King <[email-masked]>
Date: Mon, 20 Jul 1998 12:07:14 +0100 (BST)

Philip Blundell writes:
> > >Ok, I've recompiled the kernel with this option. I get this now,
> >
> >Partition Check:
> >hda: unknown partition table
> >hdb: unknown partition table
> >VFS: Cannot open root device 00:03
> >Kernel panic:VFS: Unable to mount root fs on 00:03
>
> You probably forgot to turn on support for the appropriate type of partition
> tables.

I'm still not convinced about this 'root fs on 00:03'.  That's not right.
Have you tried giving the loader on the extra kernel arguments line
'root=/dev/hda3'?  It's the question it asks after you select the kernel
to boot.

--
Russell King ([email-masked])

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Stefan Hanske <[email-masked]>
Date: Mon, 20 Jul 1998 16:25:39 +0200 (METDST)

> 'root=/dev/hda3'?  It's the question it asks after you select the kernel

When I looked through the mails today I found out that the ADFS partition 
support was disabled. Maybe the kernel will boot from 03:03 when it finds 
a valid partition table. Nevertheless, the kernel will have to be 
recompiled.

----------------------------------------------------------
|mailto: Stefan Hanske ([email-masked] |
|WWW : http://www.rzuser.uni-heidelberg.de/~shanske      |
|phone: I'm not silly                                    |
|--------------------------------------------------------|
| And don't forget to remember what you remembered not   |
| to forget to remember...				 |
----------------------------------------------------------

---

From: Chris Gransden <[email-masked]>
Date: Mon, 20 Jul 1998 20:40:46 +0100

> 'root=/dev/hda3'?  It's the question it asks after you select the kernel

Tried this. Same result I'm afraid.
I've compiled the kernel again this time with Acorn partition support.
Now I get,

Partition Check:
hda: <0> Kernel panic: Free list corrupted.

Chris

-- 
Email: [email-masked]
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Mon, 20 Jul 1998 23:15:08 +0100 (BST)

> hda: <0> Kernel panic: Free list corrupted.

I've never seen that on any 2.1.108 kernels I've tried on the RiscPC.
Phil> this looks like a compiler bug - could you check it out with
Chris please?
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.uk.linux.org/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |
 --------------------- Email-relevent MINI FAQ ----------------------
 Installer keys   : ALT-F1 installer, ALT-F2 shell, ALT-F3 installer
                    messages, ALT-F4 kernel messages
 Ether3/B problems: try latest 2.0.34 kernel and root disk.
 --------------------------------------------------------------------

---

From: Chris Gransden <[email-masked]>
Date: Tue, 21 Jul 1998 15:44:14 +0100

> Phil> this looks like a compiler bug - could you check it out with

You're right. I've now managed to successfully boot the kernel. This time I
used gcc 2.7.2.2 & binutils 2.9.1.0.6.
Thanks for your help.

Chris.

---

From: Philip Blundell <[email-masked]>
Date: Tue, 21 Jul 1998 20:26:11 +0100

>used gcc 2.7.2.2 & binutils 2.9.1.0.6.

That's certainly something of a smoking gun.  Somewhere near the top of my 
list of things to do is making an egcs-1.1-based compiler release for ARM/ELF 
and this problem may come out in the wash.

(Incidentally, if you use -mcpu=strongarm110 then GCC 2.8 will generate ldrh/
strh instructions that don't work on the RiscPC.  You might need to fiddle the 
Makefile to turn this off if you get it by default.)

p.