Subject: StrongARM Revision K

From: Matt Nicholls <[email-masked]>
Date: Sun, 19 Jul 1998 20:59:28 +0100 (BST)

Hi there,

Someone on IRC told me that there is a bug in K which can stop
ARMLinux and RiscBSD providing safe virtual memory.

I was just wondering if ARM Linux has a fix for this or not.
Any ideas?

-- 
 __  __      _   _        _  _ 
|  \/  |__ _| |_| |_ _  _| \| |    [email-masked]
| |\/| / _` |  _|  _| || | .` |    http://www.altern.org/dhcomet/
|_|  |_\__,_|\__|\__|\_, |_|\_|    ICQ UIN : 15479212
                     |__/      
We can try to understand the New York Times' effect on man

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Dickon Hood <[email-masked]>
Date: Sun, 19 Jul 1998 21:03:15 +0100

In message <[email-masked]>
          Matt Nicholls <[email-masked]> wrote:

: Hi there,

: Someone on IRC told me that there is a bug in K which can stop
: ARMLinux and RiscBSD providing safe virtual memory.

Yup.

: I was just wondering if ARM Linux has a fix for this or not.
: Any ideas?

It's impossible to fix given that the processor trashes r14_abort at the
critical point.  Bad luck.  Nice idea.  Upgrade to a rev. S chip.

Doesn't seem to affect Linux/arm too much or even NetBSD/arm32 with the UVM
kernel, but I'd not be seen dead running either given the problems.

-- 
Dickon Hood

I've now managed to find my .signature file, normal service
will be resumed when Connex South Central get their act together.
We apologise for the inconvenience in the mean time.
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Dave Gilbert <[email-masked]>
Date: Sun, 19 Jul 1998 21:15:31 +0100 (BST)

> critical point.  Bad luck.  Nice idea.  Upgrade to a rev. S chip.

Can you give the list some more details of this 'feature' please.

Dave

 --------------------------------------------------------------------
/ Dr. David Alan Gilbert      | Running Linux on Alpha & ARM         \ 
\   gro.gilbert @ treblig.org | ------- Happy in hex -------         /
 \____________________________|___ http://www.treblig.demon.co.uk __/

---

From: Dickon Hood <[email-masked]>
Date: Sun, 19 Jul 1998 21:23:05 +0100

In message <[email-masked]>
          Dave Gilbert <[email-masked]> wrote:

: On Sun, 19 Jul 1998, Dickon Hood wrote:

: > : I was just wondering if ARM Linux has a fix for this or not.
: > : Any ideas?

: > It's impossible to fix given that the processor trashes r14_abort at the
: > critical point.  Bad luck.  Nice idea.  Upgrade to a rev. S chip.

: Can you give the list some more details of this 'feature' please.

Nope, 'cos I can't remember them.  Look back through the NetBSD/arm32 mailing
list ('RiscBSD'); it was done to death there a while back.  Something to do
with PC being in a register pull list and on the last word of a page boundary
with the next page unmapped...

-- 
Dickon Hood

---

From: Alan Cox <[email-masked]>
Date: Mon, 20 Jul 1998 00:15:17 +0100 (BST)

> kernel, but I'd not be seen dead running either given the problems.

Most people dont see to worry too much about such things. Similar problems
havent stopped everyone running a 486 with the FPU enabled

---

From: Timothy Baldwin <[email-masked]>
Date: Mon, 20 Jul 1998 07:58:47 +0100

In message <[email-masked]>

> with the next page unmapped...

To clarify it is the LDM instruction that is on the last word of the page.
There are two software fixes for this :
 1. Ensure there are no offending LDM instructions on the last word of a
    page. (ie. modify ld, rather simple I expect, and write a program to
    find the offending binaries so you don't have to recomplie everything.)
 2. Ensure that the next page is not unmapped (I expect it would add
    a significant amount of complexity to the kernel.)
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]