Subject: Booting kernel V2.1.108

From: Chris Gransden <[email-masked]>
Date: Sun, 19 Jul 1998 13:20:38 +0100

When I boot everything seems to go successfully until,

Partition Check:
VFS: Cannot open root device 00:03
Kernel panic:VFS: Unable to mount root fs on 00:03

The linux partition is on the built in ide interface ( RiscPC SA ). Anyone
know what could be wrong.

Thanks,

Chris

-- 
Email: [email-masked]
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Sun, 19 Jul 1998 14:04:14 +0100 (BST)

> know what could be wrong.

Hmm, maybe it doesn't work?

Give some more information, eg, what you're giving the loader, what you
used to compile this kernel up, what patches and from where, what
options you configured for the kernel when you built it.

Like any problem, too much information is better than too little.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.uk.linux.org/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |
 --------------------- Email-relevent MINI FAQ ----------------------
 Installer keys   : ALT-F1 installer, ALT-F2 shell, ALT-F3 installer
                    messages, ALT-F4 kernel messages
 Ether3/B problems: try latest 2.0.34 kernel and root disk.
 --------------------------------------------------------------------

---

From: Chris Gransden <[email-masked]>
Date: Sun, 19 Jul 1998 19:48:59 +0100

> options you configured for the kernel when you built it.

Sorry about that. I had hoped it would be something simple.

I used gcc 2.8.1 & binutils 2.1.9.0.6 to compile the kernel with
pre-patch-2.1.108-19980712-1.gz from the ARM Linux ftp site. The loader
points to *ADFS::4.3. (/dev/hda3). RiscPC has 24MB ram & 2MB vram. 
The linux partition is on a 2.1GB drive partitioned as

1       0    2015999 984 MB  Filecore
2 2016000    2016001   1 KB  Linux Table
3 2016002    4029454 983 MB  Linux Native
4 4029455    4127759  48 MB  Linux Swap

Here's the output from 'make config',

rm -f include/asm-arm/arch include/asm-arm/proc
(cd include/asm-arm; ln -sf arch- arch; ln -sf proc- proc)
rm -f include/asm
( cd include ; ln -sf asm-arm asm)
/bin/sh scripts/Configure arch/arm/config.in
#
# Using defaults found in arch/arm/defconfig
#
*
* System and processor type
*
ARM system type (Archimedes, A5000, RiscPC, EBSA-110, EBSA-285, NexusPCI,
Corel-VNC, Tbox) [RiscPC] 
  defined CONFIG_ARCH_RPC
Optimise for CPU (ARM2, ARM3, ARM6, ARM7, SA110) [SA110] 
  defined CONFIG_CPU_SA110
*
* Code maturity level options
*
Prompt for development and/or incomplete code/drivers (CONFIG_EXPERIMENTAL)
[Y/n/?] y
Use new compilation options (for GCC 2.8) (CONFIG_BINUTILS_NEW) [N/y/?] y
Compile kernel with frame pointer (for useful debugging)
(CONFIG_FRAME_POINTER) [Y/n/?] y
*
* Loadable module support
*
Enable loadable module support (CONFIG_MODULES) [Y/n/?] y
Set version information on all symbols for modules (CONFIG_MODVERSIONS)
[Y/n/?] y
Kernel module loader (CONFIG_KMOD) [Y/n/?] y
*
* General setup
*
Networking support (CONFIG_NET) [Y/n/?] y
System V IPC (CONFIG_SYSVIPC) [Y/n/?] y
BSD Process Accounting (CONFIG_BSD_PROCESS_ACCT) [N/y/?] (NEW) n
Sysctl support (CONFIG_SYSCTL) [Y/n/?] y
Kernel support for a.out binaries (CONFIG_BINFMT_AOUT) [Y/m/n/?] y
Kernel support for ELF binaries (CONFIG_BINFMT_ELF) [M/n/y/?] y
Kernel support for MISC binaries (CONFIG_BINFMT_MISC) [N/y/m/?] (NEW) n
Parallel port support (CONFIG_PARPORT) [Y/m/n/?] y
  PC-style hardware (CONFIG_PARPORT_PC) [Y/m/n/?] y
  Archimedes hardware (CONFIG_PARPORT_ARC) [N/y/m/?] (NEW) n
   Support foreign hardware (CONFIG_PARPORT_OTHER) [N/y/?] (NEW) n
*
* Floppy, IDE, and other block devices
*
Normal floppy disk support (CONFIG_BLK_DEV_FD) [Y/m/n/?] y
Enhanced IDE disk/cdrom/tape support (CONFIG_BLK_DEV_IDE) [Y/m/n/?] y
*
* Please see Documentation/ide.txt for help/info on IDE drives
*
   Use old disk-only driver on primary interface (CONFIG_BLK_DEV_HD_IDE)
[N/y/?] n
   Include IDE/ATA-2 DISK support (CONFIG_BLK_DEV_IDEDISK) [Y/m/n/?] n
   Include IDE/ATAPI CDROM support (CONFIG_BLK_DEV_IDECD) [Y/m/n/?] n
   Include IDE/ATAPI TAPE support (CONFIG_BLK_DEV_IDETAPE) [N/y/m/?] n
   Include IDE/ATAPI FLOPPY support (CONFIG_BLK_DEV_IDEFLOPPY) [N/y/m/?] n
   SCSI emulation support (CONFIG_BLK_DEV_IDESCSI) [N/y/m/?] n
*
* Additional Block Devices
*
Loopback device support (CONFIG_BLK_DEV_LOOP) [M/n/y/?] y
Multiple devices driver support (CONFIG_BLK_DEV_MD) [N/y/?] n
RAM disk support (CONFIG_BLK_DEV_RAM) [Y/m/n/?] y
   Initial RAM disk (initrd) support (CONFIG_BLK_DEV_INITRD) [Y/n/?] y
Parallel port IDE device support (CONFIG_PARIDE) [N/y/m/?] n
*
* Acorn-specific block devices
*
   Support expansion card IDE interfaces (CONFIG_BLK_DEV_IDE_CARDS) [Y/n/?]
n
MFM harddisk support (CONFIG_BLK_DEV_MFM) [N/y/m/?] (NEW) n
*
* Character devices
*
Virtual terminal (CONFIG_VT) [Y/n/?] y
Support for console on virtual terminal (CONFIG_VT_CONSOLE) [Y/n/?] y
Standard/generic (dumb) serial support (CONFIG_SERIAL) [Y/m/n/?] y
   Support for console on serial port (CONFIG_SERIAL_CONSOLE) [N/y/?] n
Extended dumb serial driver options (CONFIG_SERIAL_EXTENDED) [N/y/?] n
   Atomwide serial port support (CONFIG_ATOMWIDE_SERIAL) [Y/m/n/?] n
   Dual serial port support (CONFIG_DUALSP_SERIAL) [Y/m/n/?] n
Parallel printer support (CONFIG_PRINTER) [M/n/y/?] y
  Support IEEE1284 status readback (CONFIG_PRINTER_READBACK) [Y/n/?] n
Support for user misc device modules (CONFIG_UMISC) [N/y/?] n
Watchdog Timer Support (CONFIG_WATCHDOG) [N/y/?] n
Mouse support (CONFIG_MOUSE) [Y/n/?] y
Support Frame buffer devices (CONFIG_FB) [N/y/?] (NEW) n
*
* Networking options
*
Packet socket (CONFIG_PACKET) [N/y/m/?] n
Kernel/User netlink socket (CONFIG_NETLINK) [N/y/?] n
Network firewalls (CONFIG_FIREWALL) [N/y/?] n
Network aliasing (CONFIG_NET_ALIAS) [N/y/?] n
Socket Filtering (CONFIG_FILTER) [N/y/?] n
Unix domain sockets (CONFIG_UNIX) [Y/m/n/?] y
TCP/IP networking (CONFIG_INET) [Y/n/?] y
IP: multicasting (CONFIG_IP_MULTICAST) [N/y/?] n
IP: advanced router (CONFIG_IP_ADVANCED_ROUTER) [N/y/?] n
IP: kernel level autoconfiguration (CONFIG_IP_PNP) [N/y/?] n
IP: optimize as router not host (CONFIG_IP_ROUTER) [N/y/?] n
IP: tunneling (CONFIG_NET_IPIP) [N/y/m/?] y
IP: GRE tunnels over IP (CONFIG_NET_IPGRE) [N/y/m/?] n
IP: aliasing support (CONFIG_IP_ALIAS) [N/y/?] n
IP: TCP syncookie support (not enabled per default)  (CONFIG_SYN_COOKIES)
[N/y/?] n
*
* (it is safe to leave these untouched)
*
IP: Reverse ARP (CONFIG_INET_RARP) [N/y/m/?] n
IP: Drop source routed frames (CONFIG_IP_NOSR) [Y/n/?] n
IP: Allow large windows (not recommended if <16Mb of memory)
(CONFIG_SKB_LARGE) [N/y/?] n
The IPv6 protocol (EXPERIMENTAL) (CONFIG_IPV6) [N/y/m/?] n
*
*  
*
The IPX protocol (CONFIG_IPX) [N/y/m/?] n
Appletalk DDP (CONFIG_ATALK) [N/y/m/?] n
CCITT X.25 Packet Layer (EXPERIMENTAL) (CONFIG_X25) [N/y/m/?] n
LAPB Data Link Driver (EXPERIMENTAL) (CONFIG_LAPB) [N/y/m/?] n
Bridging (EXPERIMENTAL) (CONFIG_BRIDGE) [N/y/?] n
802.2 LLC (EXPERIMENTAL) (CONFIG_LLC) [N/y/?] n
Acorn Econet/AUN protocols (EXPERIMENTAL) (CONFIG_ECONET) [N/y/m/?] (NEW) n
WAN router (CONFIG_WAN_ROUTER) [N/y/m/?] n
Fast switching (read help!) (CONFIG_NET_FASTROUTE) [N/y/?] n
Forwarding between high speed interfaces (CONFIG_NET_HW_FLOWCONTROL)
[N/y/?] n
CPU is too slow to handle full bandwidth (CONFIG_CPU_IS_SLOW) [N/y/?] n
QoS and/or fair queueing (CONFIG_NET_SCHED) [N/y/?] n
*
* Network device support
*
Network device support? (CONFIG_NETDEVICES) [Y/n/?] y
ARCnet support (CONFIG_ARCNET) [N/y/m/?] (NEW) n
Dummy net driver support (CONFIG_DUMMY) [N/y/m/?] y
EQL (serial line load balancing) support (CONFIG_EQUALIZER) [N/y/m/?] n
Ethernet (10 or 100Mbit) (CONFIG_NET_ETHERNET) [N/y/?] (NEW) n
FDDI driver support (CONFIG_FDDI) [N/y/?] (NEW) n
Frame relay DLCI support (CONFIG_DLCI) [N/y/m/?] (NEW) n
PLIP (parallel port) support (CONFIG_PLIP) [N/y/m/?] (NEW) n
PPP (point-to-point) support (CONFIG_PPP) [M/n/y/?] y
*
* CCP compressors for PPP are only built as modules.
*
SLIP (serial line) support (CONFIG_SLIP) [N/y/m/?] n
Wireless LAN (non-hamradio) (CONFIG_NET_RADIO) [N/y/?] (NEW) n
Token Ring driver support (CONFIG_TR) [N/y/?] (NEW) n
Traffic Shaper (EXPERIMENTAL) (CONFIG_SHAPER) [N/y/m/?] (NEW) n
*
* SCSI support
*
SCSI support? (CONFIG_SCSI) [Y/m/n/?] n
*
* Sound
*
Sound support (CONFIG_SOUND) [M/n/y/?] y
OSS sound modules (CONFIG_SOUND_OSS) [N/y/m/?] (NEW) n
*
* Filesystems
*
Quota support (CONFIG_QUOTA) [N/y/?] n
Minix fs support (CONFIG_MINIX_FS) [N/y/m/?] n
Second extended fs support (CONFIG_EXT2_FS) [Y/m/n/?] y
ISO 9660 CDROM filesystem support (CONFIG_ISO9660_FS) [Y/m/n/?] n
DOS FAT fs support (CONFIG_FAT_FS) [Y/m/n/?] y
MSDOS fs support (CONFIG_MSDOS_FS) [Y/m/n/?] y
UMSDOS: Unix-like filesystem on top of standard MSDOS filesystem
(CONFIG_UMSDOS_FS) [N/y/m/?] n
VFAT (Windows-95) fs support (CONFIG_VFAT_FS) [Y/m/n/?] n
/proc filesystem support (CONFIG_PROC_FS) [Y/n/?] y
NFS filesystem support (CONFIG_NFS_FS) [Y/m/n/?] y
NFS server support (CONFIG_NFSD) [Y/m/n/?] y
Coda filesystem support (advanced network fs) (CONFIG_CODA_FS) [N/y/m/?] n
SMB filesystem support (to mount WfW shares etc.) (CONFIG_SMB_FS) [N/y/m/?]
n
OS/2 HPFS filesystem support (read only) (CONFIG_HPFS_FS) [N/y/m/?] n
NTFS filesystem support (read only) (CONFIG_NTFS_FS) [N/y/m/?] n
System V and Coherent filesystem support (CONFIG_SYSV_FS) [N/y/m/?] n
Amiga FFS filesystem support (CONFIG_AFFS_FS) [N/y/m/?] n
Apple Macintosh filesystem support (experimental) (CONFIG_HFS_FS) [N/y/m/?]
n
ROM filesystem support (CONFIG_ROMFS_FS) [N/y/m/?] n
Kernel automounter support (CONFIG_AUTOFS_FS) [N/y/m/?] n
UFS filesystem support (read only) (CONFIG_UFS_FS) [N/y/m/?] n
ADFS filesystem support (read only) (EXPERIMENTAL) (CONFIG_ADFS_FS)
[Y/m/n/?] y
/dev/pts filesystem support (EXPERIMENTAL) (CONFIG_DEVPTS_FS) [N/y/m/?]
(NEW) n
*
* Partitions
*
Alpha OSF partition support (CONFIG_OSF_PARTITION) [N/y/?] (NEW) n
Macintosh partition map support (CONFIG_MAC_PARTITION) [N/y/?] n
PC BIOS (MSDOS partition tables) support (CONFIG_MSDOS_PARTITION) [N/y/?]
(NEW) n
SPARC partition support (CONFIG_SUN_PARTITION) [N/y/?] (NEW) n
Amiga partition table support (CONFIG_AMIGA_PARTITION) [N/y/?] (NEW) n
Acorn partition support (CONFIG_ACORN_PARTITION) [N/y/?] (NEW) n
*
* Native Language Support
*
Codepage 437 (CONFIG_NLS_CODEPAGE_437) [N/y/m/?] n
Codepage 737 (CONFIG_NLS_CODEPAGE_737) [N/y/m/?] n
Codepage 775 (CONFIG_NLS_CODEPAGE_775) [N/y/m/?] n
Codepage 850 (CONFIG_NLS_CODEPAGE_850) [N/y/m/?] n
Codepage 852 (CONFIG_NLS_CODEPAGE_852) [N/y/m/?] n
Codepage 855 (CONFIG_NLS_CODEPAGE_855) [N/y/m/?] n
Codepage 857 (CONFIG_NLS_CODEPAGE_857) [N/y/m/?] n
Codepage 860 (CONFIG_NLS_CODEPAGE_860) [N/y/m/?] n
Codepage 861 (CONFIG_NLS_CODEPAGE_861) [N/y/m/?] n
Codepage 862 (CONFIG_NLS_CODEPAGE_862) [N/y/m/?] n
Codepage 863 (CONFIG_NLS_CODEPAGE_863) [N/y/m/?] n
Codepage 864 (CONFIG_NLS_CODEPAGE_864) [N/y/m/?] n
Codepage 865 (CONFIG_NLS_CODEPAGE_865) [N/y/m/?] n
Codepage 866 (CONFIG_NLS_CODEPAGE_866) [N/y/m/?] n
Codepage 869 (CONFIG_NLS_CODEPAGE_869) [N/y/m/?] n
Codepage 874 (CONFIG_NLS_CODEPAGE_874) [N/y/m/?] n
NLS ISO 8859-1 (CONFIG_NLS_ISO8859_1) [N/y/m/?] n
NLS ISO 8859-2 (CONFIG_NLS_ISO8859_2) [N/y/m/?] n
NLS ISO 8859-3 (CONFIG_NLS_ISO8859_3) [N/y/m/?] n
NLS ISO 8859-4 (CONFIG_NLS_ISO8859_4) [N/y/m/?] n
NLS ISO 8859-5 (CONFIG_NLS_ISO8859_5) [N/y/m/?] n
NLS ISO 8859-6 (CONFIG_NLS_ISO8859_6) [N/y/m/?] n
NLS ISO 8859-7 (CONFIG_NLS_ISO8859_7) [N/y/m/?] n
NLS ISO 8859-8 (CONFIG_NLS_ISO8859_8) [N/y/m/?] n
NLS ISO 8859-9 (CONFIG_NLS_ISO8859_9) [N/y/m/?] n
NLS KOI8-R (CONFIG_NLS_KOI8_R) [N/y/m/?] n
*
* Kernel hacking
*
Debug kernel errors (CONFIG_DEBUG_ERRORS) [Y/n/?] y
Kernel profiling support (CONFIG_PROFILE) [N/y/?] n
Magic SysRq key (CONFIG_MAGIC_SYSRQ) [Y/n/?] y

The Linux kernel should now be configured for your setup.
Check the top-level Makefile for additional configuration,
and do a 'make dep ; make clean' if you want to be sure all
the files are correctly re-made

if [ -r include/linux/autoconf.h ]; then \
    scripts/split-include include/linux/autoconf.h include/config; \
fi

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Sun, 19 Jul 1998 21:20:32 +0100 (BST)

> points to *ADFS::4.3. (/dev/hda3). RiscPC has 24MB ram & 2MB vram. 

Chris: was that original panic: can't mount root filesystem on device 03:03?
Chris: Ok, which version of the loader?  Did you apply any patches to
Chris: gcc 2.8.1?

PhilB: are these the correct gcc and binutils versions?

> Enhanced IDE disk/cdrom/tape support (CONFIG_BLK_DEV_IDE) [Y/m/n/?] y

Ok, IDE support.

>    Include IDE/ATAPI FLOPPY support (CONFIG_BLK_DEV_IDEFLOPPY) [N/y/m/?] n

But no IDE device drivers?  You at least want IDE/ATA-2 DISK support.

> Support Frame buffer devices (CONFIG_FB) [N/y/?] (NEW) n

Good choice at the moment ;)

> IP: Drop source routed frames (CONFIG_IP_NOSR) [Y/n/?] n

It is generally at good idea to turn this option on.
   _____

---

From: Philip Blundell <[email-masked]>
Date: Sun, 19 Jul 1998 22:51:10 +0100

>PhilB: are these the correct gcc and binutils versions?

They should be fine for the kernel.  The binutils problems that people have 
had would usually stop the kernel from either linking or booting at all.

If it really was the `can't mount root on 03:03' problem then not having IDE 
disk support is certainly a bit of a smoking gun.  03:03 is hda3 I think.

p.

---

From: Chris Gransden <[email-masked]>
Date: Sun, 19 Jul 1998 23:52:33 +0100

> Chris: Ok, which version of the loader?  Did you apply any patches to

I'm using V3.26 (28 Jun 1998) of the loader and I applied Phil's ELF
patches to gcc & binutils.

> But no IDE device drivers?  You at least want IDE/ATA-2 DISK support.

Ok, I've recompiled the kernel with this option. I get this now,

Partition Check:
hda: unknown partition table
hdb: unknown partition table
VFS: Cannot open root device 00:03
Kernel panic:VFS: Unable to mount root fs on 00:03

Chris

---

From: Philip Blundell <[email-masked]>
Date: Mon, 20 Jul 1998 09:50:53 +0100

>Kernel panic:VFS: Unable to mount root fs on 00:03

You probably forgot to turn on support for the appropriate type of partition 
tables.

p.