Subject: Problems with 2.0.34

From: Jan Magnussen <[email-masked]>
Date: Fri, 12 Jun 1998 02:27:11 +0200

Hello there

I have compiled the 2.0.34 kernel for my own system with Powertec and etherh
support built into the kernel, but I cannot get either of them to work. Here
is what my kernel writes on startup:

Console: colour A-series 160x128x256, 1 virtual console (max 63)
Installed expansion cards:
  0: [0046:00D4] EtherLan 500 interface (00:c0:32:00:1d:63)
  1: [005B:0107] AlSystems PowerTec SCSI (loader blacklisted)
Calibrating delay loop.. ok - 152.37 BogoMIPS
Memory: 47028k/49152k available (860k kernel code, 36k reserved, 1228k data)
Swansea University Computer Society NET3.035 for Linux 2.0
NET3: Unix domain sockets 0.13 for Linux NET3.035.
Swansea University Computer Society TCP/IP for NET3.034
IP Protocols: ICMP, UDP, TCP
Linux version 2.0.34 ([email-masked]) (gcc version 2.7.2.2) #2 Mon Jun 8 16:48:34 MET DST 1998
Starting kswapd v 1.4.2.2 
Keyboard driver v1.00
Serial driver version 4.13 with no serial options enabled
tty00 at 0x03f8 (irq = 10) is a 16550A
lp2 at 0x0278, (polling)
Sound initialization started
<VIDCsound: VIDC 16-bit sound> at 0x000 irq 20 dma 7,0
Sound initialization complete
hda: Conner Peripherals 540MB - CFS541A, 516MB w/0kB Cache, CHS=1048/16/63
ide0 at 0x1f0-0x1f7,0x3f6 on irq 9
Floppy drive(s): fd0 is 1.44M, fd1 is 1.44M
FDC 0 is a post-1991 82077
scsi0.H: fas216: bus reset detected
scsi0 : PowerTec SCSI at port 800D1000 irq 33 dma 3 v0.0.2 scsi NCR53C9x terminators on
scsi : 1 host.
scsi0.3: using synchronous transfer, offset 7, 100 ns
  Vendor: QUANTUM   Model: FIREBALL ST4.3S   Rev: 0F0C
  Type:   Direct-Access                      ANSI SCSI revision: 02 TAG

Detected scsi disk sda at scsi0, channel 0, id 3, lun 0
scsi0.4: using synchronous transfer, offset 7, 100 ns
  Vendor: CONNER    Model: CFP1080S          Rev: 4649
  Type:   Direct-Access                      ANSI SCSI revision: 02 TAG

Detected scsi disk sdb at scsi0, channel 0, id 4, lun 0
scsi0.6: using synchronous transfer, offset 7, 200 ns
  Vendor: MATSHITA  Model: CD-ROM CR-504     Rev: ST23
  Type:   CD-ROM                             ANSI SCSI revision: 02
Detected scsi CD-ROM sr0 at scsi0, channel 0, id 6, lun 0
scsi : detected 1 SCSI cdrom 2 SCSI disks total.
scsi0.H: incomplete data transfer detected: res=00000000 ptr=c2ff3000 len=200 command=Test Unit Ready 00 00 00 00 00 
SCSI device sda: hdwr sector= 512 bytes. Sectors= 8471232 [4136 MB] [4.1 GB]
scsi0.H: incomplete data transfer detected: res=00000000 ptr=c2ff3000 len=200 command=Test Unit Ready 00 00 00 00 00 
SCSI device sdb: hdwr sector= 512 bytes. Sectors= 2110812 [1030 MB] [1.0 GB]
eth0: etherh 500 found at 80000000, IRQ32, ether address 00:c0:32:00:1d:63 10BaseT
Partition check:
 sda: [PTEC] sda1 sda2 sda3
 sdb:<3>scsi0.H: incomplete data transfer detected: res=00000000 ptr=c021e7fc len=4 command=Read (6) 00 00 00 02 00 
 [PTEC] sdb1
 hda: [ADFS] hda1 [Linux] hda2 < hda3 hda4 >
VFS: Mounted root (ext2 filesystem) readonly.
FPEmulator V4.07 (c) Acorn Computers Ltd.  Ported to ARM Linux by Russell King.
Disclaimer: (this message can be removed by: insmod fpem.o license=0)
  The software is provided "as is"; Acorn Computers Limited ("Acorn") makes no
  warranty, express or implied, of the merchantability of this software or its
  fitness for any particular purpose.  In no circumstance shall Acorn be liable
  for any damage, loss of profits, or any indirect or consequential loss arising
  out of the use of this software or inability to use this software, even if Acorn
  has been advised of the possibility of such loss.
Adding Swap: 36432k swap-space (priority 283)
fcntl_setlk() called by process 85 (syslogd) with broken flock() emulation

-----------------------------------------------------------------------------

There is something very wrong with the etherh driver, because now it says,
that I am using a 10BaseT connection, but I am using 10Base2. I, until very
reasantly used 10BaseT, but then the driver said, that it was a 10Base2
connection, that I was using. Either way I have not been able to get in
contact with any other computer on the network from Linux. It works fine
using RiscOS.

Here is the output from ifconfig if it can help solving the mystery.

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Bcast:127.255.255.255  Mask:255.0.0.0
          UP BROADCAST LOOPBACK RUNNING  MTU:3584  Metric:1
          RX packets:106 errors:0 dropped:0 overruns:0
          TX packets:106 errors:0 dropped:0 overruns:0

eth0      Link encap:10Mbps Ethernet  HWaddr 00:C0:32:00:1D:63
          inet addr:192.255.0.115  Bcast:192.255.255.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:746 overruns:0
          TX packets:0 errors:0 dropped:0 overruns:0
          Interrupt:32 Memory:80000200-d4 

-----------------------------------------------------------------------------

Also most of the time, when I try to mount any of the SCSI disks, the
computer freezes completely and requires a hard reset.

I will be most grateful, if anybody could find out what is wrong, as I need
it badly. (Network using Risc OS sucks:-(   )

Regards,

Jan Magnussen
http://www.kom.auc.dk/~janm
Fidonet : 2:234/181.8

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Thu, 25 Jun 1998 21:04:07 +0100 (BST)

Jan Magnussen writes:
>...

Ok, I'll have a look into the etherh problem soon (probably after the weekend).
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.uk.linux.org/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |