Subject: RE: Installing - phase 3 (the saga continues!)

From: Simon Ogilvie <[email-masked]>
Date: Fri, 12 Jun 1998 12:57:20 +0100

Philip Blundell wrote:
>By the looks of it some module branched to a wild address.  The strange thing
>is that it seems to happen before I'd expect any modules to have been loaded 
>(excepting maybe the FP emulator).
>
>The kernel's already running by that point (and you can probably boot with
>the 
>"init=/bin/sh" option and get to a prompt...) but something is happening that
>makes it fall over when it tries to start userland.

I'll try that tonight.  Is that just specified at the optional
parameters prompt?
>
>You could try taking them out in any case; there may be some bad interaction 
>going on.  The Scanlight in particular is probably quite rare and it may be 
>nobody has run Linux on a machine with one before.

OK, I'll try that too.  Presumably if it does turn out to be one of
them, it
can be blacklisted to that I don't have to keep pulling it out when I
want
to run Linux, and putting it back in when I want to use it...?
>
>Can you remember which modules you selected during installation?

Umm, not sure - it's all a bit hazy!  What part of the installation
process
is that exactly?!

Thanks,
Simon.

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Simon Ogilvie <[email-masked]>
Date: Fri, 12 Jun 1998 23:26:51 +0100

>>However, if I try /bin/csh it works OK and drops me out to
>>a shell with a read-only filesystem, so I still can't change 
>>anything.  At least this is one stage further though...!
>
>You can fix the read-only-ness by using the `rw' parameter.

Where do I put the rw?  The only place I get to specify anything
non-standard is at the optional parameters prompt - is this where
I should specify it, and if so how?
>
>No.  I guessed you had 48MB already but I don't think it's likely to be a 
>problem.

That's good - I didn't want to have to strip my machine down again 
to remove a SIMM!
>
>Do you have a System.map file for that kernel?  (Or, if you're using a 
>precompiled kernel, can you remind me which one?)

The kernel is just the standard 2.0.33 for the rpc off the ARM Linux
web site.  I haven't done anything with it as I haven't had a system
sufficiently up to try regening it!

Cheers,
Simon.

---

From: Simon Ogilvie <[email-masked]>
Date: Sat, 13 Jun 1998 21:45:36 +0100

Right, now we're getting somewhere!

I have booted the system as below, and moved the
fpem module out of the way.  The system then complains
it can't find it on bootup, but continues booting anyway,
and goes all the way to the login prompt!  At this point
it won't log me in though, as it says in the FAQ...

Do I need to do what it says in the FAQ about getting a 
newer insmod and removing some RAM???  I'd thought
as I'd downloaded this from the web site this week I would
already have the latest insmod and modules, but perhaps
not.

Simon.

>----------
>From: 	Simon Ogilvie
>Sent: 	13 June 1998 21:36
>To: 	'Dave Gilbert'
>Cc: 	'Philip Blundell'; [email-masked]'
>Subject: 	RE: Installing - phase 3 (the saga continues!) 
>
>Dave Gilbert wrote:
>See if you can mount /proc and see /proc/modules to see if the fpem is
>mounted.
>
>Thanks to a suggestion from Philip, I have now 
>been able to run up a csh and then remount the
>disk rw using the remount option of mount as
>well as rw.  (Thanks Philip!)
>
>I can now mount the proc directory, but /proc/modules
>is a zero length file - is that correct?
>
>Simon.
>
>