Subject: Installing - phase 3 (the saga continues!)

From: Simon Ogilvie <[email-masked]>
Date: Thu, 11 Jun 1998 21:14:16 +0100

Right, got through the next hurdle, only to find another one
lurking beyond it!  I copied the kernel file in as /vmlinux,
created a /etc/boot.conf file and ran the loadmap -v command
to create the /boot/boot.map file (after linking /dev/root to 
/dev/hda3).  So far so good...

Then I tried to boot the system, and it correctly identifies the
kernel and then crashes when it tries to load it!  The messages
go like this:
....
VFS: Mounted root (ext2 filesystem) readonly.
INIT: version 2.64 booting
Bad mode in prefetch abort handler detected: mode SVC_32
Internal error:  Oops:  0
CPU: 0
pc  :  [<c4018500>]
lr  :  [<c3805254>]
....

and then goes on to dump the register contents and give
a backtrace.  The machine then stiffs and requires a reset
switch to get it back.

Incidentally, the same thing happens if I boot from the kernel
in the adfs partition and specify root=/dev/hda3 at the bootloader
optional parameter prompt.

Any ideas anyone?  I've checked the FAQ this time, and I don't
seem to be able to find this problem there.  It did mention
something about incompatible expansion cards, but I don't think
that can be it can it?  I've got a (blacklisted) Oak SCSI card,
a Scanlight Video256 card and an Acorn MIDI podule, all of which
are irrelevant as far as Linux is concerned.

Once again, any help much appreciated!

Thanks,
Simon.

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Thu, 11 Jun 1998 22:49:21 +0100

>lr  :  [<c3805254>]

By the looks of it some module branched to a wild address.  The strange thing 
is that it seems to happen before I'd expect any modules to have been loaded 
(excepting maybe the FP emulator).

>kernel and then crashes when it tries to load it!

The kernel's already running by that point (and you can probably boot with the 
"init=/bin/sh" option and get to a prompt...) but something is happening that 
makes it fall over when it tries to start userland.

>are irrelevant as far as Linux is concerned.

You could try taking them out in any case; there may be some bad interaction 
going on.  The Scanlight in particular is probably quite rare and it may be 
nobody has run Linux on a machine with one before.

Can you remember which modules you selected during installation?

p.