Subject: RE: Installing - phase 3 (the saga continues!)

From: Simon Ogilvie <[email-masked]>
Date: Sat, 13 Jun 1998 21:36:57 +0100

Dave Gilbert wrote:
>See if you can mount /proc and see /proc/modules to see if the fpem is
>mounted.

Thanks to a suggestion from Philip, I have now 
been able to run up a csh and then remount the
disk rw using the remount option of mount as
well as rw.  (Thanks Philip!)

I can now mount the proc directory, but /proc/modules
is a zero length file - is that correct?

Simon.
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Sat, 13 Jun 1998 22:38:17 +0100

>is a zero length file - is that correct?

Yes - it just means no modules are loaded.

p.

---

From: Matthew Wilcox <[email-masked]>
Date: Sun, 14 Jun 1998 12:01:14 +0100 (BST)

Simon Ogilvie
> is a zero length file - is that correct?

Many files in /proc have zero length; this does not necessarily mean that
they are empty.  It means you can't use `less' on them, but you can use
`cat'.

-- 
Set Alias$Case Set Alias$[ |||| |MSet Alias$Otherwise Set Alias$[ \ Matthew
"" |MSet Alias$When If %0=%%0 Then Set Alias$[ "" ||MIf %0=%%0    \ Wilcox
Then Set Alias$Otherwise Set Alias$[ |||||||||||||||| ||MIf       \
%0=%%0 Then Set Alias$When Set Alias$[ ||||||||||||||||
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Stefan Hanske <[email-masked]>
Date: Mon, 15 Jun 1998 16:43:54 +0200 (METDST)

> Yes - it just means no modules are loaded.

No, all files in /proc have a zero length, this is 'cause this is no 
regular file system. You just need to 'cat file' to see it's contents. 
Even if you'd loaded a whole of 20 modules (if exist) the file would have 
a length of zero.

----------------------------------------------------------
|mailto: Stefan Hanske ([email-masked] |
|WWW : http://www.rzuser.uni-heidelberg.de/~shanske      |
|phone: I'm not silly                                    |
|--------------------------------------------------------|
| And don't forget to remember what you remembered not   |
| to forget to remember...				 |
----------------------------------------------------------

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Thu, 25 Jun 1998 20:35:36 +0100 (BST)

> Yes - it just means no modules are loaded.

Because all 'files' in the /proc filesystem are generated on the
fly (except kcore), their size is unknown.  Therefore, they always
report a size of zero.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.uk.linux.org/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |