Subject: binutils bug

From: Philip Blundell <[email-masked]>
Date: Sun, 21 Jun 1998 10:40:46 +0100

Hi,

Can people who were having trouble with a.out targets using my latest binutils 
try this patch?  It seems to fix the problem for me.

p.

--- gas/write.c~	Sun Jun  7 00:44:19 1998
+++ gas/write.c	Sun Jun 21 10:33:48 1998
@@ -2645,7 +2645,7 @@
 		  seg_reloc_count++;
 #if !(defined (TC_V850) && defined (OBJ_ELF))
 #if !(defined (TC_M68K) && defined (OBJ_ELF))
-#if !(defined (TC_ARM) && defined (OBJ_ELF))
+#if !(defined (TC_ARM))
 #if !defined (TC_I386) || !(defined (OBJ_ELF) || defined (OBJ_COFF)) || defined (TE_PE)
 		  add_number += S_GET_VALUE (add_symbolP);
 #endif

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Stefan Voss <[email-masked]>
Date: Sun, 21 Jun 1998 22:15:03 +0200

In message <[email-masked]>,
     Philip Blundell wrote:

> 
> Can people who were having trouble with a.out targets using my latest
> binutils try this patch?  It seems to fix the problem for me.

Works for me, too. No problems building gas for a.out with the patch. No
problems building gcc for a.out using the newly build gas.

> p.

Regards,
   Stefan

-- 
Stefan Voss
([email-masked])