Subject: Re: ARM and RPM

From: "Andrew E. Mileski" <[email-masked]>
Date: Tue, 30 Jun 1998 17:24:29 -0400

> >StrongARM is ARM4 architecture, and not compatible with
> >ARM3 architecture processors.  The most notable difference
> >is half-word load/store.
> 
> However, you can compile code for v3 and it will then run on v4.  This seems
> the sensible way to proceed except in a very few cases.

Yes, yes, yes!  This is the whole point of what I'm hoping
to get some agreement on.  So can we quit the arguing and come
to a "standard" now, rather than later (=headaches)?

I think a "reasonable" (ie. not perfect) solution is
uname -m to report armN* where N is the architecture, and
anything else is optional (like "t" for thumb or whatever).

I also think it is "reasonable" (ie. not perfect) to use
armN*-*-linux for the ELF compiler and armN*-*-linuxaout for
the a.out compiler.

Pros: armN* strings have the same easily matchable prefixes
      Using "linux" and "linuxaout" is also done on the x86.
Cons: others may not agree :-)

Whatever is agreed upon, it really needs to be done asap
before the ARM-aware applications increase in number.

--
Andrew E. Mileski          mailto:[email-masked]
Software Developer
Corel Computer Corp.       http://www.CorelComputer.com/
OSC-CCC Technical Liaison  http://www.NetWinder.org/
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Tue, 30 Jun 1998 22:32:41 +0100 (BST)

> anything else is optional (like "t" for thumb or whatever).

Did you get my mail on uname -m?

I don't think that this is a good idea.  The official name of the
ARM3 is ARM3, and it could be confusing to use ARM3 to mean ARM
Architecture version 3.  Likewise, there is the ARM2, ARM6, ARM7 etc,
and I think that we'd be storing up trouble.

A better solution may be to use ARMv3 and ARMv4, since there can be
no mistaking these.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.uk.linux.org/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |

---

From: Philip Blundell <[email-masked]>
Date: Tue, 30 Jun 1998 22:42:34 +0100

>anything else is optional (like "t" for thumb or whatever).

That sounds perfectly reasonable to me.

>armN*-*-linux for the ELF compiler and armN*-*-linuxaout for

That also, though the N should be optional.

p.

---

From: Philip Blundell <[email-masked]>
Date: Tue, 30 Jun 1998 23:27:17 +0100

>and I think that we'd be storing up trouble.

This seems like a red herring.  Can you think of any situation where it would 
cause trouble?  As far as I can see there is no need to be able to refer to 
specific CPUs in the machine-name string.  Any program that has sufficiently 
detailed knowledge of the ARM architecture that it needs to know which CPU is 
in use can easily enough include a specific autoconf check for that.

Also, if it _did_ turn out that people needed to be able to do this, it 
wouldn't be the end of the world to extend the machine name string at some 
future date, either by adding an extra component or extending the first one
to, say, `arm4_sa110'.  I imagine we could devise some way to do this without 
terminally upsetting RPM.

(On a somewhat unrelated topic, where did the `armo' and `armv' terminology 
spring from?  I've wondered that on and off for years.)

p.

---

From: "Andrew E. Mileski" <[email-masked]>
Date: Tue, 30 Jun 1998 23:05:01 -0400

> Did you get my mail on uname -m?

Err...probably, but as I got >1500 messages in my box this
morning, there's a chance I overlooked it.  Sorry.

> A better solution may be to use ARMv3 and ARMv4, since there can be

I agree.  Shall we etch this one in stone then?