Subject: RE: Installing - phase 3 (the saga continues!)

From: Simon Ogilvie <[email-masked]>
Date: Fri, 12 Jun 1998 20:29:19 +0100

Philip Blundell wrote:
>You could try taking them out in any case; there may be some bad interaction 
>going on.  The Scanlight in particular is probably quite rare and it may be 
>nobody has run Linux on a machine with one before.

OK tried removing all the expansion cards and the PC card.
No joy.

>The kernel's already running by that point (and you can probably boot with
>the 
>"init=/bin/sh" option and get to a prompt...) but something is happening that
>makes it fall over when it tries to start userland.

Tried that too, and it doesn't stack-dump, but it still hangs!
However, if I try /bin/csh it works OK and drops me out to
a shell with a read-only filesystem, so I still can't change 
anything.  At least this is one stage further though...!
>
>By the looks of it some module branched to a wild address.  The strange thing
>is that it seems to happen before I'd expect any modules to have been loaded 
>(excepting maybe the FP emulator).

The rest of the stack trace is:

pc  :  [<c4018500>]
lr  :  [<c3805254>]
sp  :  c2f25ec4  ip : c2f25f1c  fp : c2f25f18
r10 :  00000000  r9 : 0001c000  r8 : 00018f80
r7  :  0000007a  r6 : c2feec18  r5 : 00000000  r4 : c02189f0
r3  :  00000001  r2 : c3805000  r1 : 00000006  r0 : c380af6c
Flags: nZCv  IRQs on  FIQs on  Mode SVC_32
Process insmod (pid: 9, stackpage=c2f25000)
Stack:
Backtrace:
Function entered at [<c3805240>] from [<c001abc8>]
Function entered at [<c001a924>] from [<c000e474>]
  r9 = c2f25fb8
  r8 = 00017000
  r7 = 0001c000
  r6 = c00fa7e0
  r5 = 00006094
  r4 = 03fffd8c
Function entered at [<c000e3b8>] from [<c0009f14>]
  r8 = c2f25ff4
  r7 = 00900080
  r6 = 00000080
  r5 = c2f27018
  r4 = 00018f80
Code: pc not in code space 

At this point it stiffs and requires a reset.
The fact that I can get it to boot into a shell suggests that
it must be close, doesn't it...?!  The only thing I've got left
in my machine is the SA110 processor, 48Mb of RAM and
2Mb video RAM.  The memory shouldn't affect it, or the 
version of the SA card should it?  

Any help greatly appreciated!

Thanks,
Simon.
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Dave Gilbert <[email-masked]>
Date: Sat, 13 Jun 1998 13:10:08 +0100 (BST)

> anything.  At least this is one stage further though...!

OK so you have /bin/csh; try executing

/sbin/insmod /lib/modules/misc/fpem.o
(I think!)
and see what it says.
See if you can mount /proc and see /proc/modules to see if the fpem is
mounted.

Dave> 

 --------------------------------------------------------------------
/ Dr. David Alan Gilbert      | Running Linux on Alpha & ARM         \ 
\   gro.gilbert @ treblig.org | ------- Happy in hex -------         /
 \____________________________|___ http://www.treblig.demon.co.uk __/

---

From: James Craig <[email-masked]>
Date: Sat, 13 Jun 1998 08:14:25 +0100 (BST)

> anything.  At least this is one stage further though...!
You can get the kernel to mount root as RW instead of RW just by showing
exactly that on the command line - i.e. your command line should have "rw"
on it somewhere.

--
James Craig <[email-masked]>
            <[email-masked]>

---

From: Philip Blundell <[email-masked]>
Date: Fri, 12 Jun 1998 21:40:46 +0100

>Tried that too, and it doesn't stack-dump, but it still hangs!

Thinking more, that's probably because sh is bash and needs floating point to 
be in place before it will run.  One of the endearing features of the ARM. :-)

>anything.  At least this is one stage further though...!

You can fix the read-only-ness by using the `rw' parameter.

>version of the SA card should it?  

No.  I guessed you had 48MB already but I don't think it's likely to be a 
problem.

Do you have a System.map file for that kernel?  (Or, if you're using a 
precompiled kernel, can you remind me which one?)

p.

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Thu, 25 Jun 1998 20:32:39 +0100 (BST)

> At this point it stiffs and requires a reset.

This indicates that you need to upgrade your version of the module tools.
Get the latest modules package (in RPMS) off of the FTP site, and ask the
installer to upgrade it for you.  (Put the new RPM in your RPMs directory,
and then re-run the installer asking it to upgrade your system).
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.uk.linux.org/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |