Subject: Installing - phase 2!

From: Simon Ogilvie <[email-masked]>
Date: Wed, 10 Jun 1998 22:38:47 +0100

OK, with help from this list I've got passed the
problems I was having with my initial install.
I took the advice offered and reduced my swap
partition size to 20Mb giving me more space on
both the RiscOS and Linux partition of the IDE
drive.  I've now got all the RPMS installed, and
the RedHat installer did its thing to the point where
I've set a root password.  As it says in the FAQ,
it stops at this point as it doesn't have a kernel,
so I sync'd the disk and rebooted to get out.

I then did the !LinConfig bit as it says in the
installation instructions (from Russell's web site),
but this didn't seem to work.  When running the
!Linux application I get the error :

Error: Invalid bmap magicin first sector of partition

I assume this means it can't find a kernel to
boot from.  If I boot from the initial install kernel
it goes into the RedHat installation program as
before, and I can break out and mount the disk,
and it seems OK, although there is nothing in
the /boot directory on the disk.  Should there be
a kernel file in here?

When I run !LinConfig and save the configuration
the files in the !Linux app don't seem to get changed
although the changes are saved somewhere as the
disk light flashes, and the changes are remembered
next time I run !LinConfig.

Help!  What am I doing wrong?

Simon.

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Simon Ogilvie <[email-masked]>
Date: Thu, 11 Jun 1998 13:24:47 +0100

>Error: Invalid bmap magicin first sector of partition

It appears I committed the ultimate sin of asking
a documented FAQ - sorry!  I had read the FAQ
but when your new to all of this, something that
you haven't yet come across has no meaning and
gets forgotten very easily.  What I should have 
done was re-read the FAQ, and I will certainly do
that if I come across any other problems, before
posting to this list!

Thanks to those who gently pointed this out to
me off list!

Hopefully I should have a working installation
by the end of the day  :-)

Simon.