Subject: The Corel THing - in full

From: [email-masked] (Alan Cox)
Date: Fri, 8 May 98 02:09 BST

<spud> He donated a Corel NC to Dave Neil.
<spud> And OCLUG gave him a T-shirt and a Running Linux book.
<spud> Something that everyone who joins OCLUGS gets.
<spud> pres: Hello everyone.
<spud> Since it's inseption, a year ago, they have taken a lead in the
<spud> Open Software project.
<spud> We have used a lot resources in producing this.
<spud> We chose linux because of many features.
<spud> Corel Computer will be giving all of it's development work to the Linux
  comminity.
<spud> They will be offering code for both Linux and Java.
<spud> They want to make it open and subjective to peer review.
<spud> Corel Computer is promoting Linux as the ultimate platform.
<spud> But Michael Cowpland will say more about Corel.
<spud> It is obvious that we can't make good products using Microsoft's
  techology.
<spud> Microsoft invented a high volume, low cost solution to the masses.
<spud> Today, Corel, Symantec, and other must realize have little change at
  competing against Microsoft on it's own turf.
<spud> low prices won't do. 
<spud> The solution is to produce a better product, and linux is the only
  alternative to windows. 
<spud> It's not only more stable, but because of the grass roots, and GPL it
  is superior. 
<spud> It's been proven that free software does not conflict with building a
  provitable buisness.
<spud> services and support are the key to this.  
<spud> Much like roads, OS's are infrastructure. They should not be controled
  by any vendor. 
<spud> Michael Cowpland is now speaking.
<spud> We are very proud of being part of the Linux Computer.  
<spud> Comunity, sorry.   
<spud> We have been competeing in Windows, with Ventura, Draw and others.    
<spud> We have could have more application software than MS.
<spud> It's an uphill battle because they wrote the OS.
<spud> We are used to competeing in windows, and we will continue to compete. 
<spud> We like free OSs. 
<spud> We also like Java, but it's not moving as expected.    
<spud> We see Java as more of a glue for all the OSs.
<spud> We see the future OS as Linux because it is open and free.   
<spud> It's interesting to see that the FTC is investigating MS. 
<spud> The thing that the FTC can't do, we see that Linux can do it.   
<spud> We also believe that comercial applications on Linux.
<spud> So that hte environment becomes rich and robust so that others can join
  in.
<spud> We are makjing a comitment to port all applications over to Linux.
<spud> (applause).
<spud> (lots of applause).
<spud> And as the major competitor, we are making a signal to the others to
  follow us.
<spud> We are very excited to move ahead.
<spud> We are going to release WP8 in Linux for $99. 
<spud> Including the rest of the suite.
<spud> We are looking forward for a veryt long and exciting future with Linux. 
<spud> Mike Cowpland has sat down now. 
<spud:#corel> Dave Neil speaking again.
<spud:#corel> We will be having a demonstration. 
<spud:#corel> We will be demonstrating the NetWinder. 
<spud> He's appologizing for the fact there was Windows on the screen earlier.
<spud> That was another mahcine. 
<spud> Just over a year ago, wehen the NetWinder was gaining momentum, we were
  looking for an OS.  
<spud> We were looking for performance. 
<spud> We were looking for a future of the OS.
<spud> So we chose Linux.
<spud> Sorry, the name of the President of CC is Eid Eid.
<spud> We have been progressing in leaps and bounds.      
<spud> He is introducing the developers
<spud> I will get the names as soon as possible.   
<puffin> I'm the one who organized this.
<spud> We had nearly completed our Netscape port in 3 days. 
<spud> The virtual network application will allow you to use Windows over the
  network.
<spud> There is win95 running in a window in X.
<spud> It's running Quatro Pro.  
<spud> HE is also running Corel WordPerfect 8.
<spud> The NC will run with 64 megs and 3 gigs. 
<spud:#corel> it will support onboard 10BaseT, ASDL, ISDN.  
<spud> it also has a infrared port and a serial port. 
<spud> GIMP was ported to the NC in 4 hours.
<spud> He will be giving a demonstration of it now.  
<spud> he is loading up GIMP now.  
spud> he is loading up GIMP now.
<spud> The NetWinder has many audio and video capabilities.
<spud> It also includes telephony suport.  
<spud> It offers SVGA output.  
<spud> It also offers video capture, 16 bit sound. 
<spud> They are passing around a couple motherboards.       
<spud> It supports Zip, floppy, CDROM, and Jazz.
<spud> The machine can diskless boot by a number of methos, DHCP, Bootp and
  others.
<spud> tftp, as well as ftp.
<spud> The root filesystem can be boot disk, NFS or SMB.
<spud> If it can't boot from the drive, the firmware can contact a rescue
  server and reconstruct the disk. 
<spud> They are calling the join OCLUG, Corel, Netwinder development team. 
<spud> Richard Holm engineering manager at Corel.    
<spud> and others...  
<spud> I'll get the list after they are done announcing.     
<spud> Corel Computer would like to recognize and thank the OCLUG people.  
<spud> The corel team is: 
<spud> Richard Hone - Product development and engineering manager    <spud> San Mehat - Senior Software Engineer
<spud> Zak Sprackett - Unix Specialist      
<spud> Jim Bridgeman Project Manager
<spud> Pat Burn - Cheif Engineer      
<spud> Oliver Bendzsa - Media Relations 
<spud> Bill Pope - Market Development Manager
<spud> Roger Bryanton - Director of Engineering 
<spud> Couple of comments from Caldera and Redhat.  
<spud> Bob Young - Redhat: 
<spud> The entrance of Corel into the Open Code is wonderful. 
<spud> The desision was based on business reasons.   
<spud> I will get the transcript, and post it. 
<spud:#corel> He just quoted an article from ZDNet about giving the Linux
  comunity money in order to hurt MS. 
<spud> It's now time for a Q&A session.
<spud> And questions?                  
<spud> WP is in final testing now.
<spud> WP7 has been ready for a while for Linux, you can download it off the
  NET.   
<spud> The cost of the machine will be about $1000.   
<spud> The hardware is available now for a pilot, and they are waiting on the
  FCC.       
<spud> They haven't decided weither or not they should port their code to
  other platforms.
<spud> the code for the NC specifically.   
<spud> Linux gives you the volume and mass appeal.  
<spud> There are many books on Linux.  
<spud> It gives critical mass to enter other unix markets. 
<spud:#corel> We are committed to keeping the infrastructure freely available, 
<spud:#corel> but the applications are not planed to be free in order to keep
  the investment on them.  
<spud> Every night, I unplug my computer and take it home because it's so
  small. 
<spud> That's why I don't have a long uptime.  
<spud> They have a 1.2 gig HD model, and they can support up to 5 gigs. 
<spud> The processor is a sa110, which I do believe is a StrongArm.      
<spud> It uses a digital StrongARM SA-110S.   
<spud> The release date is June first. 
<spud> I am speaking with San Mehat here now.  He is the senior engineer at
  CC. 
<spud> For June first, there will be a couple of releases.
<spud> One release will be a diskless terminal replacement. 
<spud> With that will be a stand alone 32 meg, 1 gig hd machine.      
<spud> And there will be a developer release of 64 megs and 3 gig hd. 
<spud> We use SODimms, laptop memory. 
<spud> The board has EIDE for the HD, however if the development comunity
  speaks up, they can be a SCSI interface.    
<spud> For Corel Computer itself, they will be releasing the full source code
  for any modifications that they have made.    
<spud> Our compiler, assembler, linker.  
<spud> CC has been the main component for making a ELF compiler for StrongArm  
<spud> The process runs at 300Mhz offering 250MIPS of power.
<spud> Currently they are running 2.0.31, but they will be integrating back to
  the linux tree, and they will be going ahead with the development.  
<spud> They will be announcing at Linux Expo.  
<spud> They will be available there for orders and demo machines available.  
<spud> any other questions?  
<spud> They are releasing the all the source from Corel Computer that makes
  the NetWinder work.   

<spud> When we go into full development, we will finalize the price.     
<spud> There may be a discount for registered developers.   
<spud> This must go through OCLUG because they are the liason to the
  development. 
<spud> They are currently at Phase 1, which is OCLUG only.
<Nat_> Can you ask them if them if they are releasing the source to their JIT?
<spud> Opening the registration to the internet community as a whole is phase
  2.   
<spud> The Wordperfect currently uses motif. 
puffin> It sounds like things are slowing down, so I think we should all
  thank Dave Kennedy (spud) for commentating, and Clayton Scott for setting up
  hardware, and Corel, of course.    
<spud> The Win95 viewer is a GPLed app.      
<spud> The size of the machine is 2 inches tall, by 6 inches by 9 inches
  about.
<spud> It has an integrated speaker, microphone. 
<spud> On the back, it has the following connectors:        
<spud> line ine (modem), phone out, serial, 10/100Base-t as well as 10Base-t 
<spud> video in, vbideo out, SVGA out.       
<spud> Parallel connector, stereo line in, handset, stereo line out.  
<spud> PS/2 keyboard, PS/2 mouse.. and of course power.        
<spud> Corel Draw is being considered for being released to Linux.     
<spud> There is a software codec that can be used for many things, including a
  modem. 
<spud> Only the source code from Corel Computer is being released.    
<spud> The following people are part of the OCLUG development team:  
<spud> Chris Herrnberger - Project Founder and Coordinator     
<spud> Dr. Francis Pinteric - Software and Apps Coordinator   
<spud> Andrew Mileski - X windows and kernel coordinator.
<spud> David Neil - Communications
<spud> Stan Vardomskiy - Developer   
<spud> Eric Laforest - Developer 
<spud> These are the people who have joined the team and doing work.   
<spud> More are comming, and we are looking for more. 
<spud> I am currently trying to get those quotes I didn't type up.   
<Nat_> Spud, can you tell us if $99 is the price for the whole office suite or
  just WP?  Lots of people want to know. 
<spud> The suite is being ported now. 
<spud> The suite will be released near the end of the year, or early next
  year. 
<spud> They have not set a price on the WP Suite yet.    

<spud> I am talking to Oliver Bendzsa from Corel Computer.
<spud> I also talking to Pat Burn.   
<spud> Word Perfect 7 is available now.
<spud> WP8 probably by the end of June. 
<spud> for $99 US. 
<spud:#corel> $99 is for the desktop version. 
<spud> webmin.com (or soemthing liek that) has a RPM manager which will
  automatically download the latest kernel.   
<spud> There will be a server version which costs more.
<spud> I'm unsure how that would work.        
<spud> Word Perfect 8 supports international features like national
  characters.       
<spud> Last call for questions.  
<spud> corelcomputer's website has a question field and they will take your
  question and add it to the FAC. 
<spud> Corel computer developed only on the StrongArm processor.   
<spud> They programmed it by toggling switches.
<spud> The first peice of code was a loop.
<spud> It went from there. 
<spud> A serial debugger was impletemented, the VGA, then a mini debugger
<spud> Then we worked on the kernel.          
<spud> It always linux, with crosscompiling gcc. 
<spud> the OS for the NetWinder was always going to be Linux. 
<spud> Sorry for the delay.
<spud> I have the quotes from the industry, from Robert Young, RedHat Software
  and Ransom Love, Caldera, Inc.
<spud> First up is from RedHat.,   
<spud> The entrance of a leading commercial hardware vendor, such as Corel
  Computer, into the Linux model of cooperative development and open     
<spud> code is highly significant.  Corel Computer's decision to select Linux
  for      
<spud> it's network computer was based on solid technical reasons- a robust, 
<spud> reliable, innovative OS they could quickly port to their unique
  platform.  
<spud> The decision to open this code and support the model is based on solid
  business reasons-faster development, more reliable offerings
<spud> and a closer relationship with their customers.  Red Hat is
  enthusiastic about     
<spud> the entrance of Corel Computer to the Linux software development
  community.
<spud> And now from Caldera. 
<spud> Caldera applauds Corel Computer for being one of the first hardware
<spud> vendors to see the value of supporting Open-Source Software.        
<spud> The announcement of the NetWinder solution based on Linux reiterates
  that Linux is a great technology for the commercial thin-client space.
  Caldera   
<spud:#corel> Continues to focus on a Linux thin-server for business and looks
  to other 
<spud> hardware providers to follow Corel's lead in considering Linux as an OS 
<spud> Ok.. that's it...
<spud> I'm out of here.. ;) 
<Nat_> Everyone in #coreld give David Kennedy (spud) a big hand for his effort
<puffin> A huge round of thanks for spud....
<puffin> And Nat... 
<Nat_> Also, if you joined late a full log is available at
  http://linux.mit.edu/cgi-bin/corel.cgi    
<Nat_> And for puffin for organizing this whole broadcast     
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Fri, 8 May 1998 23:29:02 +0100 (BST)

Full information on Corel's standpoint and details of their announcement
can be found on their Corporate Web site at:

	http://www.corelcomputer.com/

Enjoy!
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.uk.linux.org/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |

---

From: "Neil A. Carson" <[email-masked]>
Date: Sat, 09 May 1998 00:07:55 +0100

Just a 2nd person to say 'well done' --- it's always great to see 'pet'
projects taking on the world!!!

	Neil

---

From: Charles Esson <[email-masked]>
Date: Tue, 12 May 1998 11:01:37 +1000

Yes congratulations to Russell and all who worked on the Linux kernel
and the ARM tool chain.

I might be stiring the pot but has any one got a view on the future of
the Phoebe project. It looks like they are working on another closed OS
where Corel are delivering a solotion with an OPEN OS.
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: "Neil A. Carson" <[email-masked]>
Date: Tue, 12 May 1998 17:01:35 +0100

> where Corel are delivering a solotion with an OPEN OS.

Bit of a waste of time, really.