Subject: Re: Probs compiling kernel 2.0.33

From: Jan Magnussen <[email-masked]>
Date: Mon, 04 May 1998 14:43:38 +0200

On Sun 03 May, Jan Magnussen wrote:
> Hello
> 
> I just reinstalled Linux, after accidentally deleting it a few months back,
> but when I try to compile the newest (260498) 2.0.33 kernel, I get the
> following error:
> 
> gcc -D__KERNEL__ -I/usr/src/linux/include -m6 -Wall -Wstrict-prototypes -O2 -fomit-fra
> me-pointer -fno-strength-reduce -pipe -c -o proc-sa110.o ..tmp.s
> proc-sa110.S: Assembler messages:
> proc-sa110.S:174: Error: Internal_relocation (type 159) not fixed up (OFFSET_IMM)
> proc-sa110.S:177: Error: Internal_relocation (type 159) not fixed up (OFFSET_IMM)
> proc-sa110.S:178: Error: Internal_relocation (type 159) not fixed up (OFFSET_IMM)
> make[2]: *** [proc-sa110.o] Error 1
> make[2]: Leaving directory `/usr/src/linux/arch/arm/mm'
> make[1]: *** [first_rule] Error 2
> make[1]: Leaving directory `/usr/src/linux/arch/arm/mm'
> make: *** [linuxsubdirs] Error 2
> 
> What could be wrong?

Hmmm. I found the error.
arch/arm/mm/constants.h were missing, so I made a symbolic link from
arch/arm/lib/constants.h to mm. That did the trick.

Regards,

Jan Magnussen
http://www.kom.auc.dk/~janm
Fidonet : 2:234/181.8

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Tue, 5 May 1998 23:43:13 +0100 (BST)

> arch/arm/lib/constants.h to mm. That did the trick.

Or replace the #include "constants.h" with #include "../lib/constants.h".

It's good to know that ppl are compiling their own kernels ;)
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.uk.linux.org/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |