Subject: Probs compiling 2.1.99

From: Jan Magnussen <[email-masked]>
Date: Mon, 11 May 1998 19:03:13 +0200

Hi there.

I have been trying to compile 2.1.99 with the latest patches, but I have been
having some problems:

1) A file called autoconf.h was missing. I solved this by making an empty
file called /usr/src/linux/include/linux/autoconf.h !! Is this the proper
way?

2) When doing 'make xconfig' I got many warnings like this ones:
WARNING - broken Config.in!  CONFIG_APOLLO was not declared!
WARNING - broken Config.in!  CONFIG_MAC was not declared!
WARNING - broken Config.in!  CONFIG_TGA_CONSOLE was not declared!
WARNING - broken Config.in!  CONFIG_FB_MAC was not declared!
WARNING - broken Config.in!  CONFIG_FB_TGA was not declared!
WARNING - broken Config.in!  CONFIG_FB_ACORN was not declared!
WARNING - broken Config.in!  ARCH was not declared!
WARNING - broken Config.in!  CONFIG_AMIGA was not declared!
WARNING - broken Config.in!  CONFIG_ATARI was not declared!
WARNING - broken Config.in!  CONFIG_PPC was not declared!
WARNING - broken Config.in!  CONFIG_PMAC was not declared!
WARNING - broken Config.in!  CONFIG_MIPS_JAZZ was not declared!
WARNING - broken Config.in!  CONFIG_MCA was not declared!
I was able to configure the kernel anyway, but is it supposed to complain
about this broken Config.in?

3) After configuring the kernel, I did a 'make dep' which returned :
/bin/sh: /usr/src/bin/arm/arm-linuxelf-gcc: No such file or directory
usage: genksyms [-gwqdD] directory
make[1]: *** [/usr/src/linux/include/linux/modules/signal.ver] Error 1
make[1]: Leaving directory `/usr/src/linux/kernel'
make: *** [dep-files] Error 2
How do I get past this???

Regards,

Jan Magnussen
http://www.kom.auc.dk/~janm
Fidonet : 2:234/181.8

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Mon, 11 May 1998 18:36:59 +0100

>file called /usr/src/linux/include/linux/autoconf.h !! Is this the proper

It should be created by `make config'.

>WARNING - broken Config.in!  CONFIG_APOLLO was not declared!

You can ignore those.

>How do I get past this???

You need to modify the Makefile a bit.  Where it says `CROSS-COMPILE = /usr/
src/...', change that to just `CROSS-COMPILE = arm-linux-'.

p.

---

From: Jan Magnussen <[email-masked]>
Date: Mon, 11 May 1998 20:04:12 +0200

> src/...', change that to just `CROSS-COMPILE = arm-linux-'.

That didn't work either. I changed it to 'arm-unknown-linuxaout-' instead,
but got the following error instead:
| /sbin/genksyms  -k 2.1.99 > /usr/src/linux/include/linux/modules/signal.ver.tmp
usage: genksyms [-gwqdD] directory
cpp: output pipe has been closed
make[1]: *** [/usr/src/linux/include/linux/modules/signal.ver] Error 1
make[1]: Leaving directory `/usr/src/linux/kernel'
make: *** [dep-files] Error 2

Any other suggestions?

Regards,

Jan Magnussen

---

From: Philip Blundell <[email-masked]>
Date: Mon, 11 May 1998 19:40:32 +0100

>usage: genksyms [-gwqdD] directory

Your genksyms is too old.  But you're unlikely to have much joy compiling 
2.1.99 with a.out tools in any case.

p.

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Mon, 11 May 1998 21:27:00 +0100 (BST)

> file called /usr/src/linux/include/linux/autoconf.h !! Is this the proper

This is normally created by make config/xconfig or whatever your prefered
configuration system is.

> about this broken Config.in?

This happens on all architectures - it is nothing to worry about, and is something
that others are looking into (apparantly from what I've been told).

> How do I get past this???

1.  You need a new version of genkeysyms - get the latest modules package
    and compile it up.  Now that some people want it, I shall be uploading
    patches for it.

2.  Please read the Documentation/ARM-README - it will tell you what you
    need to change.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.uk.linux.org/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |