Subject: Re: New User Help Please!!!

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Tue, 19 May 1998 19:12:42 +0100 (BST)

Jonathan Peace writes:
> So I type ADFS::0.$.!Linux -bootkernel ADFS::0.$.rpc
> 
> and the RiscPC jumps to a lowish resolution (640*480?) text
> mode screen, with 

That is correct.

> >Press Alt for boot loader   <<<(what does this mean?)

Exactly what it says.  Press the 'alt' key and it gives you a menu for
the boot loader.  Maybe I ought to add the word 'menu' to it?

> >Enter extra args      <<< what args?

I'll think about putting extra explaination here if you supply a -bootkernel
option to the loader...

> >Now booting the kernel
> 
> At this point a get a short row of red pixels at the top left of the screen
> and the machine hangs.

This has now been added to the FAQ.

> I guess the video RAM is getting trampled on, but apart from that I'm stuck.

It's because your particular processor is probably an ARM710A, which Linux doesn't
yet know about.

> Do I need to reinitialise the RiscPC in some way?

No.

> Do I need to partition or setup the HD in anyway to run this test?

No.

> Is there some sort of RiscOS upgrade I need to make?

No.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.uk.linux.org/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: "Jonathan Peace" <[email-masked]>
Date: 19 May 1998 14:33:11 -0000

OK, OK, I know, I'm doing something stupid, but what?
Would any ARMLinux gurus out there please help, I do want to use Linux!

My system
===========
 I have a RiscPC, with 40MHz ARM710, 16Mb DRAM, VRAM, IDE CDROM, 850Mb IDE HD, AcornFD, Acorn Ethernet adapter, Acorn keyboard, 3 button mouse in mouseport, ROMs marked RiscOS 3.6.
 The system used to have a 486 coprocessor, but I removed it
 There are no expansion cards.
 ie pretty bog standard

 Under RiscOS, the machine is fully operational on the network with Ant internet suite and Omniclient to access an NT server over ethernet
The machine has had no other software installed since it was shipped from Acorn about 2 years ago.

What I did
===========

First, I've read Russell's downloading ARMLinux installation guide, Phil Norman's installing from Clan CD (even though I don't have 
the clan CD), I've read the FAQ, and the whole of the ARMLinux website.

I've downloaded the 4 ARMLinux utility files, sparkplugged them onto an ADFS floppy, along with the precompiled  self-ungzipping kernel, rpc,  v2.0.33.

I have transferred root-pc and supplemental onto MSDOS floppies (though haven't got to use them yet)

And now I try and check if my kernel will run.

and the RiscPC jumps to a lowish resolution (640*480?) text mode screen, with 

>Kernel loader v3.21

>1. Return to RiscOS
>2. Linux

I select 2, and see 

>Enter extra args      <<< what args?

 I hit return and get the message 

>Uncompressing Linux...    

then 

>Now booting the kernel

At this point a get a short row of red pixels at the top left of the screen and the machine hangs.

Anyone else seen this, or can help?

Thanks in advance