Subject: Re: New User Help Please!!!

From: "Jonathan Peace" <[email-masked]>
Date: 19 May 1998 17:25:06 -0000

> On 19 May 1998, Jonathan Peace wrote:
> 
> > OK, OK, I know, I'm doing something stupid, but what?
> > Would any ARMLinux gurus out there please help, I do want to use Linux!
> > 
> > My system
> > ===========
> >  I have a RiscPC, with 40MHz ARM710, 16Mb DRAM, VRAM, IDE CDROM, 850Mb IDE HD, AcornFD, Acorn Ethernet adapter, Acorn keyboard, 3 button mouse in mouseport, ROMs marked RiscOS 3.6.
> >  The system used to have a 486 coprocessor, but I removed it
> >  There are no expansion cards.
> >  ie pretty bog standard
> > 
> >  Under RiscOS, the machine is fully operational on the network with Ant internet suite and Omniclient to access an NT server over ethernet
> > The machine has had no other software installed since it was shipped from Acorn about 2 years ago.
> > 
> > 
> > What I did
> > ===========
> > 
> > First, I've read Russell's downloading ARMLinux installation guide, Phil Norman's installing from Clan CD (even though I don't have 
> > the clan CD), I've read the FAQ, and the whole of the ARMLinux website.
> > 
> > I've downloaded the 4 ARMLinux utility files, sparkplugged them onto an ADFS floppy, along with the precompiled  self-ungzipping kernel, rpc,  v2.0.33.
> > 
> > I have transferred root-pc and supplemental onto MSDOS floppies (though haven't got to use them yet)
> > 
> > And now I try and check if my kernel will run.
> > 
> > 
> > So I type ADFS::0.$.!Linux -bootkernel ADFS::0.$.rpc
> > 
> > and the RiscPC jumps to a lowish resolution (640*480?) text mode screen, with 
> > 
> > >Press Alt for boot loader   <<<(what does this mean?)
> > >Kernel loader v3.21
> > 
> > >1. Return to RiscOS
> > >2. Linux
> > 
> > I select 2, and see 
> > 
> > >Enter extra args      <<< what args?
> > 
> >  I hit return and get the message 
> > 
> > >Uncompressing Linux...    
> > 
> > then 
> > 
> > >Now booting the kernel
> > 
> > At this point a get a short row of red pixels at the top left of the screen and the machine hangs.
> > 
> > I guess the video RAM is getting trampled on, but apart from that I'm stuck.
> > 
> > Anyone else seen this, or can help?
> > 
> > Do I need to reinitialise the RiscPC in some way?
> > Do I need to partition or setup the HD in anyway to run this test?
> > Is there some sort of RiscOS upgrade I need to make?
> > 
> > 
> > Thanks in advance
> > unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
> > 
> Seems you're having the same problem as I did. Are you sure you have an 
> ARM710 fitted, not an ARM710a ???
> There is no other way of finding out than to read the processor ID 
> register. This only works with machine code, so you should write a small 
> program to do this. Maybe I'll do this small task this weekend.
> 
> Here's what might happen:
> The kernel tries to find out which processor it is running on even 
> before starting to actually boot the kernel. The ID register of an ARM710 
> contains &4100710x (x is the revision No.) that one of an ARM710 contains 
> &4104710x. This confuses the kernel and it refuses to boot.
> 
> Btw: 1.) It is useful to partition the hard disc BEFORE attempting to 
> install arm-linux 'cos the partition manager linux uses still doesn't write 
> partition tables.
> 2.) I've got an running kernel for ARM710a
> 
> unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
> 
> 
Thanks Stefan, one of your previous postings had already given me the idea (I have indeed a 710a)

(Isn't the net wonderful!)

Do you think your compiled kernel will work on a RiscPC? If so, could you mail it to me?

Jonathan

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: "Jonathan Peace" <[email-masked]>
Date: 19 May 1998 16:01:36 -0000

After looking at the linux-2.0.33-arm-3.diff file, it seems that the ARM710a processor which I have is not defined only the 710,

+	{ 0x41007100, 0xffffff00, F_MMU|F_32BIT , "ARM/VLSI",   "arm710"	, 

(the 710a should be 0x41047100 according to Stefan Hanske) hence the debug display of a red line on the screen because of unrecognised architecture.

I'm not very well up on compiling the kernel yet; is there any chance this kind of thing will get fixed in a future compiled kernel on the ARM Linux web site (Russell??)

Does anyone have a compiled kernel they can mail me for  a ARM710a RPC?

---

From: Stefan Hanske <[email-masked]>
Date: Tue, 19 May 1998 17:43:28 +0200 (METDST)

---

From: "Jonathan Peace" <[email-masked]>
Date: 20 May 1998 16:03:53 -0000

> Of course I can compile and mail you a kernel for ARM710a but I suppose 
> it's better to mail a kernel for ARM710 and ARM710a to this mailing list 
> (if Russel doesn't get angry). Just send me the config specs (i.e. which 
> drivers should be included, which file_systems a.s.o.)
> 
> 

The config is a standard RiscPC with no expansion cards and an Acorn Ethernet adapter.

As for file-systems, I just want to access my IDE FD, IDE CDROM, Network and standard floppy.

Is this enough info?

I think such a compiled kernel for 2.0.33 would be useful to other people too, so I'm sure Russell would not be upset. (I asked him to do it but I guess 2.0 on an ARM7  is all rather old hat for him!)

Thanks in advance.

---

From: Stefan Hanske <[email-masked]>
Date: Wed, 20 May 1998 17:19:50 +0200 (METDST)

---

From: Philip Blundell <[email-masked]>
Date: Wed, 20 May 1998 17:41:59 +0100

>drivers should be included, which file_systems a.s.o.)

If you start mailing complete kernels to this list then I think lots of people 
will get angry (and Russell will probably drop dead from apoplexy).  Either 
send it in private mail to people who want it, or put it on an ftp site and 
post the location.

p.

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Wed, 20 May 1998 18:17:00 +0100 (BST)

Jonathan Peace writes:
> I think such a compiled kernel for 2.0.33 would be useful to other people
> too, so I'm sure Russell would not be upset. (I asked him to do it but I
> guess 2.0 on an ARM7  is all rather old hat for him!)

Not at all, since I'm running 2.0.34 to death on the RiscPC at the moment.
I'm going to get the complete info off Stephan (?) and integrate it in the
2.0.34 once it comes out.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.uk.linux.org/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |

---

From: Matthew Wilcox <[email-masked]>
Date: Wed, 20 May 1998 18:50:10 +0100 (BST)

Can people please line-wrap at less than 77 columns?  It's actually rather
difficult to read from this SGI.

Jonathan Peace
> > drivers should be included, which file_systems a.s.o.)

You should not send a kernel to a mailing list.  By all means compile one
and make it available on an ftp or web site.  If you don't have write
access to a site, there are many people on this list who do.  You will
annoy everyone (particularly Russell!) by sending a 400k uuencode to
the list!

> guess 2.0 on an ARM7  is all rather old hat for him!)

If you look on the `What I'm doing today' section of the website, you'll
see that Russell is working on the 2.0.34pre15 code and currently has that
working.  Expect 2.0.34 `imminently' - and now that this problem has been
pointed out, I suspect it will have a fix in this release.

-- 
Set Alias$Case Set Alias$[ |||| |MSet Alias$Otherwise Set Alias$[ \ Matthew
"" |MSet Alias$When If %0=%%0 Then Set Alias$[ "" ||MIf %0=%%0    \ Wilcox
Then Set Alias$Otherwise Set Alias$[ |||||||||||||||| ||MIf       \
%0=%%0 Then Set Alias$When Set Alias$[ ||||||||||||||||
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]