Subject: mknod and mke2fs

From: micm <[email-masked]>
Date: Wed, 18 Feb 1998 02:01:03 +0000 (GMT)

Here's one for all the experts.....

I'm trying to install ArmLinux on my ADFS HD.  Machine is SA RPC.

Need to format the Linux partition (number 3) as ext 2.

1. Load up installer using root disk.
2. Load supplemental disk.
3. Go to virtual console.
4. Drive is ADFS::4 - native partition is 3 so make /dev/hda3 with
   mknod /dev/hda3 b 3 3
5. Try to ext2 format the partition with
   mke2fs /dev/hda3

Get the following error:

mke2fs 1.04, 16 May 96 for EXT2FS 0.5b 95/08/09
ext2fs_check_if_mount: No such file or dir while determining whether
/dev/hda3 is mounted
/dev/hda3: Invalid argument while setting up superblock

Why???????!!

Setup of machine is:
ADFS:4 - 1.6Mb Seagate HD.  3146 Cyl.  2000 for Filecore
ADFS:5 - not present.
CDFS:0 - ATAPI CD on ADFS bus as slave to Seagate drive.

IDEFS:4 / IDEFS:5 - BigFoot 4Gb drive split into 2 2Gb filecore
partitions.  Linux has nothing to do with this drive.

SCSI:0 - Zip drive
CDFS:1 - SCSI CD drive - both on castle card so not recognised.

Any ideas what's wrong?

I can mount /dev/hda1 as an adfs disk
(using mount -t adfs /dev/hda1 /adfs)

so why does it not seem to recognise my hda3 so it can format it??

PartMan 1.04 shows:

Partition	Start		End		Size		Type
1 		0 		2015999 	984 MB 		Filecore
2		2016000		2016001		1   KB		Table
3		2016002		3025007		493 MB		Linux Native
4		3025008		3171167		71  MB		Linux Swap

Stats are shown as
Total size : 1548
Sector size: 512
Cylinders  : 3146
Heads      : 16
Sectors    : 63

Partman 1.11 shows the disc as having no partitions i.e. all free and
won't do anything to it.  This is obviously wrong as I have all sorts of
(backed up!) stuff sitting in the ~1000Mb filecore partition on that
disc.

Hope this is enough information!! If you want to know anything that I've
not (!!) mentioned then drop me an email...

Thanks in advance...

Mike.
-- 
   From Michael Marshall, using an Acorn StrongARM RiscPC @ 202.4MHz
                 Mail me at: mailto:[email-masked]

      Visit the NUMPTIE XONE : http://homepages.enterprise.net/micm
  
                           The genuine article!

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Wed, 18 Feb 1998 20:29:57 +0000 (GMT)

> /dev/hda3: Invalid argument while setting up superblock

Could you please mail the last few kernel messages (on Alt-F4)?  You should
see something like:

Partition check:
   hda: [ADFS] hda1 [Linux] hda2 hda3 hda4

Thanks.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King        [email-masked]        --- ---
  | | | |    http://www.arm.uk.linux.org/~rmk/home.html      /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |