Subject: binutils 2.8.1.0.19

From: Philip Blundell <[email-masked]>
Date: Fri, 16 Jan 1998 10:21:20 +0000

Hi.

Pat Beirne sent me this small patch.  It is needed for BFD to generate
working ELF code on the ARM.

HJ, is it possible to get hold of the gas snapshot source that you based your 
release on?  I'd like to make a patch to send to the gas2 people for inclusion 
in the master sources.  Although I thought I was subscribed to the gas2 
mailing list I don't think I've ever had a message from it, so either it's not 
working or my subscription didn't happen.

p.

Index: bfd/ChangeLog.linux
===================================================================
RCS file: /usr/repository/gnu/binutils/bfd/ChangeLog.linux,v
retrieving revision 1.3
diff -u -r1.3 ChangeLog.linux
--- ChangeLog.linux	1998/01/16 10:00:01	1.3
+++ ChangeLog.linux	1998/01/16 10:06:27
@@ -1,3 +1,7 @@
+Fri Jan 16 10:06:19 1998  Philip Blundell  <[email-masked]>
+
+	* elf32-arm.c: Use REL relocs not RELA.
+
 Thu Dec 25 23:42:21 1997  Philip Blundell  <[email-masked]>
 
 	* config.bfd: (arm-*-linux*, arm-*-elf, arm-*-netbsd): New
Index: bfd/elf32-arm.c
===================================================================
RCS file: /usr/repository/gnu/binutils/bfd/elf32-arm.c,v
retrieving revision 1.1
diff -u -r1.1 elf32-arm.c
--- elf32-arm.c	1998/01/16 10:00:05	1.1
+++ elf32-arm.c	1998/01/16 10:06:14
@@ -23,7 +23,7 @@
 #include "libbfd.h"
 #include "elf-bfd.h"
 
-#define USE_RELA		/* we want RELA relocations, not REL */
+#define USE_REL			/* we want REL relocations, not RELA */
 
 /* ARM relocations */
 enum arm_reloc_type

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: John Vickers <[email-masked]>
Date: Fri, 16 Jan 1998 11:37:01 +0000 (GMT)

Hi.

> working ELF code on the ARM.
[...]

What compiler are you using for arm-elf ?

	John Vickers.