Subject: Re: libgcc.a

From: [email-masked] (S. Richard Grint)
Date: Thu, 8 Jan 1998 12:24:12 +0000 (GMT)

> >cross-compile the compiler, it says I must find libgcc.a, which I don have
> >and am unable to find anywhere.
> 
> What version of GCC are you using?  There's an assembler source file for 
> libgcc1.a supplied and recent versions know how to use this automatically.
> 
> p.
> 
 GCC 2.7.2.2 - It may know how to make libgcc1.a automatically, but when
cross compiling, it wont ...extracted from the Makefile:

# Specify the rule for actually making libgcc.a,
LIBGCC = libgcc.a
# and the rule for installing it.
INSTALL_LIBGCC = install-libgcc

# Specify the rule for actually making libgcc1.a.
# The value may be empty; that means to do absolutely nothing
# with or for libgcc1.a.
LIBGCC1 = libgcc1.a

# Specify the rule for making libgcc1.a for a cross-compiler.
# The default rule assumes that libgcc1.a is supplied by the user.
CROSS_LIBGCC1 = libgcc1.cross     

Do I need to edit the makefile to get it to try and compile libgcc1.a for
me?  If so how??

Rich

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Philip Blundell <[email-masked]>
Date: Thu, 08 Jan 1998 22:17:15 +0000

>Do I need to edit the makefile to get it to try and compile libgcc1.a for

In config/arm/t-linux, add these lines:

# Since libgcc1 is an assembler file, we can build it automatically for the
# cross-compiler.
CROSS_LIBGCC1 = libgcc1-asm.a
LIBGCC1 = libgcc1-asm.a

(The last one may be there already)

p.

---

From: Matthew Wilcox <[email-masked]>
Date: Fri, 9 Jan 1998 02:03:14 +0000 (GMT)

> cross compiling, it wont ...extracted from the Makefile:
[deletia]
> Do I need to edit the makefile to get it to try and compile libgcc1.a for

I told you where to get libgcc.a from already.. why are you still asking?