Subject: Problems when compiling (lack of the right header files)....

From: [email-masked] (Tom Palmer)
Date: Fri, 5 Dec 1997 14:02:27 GMT

Hi,

  I'm trying to compile some programs on my newly installed RiscPC Arm-linux machine. I've installed the kernel 2.0.31 sources and patched them for arm-linux. I have also made the various symbolic links from /usr/include/ to /usr/src/linux/include.

  The prblem that I have is that when I try to compile any programs (most noteably passwd, as I don't seem to have it on the system) I get the error that page.h in usr/src/linux/include/asm-arm/ cannot find asm/proc/page.h.

  I have had a look at the header file and all that I can see is that it just points to another header file. On other architectures it actually has something in it.  Have I missed installing an essential patch or just not installed the right packages? (as far as I know I have installed everything).

  Thanks in advance,

  Tom Palmer,
  Webmaster, The Netherhall School,
  Cambridge,
  United Kingdom

  BTW: Thanks to all those who answered my posts for help over the last few days. Much appreciated.

---

From: Matthew Wilcox <[email-masked]>
Date: Fri, 5 Dec 1997 16:08:54 +0000 (GMT)

>   I'm trying to compile some programs on my newly installed RiscPC
Arm-linux machine. I've installed the kernel 2.0.31 sources and patched
them for arm-linux. I have also made the various symbolic links from
/usr/include/ to /usr/src/linux/include.

>   The prblem that I have is that when I try to compile any programs
(most noteably passwd, as I don't seem to have it on the system) I get
the error that page.h in usr/src/linux/include/asm-arm/ cannot find
asm/proc/page.h.

I know what this one is.  You need to `make config' in the kernel source
tree.  This sets up symbolic links to the appropriate proc - either proc-rpc
or proc-arc.

>   BTW: Thanks to all those who answered my posts for help over the
last few days. Much appreciated.

It's nice to be appreciated ;-)
Is there any chance you could reformat your postings to 75 chars or so?
it's a bit inconvenient otherwise..