Subject: Problems with install (will not find any kernels)...

From: [email-masked] (Tom Palmer)
Date: Thu, 4 Dec 1997 11:51:41 GMT

Hi,

  I have finally managed to get Arm-linux installed on my RiscPC all bar one thing, a kernel! When the install program gets to this point it pops up a statment saying that it cannot find any kernels.

  I installed Arm-linux via the ftp site, ftp.arm.uk.linux.org. I have tried both the /pub/armlinux/distrib directory and the /pub/armlinux/ directory.

  I can drop out of the install program and mount the hard disc partition which has Arm-linux on it. From here I can see everything that I have installed.

  I have tried to mount an MSDOS disc which contains the initial rpc kernel however no matter how I type the command it will not want to mount (I am trying to mount the floppy disc to /mnt/mnt/floppy as the hard disc partition has read/write access).

  Does anybody know of a fix for this? Preferably not to start all over again as all I need is to install the kernel.

  Thanks in advance,

  Tom Palmer,
  Webmaster,  The Netherhall School,
  Cambridge,
  United Kingdom

---

From: Matthew Wilcox <[email-masked]>
Date: Thu, 4 Dec 1997 15:54:36 +0000 (GMT)

[post reformatted.  please try to wordwrap at 75 columns..]

>   I have finally managed to get Arm-linux installed on my RiscPC all
> bar one thing, a kernel! When the install program gets to this point it
> pops up a statment saying that it cannot find any kernels.

This happened to me too.

>   I can drop out of the install program and mount the hard disc
> partition which has Arm-linux on it. From here I can see everything that
> I have installed.

Excellent.

>   I have tried to mount an MSDOS disc which contains the initial rpc
> kernel however no matter how I type the command it will not want to mount
> (I am trying to mount the floppy disc to /mnt/mnt/floppy as the hard
> disc partition has read/write access).

the correct command to use is:

mount -t msdos /dev/fd0 /mnt/mnt/floppy

Personally, I'd mkdir /mnt/flp && mount -t msdos /dev/fd0 /mnt/flp,
but that's just my personalpreference.  What error messages do youget?
Remember you canalso mount /dev/hda1 on /mnt/adfs and copy kernels from
there.

Some dos and don'ts with kernels:

(0) Do edit /etc/boot.conf
(1) Do remember to run loadmap
(2) If you build your own kernel, use /usr/src/linux/arch/arm/boot/zImage
    as the kernel, not /usr/src/linux/vmlinux.  This *seems* to be the
    problem that someone else was experiencing.
(3) Currently, you need to leave the versioning of symbols on in order
    for the FP Emulator to work.

---

From: Russ King <[email-masked]>
Date: Thu, 4 Dec 1997 13:47:56 +0000 (GMT)

Tom Palmer writes:
> I have finally managed to get Arm-linux installed on my RiscPC all bar 
> one thing, a kernel! When the install program gets to this point it pops 
> up a statment saying that it cannot find any kernels.

Please see the FAQ on my web site.  It tells you what to do at this
point.