Subject: new patch

From: Philip Blundell <[email-masked]>
Date: Wed, 24 Dec 1997 20:12:22 +0000

Hi.

I made a new kernel patch, to be applied on top of my last 2.0.33 one.  This 
fixes a few problems, particularly with support for older machines.

Get it at

	http://www.tazenda.demon.co.uk/phil/armlinux

p.

unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Thu, 25 Dec 1997 01:07:22 +0000 (GMT)

> fixes a few problems, particularly with support for older machines.

No Phil.  Your patch does the following:

*	Changes the help descriptions for the ethernet cards.
*	Moves the kernel link address back to 0x1800000, which is where it was originally.
*	Unnecessarily ndoes my change to the 8390 driver to make it run faster
	(only slightly mind you), and introduces a bug into this area.
	I will not detail the bug though.
*	Changes a few #definitions to to with processor and machine type with no overall
	effect, especially the processor definitions.
	Do you really understand the meaning of the __arm2__ __arm3__ etc *compiler*
	definitions?
*	Removes *all* support for the binutils currently supplied with the ARM Linux
	distribution.
*	Removes the floppy code's ARM architecture dependence.
*	Slightly optimises the __xchg() function in terms of memory data space.
*	Unnecessarily changes the decompressor code.
	If your compiler can't hack that, then throw it away - it's not ANSI
	conformant, and must be broken.
*	Various spelling corrections.

In effect, what Phil is trying to do is to remove as many changes as possible to the
driver code that has moved from the drivers directories to the arch/arm/drivers heirarchy.

What is the point in reversing some of the changes made to *improve* the performance of the
2.0 kernels when we're moving towards the 2.1 kernels?

There have been *no* bug fixes in this patch whatsoever, in fact, there have been bugs
introduced in this patch!

I strongly advise anyone NOT to apply this patch at all!
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King        [email-masked]        --- ---
  | | | |    http://www.arm.uk.linux.org/~rmk/home.html      /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |

---

From: "Neil A. Carson" <[email-masked]>
Date: Thu, 25 Dec 1997 09:22:16 +0000

Russel, not working on Christmas Day are you :-)

	Neil