Subject: Re: Problems with install (will not find any kernels)...

From: [email-masked] (Tom Palmer)
Date: Thu, 4 Dec 1997 16:07:26 GMT

Hi,
> 
> >   I have tried to mount an MSDOS disc which contains the initial rpc
> > kernel however no matter how I type the command it will not want to mount
> > (I am trying to mount the floppy disc to /mnt/mnt/floppy as the hard
> > disc partition has read/write access).
> 
> the correct command to use is:
> 
> mount -t msdos /dev/fd0 /mnt/mnt/floppy
> 
> 

  Thanks for the advice. I figured that out after I sent the post. So now I finally have Arm-Linux running on my RiscPC, but I am still having problems.

  The problem that I now have is that I cannot get the network side of things to work. If I try the command "ifconfig eth0 194.128.208.10 netmask 255.255.255.0 up" the computer gives the message that ther is "No such device".

  I am using an EtherH card (made by i-cubed). I have had the computer using the network under the install program but am unsure of how to configure it now that I have Arm-Linux running.

  Is it that I need a different device name?

  Thanks in advance,

  Tom Palmer

---

From: Matthew Wilcox <[email-masked]>
Date: Thu, 4 Dec 1997 16:18:35 +0000 (GMT)

>   The problem that I now have is that I cannot get the network side
> of things to work. If I try the command "ifconfig eth0 194.128.208.10
> netmask 255.255.255.0 up" the computer gives the message that ther is
> "No such device".

Generically, this is because you do not have an Ethernet driver installed.

>   I am using an EtherH card (made by i-cubed). I have had the computer
> using the network under the install program but am unsure of how to
> configure it now that I have Arm-Linux running.

Is it an EtherLan 500 or 600?  The 500 (which I have) does not yet work.
Russell knows of this problem.  If it's a 600, you'll need to insmod the
appropriate modules - 8390.o and etherh.o.  You can find them on the root
floppy, in /lib/modules if they aren't already on your hard disc.