Subject: Problem with getting Linux running with an Ether3 (ANT) network card...

From: [email-masked] (Tom Palmer)
Date: Wed, 3 Dec 1997 13:10:03 GMT

Hi,

  I am in the middle of trying to get my RiscPC at work running Arm-Linux. Everything on the RiscOS side of things is working.

  The problem is that I cannot get the kernel to load properly. Originally I had an I-Cubed card in there and the kernel would identify it correctly and (I assume) ignore it. It would then lock up.

  I changed this card for an ANT Ether3 card and now when trying out the kernel I get the following message filling up the whole screen :

  "Wild interrupt from backplane?"

  The specs of the RiscPC are as follows:

  Arm 710, 20MB memory, Sony CD Drive (x4 speed), 850MB hard disc. 1MB VRAM, 486 PC Card, and an ANT Ether3 card.

  A *podules tells me that in pod 0 I have an ANT Ethernet AUN discless card.

  If anybody has any ideas they would be gratefully received. (Am I running the wrong kernel? Its the one pointed to from the website. Should I change the network card for a different type?)

  Thanks in advance,

  Tom Palmer,
  Webmaster, The Netherhall School,
  Cambridge,
  United Kingdom

---

From: Russ King <[email-masked]>
Date: Wed, 3 Dec 1997 13:58:54 +0000 (GMT)

Tom Palmer writes:
> I am in the middle of trying to get my RiscPC at work running Arm-Linux.
> Everything on the RiscOS side of things is working.
> 
> The problem is that I cannot get the kernel to load properly. 
> Originally I had an I-Cubed card in there and the kernel would identify 
> it correctly and (I assume) ignore it. It would then lock up.

Could you send me the name of the card, the version (which is on the
sticker on the card), and the first few kernel messages relating to the 
expansion cards?  Also, what is the last message that you see?

> I changed this card for an ANT Ether3 card and now when trying out the 
> kernel I get the following message filling up the whole screen :

This would be caused by a Podule not shutting down correctly when told to,
and there isn't an easy fix for Linux - except to complain to the 
manufacturer that they don't implement the expansion card specs properly!