Subject: Re: Troubles compiling kernel

From: Russell King <[email-masked]>
Date: Tue, 9 Dec 1997 21:03:27 +0000 (GMT)

Jan Magnussen writes:
> [root@fbi /root]# ifconfig
> lo        Link encap:Local Loopback  
>           inet addr:127.0.0.1  Bcast:127.255.255.255  Mask:255.0.0.0
>           UP BROADCAST LOOPBACK RUNNING  MTU:3584  Metric:1
>           RX packets:12 errors:0 dropped:0 overruns:0
>           TX packets:12 errors:0 dropped:0 overruns:0
> 
> eth0      Link encap:10Mbps Ethernet  HWaddr 00:C0:32:00:1D:63
>           inet addr:192.0.0.115  Bcast:192.0.0.255  Mask:255.255.255.0
>           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>           RX packets:0 errors:0 dropped:260 overruns:0
>           TX packets:0 errors:0 dropped:0 overruns:0
>           Interrupt:32 Memory:80000200-0 
> 
> [root@fbi /root]# ping fbi
> PING fbi (192.0.0.115): 56 data bytes
> ping: sendto: Network is unreachable
> ping: wrote fbi 64 chars, ret=-1
> ping: sendto: Network is unreachable
> ping: wrote fbi 64 chars, ret=-1
> ping: sendto: Network is unreachable
> ping: wrote fbi 64 chars, ret=-1
> 
> --- fbi ping statistics ---
> 3 packets transmitted, 0 packets received, 100% packet loss

Things to try:

route - print/modify a routing table.
	Simply configuring an interface does not automatically mean that
	packets are routed to it (since you may not actually want that
	to happen, or you only want certain packets to go through that
	interface.

ping localhost
	This will indicate if your loopback interface is working.  If
	not, then ping fbi won't work either - the packets for the local
	interfaces are internally routed via lo.

cat /proc/interrupts
	This will give information about the number of interrupts received
	per IRQ channel, and would be useful for tracking  down this problem.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |         Russell King        [email-masked]       --- ---
  | | | |     http://www.arm.uk.linux.org/~rmk/home.html     /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]

---

From: Jan Magnussen <[email-masked]>
Date: Wed, 10 Dec 1997 10:05:58 +0100

>         to happen, or you only want certain packets to go through that

[root@fbi /root]# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use
Iface
127.0.0.0       *               255.0.0.0       U     0      0        1
lo

I managed to set up a default route, and after I did that, I was able to
ping myself :-)
How do I make the default route automatic start on bootup? I was able to
configure eth0 to start on default
(/etc/sysconfig/network-scripts/ifcfg-eth0)

>         interfaces are internally routed via lo.

I could ping the localhost before I set up the default route (and
afterwards as well) :-)
Unfortunately I'm atm. the only one on our local network, so I can't
test if it can talk to other computers than my own, but I will let know
as soon as they rejoin the net.

>         per IRQ channel, and would be useful for tracking  down this problem.

[root@fbi /root]# cat /proc/interrupts
32:          0   etherh

Regards,

Jan Magnussen
http://www.kom.auc.dk/~janm
Fidonet 2:234/181.8
unsubscribe: body of `unsubscribe linux-arm' to [email-masked]