Subject: Qs

From: [email-masked] (Thomas Marx)
Date: Sat, 15 Nov 1997 19:29:37 +0100 (MET)

Hi!
I have some more questions to clarify things for me :
- Where do I find the kernel sources (is linux-2.0.30.tar.gz( why 30 and not 31)?)
- What for is the system map file?
- I have a tar named armtools. Do I need it for anything? Or is it too old?

Thanx in advance, Tom

---

From: Matthew Wilcox <[email-masked]>
Date: Sun, 16 Nov 1997 00:23:52 +0000 (GMT)

> - Where do I find the kernel sources (is linux-2.0.30.tar.gz( why 30 and not 31)?)

Linus releases the kernel sources to ftp.funet.fi and ftp.kernel.org.
I find my nearest mirror of ftp.funet.fi, look in the directory
pub/Linux/PEOPLE/Linus/v2.0 and get the latest source tree.  You can
patch to the latest version by downloading patch files if you have an
earlier version.

> - What for is the system map file?

Not 100% sure to be honest.  I think it's the symbols-addresses map and
you'd need it in order to report a kernel oops.

> - I have a tar named armtools. Do I need it for anything? Or is it too old?

No idea.

---

From: Philip Blundell <[email-masked]>
Date: Sun, 16 Nov 1997 03:19:44 +0000

>you'd need it in order to report a kernel oops.

That's pretty much it.  It's just a sorted list of the symbols in the kernel.
Without that information the numbers in oopses don't mean a lot.

p.