Subject: Progs with compiling

From: [email-masked] (Thomas Marx)
Date: Wed, 26 Nov 1997 18:49:38 +0100 (MET)

Hi!
I am happy that my Linux runs mostly stable.
I tried to to compile the QT library. I use the option linux-gcc-static and
it compiled after I set a link from proc to proc-armv (is this right for a
RPC?) somewhere in the /usr/src tree.
But every program (the tutorials and the exapmles) crash or say that virtual
memory is exhausted although I have lots free.

Beside of this I tried to compile python. It compiled the most part but when run a test 
it said that there was a mistake within the sqrt routine. What is the source
of this error?
Another mistake was when compiling an assembler file the routine 
ASM_OUTPUT_ADDDIR_DIFF_ELT was not known. What is this?

Thanx in advance.
Regards, Tom

---

From: Matthew Wilcox <[email-masked]>
Date: Wed, 26 Nov 1997 20:28:12 +0000 (GMT)

> RPC?) somewhere in the /usr/src tree.

Yes, this is right.  It's a consequence of how Russell has decided to
organise the ARM port.  The right way to get the symlinks setup is to
configure the kernel, the `make config' sets up the links for you.
Whether the port should be organised into separate arm26 and arm32
architectures, I don't know.  That's the way the Sparc32 & Sparc64 are
set up, but it's really up to Russell.

> memory is exhausted although I have lots free.

Don't know about this.  But without ELF, compiling a library is
non-trivial, and you may well need Russell to assign you a base number -
if this library builds for a.out at all!

> it said that there was a mistake within the sqrt routine. What is the source

I don't know.  I may test this tonight - I certainly know of one bug in
libm, and there may be others.  This was due to a very poor specification
of the FP instructions in the RISC OS 3 PRMs.

Phil, are the libc6 routines taken from the current libc4?  Do you want
to be cc'd on any bug reports?

> ASM_OUTPUT_ADDDIR_DIFF_ELT was not known. What is this?

Umm.. if it's an assembler file, it's almost certainly not ARM assembler!
You'll need to rewrite this file in any case.

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Wed, 26 Nov 1997 22:06:06 +0000 (GMT)

> memory is exhausted although I have lots free.

When you say it crashes, do you have any kernel messages relating to the crash?
An 'Oops' maybe?

> Beside of this I tried to compile python. It compiled the most part but
> when run a test it said that there was a mistake within the sqrt routine.
> What is the source of this error?

I seem to remember that this is what happened when I attempted it.  If anyone
can track down the error...  Let me guess... sqtd doesn't work the way that
I thought it ought to???

                .file   "sqrt.S"
#include <linux/errno.h>
                .text

                .global _sqrt
_sqrt:          stmfd   sp!, {r0, r1}
                ldfd    f0, [sp], #8
                cmfe    f0, #0
                bmi     domainerr
                sqtd    f0, f0
                movs    pc, lr

domainerr:      mov     r0, #EDOM
                ldr     r1, =_errno
                str     r0, [r1]
                ldr     r0, =___huge_val
                ldfd    f0, [r0]
                mnfd    f0, f0
                movs    pc, lr

> ASM_OUTPUT_ADDDIR_DIFF_ELT was not known. What is this?

Don't give the compiler -fPIC or -fpic options!!!
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King        [email-masked]        --- ---
  | | | |    http://www.arm.uk.linux.org/~rmk/home.html      /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |

---

From: Philip Blundell <[email-masked]>
Date: Thu, 27 Nov 1997 11:56:24 +0000

>to be cc'd on any bug reports?

Some are, and yes please.

p.