Subject: Fatal error: invalid listing option `r'

From: "A.S.MCGough" <[email-masked]>
Date: Thu, 16 Oct 1997 22:18:45 +0100 (BST)

Ok changing the cross compiler line in config/arm/t-linux gets me further 
but still won't compile, I now get as far as compiling libgcc1 but then 
end up with the error stated in the subject line. The make ends with:

rm -f tmplibgcc1.a libgcc1.S
cp ./config/arm/lib1funcs-linux.asm libgcc1.S
for name in _udivsi3 _divsi3 _umodsi3 _modsi3 _dvmd_tls; \
do \
  echo ${name}; \
  ./xgcc -B./ -O2 -fomit-frame-pointer  -DCROSS_COMPILE -DIN_GCC   -g 
-I./include -g0 -I. -I. -I./config -c -DL${name} libgcc1.S; \
  if [ $? -eq 0 ] ; then true; else exit 1; fi; \
  mv libgcc1.o ${name}.o; \
  /usr/arm-unknown-linuxaout/bin/ar -rc tmplibgcc1.a ${name}.o; \
  rm -f ${name}.o; \
done
_udivsi3
Assembler messages:
Fatal error: invalid listing option `r'
make: *** [libgcc1-asm.a] Error 1

With the line ./xgcc being the point where everything fails at.

any suggestions welcome.

steve..

---

From: Philip Blundell <[email-masked]>
Date: Fri, 17 Oct 1997 20:40:57 -0000

>With the line ./xgcc being the point where everything fails at.

Issue the `xgcc' command by hand and add the -v flag.  That way you get to see 
what's being passed to the assembler.  It looks like you have a problem with 
the ASM_SPEC you built gcc with not agreeing with the version of binutils 
you're using.

p.