Subject: Installing Linux using soft links

From: Jan Magnussen <[email-masked]>
Date: Sun, 21 Sep 1997 14:46:47 +0200

Hi!

I just installed ARMLinux from my ADFS partition using softlinks to my ext2
formatted partition.

Here is how to do it:
First you need some binaries: cp, ln and mv, I can mail these to you, if you
cannot get them from anywhere else.
Copy these to a msdos formatted floppy
Copy the RedHat/base files to your ADFS hdd as RedHat/base/*
Copy the RedHat/RPMS files to your ADFS hdd as RedHat/RPMS/*
Copy maketree, linkbase and linkrpms to the floppy. These scripts are listed
below.
Copy kernel to the floppy as vmlinux
Copy modules-rpc-1997.09.07.gz to msdos-floppy as modules.gz
Start linux with <Linux$Dir>.!Run -bootkernel <path to your kernel>
Follow installation until both Root and Supplemental disk is loaded.
Press Alt-F2

Type:
mknod /dev/fd0 b 2 0
mknod /dev/hda1 b 3 1
mknod /dev/hda3 b 3 3
mount -t msdos /dev/fd0 /fd0
mount -t adfs /dev/hda1 /hda1
mke2fs /dev/hda3. This command is only nessecary if you haven't already
initialised your ext2 partition.
mount -t ext2 /dev/hda3 /hda3
cd /fd0
PATH=$PATH:.
cp mv /bin
cd ln /bin
cp maketree /
cp link* /
cd
maketree
linkbase
linkrpms
cd
umount /fd0
umount /hda3

Press Alt+F1
Follow installation as if you have copied the installation files to the root of /dev/hda3.
Do *NOT* format the partition when asked.

If you are not using the ADFS disc to install from, you may have to change some
of the paths used.

---- maketree ----
mkdir /hda3/RedHat
mkdir /hda3/RedHat/RPMS
mkdir /hda3/RedHat/base

---- linkbase ----
cd /hda1/RedHat/base
for i in *; do ln -s /hda1/RedHat/base/$i /hda3/RedHat/base/$i; done
cd /hda3//RedHat/base
mv skeleton.c skeleton.cgz
cd

---- linkrpms ----
cd /hda1/RedHat/RPMS/0
for i in *; do ln -s /hda1/RedHat/RPMS/0/$i /hda3/RedHat/RPMS/$i.rpm; done
cd /hda1/RedHat/RPMS/1
for i in *; do ln -s /hda1/RedHat/RPMS/1/$i /hda3/RedHat/RPMS/$i.rpm; done
cd /hda1/RedHat/RPMS/2
for i in *; do ln -s /hda1/RedHat/RPMS/2/$i /hda3/RedHat/RPMS/$i.rpm; done
cd /hda1/RedHat/RPMS/3
for i in *; do ln -s /hda1/RedHat/RPMS/3/$i /hda3/RedHat/RPMS/$i.rpm; done
cd /hda1/RedHat/RPMS/4
for i in *; do ln -s /hda1/RedHat/RPMS/4/$i /hda3/RedHat/RPMS/$i.rpm; done
cd

This method worked for me, and it installed all the files in less than half an
hour.

Hope this helps.

Regards,

Jan Magnussen
http://www.kom.auc.dk/~janm
Fidonet : 2:234/181.8

---

From: Jan Magnussen <[email-masked]>
Date: Sun, 21 Sep 1997 20:33:12 +0200

> Copy the RedHat/RPMS files to your ADFS hdd as RedHat/RPMS/*

Of course all the RPMS cannot be held in one directory, so subdirectories
should be created under RPMS called 0-4 to make room for all the RPMS.
Copy the first 77 files into the '0' directory making sure that there are
no files called the same after truncating the filenames making the files
overwrite each other.

Regards,

Jan Magnussen