Subject: RE: Linux on CD

From: "Roland Groepmair" <[email-masked]>
Date: Wed, 20 Aug 1997 13:04:53 +0200

Hello!

Watching this discussion about contollers and ARM Linux, 
my old (not really answered) question (7/7/97) comes again
(I'm sorry, but I don't give up!):  =8-)

I have a Cumana SCSI-2 Adapter. Will it be supported by ARM Linux in the future?
Although I wanna install on an IDE HD, my CD-ROM is connected with the SCSI-Adapter.

The technical specification is:

Podule ID's: I used the kernel loader v3.13 (May 11 1997) and the kernel dated 30. Jun 1997, 12:47:20. I think you are interested in the message 
"Installed expansion cards: 
0: [003A:003A] SCSI-2 & CDFS Expansion Card"

The hardware information is:
CUMANA 16/32 BIT SCSI II
DRG NO CL1822 ISS53
FCQR26343/B 3594
Ser No 1300

I have found the following major ICs:
- 74HC652AP (four times)
- MC74AC04N
- Flash N28F010
  -150
  U41013J2
- FLEXlogic Intel
  N68FX740-15
  L3462425
- Emulex
  2400148
  FAS 216
  E MR 03448
  N9311
- AMI 9437LTE
  22CV10AP-25
  
and four small chips

Thanks, Roland

--- the one who wishes to use ARM Linux one day ---
----------
From: 	Andy Armstrong[SMTP:[email-masked]]
Sent: 	Tuesday, August 19, 1997 5:55 PM
To: 	[email-masked]
Subject: 	Re: Linux on CD 

There are a number of products:

8 bit SCSI regular podule, 8 bit SCSI micropodule, 8 bit SCSI minipodule, 
SCSI hardcard, 16 bit SCSI.

8 bit IDE minipodule, 16 bit IDE podule, 8 bit IDE Ultimate.

The 8 bit SCSI cards use a DP8490 controller (Nat Semi, 40 pin DIL 
package) in that chip's DMA mode. The micropodule version provides a 
memory mapped status register so you can poll DRQ. The other 8 bit cards 
have a horrid state machine which stalls the MEMC cycle while waiting for 
DRQ.

The 16 bit card has a NCR 53C94 or equivalent. The hardware of that card 
is involved...

The IDE cards work about the same way as everyone else's bog standard 
memory mapped IDE cards I expect :-) Only the addresses will be different.

The SCSI cards provide the standard Acorn SCSIDriver API and so work fine 
with CDFS. The IDE cards don't support CDROMs although I do have some 
working ATAPI code which never got released.

I would hazard a guess that it would be very easy to support the IDE 
interfaces and reasonably tricky to support the SCSI ones. The simplest 
SCSI interface to program is probably the 8 bit Micropodule.

-- 
http://www.wonderworks.co.uk --> Free RISC OS software
Andy Armstrong

---

From: [email-masked]
Date: Wed, 20 Aug 1997 19:15:10 +0100 (BST)

> I have found the following major ICs:

I have started to look at this lately (since I have access to a machine
with one in). At first glance, it looks like this chip may be a QLogic
FAS clone, and I have looked at this from that point of view.

However, I cannot get the chip to respond in the same way as the QLogic
FAS SCSI driver would have me believe, so I must assume that it is not.
Back to the drawing board then.

However, while I have the hardware available, I will be looking into
this as a matter of urgency.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |       Russell King        [email-masked]         --- ---
  | | | | http://whirligig.ecs.soton.ac.uk/~rmk92/home.html  /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |