Subject: Machine hangs during "format partition" stage of install

From: [email-masked] (Glenn Ramsey)
Date: Sat, 23 Aug 1997 09:45:18 +1300

While trying to install arm linux my machine hangs while
mke2fs is running on my linux partition.

This is the setup:
rpc700  8M/2M ram/vram  arm 710   ro3.6

Drive ADFS::4 Seagate ST32132A - 2.1 Gb - master

partition 1 997 MB  Filecore
partition 2   1 kB  Table
partition 3 100 Mb  Linux Swap 
partition 4 918 Mb  Linux Native  

Drive ADFS::5 Seagate ST32132A - slave
borrowed from my 386 Linux machine at work and formatted by
Linux 2/0/30 (Debian-'cos it's mirrored in NZ):

partition 1 Linux
partition 2 Linux swap
partition 3 MSDOS
partition 4 extended (type 5?)
partition 5 /var
partition 6 /usr
partition 7 /home

The redhat install directories are in the root directory of
partition 1 of this drive.  

The problem occurs when mke2fs is writing inode tables on /dev/hda4.

It gets through the install process until the "format
partitions" section which is where it hangs:

Console 3 says:
running /usr/bin/mke2fs mke2fs /dev/hda4

Console 5 says:
..
blocksize=1024 (log 0)
fragment size=1024 (log 0)
115 block groups
2048 inodes per group
superblock backup stored on blocks:
<list of block numbers>
writing inode tables 32/115 - this is where it hangs.

What can I do about this?

Other problems and fixes that may be worth noting:

1. Couldn't find valid redhat install tree.
 
I had copied the redhat RPMS directory onto the Linux disk
as /RedHat/RPMS but the install program kept reporting it
couldn't find a valid redhat install tree.

You also need a RedHat/base with the relevant files in it.
The "downloading" section on the web page:
"http://whirligig.ecs.soton.ac.uk/~rmk92/armlinux/downloading.html"
doesn't mention this.  It only mentions the RPM packages.

Perhaps this could be reworded to say something like: 
"You will also need a RedHat install tree containing the directories:
        RedHat/RPMS
        RedHat/base
and all the files in them, which are available from ftp://...

I guess that if you do an ftp install then you don't have
this problem.

2. Linux hard disc not recognised.
 
Thanks to Russel for the fix to this one.

The Linux disc from my work PC had previously been formatted
as an ADFS disc (to allow reformatting of my ailing
CFS850A).

When reformatting it as a Linux disk the ADFS boot sector is
not overwritten.

Because this disc still had a valid ADFS boot sector the
kernel thought it was an ADFS disc.  I just wrote zeros to
the boot sector to get rid of it.

Now during startup the kernel thinks it's a DOS disc and can
see all the partitions, and the redhat install program can
mount the 3 primary partitions.  

However the redhat install program can't see the extended
partitions.  Why is this ?

g

-- 
Glenn Ramsey
[email-masked]

-- 
Glenn Ramsey
[email-masked]

---

From: ARM Linux Admin (Russell King) <[email-masked]>
Date: Sat, 23 Aug 1997 10:43:14 +0100 (BST)

Glenn Ramsey writes:
>...

I presume that this has been tried quite a few times?  Does it always
hang in the same place at the same inode table number?  Which kernel
(date on the corresponding file on the FTP site please) are you using?
What happens if you repartition the disk with Linux Native in partition
3 and Linux Swap in 4?  Does the mke2fs go further?

>...

Eek!  Please change that web address to:
  http://www.arm.uk.linux.org/~rmk92/armlinux/downloading.html

I'd like to have some site-independence please (since they're going
to be moving at a later date... ;)

> I guess that if you do an ftp install then you don't have

That is correct - the ftp install method will find the relevent
files in RedHat/RPMS and RedHat/base.

> When reformatting it as a Linux disk the ADFS boot sector is

I think I'll add this one to the FAQ...

> partitions.  Why is this ?

The RedHat installer runs the `fdisk' program to get a list of
the partitions available on the drive.  The version of `fdisk'
with ARM Linux is an unfinished re-write of the real `fdisk'
program.  `fdisk' has enough functionality to report most of the
available partitions, and modify the information in memory, but
won't currently display PC extended partitions nor allow the
altered partition information to be written back.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |       Russell King        [email-masked]         --- ---
  | | | | http://whirligig.ecs.soton.ac.uk/~rmk92/home.html  /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |

---

From: Philip Blundell <[email-masked]>
Date: Sat, 23 Aug 1997 18:11:17 -0000

>hang in the same place at the same inode table number?  Which kernel

That can be symptomatic of running out of memory.  mke2fs needs a
surprising amount to work, particularly for bigger disks.

p.

---

From: [email-masked] (Glenn Ramsey)
Date: Sun, 24 Aug 1997 13:04:21 +1300

> > mke2fs is running on my linux partition.

(...)

> 3 and Linux Swap in 4?  Does the mke2fs go further?

I'm using the files:

root-rpc-1997.08.06
supplemental-1997.08.06
rpc-2.0.30-1997.07.20

I tried using partition 3, sized at 954 Mb instead of 4 and
it still didn't work, but mke2fs did appear to go further.

It stops on a different place each time.  The last 3 times
it has stopped on inodes 84/120, 38/120 and  73/120.

Using the previous setup on partition 4 it was stopping
around the 30 mark.  But the last time I tried before
changing the partitions it stopped at 13.

The last 2 messages on console 4 (I think?), the last time I
tried,  were:

<4> adding swap ...
<4> couldn't get a free page

Is this relevant?

g

-- 
Glenn Ramsey
[email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Mon, 25 Aug 1997 23:46:07 +0100 (BST)

Hiya.

A little more bad news.  I didn't read Alan Cox's message correctly.

Basically, I can now say that I have experienced your (Glenn) kernel hang
problem here today in a slightly more aggressive way:

Aug 25 15:17:28 raistlin kernel: Couldn't get a free page.....
Aug 25 15:18:09 raistlin last message repeated 4 times
Aug 25 15:19:09 raistlin last message repeated 6 times
Aug 25 15:20:09 raistlin last message repeated 6 times
Aug 25 15:20:19 raistlin kernel: Couldn't get a free page.....

However, I was able to recover the situation by quiting some of the
programs I was running.  The problem appears to be caused by deadlock in
the v2.0.30 of the kernel.

The solution is on it's way however, in the form of v2.0.31 (or v2.0.31pre7).
Either should fix this deadlock problem, and allow your install to complete
correctly.

Please wait for a v2.0.31 kernel and a new RiscPC root install disk (also if
anyone else sees this problem, I know about it, yes, it's annoying, and no
I can't do anything about it without releasing yet new kernels and root
disks ;( ).

I can't at the moment put a time scale on it since I'm not certain what I'm
doing (work-wise) over the rest of this week.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |       Russell King        [email-masked]         --- ---
  | | | | http://whirligig.ecs.soton.ac.uk/~rmk92/home.html  /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |