Subject: Re: Machine hangs during "format partition" stage of install

From: Russell King <[email-masked]>
Date: Sat, 23 Aug 1997 19:08:05 +0100 (BST)

Philip Blundell writes:
> >Glenn Ramsey writes:
> >> writing inode tables 32/115 - this is where it hangs.
> >> 
> >> What can I do about this?
> >
> >I presume that this has been tried quite a few times?  Does it always
> >hang in the same place at the same inode table number?  Which kernel
> 
> That can be symptomatic of running out of memory.  mke2fs needs a
> surprising amount to work, particularly for bigger disks.

But I wouldn't have expected it to just stop - I'd expect it to say
'Out of memory' and exit with a bad error code.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |       Russell King        [email-masked]         --- ---
  | | | | http://whirligig.ecs.soton.ac.uk/~rmk92/home.html  /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |

---

From: [email-masked] (Glenn Ramsey)
Date: Mon, 25 Aug 1997 17:39:52 +1300

Hi,

I tried the new disks:

root-rpc-1997.24.06
supplemental-1997.24.06
rpc-2.0.30-1997.07.20

mke2fs still hangs while writing inode tables:
 
44/120 - the last mesage on console 4 was <4> Adding swap .... 
there were no messages after this one.
 
61/120
console 4 says:

<4> Adding swap: 65516 k swap-space (priority -1)
<4> Couldn't get a free page.....

-- 
Glenn Ramsey
[email-masked]