Subject: Re: Any more feedback on ARM Linux?

From: [email-masked]
Date: Wed, 23 Jul 1997 23:48:43 +0100 (BST)

Philip Blundell writes:
> I think your mailer is putting a broken From address in, which may not help...

I've tried the RedHat version of Elm, my own version of Elm, but I can't get
anything to give me a correct From: line.

Sendmail won't even do it.  If you set the flag on the local mailer (w), it
just goes totally barmy and says that all users are unknown!

I am half tempted to put a From: into my elmheaders file to force it to put
one on correctly.

I'm using sendmail 8.7.4 with elm 2.4.24.

As far as I can tell, I've got everything set up correctly, but it just doesn't
want to know.  (and yes, the passwd file is correct).
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |       Russell King      [email-masked]         --- ---
  | | | | http://whirligig.ecs.soton.ac.uk/~rmk92/home.html  /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |

---

From: Philip Blundell <[email-masked]>
Date: Thu, 24 Jul 1997 00:37:55 +0100

>anything to give me a correct From: line.

My solution for this is to let my MUA put in what it likes (which is easier than convincing all the different programs that can send mail to get it right) and have the MTA (Exim in my case) rewrite my headers.  I imagine you can do this with sendmail, but I'm not sure how.

p.