Subject: What will PCI give ?

From: Mark Smith <[email-masked]>
Date: Mon, 21 Jul 1997 12:09:48 +0100

Hi,
Not sure if this question belongs in here but ...

When the Risc PC comes out with PCI will it give access to all those nice toys that are available for PCs ? Like could I plug in my Adaptec 2940 and with a little driver see SCSI disks ? Or plug in my Millenium and have graphics ?

Or will hardware have to be made specifically for the Risc PC (maybe a different BIOS) ?

The reason I want to know is that I would like a Risc PC but don't want the stodgy old bus it's currently got.

Thanks.

Mark.
[email-masked]

PS. If anyones got a cheap Risc PC going for sale, I'd be interested.  I've tried lots of times but you lot just won't give them up easily :(

---

From: Alan Cox <[email-masked]>
Date: Mon, 21 Jul 1997 13:55:27 +0100 (BST)

> When the Risc PC comes out with PCI will it give access to all those nice 
> toys that are available for PCs ? Like could I plug in my Adaptec 2940 and 
> with a little driver see SCSI disks ? Or plug in my Millenium and have
> graphics ?

You have to add three components to make all this work. Firstly its
improbable the RiscPC will have an intel PCI bios so you will need to write
the PCI bios equivalents for your platform and add them to the kernel

Secondly you will need to sort out PCI translations to make the drivers port
cleanly. That shouldnt be too hard. However some drivers will bite you as
they aren't very portable, (The worst of that got sorted by the Alpha)

> Or will hardware have to be made specifically for the Risc PC (maybe a 

This is #3. You will need an intel CPU emulator. There is a GPL'd i386
emulator in the now GPL willows toolkit. With some hacking its probably up
to initialising most boards.

Alan