Subject: Re: HURD progress

From: [email-masked] (Thomas Bushnell, n/BSG)
Date: Tue, 3 Jun 1997 13:09:56 -0400 (EDT)

Date: Mon, 02 Jun 1997 20:40:35 -0500 (EST)
   From: [email-masked]

   Has there been any progress since last September?  Since we so rarely 
   hear from the development team, I guess these are the questions I'd pose 
   for inclusion in an updated FAQ:

Lots of progress!  Our 0.2 release, complete with binaries, is
expected Real Soon Now (probably this week).

   Was an independent floppy installation ever created?  If so, where can it 
   be found?

No, because it's just not our biggest priority...

   Is the HURD stable enough now to run a multi-user system reliably?

Stability has vastly improved since 0.1.

   Has any progress been made to improve the Mach 3.0 driver system so
   that more modern Linux device drivers (circa Linux 2.0 and above)
   can be included?
   
I don't know; take a look at the gnumach stuff.  That's got Goel's
work on Linux drivers in Mach.  I don't know what was involved in 2.0
linux over 1.x linus.

   There was a report a few months ago that a gentleman from Japan was busy 
   porting the HURD to a MIPS R4x00-based evaluation board;  did this person 
   get in touch with the developers and did they coordinate anything?

Yes; after the release I will be merging in his work.

   Was the GRUB bootloader ever completed?

Yes, Grub 0.4 is excellent and will be in 0.2.  You can use it now if
you want...

Thomas

---

From: Scott McClung <[email-masked]>
Date: Tue, 3 Jun 1997 15:23:37 -0700 (PDT)

Hi,

> expected Real Soon Now (probably this week).

Will it be on prep.ai.mit.edu?  I just recently installed the hurd,
from the gnu-0.0-stripped file there, from a Linux system.  It boots
from floppy (GRUB), and I can get a shell, but I get some unexplained
crashes, and haven't had time to get the unstripped one for debugging
yet.

Is there a recent distribution/snapshot?  I've tried to set up a
cross compiler from Linux, so that might be another way to go, if
necessary.

Where do I send patches?  Maybe I should read some docs or an FAQ
now.  :-)

> Yes, Grub 0.4 is excellent and will be in 0.2.  You can use it now if

Can Grub be made to boot Linux?  I remember reading that it can (or
will eventually), but I haven't tried it myself...

-- 
Scott McClung ([email-masked])

---

From: Christopher Biggs <[email-masked]>
Date: 04 Jun 1997 09:12:39 +1000

> will eventually), but I haven't tried it myself...

I use GRUB to boot dos/linux/hurd right now, and have been ever since
hurd 0.0.

I store my linux images on a dos partition so my linux root partition can
live up beyond BIOS land.

Chris.

p.s. Here's my config file.

#
# Sample boot menu configuration file
#

# Timeout here...
timeout = 30
default= 1
fallback= 0

# For booting Windows NT 3.5 or DOS
title=      Windows 95/DOS boot menu
root=       (0x80,0)
makeactive
chainloader=    +1

# For booting linux from the DOS partition
title=      Linux
root=       (0x80,0)
kernel=     /linux/vmlinuz root=/dev/hda3 ro 

# For booting linux into maintenance mode from the DOS partition
title=      Linux (Single user mode)
root=       (0x80,0)
kernel=     /linux/vmlinuz root=/dev/hda3 ro S

# For booting a backup linux kernel from the DOS partition
title=      Linux (previous kernel version)
root=       (0x80,0)
kernel=     /linux/vmlinuz.old root=/dev/hda3 ro

# For booting a new untrusted linux kernel from the DOS partition
title=      Linux (experimental kernel version)
root=       (0x80,0)
kernel=     /linux/vmlinuz.exp root=/dev/hda3 ro

# For booting the HURD single user mode
#title=      GNU 0.0 (single user mode)
#root=       (hd0,1)
#kernel=     /boot/kernel -s root=hd0s2
#module=     /boot/serverboot

# For booting the HURD multi-user mode
#title=      GNU 0.0 (multi user mode)
#root=       (hd0,1)
#kernel=     /boot/kernel root=hd0s2
#module=     /boot/serverboot

# Re-install the boot loader
title=      Re-install the GRUB loader on Disk 0 Sector 0
install=    (hd0,0)/linux/grub/stage1 (hd0) (hd0,0)/linux/grub/stage2 0x8000 p (hd0,0)/linux/grub/menu.lst
root=       (hd0)
chainloader=+1
pause=      New GRUB setup has been installed, press any key to reboot.

--
| Christopher Biggs email:[email-masked] | Linux: The choice of a GNU  |
| Stallion Technologies, Queensland, Australia |        Generation.          |
| VoiceNet +61-7-3270-4266 Fax +61-7-3270-4245 | Mates dont let mates do DOS |
| Send mail with "Subject: sendpgpkey" for my PGP public key.   MIME mail OK |