Subject: Probs setting up the Config-file

From: Jan Magnussen <[email-masked]>
Date: Mon, 09 Jun 1997 21:53:39 +0200

Hi there,

I can't get Linux to find my HD-partitions. I have looked in all the help files
I could find, but with no luck.
I have formatted my HD on my ICS IDEFS to use for linux, but I can't seem to
make it work.
Here is my Config-file (What have I done wrong?):

# Linux Boot Configuration file
# *** This file is automatically generated by !LinConfig - do not edit!!! ***
# List kernels at startup
List:		on
#
# Partition containing kernels
Root:
# ADFS::4.$.Linux.Part1
*IDEFS::4.0
#
# Partition List
Partitions:
0301 Linux.Part1
0301 Linux.Swap
0301 Linux.MSDOS
0000
0000
0000
0000
0000

I am using BootLoader 3.13, and I have to comment the root-partition out to
avoid getting an 'illegal magic in bmap file'-error. Even when I use the
-BootKernel option when starting the BootLoader.

I have initialised two partitions on my IDEFS-disk. One on 100MB and one on 20MB
What is the correct setting?

I also have a Powertec SCSI-II card. When will this be supported, and will my
CDROM-drive work, if it is attached to the card?

PS: How do I access a Linux partition from RISC OS? Or how do I make one shared
(MSDOS-formatted?) partition from/to which I can both read and write from Linux
and RISC OS (for transferring files bigger than 1440k between the two systems)?

PPS: When is the Linux-CDROM released?

Regards,

Jan Magnussen
http://www.but.auc.dk/~36jan
Fidonet : 2:234/181.8

---

From: Joseph Heenan <[email-masked]>
Date: Mon, 09 Jun 1997 21:24:25 +0100

Hi,

In message <[email-masked]>
          Jan Magnussen <[email-masked]> wrote:

> [snip config file... looks okay as far as I know...]
>
> I am using BootLoader 3.13, and I have to comment the
> root-partition out to avoid getting an 'illegal magic in bmap
> file'-error. Even when I use the -BootKernel option when starting
> the BootLoader.

Have you setup /etc/boot.conf and run loadmap?
see man boot.conf, man loadmap
These are how you setup which kernels the bootloader offers you a
choice of, and where the root partition is (I think) and a few other
things.

> I have initialised two partitions on my IDEFS-disk. One on 100MB
> and one on 20MB What is the correct setting?

If the first linux partition is your root partition, then it should
be, yes.

> [snip]

Don't know the answers for the rest, I'm afraid. I don't think
there's an easy way of getting files risc os <-> linux atm, although
I'd love to be proved wrong. A totally dos formatted HD might work.
(or a zip drive... I'm sure I saw a ppa module somewhere!)

Cheers,

Joseph

-- 
Joseph Heenan
email: [email-masked], [email-masked]

---

From: Jan Magnussen <[email-masked]>
Date: Mon, 09 Jun 1997 23:12:23 +0200

> choice of, and where the root partition is (I think) and a few other

How can I edit these when I cannot boot Linux?

Regards,

Jan Magnussen

---

From: Joseph Heenan <[email-masked]>
Date: Mon, 09 Jun 1997 22:07:19 +0100

> Here is my Config-file (What have I done wrong?):

I think I got things wrong in my last email... I'd assumed you'd
installed armlinux, but looking at this again, I don't think you
have. Apologies if I'd got this right the first time.. ;-)

Anyway, if you're following the INSTALL instructions from the ftp
site, it doesn't tell you to setup the config file for !Linux until
after you've installed linux. If your harddrive partitions aren't
been recognised, then it's something to do with the kernel, and you
should post the partition check stage of the bootup messages for our
perusal. The web pages seem to say that the ICS IDEFS driver is
untested & unfinished, maybe this is the problem...

HTH

Joseph

---

From: Philip Blundell <[email-masked]>
Date: Tue, 10 Jun 1997 00:35:15 +0100 (BST)

> (or a zip drive... I'm sure I saw a ppa module somewhere!)

PPA isn't tested on the ARM yet.  It ought to work on A5000 and RPC
hardware though - I'd like to hear if anybody has any problems.  We're
working on ARC support, which should come with SPARC and m68k soon.

p.

---

From: [email-masked] (Russell King)
Date: Mon, 9 Jun 1997 23:25:03 +0100 (BST)

> 0301 Linux.MSDOS

This is currently an unsupported partitioning method.  You should be using the
PartMan method of partitioning your drive.  Linux will automatically detect these.

Please read *all* the documentation, including the INSTALL file on the FTP site
in /pub/armlinux/distrib/riscos/INSTALL.

> CDROM-drive work, if it is attached to the card?

There is currently no work being performed on this card.  However, if someone would
like to have a go...

> and RISC OS (for transferring files bigger than 1440k between the two systems)?

The Linux kernel (as I mentioned above) does not support shared partition files
at the moment.  However, rudimentiary support will be returning shortly.

> PPS: When is the Linux-CDROM released?

I hope in a week's time.  There are a few problems that need sorting out first.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |       Russell King      [email-masked]         --- ---
  | | | | http://whirligig.ecs.soton.ac.uk/~rmk92/home.html  /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |      *  who wishes that he was in Hong Kong  *      ---  |
    +-+-+ -------------------------------------------------  /\\\  |

---

From: Jan Magnussen <[email-masked]>
Date: Tue, 10 Jun 1997 01:01:06 +0200

> have. Apologies if I'd got this right the first time.. ;-)

;)

> untested & unfinished, maybe this is the problem...

Partial kernel bootup message:
Console: colour A-series 160x128x256, 1 virtual console (max 63)
Installed expansion cards:
  0: [005B:0107] Power-tec (Alsystems) Generic SCSI with ATAPI & CDFS
  1: [003C:00AE] IDE Interface
Calibrating delay loop.. ok - 270.34 BogoMIPS
Memory: 22940k/24576k available (732k kernel code, 36k reserved, 868k data)
[snip]
hda: Conner .........
ide0 at 0x1f7, 0x3f6 on irq 9
Floppy drive(s): fd0 is 1.44M, fd1 is 1.44M
Started kswapd v 1.4.2.2
FDC 0 is a post-1991 82077
scsi : 0 hosts.
scsi : detected total.
Partition check:
 hda: [ADFS] hda1
VFS: Insert root........

Hope this helps.

Regards,

Jan Magnussen

---

From: Jan Magnussen <[email-masked]>
Date: Tue, 10 Jun 1997 22:50:42 +0200

> PartMan method of partitioning your drive.  Linux will automatically detect these.

I did, but Linux wasn't able to detect my drive at all (see my ealier mail), and I
didn't think that it would matter that I defined the unsupported partitions. I
thought that they just were ignored.

> in /pub/armlinux/distrib/riscos/INSTALL.

I think I already did skim it all through but a second look wouldn't hurt (I think) ;)

> There is currently no work being performed on this card.  However, if someone would

Does this mean that I can't get my CD-ROM, which is attached to the SCSI-card, to work
either?

> at the moment.  However, rudimentiary support will be returning shortly.

Does that mean an 'EXT2FS for RO' or something like that?

> I hope in a week's time.  There are a few problems that need sorting out first.

I hope that I can make it work with my SCSI-II CD-ROM...

Regards,

Jan Magnussen

---

From: [email-masked] (Russell King)
Date: Tue, 10 Jun 1997 21:36:25 +0100 (BST)

> working on ARC support, which should come with SPARC and m68k soon.

Wrong!  The PPA module has been tested on ARM, and appears to work
fine.  However, the current state of the Linux PPA module in the 2.0
kernels means that you don't get the high-speed parallel port speeds.

The ppa module is on the installation disk for RedHat ARM Linux.

BTW, I have been getting complaints about mis-information being
broadcast about ARM Linux.  Could people please ensure that they
get their facts right before commenting.  Althoug the Web site
pages may say that they're a month old, they are probably correct.
Thanks.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |       Russell King      [email-masked]         --- ---
  | | | | http://whirligig.ecs.soton.ac.uk/~rmk92/home.html  /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |      *  who wishes that he was in Hong Kong  *      ---  |
    +-+-+ -------------------------------------------------  /\\\  |

---

From: Philip Blundell <[email-masked]>
Date: Thu, 12 Jun 1997 00:35:20 +0100 (BST)

On Tue, 10 Jun 1997, Russell King wrote:

> fine. 

It would be nice if people told us these things.  Still, PPA is due for
another breakage soon.  BTW, it won't work on pre-A5000 hardware unless
Russell has done something really evil to it (which I sincerely hope he
hasn't).

ObDig: Russell, have you signed the FSF disclaimer yet?

p.

---

From: Steve Potts <[email-masked]>
Date: Thu, 12 Jun 1997 21:12:25 +0100

Would it be possible to set up linux to run on a parallel port zip drive
???

I'm thinking about my A3010 with zip drive?  Basically, all I'm after is
a set of install discs/files which could be used on my machine.  I don't
have the time, facilities or knowledge to compile a system for myself
though.

Steve

---

From: Philip Blundell <[email-masked]>
Date: Thu, 12 Jun 1997 22:41:09 +0100 (BST)

> Would it be possible to set up linux to run on a parallel port zip drive

As your main disk?  Yes, but it would be deathly slow.

p.

---

From: [email-masked]
Date: Thu, 12 Jun 1997 23:09:21 +0100 (BST)

> Russell has done something really evil to it (which I sincerely hope he

The web pages are uptodate...

And it is not modified in any functional way from the standard code.  The
only modification done to the code is to correct a bug in it that
prevents it working!  (How the hell does it work on the PC?)
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |       Russell King      [email-masked]         --- ---
  | | | | http://whirligig.ecs.soton.ac.uk/~rmk92/home.html  /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |      *  who wishes that he was in Hong Kong  *      ---  |
    +-+-+ -------------------------------------------------  /\\\  |

---

From: Philip Blundell <[email-masked]>
Date: Thu, 12 Jun 1997 23:30:05 +0100 (BST)

> prevents it working!  (How the hell does it work on the PC?)

That version doesn't - at least not very reliably.

p.

---

From: Steve Potts <[email-masked]>
Date: Fri, 13 Jun 1997 10:08:43 +0100

Philip Blundell wrote:
>                        Postage paid by: [Image]
Yes, that was what I wanted, I have no other option really.

>     ---------------------------------------------------------------
>