Subject: Re: ARM Patches (fwd)

From: [email-masked]
Date: Sat, 28 Jun 1997 20:02:21 +0100 (BST)

Erik Troan writes:
> On Sat, 28 Jun 1997 [email-masked] wrote:
>
> > Would you be interested in patches for the ARM port of Linux?  I currently have
> > (out of a mixture of 3.0.3, 4.0, and 4.1) the following patches.  I am working
> > on some of 4.2 now.  Anyway, here is a list of packages that have patches of one
> > sort or another.
>
> Good grief.
>
> > Please note that at the moment, ELF is not supported on the ARM platforms due to
> > a lack of standard (and time to work out how to do ELF).  That's not to say that
> > it won't happen - it has to happen some time.
>
> I'm not that interested in them until ELF is supported, the diffs would
> be too difficult to integrate w/o shared libs.

Anyone want to work on a proper ELF standard for ARM Linux?  (One that is the full
works - shared libraries etc).  This will of course require GCC and binutils changes.

This is extremely urgent - the later kernels have been 'designed' for ELF, and so
have most of the libraries.  RH 4.2 is as well.

Anyone wanting to work on ELF, please email me.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |       Russell King      [email-masked]         --- ---
  | | | | http://whirligig.ecs.soton.ac.uk/~rmk92/home.html  /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |      *  who wishes that he was in Hong Kong  *      ---  |
    +-+-+ -------------------------------------------------  /\\\  |

---

From: "Ka'Plagh" <[email-masked]>
Date: Mon, 30 Jun 1997 05:13:56 +0000

Good idea, one of the big moves forward with Alpha Linux was ELF shared 
libraries.
If anyone out there wishes to volunteer, I can get them some StrongARM hardware
to play with...