Subject: Image-files as Partitions

From: Jan Magnussen <[email-masked]>
Date: Wed, 04 Jun 1997 14:11:28 +0200

Hi,

Is it possible to make image files work as partitions for ArmLinux? I have (sort
of) made the 2.0.30 kernel run on my SA using the bootdisk from the old
distribution (This is probably also why I cant make the Install procedure
work?), but I cannot mount a partition on my ADFS HDD not even if it is
preformatted to MSDOS-format using my PC-card. Is this because it is not
supported, or is it because I'm doing something wrong?
Here's my procedure :
Booting :
/SCSI::Main.$.Linux.!Linux -bootkernel ADFS::IdeA.$.Linux.rpc-2/0/30
In Linux : mount -t msdos /dev/hda3 /mnt
And my Config-file :
# Linux Boot Configuration file
# *** This file is automatically generated by !LinConfig - do not edit!!! ***
# List kernels at startup
List:		on
#
# Partition containing kernels
# Root:
# ADFS::4.$.Linux.Part1
#
# Partition List
Partitions:
0301 Linux.Part1
0301 Linux.Swap
0301 Linux.MSDOS
0000
0000
0000
0000
0000

I had to comment the root-partition out when using BootLoader 1.13. If I didn't
I would get an 'Invalid magic'-error because the hda1 (and hda2) partition is
blank.

Regards,

Jan Magnussen
http://www.but.auc.dk/~36jan
Fidonet : 2:234/181.8

---

From: Philip Blundell <[email-masked]>
Date: Wed, 4 Jun 1997 21:10:20 +0100 (BST)

On Wed, 4 Jun 1997, Jan Magnussen wrote:

> Is it possible to make image files work as partitions for ArmLinux? I

Not reliably at the moment.  The code exists, but I don't think it's
tested and there may be holes in it. 

p.

---

From: Jan Magnussen <[email-masked]>
Date: Wed, 04 Jun 1997 22:53:00 +0200

> tested and there may be holes in it. 

How do I make it work?

Jan Magnussen

---

From: Philip Blundell <[email-masked]>
Date: Wed, 4 Jun 1997 22:09:33 +0100 (BST)

> > tested and there may be holes in it. 

Don't know off the top of my head.  Try reading the source.

p.

---

From: Kaustav Bhattacharya <[email-masked]>
Date: Wed, 04 Jun 1997 22:33:50 +0100

I have an internal SCSI JAZ drive running on my RPC600 (610).  It's
formatted to SCSI in 2 x 512Mb chucks.  I use a Morley Cache card
running v1.17 SCSI firmware.  Can I install ARM Linux one of the 512Mb
chunks and expect it to behave itself if I run it completely off the
JAZ?  What was that?  You saw a pig flying? ;-)  

Kozzey.

-- 
Kaustav Bhattacharya (aka Kozzey) 
[email-masked] / [email-masked]
http://redhotcountry.co.uk - Europe's eye on country music world-wide
MEMBER OF THE COUNTRY MUSIC ASSOCIATION. No. 106306

---

From: Philip Blundell <[email-masked]>
Date: Wed, 4 Jun 1997 22:41:21 +0100 (BST)

> JAZ?  What was that?  You saw a pig flying? ;-)  

Morley SCSI isn't supported as far as I know.  The Jaz itself should be no
problem though.

p.

---

From: [email-masked]
Date: Wed, 4 Jun 1997 22:28:30 +0100 (BST)

> tested and there may be holes in it. 

The code does exist, but it's in extremely bad shape.  It basically requires
a partial re-write to get it working with the (newish) page cache.

Until such time, the image file code is non-functional.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |       Russell King      [email-masked]         --- ---
  | | | | http://whirligig.ecs.soton.ac.uk/~rmk92/home.html  /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |      *  who wishes that he was in Hong Kong  *      ---  |
    +-+-+ -------------------------------------------------  /\\\  |

---

From: [email-masked]
Date: Fri, 6 Jun 1997 00:02:58 +0100 (BST)

> > tested and there may be holes in it. 

It requires a partial re-write to take account of the page cache.  It is
currently known that if it is enabled, it will scribble all over your disk,
so please don't try it out without fixing it!

Are you able to read and code in C?  How much do you know about the Linux
kernel?
   _____

---

From: Jan Magnussen <[email-masked]>
Date: Wed, 18 Jun 1997 08:37:19 +0200

> Are you able to read and code in C?  How much do you know about the Linux

The answer to both questions is no and absolutely nothing:-( (Not yet
anyway, but I'll be taking some lessons in C-programming at the next
semester.)
And about the Linux kernel: Does it support sound?

Regards,

Jan Magnussen
http://www.but.auc.dk/~36jan/
Fidonet 2:234/181.8