Subject: Problems installing

From: Jan Magnussen <[email-masked]>
Date: Wed, 11 Jun 1997 22:29:26 +0200

Hello again,

I have given up on my IDEFS-hd and have reformatted my ADFS-hd, partitioned it
with a 250MB Linux Native and a 20MB Linux Swap-partition.
I have also deleted the Config file, because as far as I can understand, this is
required for the kernel to boot properly the first time.
I start Linux by the command-prompt typing:
/SCSI::Main.$.Linux.!Linux -bootkernel SCSI::Main.$.Linux.rpc-2/0/30
and I do not type in any extra arguments.
The kernel writes (among other things):
Partition check:
 hda: [ADFS] hda1 [Linux] hda2 < hda3 hda4 >
I guess this means, that the kernel have found my Linux-partitions?
When the Red Hat Installation comes to choosing partitions it tells me, that the
only partition available is /dev/hda saying that this partition is 8 block of
size, and if I accepts this then later on I am told that I do not have a swap-
partition either, and if I try to correct the partitions using fdisk (edit from
the partition menu), it can not read or write the HD.
Why is this? What am I doing wrong?
I have tried typing 'rw' at the extra arguments query in the bootloader, but
with no difference.

Regards,

Jan Magnussen
http://www.but.auc.dk/~36jan
Fidonet : 2:234/181.8

---

From: Joseph Heenan <[email-masked]>
Date: Wed, 11 Jun 1997 21:53:47 +0100

In message <[email-masked]>
          Jan Magnussen <[email-masked]> wrote:

> Hello again,
> 
> I have given up on my IDEFS-hd and have reformatted my ADFS-hd,
> partitioned it with a 250MB Linux Native and a 20MB Linux
> Swap-partition.

Good move :)

> I have also deleted the Config file, because as far
> as I can understand, this is required for the kernel to boot
> properly the first time. I start Linux by the command-prompt
> typing: /SCSI::Main.$.Linux.!Linux -bootkernel
> SCSI::Main.$.Linux.rpc-2/0/30 and I do not type in any extra
> arguments.

Looks good.

> The kernel writes (among other things): Partition check:

Yes.

> When the Red Hat Installation comes to choosing partitions it tells
> me, that the only partition available is /dev/hda saying that this
> partition is 8 block of size, and if I accepts this then later on I
> am told that I do not have a swap- partition either, and if I try
> to correct the partitions using fdisk (edit from the partition
> menu), it can not read or write the HD. Why is this? What am I
> doing wrong?

Okay. I assume/hope you mean it says the only available partition is
/dev/hda3 or something, and /dev/hda was the only disk is offered to
allow you to partition. Which is okay.
I think swap is 'work in progress'.

As for fdisk, it's compiled so you can't edit the partitions. I can't
remember why, though. :-(

Does it actually go through and install okay if you tell it to carry
on without any swap?

HTH,

Joseph

-- 
Joseph Heenan
email: [email-masked], [email-masked]

---

From: Alan Cox <[email-masked]>
Date: Wed, 11 Jun 1997 21:59:16 +0100 (BST)

Has anyone got the ARM kernel running on the ARM 7100 and/or 7500 CPU's.
They seem to be otherwise sane except for the data sheet "object oriented
MMU". Is this a different MMU or marketing buzzwordifying the existing one ?

Alan

---

From: Jan Magnussen <[email-masked]>
Date: Thu, 12 Jun 1997 00:15:41 +0200

> I think swap is 'work in progress'.

No. The only HD available is /dev/hda which (according to Red Hat) contains no
partitions :-(

> Does it actually go through and install okay if you tell it to carry

No. In the 'Find installation files'-menu it tries to mount /dev/hda1, which is
8k of size!! but (of course?) it cannot access this partition giving the error
'mount failed: Invalid argument'.

Regards,

Jan Magnussen