Subject: Re: Installation problems

From: Philip Blundell <[email-masked]>
Date: Wed, 14 May 1997 12:12:41 +0100 (BST)

On Wed, 14 May 1997, Jan Magnussen wrote:

> I have been trying to install linux on my StrongARM'ed RPC, but when the
> kernel loads, I get a strange error: Something like "Illegal magic (some
> address) in bmap file - aborting" why do I get this error?

Can you be more specific about the error?  It would be good to know the
exact text of the error (I couldn't find the one you described anywhere in
the kernel source) and a better idea of _when_ it happens.  

p.

---

From: Jan Magnussen <[email-masked]>
Date: Wed, 14 May 1997 12:32:37 +0200

Hi.

Thank you!

Jan Magnussen
http://www.but.auc.dk/~36jan/
Fidonet 2:234/181.8

---

From: Jan Magnussen <[email-masked]>
Date: Wed, 14 May 1997 19:21:23 +0200

> the kernel source) and a better idea of _when_ it happens.  

OK. Here goes:
Here is a copy of SCSI::Main.$.!Boot.Choices.Linux.Config:

# Linux Boot Configuration file
# *** This file is automatically generated by !LinConfig - do not edit!!! ***
# List kernels at startup
List:		off
#
# Partition containing kernels
Root:
ADFS::IdeA.$.Linux.rpc-2/0/30
#
# Partition List
Partitions:
0301 $.Linux.BootDisk
0301 $.Linux.Part1
0301 $.Linux.Swap
0000
0000
0000
0000
0000

The BootDisk partition is a Partition I found under /old/ (I think) on the
ARMLinux ftp-site. The two other partitions are made manually and contains only 0's (that's ascii 0). I have a Powertec SCSI-II card on which HD my BootLoader
software is on, but I don't think that that card is supported (yet?). The two
empty partitions are just test partitions and are only 10MB a piece.
The problem is when I double-click on the !Linux app then the program returns a
"Invalid magic (EA000006) in bmap file - aborting"-error. This is as much detail
as I can give you. I hope it is enough?

Thanx!

Jan Magnussen
http://www.but.auc.dk/~36jan
Fidonet : 2:234/181.8