Subject: kernel oops.. error

From: "Sun, Lei" <[email-masked]>
Date: Fri, 1 Sep 2000 14:11:46 -0400

Hi all:
   I have SA1110 Assabet and Neponset with linux 2.4.0-test4 running on it.
In order to do data aquisition and control via the strong Arm board, I wrote
a simple driver for DAQ1200 card(PCMCIA based). In testing my program, I can
read the the data, it works just fine, however, if I let my program keep
running for a hour or longer, the data read getting incorrect and finally,
kernel oops error occured, system crashed. 
   It seems like the driver has bug, but what confuse me is that why it work
just fine initially and as the time flies by, it goes wrong? what can cause
this problem? 
   My application is just a loop to constantly read the data from file
descriptor obtained by openning my device ( I implement it as a char
device!).
   Can anybody give me a hint!

regards
Lei Sun

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: "Sun, Lei" <[email-masked]>
Date: Fri, 1 Sep 2000 14:56:11 -0400

Hi:
  Forget the question I posted a while ago,I figured it out!
Sorry for the trouble!
THank you!
lei

-----Original Message-----
From: Sun, Lei [mailto:[email-masked]]
Sent: Friday, September 01, 2000 2:12 PM
To: [email-masked]'
Subject: kernel oops.. error

Hi all:

regards
Lei Sun

unsubscribe: body of `unsubscribe linux-arm-kernel' to
[email-masked]