Subject: Re: What does "external abort on non-linefetch" mean?

From: "Chien-Min Lee" <[email-masked]>
Date: Wed, 23 Aug 2000 23:41:40 +0800 (CST)

Hi:
> What's procedure do you do ??
> could give a brief??

 I am not sure exactly which code causing this error.
 I use DMA to transfer data from peripheral device of sa1110 to certain memory space.
 Due to the fifo part of that peripheral device, I have to drain data in fifo out to following address.
 That error occurred when I try to move data from fifo to memory.

kirk

> > [root@Linux /root]$Internal error: external abort on non-linefetch: 28
> > CPU: 0
> > pc : [<c00187a8>]    lr : [<c0019b1c>]
> > sp : c012ff68  ip : 00000000  fp : c012ffc0
> > r10: c001307c  r9 : ffffffff  r8 : 80000013
> > r7 : c00203ac  r6 : c0019b1c  r5 : c012ffb0  r4 : fa050000
> > r3 : c01431c4  r2 : 00000000  r1 : 00000000  r0 : 00000003
> > Flags: Nzcv  IRQs off  FIQs on  Mode SVC_32  Segment kernel
> > Control: C165917F  Table: C165917F  DAC: 0000001D
> > Process swapper (pid: 0, stackpage=c012f000)
> > Stack:
> > [skip .....]

----== Mailed via Openfind ==-----
http://mail2000.com.tw/ ���ѧK�O�q�l�l��H�c

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: Nicolas Pitre <[email-masked]>
Date: Wed, 23 Aug 2000 12:27:33 -0400 (EDT)

>  That error occurred when I try to move data from fifo to memory.

This means that you passed an invalid address to the DMA controller.

Nicolas

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Wed, 23 Aug 2000 19:21:05 +0100 (BST)

> This means that you passed an invalid address to the DMA controller.

Surely not.  If this is true, the SA1110 does not follow the ARM ARM.  Data
aborts are not supposed to be spuriously raised.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |            http://www.arm.linux.org.uk/            /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |