Subject: Re: (questions about angelboot)

From: [email-masked]
Date: Thu, 31 Aug 2000 11:42:06 +0800

Hi:

	Now I am working on porting linux to SA1110 Assabet. I had done following:
(1) download kernel and patch files to generate linux-2.4.0-test6-rmk5-np2(advised from Erik, thanks)
(2) using the binary toolchain "arm-linux-cross.tar.bz2" from "http://www.lart.tudelft.nl/lartware/compile-tools/" to compile kernel.
(3) follow make config_assabet, make coldconfig, make dep, ... to gererate zImage.
(4) download angelboot and minicom and jflash from "http://www.cs.cmu.edu/~wearable/software/assabet.html"
(5) use jflas to download angel.bin boundle with jflash.
(6) setup minicom with "9600bps, 8 data bits, no parity, 1 stop bit, and no flow control", and reset Assabet. I can see some message like:
	"...(some characters strange) | Angel Debug Monitor for DB1110 : Serial/FIQ : MMU on, ...(I can't see because character wrapping problem in my minicom)
(6) i try to use angelboot to download zImage. but how can i use? i try many ways but the message never show on the minicom, also the image size is zero. another question is how to set the r0 r1 register? Need i modify the kernel source code?

Thanks a lot! 

Peter Chen.

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: John G Dorsey <[email-masked]>
Date: Thu, 31 Aug 2000 11:39:18 -0400 (EDT)

On Thu, 31 Aug 2000 [email-masked] wrote:
> 	Now I am working on porting linux to SA1110 Assabet.

Today is your lucky day! We've already ported it for you. =)

> (6) setup minicom with "9600bps, 8 data bits, no parity, 1 stop bit, and
> no flow control", and reset Assabet. I can see some message like: 
> "...(some characters strange) | Angel Debug Monitor for DB1110 :
> Serial/FIQ : MMU on, ...(I can't see because character wrapping problem
> in my minicom) 

After you reset your board, run angelboot first. The config file that
appears on the Assabet page ("Software Setup" part 3, "Loading the
Kernel") includes a line ("exec minicom") to start your terminal package
after the kernel and ramdisk transfers complete. 

> (6) i try to use angelboot to download zImage. but how can i use? i try
> many ways but the message never show on the minicom, also the image size
> is zero. another question is how to set the r0 r1 register? Need i
> modify the kernel source code? 

Again, the .angelrc on the Assabet page includes lines that begin "r0" and
"r1" that cause Angel to load whatever values you specify into the named
registers. No kernel tweaking needed.

You mention that "the image size is zero." Do you mean the zImage file on
your development workstation, after building (`make zImage`)?

-jd