Subject: What does "external abort on non-linefetch" mean?

From: "Chien-Min Lee" <[email-masked]>
Date: Wed, 23 Aug 2000 17:31:55 +0800 (CST)

Dear All:

 I got the following error when testing a driver on arm-linux.

[root@Linux /root]$Internal error: external abort on non-linefetch: 28
CPU: 0
pc : [<c00187a8>]    lr : [<c0019b1c>]
sp : c012ff68  ip : 00000000  fp : c012ffc0
r10: c001307c  r9 : ffffffff  r8 : 80000013
r7 : c00203ac  r6 : c0019b1c  r5 : c012ffb0  r4 : fa050000
r3 : c01431c4  r2 : 00000000  r1 : 00000000  r0 : 00000003
Flags: Nzcv  IRQs off  FIQs on  Mode SVC_32  Segment kernel
Control: C165917F  Table: C165917F  DAC: 0000001D
Process swapper (pid: 0, stackpage=c012f000)
Stack:
[skip .....]

  However, I do not understand this error message.
  Could someone tell me what it talks about??

  Thanks

  kirk

----== Mailed via Openfind ==-----
http://mail2000.com.tw/ ���ѧK�O�q�l�l��H�c

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: <[email-masked]>
Date: Wed, 23 Aug 2000 22:51:53 +0800 (CST)

What's procedure do you do ??
could give a brief??

				Chester

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Wed, 23 Aug 2000 19:18:46 +0100 (BST)

Chien-Min Lee writes:
> Internal error: external abort on non-linefetch: 28

You can find all the gory details in the ARM architecture reference manual
(see the section on data aborts at the back).

Its probably not a kernel problem, but a hardware problem.

   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |            http://www.arm.linux.org.uk/            /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |

---

From: "Thomas Ritter" <[email-masked]>
Date: Thu, 24 Aug 2000 23:44:49 +0200

Hi,

I got this message when trying to access a reserved memory region.
e.g. addr >= 0x50000000 ... ;-)

See ARM architecture reference manual.

tom

> -----Ursprüngliche Nachricht-----
> Von: [email-masked]
> [mailto:[email-masked]]Im Auftrag von
> Chien-Min Lee
> Gesendet am: Mittwoch, 23. August 2000 11:32
> An: linux-arm-kernel
> Betreff: What does "external abort on non-linefetch" mean?
>
> Dear All:
>
> http://mail2000.com.tw/ ´£¨Ñ§K¶O¹q¤l¶l¥ó«H½c
>
>