Subject: FLUSH_BASE and FLUSH_BASE_PHYS

From: Mike Touloumtzis <[email-masked]>
Date: Mon, 28 Aug 2000 16:33:11 -0700

Hi,

Could anyone tell me the purpose of the mapping which uses
FLUSH_BASE and FLUSH_BASE_PHYS?  I'd very much appreciate
it.

thanks,
miket

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: Nicolas Pitre <[email-masked]>
Date: Mon, 28 Aug 2000 22:00:41 -0400 (EDT)

> FLUSH_BASE and FLUSH_BASE_PHYS?  I'd very much appreciate

See linux/arch/arm/mm/proc-*.S.

It is used to fill the cache with junk so actual dirty data is evicted
from the cache.  Yes, that's the only way to write back the whole cache on
the StrongARM.

Nicolas