Subject: SA1100 kernel booting problems

From: James Alford <[email-masked]>
Date: Wed, 12 Jul 2000 13:56:08 +0100 (BST)

Hi,

I am having a bit of a hard time getting linux up and running on my StrongARM SA-1100 multimedia devl board with
companion SA-1101 (Brutus I assume).

I am using the precompiled cross comp from LART and get the following
problems on differnt kernels.

Anybody got any ideas? Any help most welcome.

James

I am using angelboot-1.10.nk with the ramdisk provided in brutus_test.

opts file looks like

base 0xc0008000
entry 0xc0008000
r0 0x00000000
r1 0x00000010
device /dev/ttyS0
options "9600 8N1" 
baud 115200
otherfile ramdisk.gz
otherbase 0xd8000000

Method for producing kernels is

gunzip kernel
patch with rk -p1
patch with np -p1

correct the simlinks in /data/lart/cross/arm-linux/include to point at
asm -> /home/arm/armbuild/linux-2.XX/linux/include/asm-arm 
linux -> /home/arm/armbuild/linux-2.XXlinux/include/linux
were XX is somthing like 2.2.14-rmk5-np17 etc

make brutus_config
make menuconfig exit and save
make dep
make zImage

I have also build myself a cross compiler and the kernels I get to compile
give the same problem as the Brutus test ie Unable to mount root fs on
01:00

***************
Brutus test zImage and ramdisk with angelboot-1.10.nk
**************
Uncompressing Linux......................... done, booting the kernel.
Linux version 2.2.13-rmk2-np14 ([email-masked]) (gcc version
egcs-2.91.60 190
NetWinder Floating Point Emulator V0.94.1 (c) 1998 Corel Computer Corp.
Console: colour dummy device 80x30
Calibrating delay loop... 138.44 BogoMIPS
Memory: 12272k/16M available (640k code, 20k reserved, 364k data, 16k
init)
POSIX conformance testing by UNIFIX
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
Starting kswapd v 1.5 
Console: switching to colour frame buffer device 40x30
Keyboard driver v1.01
**** Turning off console printing ****
SA1100 serial driver version 4.27 with no serial options enabled
ttyS00 at 0xf8010000 (irq = 15) is a SA1100 UART
ttyS01 at 0xf8050000 (irq = 17) is a SA1100 UART
pty: 256 Unix98 ptys configured
MCP SA1100/UCB1200 module initalized
SA1100 MCP audio driver version 2.2 initialized
RAM disk driver initialized:  16 RAM disks of 8192K size
RAMDISK: Couldn't find valid RAM disk image starting at 0.
Kernel panic: VFS: Unable to mount root fs on 01:00

****************
2.2.14-rmk5-np17
****************
Uncompressing Linux......................... done, booting the kernel.
Linux version 2.2.14-rmk5-np17 ([email-masked]) (gcc version
2.95.2 190
Processor: Intel StrongARM-1100 revision 9
NetWinder Floating Point Emulator V0.94.1 (c) 1998 Corel Computer Corp.
Console: colour dummy device 80x30
Calibrating delay loop... 138.44 BogoMIPS
Memory: 12304k/16M available (632k code, 20k reserved, 340k data, 16k
init)
Dentry hash table entries: 2048 (order 2, 16k)
Buffer cache hash table entries: 16384 (order 4, 64k)
Page cache hash table entries: 4096 (order 2, 16k)
POSIX conformance testing by UNIFIX
Unable to handle kernel paging request at virtual address 0a000016
memmap = C0004000, pgd = c0004000
*pgd = 00000000, *pmd = 00000000
Internal error: Oops: 2
CPU: 0
pc : [<c001a280>]    lr : [<c001a124>]
sp : c00abf1c  ip : 00000000  fp : c00abf68
r10: 00000f00  r9 : 4401a119  r8 : c00abfbc
r7 : c00aa000  r6 : 00000078  r5 : c0ff6000  r4 : c00abf34
r3 : 0a000012  r2 : e3833080  r1 : c00ae0ec  r0 : 00000000
Flags: nzCv  IRQs on  FIQs on  Mode SVC_32  Segment kernel
Control: C000517D  Table: C000517D  DAC: 0000001F
Process swapper (pid: 0, stackpage=c00ab000)
Stack: 
c00abf00:                            c001a124  c001a280 20000013 ffffffff
c000da 
c00abf20: 00000000 fffffff5 00000001 c00abf80  00ff4480 00000000 00000000
000000 
c00abf40: c000ca98 c000d128 00000078 c00aa000  c00abfbc 4401a119 c0008560
c00abf 
c00abf60: c00abf6c c0011bf0 c001a0a0 00000000  c00abf7c c000cfa0 c0011be4
c000ca 
c00abf80: 00000f00 00000000 00000f00 60000013  c000ca98 c00cc7fc c00ac75c
c00ac7 
c00abfa0: c00ac984 4401a119 c0008560 c00abfd8  00000000 00ff4480 00000000
c000e5 
c00abfc0: 60000013 00000f00 00000000 c00abffc  c00abfdc c000c7d8 c000e55c
c00ac9 
c00abfe0: c00d1618 c00d1618 c00c5344 c00c53f0  00000000 c00ac000 c0008080
c000c6 
Backtrace: 
Function entered at [<c001a094>] from [<c0011bf0>]
 r10 = C0008560  r9 = 4401A119  r8 = C00ABFBC  r7 = C00AA000
 r6 = 00000078  r5 = C000D128  r4 = C000CA98 
Function entered at [<c0011bd8>] from [<c000cfa0>]
Code: e3530000 0a000012 (e5930004) e3500000 0a00000f 
Kernel panic: Attempted to kill the idle task!
In swapper task - not syncing

*********************
linux-2.2.14-rmk5-np17
*********************
Uncompressing Linux......................... done, booting the kernel.
Linux version 2.2.14-rmk5-np17 ([email-masked]) (gcc version
2.95.2 190
Processor: Intel StrongARM-1100 revision 9
NetWinder Floating Point Emulator V0.94.1 (c) 1998 Corel Computer Corp.
Console: colour dummy device 80x30
Calibrating delay loop... 138.44 BogoMIPS
Memory: 12304k/16M available (632k code, 20k reserved, 340k data, 16k
init)
Dentry hash table entries: 2048 (order 2, 16k)
Buffer cache hash table entries: 16384 (order 4, 64k)
Page cache hash table entries: 4096 (order 2, 16k)
POSIX conformance testing by UNIFIX

It just stops there...

*********************
linux-2.3.35-rmk1-np9
*********************
Uncompressing Linux............................ done, booting the kernel.

Does not go any further...

*****************************
linux-2.4.0-test2-ac1-rmk2-np1
******************************
arm-linux-ld -p -X -T arch/arm/vmlinux.lds arch/arm/kernel/head-armv.o
arch/arm/kernel/init_task.o init/main.o init/version.o \
        --start-group \
        arch/arm/kernel/kernel.o arch/arm/mm/mm.o kernel/kernel.o mm/mm.o
fs/fs.o ipc/ipc.o \
        drivers/block/block.o drivers/char/char.o drivers/misc/misc.o
drivers/net/net.o drivers/parport/parport.a  drivers/video/video.o
arch/arm/special/special.a \
        net/network.o \
        arch/arm/nwfpe/math-emu.o arch/arm/lib/lib.o arch/arm/lib/lib.a
/home/arm/armbuild/linux-2.4.0-test2-ac1-rmk2-np1/linux/lib/lib.a
/data/lart/cross/lib/gcc-lib/arm-linux/2.95.2/soft-float/libgcc.a \
        --end-group \
        -o vmlinux
drivers/char/char.o: In function `handle_scancode':
/home/arm/armbuild/linux-2.4.0-test2-ac1-rmk2-np1/linux/drivers/char/keyboard.c:258:
undefined reference to `Brutus_kbd_translate'

Have this or very similar compile error when make zImage with 
test2-ac1-rmk2-np[1,2,3]

------------

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: Nicolas Pitre <[email-masked]>
Date: Wed, 12 Jul 2000 10:37:09 -0400 (EDT)

> companion SA-1101 (Brutus I assume).

Strictly, Brutus is another board than what you have.  Brutus is the
"SA1100 evaluation board". I don't know what
are the similarities between them.  AFAIK nobody made the
necessary to properly run Linux on the "SA1100 multimedia board" yet.

Nicolas