Subject: Kernel 2.3.35 compiled, but init crashes ... HELP

From: Angelo <[email-masked]>
Date: Sat, 29 Jul 2000 23:58:59 +0100 (BST)

Hi,

I finally compiled a kernel (2.3.35) with binutils-2.9.5.14 and GCC 2.95.2.
This gave a kernel which boots, but after the boot it crashes when trying to
start 'init', or 'init' crashes ... (I am not sure, but I suspect init to
crash).

I recompiled a new version of sysvinit (version 2.78), with 2.7.2.2 (aout)
format as a test and this 'init' process hangs the computer (after showing
'version 2.78 booting). But it works with the 2.0.36 kernel ...

I recompiled it with gcc 2.95.2 and this crashes the init process again ...
The error message is :
(this is typed in by hand ... there is no new dmesg file)

Freeing unused kernel memory: 20k init
pgd = c047c000
*pgd=00000000, *pmd=00000000
Internal error: Oops: 2
CPU:0
pc:[<c0019834>]	lr:[<c000f9ec>]
sp:c0443f98	ip:00000000	fp:00000000
r10:4001dd20	r9:4001ef28	r8:02000b55
r7:40000000	r6:4a2f500a	r5:00030000	r4:e8a31002
r3:c0443fd4	r2:00001d14	r1:00200000	r0:3ffffffe
Flags: nzcv	ICQs off	FIQs on	Mode SVC_32	Segment user
Control: EE133510	Table: EB003863		DAC: EA00000B
process init (pid:1, stackpage=c0443000)
stack:
<lots of values ... are they important ?>
Backtrace: no frame pointer
Code: 70253d70 0000000a (e59040000) e1a029a4 e2022002

The kernel is version 2.3.35 with patch rmk-1 applied. The config values are
as default, with exeption that there is no StrongARM support compiled in.

The machine it (should) run on is a RISC PC 700, 64 + 2 Mb, 2 Harddiscs
(Linux on hdb), RISCOS 4 (hdb = old disk format, hda not accessed (new
format)), CDROM and Simtec IDE card (which is seen by the kernel).

I hope someone knows what I did wrong ... and can help me ...

(Btw ... When the old init process is used the error is with something
error 7, if someone is interesting in knowing what the error message is,
please email me ... and I will write it down and email it here).

Thanks in advance,
Angelo

-- 
Angelo Melis @ home
random quote, generated by my computer:
Ambition is the last refuge of the failure. - Oscar Wilde

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Sun, 30 Jul 2000 16:45:17 +0100 (BST)

> pc:[<c0019834>]	lr:[<c000f9ec>]

It'd help if you could look these values up in the System.map file
(The symbols around these addresses would be useful).

Thanks.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |            http://www.arm.linux.org.uk/            /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |