Subject: RE: Root NFS and SA-11x0 not cooperating?

From: Jeff Sutherland <[email-masked]>
Date: Mon, 17 Jul 2000 16:01:28 -0400

> > > Hmm. What if I were to move it out of the way...
> > Of course /sbin/init has been compiled for the ARM processor, no? ;)
> 
> Yes, actually, it has, and no, moving it did nothing. (Tried to exec
> /bin/sh, which didn't work, either.) :)
> 
> Our boards boot off of ramdisks right now, so all I did was 
> copy a good
> ramdisk to a directory and use that as a NFS mount. I've 
> stuck a pile of
> debugging messages into functions to see what's going on, but 
> I'm guessing
> that's not really going to help.
> 
> What version of the kernel are you running, by the way? I'm 
> still using
> 2.3.99pre8-I-forget-which-patches, but I'm seriously 
> considering giving
> 2.4.0test2-rmk2-np3 a shot.

I'm using 2.4.0-test2-ac1-rmk2-np3.  Take a look in init/main.c near the
end.  The sa1100 patch had disabled nfs root mounting until recently due to
a minor problem in the serial port driver that caused a kernel crash.  This
is now enabled once again in the latest SA1100 patch.

//Jeff

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: I-Gene Leong <[email-masked]>
Date: Mon, 17 Jul 2000 13:02:13 -0700 (PDT)

> is now enabled once again in the latest SA1100 patch.

Hmm, sounds about right... since I am using a console on the serial
port. I didn't see anything about disabled NFS root in there,
though... but I am going to give 2.4.0-test2 a shot now.

-- 
I-Gene Leong
[email-masked] / 604-646-6962
"We see Linux as being much of a fad as the Internet was in 1995."
  - Irving Wladawsky-Berger, IBM VP of technology and strategy