Subject: EBSA-285 jumpers

From: Christopher Lord <[email-masked]>
Date: Thu, 6 Jul 2000 12:37:35 -0700 (PDT)

Hi all,

I'd like to confirm jumper settings with those of you
using the EBSA-285 in host mode using the PCI arbiter
on the backplane.

J9 and J10 Central function per Figure A-2
J14 as X-bus (all pins connected on lower 2 rows)
J16 pins 2-3 for flash

and finally J15 pins:
2 and 3 for X-bus
4 and 6 for 'normal' flash ROM
8 and 9 for 32 bit ROM
10 and 12 [Reserved test mode set ?]
13 and 15 [Reserved test mode set ?]
no connection for 16,17,18
no connection for 20,21,22 per earlier messages
23 and 24 IDSEL connectd to PCI fingers.

I'm of course suspicious of these settings and have
problems with RMK's bios and a 21041 based net card
that fails to get a constant link status. (I've
already tested the cards/cables and hub)  I hope I
have config'ed the HW incorrectly and someone would
take a peek at their jumpers and note any changes.

Thanks in advance

Chris Duggan

__________________________________________________
Do You Yahoo!?
Send instant messages & get email alerts with Yahoo! Messenger.
http://im.yahoo.com/

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Thu, 6 Jul 2000 20:44:59 +0100 (BST)

Christopher Lord writes:
> that fails to get a constant link status.

It may be that the MII transceiver is incorrectly programmed, and is
not sensing the hub speed correctly.  It's extremely unlikely to be
anything to do with the PCI bus/arbiter settings.

Unfortunately, getting the right settings for the media for tulips is
a black art which the BIOS doesn't have.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |            http://www.arm.linux.org.uk/            /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |