Subject: configure failed!

From: "Sun, Lei" <[email-masked]>
Date: Wed, 5 Jul 2000 18:29:32 -0400

Hi:
   I am still being tortured by porting linux into SA1110 Assebet.  This
time I downloaded the newer kernel and go through the procedure starting
from building the tool chain, however I had a problem when I was trying to
build glibc, (version is glibc2.1), 
   when I issued the command :
CC=arm-linux-gcc ./configure arm-linux --build=i686-pc-linux-gnu
--prefix=/home/new_arm/arm/glibc --enable-add-ons

it give me following message:
checking for a BSD compatible install... /usr/bin/install -c
checking whether ln -s works... yes
checking build system type... i686-pc-linux-gnu
checking for arm-linux-gcc... arm-linux-gcc
checking version of arm-linux-gcc... 2.95.2, bad
checking for make... make
checking version of make... 3.78.1, ok
checking for msgfmt... msgfmt
checking version of msgfmt... 0.10.35, ok
checking for makeinfo... makeinfo
checking version of makeinfo... 4.0, bad
configure: error:
*** Some critical program is missing or too old.
*** Check the INSTALL file for required versions. 

     I used binutils2.9.5.0.42   and  gcc 2.95.2.
are they too old? if So, any body can direct me to the right place and tell
me the detail patch and file I shoud download?
    Thank you!

Regards
lei sun

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: Erik Mouw <[email-masked]>
Date: Thu 06 Jul 2000 20:30:34 +0100 (MDT)

> me the detail patch and file I shoud download?

Please read what the configure script says: makeinfo is too old.

Erik

-- 
There was a point to this story, but it has temporarily escaped the
croniclers mind. -- Douglas Adams, The Hitch Hikers Guide to the Galaxy

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Thu, 6 Jul 2000 20:48:01 +0100 (BST)

> Please read what the configure script says: makeinfo is too old.

Apparantly, arm-linux-gcc is also too old!

I guess that the configure scripts need to be regenerated.  I'm not an
expert on autoconf, but I believe if you run autoconf in that directory,
the configure script will be regenerated.

If that doesn't work, my next try would be to update autoconf.  If it
still fails, then I guess its an autoconf problem.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |            http://www.arm.linux.org.uk/            /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |