Subject: Re: Flushing I/D caches from userspace

From: Adam 'WeirdArms' Wiggins <[email-masked]>
Date: Fri, 9 Jun 2000 15:53:02 +1000 (EST)

On Thu, 8 Jun 2000, J.D. Bakker wrote:

> Hi all,
> 
> Is there any way to do cache flushes from userspace under ARMLinux ? I'm
> developing a fixed point FFT library, and I want to do timings with both
> hot and cold cache. The only way I can think of is to walk an array the
> size of the D cache, and write a dummy function that fills the I cache, but
> that seems a tad hackish.

	Allowing user space to flush the caches is can lead to real
problems. Maybe with a /dev/ to allow priviledged users but in general you
don't want any old user to do it. 
 > 
> Any thoughts ?
> 
> JDB.
> [and yes, the library will be [L]GPL'd once it works properly]
> 
> --
> LART. 250 MIPS under one Watt. Free hardware design files.
> http://www.lart.tudelft.nl/
> 
> 
> --
> To unsubscribe from this list: send the line "unsubscribe lart" in
> the body of a message to [email-masked]
> Please read the LART FAQ at http://www.lart.tudelft.nl/faq.php3
> 

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: "J.D. Bakker" <[email-masked]>
Date: Fri, 9 Jun 2000 11:38:15 +0200

At 07:53 +0200 09-06-2000, Adam 'WeirdArms' Wiggins wrote:
>problems.

Such as ? Considering that a context switch to a process with a different
VM context causes a cache flush anyway, I can't imagine what harm it would
do.

JDB.

--
Jan-Derk Bakker, [email-masked]

The lazy man's proverb:
    'There's no business like slow business !'