Subject: ramdisk file system - memory leak ??

From: "Naik, Uday" <[email-masked]>
Date: Wed, 7 Jun 2000 16:55:41 -0700

Hi,

On my IXP1200 system (little endian), I am using 
a ram disk that I got from netwinder.org. When the
system starts up it has approx 33% disk space. Every
time I run a utility, some ram disk space is gone and is
never freed. I am doing ftps to this disk and everytime
I put a file in, space is used up. But deleting the file
does not free up space. Eventually I get a disk full error.

Before I dig into this problem, anybody has any clues for
me.

regards

Uday

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Sun, 11 Jun 2000 09:10:35 +0100 (BST)

> does not free up space. Eventually I get a disk full error.

Some questions:

1. Are you quitting the ftp client between the download and the df?
2. Is something else using the file?
3. What kernel version are you using?
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |            http://www.arm.linux.org.uk/            /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |