Subject: Re: Floating Point Emulation

From: "Dan" <[email-masked]>
Date: Wed, 7 Jun 2000 11:05:37 -0600

On Wed, 7 Jun 2000, Nicolas wrote:

> If you can arrange for not using floating point operations in your 
code
> i.e. using fixed point math techniques instead, then you may just 
ignore
> the whole issue.  Do you really need floating point for your 
testing app
> anyway?

Hi Nicolas:

You are probably right. It is probably easier to remove the
floating point calculations then it is to get the FPEmulation
working. It should also make the application smaller.
Perhaps this particular issue is best left for another day
when floating point cannot be readily bypassed.

--------------------------------
Bye!
Dan McDonald
The Late Night Software Shop 
Sign up today for your Free E-mail at: http://www.canoe.ca/CanoeMail 

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: "Dan" <[email-masked]>
Date: Wed, 7 Jun 2000 11:32:13 -0600

Mark Hatle wrote:
> What timing.. :)
[snip]
>
> I am currently working on patching gcc (2.95.2) to do soft-float 
the way
> other platforms do it.  (If you look in the gcc source in 
gcc/config/arm
> you'll see a but of "t-*" files.  all of the files EXCEPT the linux 
one
> use the built-in soft-floating point.  So it should be possible.)  
FYI,
> I have yet to run the tests on the floating point, so what I have 
now
> may not work the way I think it does!
>
> If you would like a copy of my patches email me off the list and 
I'll go
> into exactly what I'm doing.
>
[snip]

Hi Mark:

Thanks for your response. I don't know if I am brave enough
to do battle with gcc and the Linux libraries. I am a wimp
in such matters - I tend not to fight the native development
environments unless absolutely necessary.

I find if I manipulate the environments too much it turns
into a support headache making it difficult to pick up
new releases, etc. It's the "when in Rome, do as the
Romans do" philosophy. :-)

I always wondered where those darn flags were.
Thanks. Good luck.

---

From: "Dan" <[email-masked]>
Date: Mon, 12 Jun 2000 10:34:07 -0600

Hello folks:

I guess I started this little confusion. When I was trying
to build a stand-alone application that used floating point
calculations. My problem was that my stand-alone application
did not import the floating point emulation using the undefined
instruction vector.

I tried re-compiling with -msoft-float and linking in libfloat;
however, libgcc.a had been compiled without -msoft-float.
The GCC manual says EVERYTHING should be compiled one way or
the other. I was reluctant to start re-compiling libraries, etc.
After all I am a newbie at this  GCC and Linux stuff.

I changed the application to use some fixed-point tricks and
my problem mostly went away.

As one recommended fix Mark Hatle recommended using the floating
point that is now built into GCC. That is, you should no longer
have to use floating point emulation or libfloat. He is working
on some patches that will allow the kernel to be compiled
without the NetWinder Emulation and without libfloat. Apparently
this is the way other targets compile Linux.

I went to the GCC site and was looking through their FAQ.
http://www.objsw.com/CrossGCC/FAQ-6.html
This site does say that libgcc supports floating point for
most embedded targets. The FAQ is a little vague though.

I am sure that Mark can shed more light on this than I can.

It may be an opportunity to eliminate the floating point
emulator from the ARM kernel if the compiler can take care
of it.

---

From: George France <[email-masked]>
Date: Mon, 12 Jun 2000 14:40:02 -0400

Hello Dan;

I think you are assuming that people only wish to use gcc. If you are using
a different compiler, you still need the floating point emulations in the
kernel.

--George

George France,      [email-masked]
Cambridge Research Laboratory, Compaq Computer Corporation
One Cambridgecenter    MS: CRL
Cambridge, MA 02142 USA

-----Original Message-----
From: Dan [mailto:[email-masked]]
Sent: Monday, June 12, 2000 12:34 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: Floating Point Emulation

Hello folks:

unsubscribe: body of `unsubscribe linux-arm-kernel' to
[email-masked]