Subject: [question] porting problem with sa1110 "ASSABET"

From: ÀÌ¿µ±â <[email-masked]>
Date: Wed, 17 May 2000 20:25:50 +0900

hello 

nowaday I Porting linux kernel to sa-1110 "assabet" dev board

My platform is i386 linux v6.0

                    binutil-2.9.5.0.27
                    egcs-1.1.2
                    glibc-2.1.3
                    linux-2.3.99-pre8
                    addtional linux patch is diiff-2.3.99-pre8-rmk1-np2.gz

downloading use angelboot
But at next point assabet is malfuction

I don't understand and don't find incorrect point
help me !!!!
file-->( linux\arch\arm\kernel\head-armv.S)
line number --> 109

__switch_data: .long __mmap_switched
  .long SYMBOL_NAME(__bss_start)
  .long SYMBOL_NAME(_end)
  .long SYMBOL_NAME(processor_id)
  .long SYMBOL_NAME(__machine_arch_type)
  .long SYMBOL_NAME(cr_alignment)
  .long SYMBOL_NAME(init_task_union)+8192

__ret:  ldr lr, __switch_data
  mcr p15, 0, r0, c1, c0                    <-- Error point
  mov r0, r0
  mov r0, r0
  mov r0, r0
  mov pc, lr

I don't subscribe mailing list I don't understand this 
please mail me to mailto:[email-masked]
.žË›±Êâmæèw*º{.nÇ+‰·¥Š{±j¹¤z¹Þ–Ú&j:+v‰¨–+-±ªæ–)îÆŠàº

---

From: Nicolas Pitre <[email-masked]>
Date: Wed, 17 May 2000 09:56:03 -0400 (EDT)

> But at next point assabet is malfuction

Did you follow exactly the instructions from
linux/Documentation/arm/SA1100/Assabet?

Nicolas

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]