Subject: Re: Kernel Compile error

From: chakrapani krishnamoorthy <[email-masked]>
Date: Thu, 11 May 2000 23:09:01 -0700 (PDT)

--- Nicolas Pitre <[email-masked]> wrote:
> 
> 
> On Wed, 10 May 2000, chakrapani krishnamoorthy
> wrote:
> 
> > Hi,
> > 
> >        When I tried to compile the Kernel for
> ARM
> > Platform I got the following Error
> > 
> > make: arm-linux-egcs:Command not found
> > make:*** [init/main.o] Error 127
> > 
> > Can any anybody please suggest me what's
> wrong 
> 
> Edit your Makefile and replace "egcs" by "gcc".
> 

Thanks a lot for your suggestion. I changed
"egcs" to "gcc" it was ok.I did not get the above
error. But now I get the following  error.

/linux/arch/arm/nwfpe/softfloat-macros:153:
undefined reference to '__ashldi3'

.       
.
.                              -macros:294:
.
.
.
.
.
.
.

make: *** [vmlinux] Error 1

I donot really understand what it is any
suggestions please.

__________________________________________________
Do You Yahoo!?
Send instant messages & get email alerts with Yahoo! Messenger.
http://im.yahoo.com/

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Fri, 12 May 2000 09:22:01 +0100 (BST)

> I donot really understand what it is any

You should have a libgcc.a file which contains these, which should have
been built during gcc's build.

If you type 'arm-linux-gcc --print-libgcc-file-name', it should tell you
where it expects this file to be.  If its not there, then gcc didn't build
or install properly.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |            http://www.arm.linux.org.uk/            /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |