Subject: Re: Question aboug cyber2000fb.c

From: "Chien-Min Lee" <[email-masked]>
Date: Sat, 06 May 2000 10:25:01 +0800 (CST)

>>  Does this mean that this driver does not support 2010
>>yet!??

>No.  It just means that that resolution is not supported
>because we don't
>know what PLL parameters to give the Cyber2010.

 Ok, Isee.

>They are a list of the possible resolutions and scan rates
>that are
>supported.  Basically, anything with a "*" means it works on
>the 2000,
and if the pixel clock lands on one of the clock periods for
a 2010, then
>it is also supported.  If it's not there, then that
resolution isn't going
>to work.

 Thanks. Then,
 how does these values come from or be resolved!?

>Having said that, I now have a new cyber2000fb.c which
>calculates the PLL
>values.
 Really!! Would you free release it??
 Or would you give me a hint to write it?
 BTW,
 There is a piece of codes before if-else statement
 that count the PLL values.
 However, the equation it ues seems not matched with
 the one mentioned in cyberpro2010 datasheet.

 Have a nice day!

 kirk

--
----== Mailed via Openfind ==-----
http://mail2000.com.tw/ ���ѧK�O�� e-mail �H�c�A��

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Sat, 6 May 2000 10:25:56 +0100 (BST)

>  Really!! Would you free release it??

Of course, it will be in the next patch with all the other stuff.

>  the one mentioned in cyberpro2010 datasheet.

That was an incomplete "guess" at what was required.  I now have a working
algorithm which seems to work for the various resolutions I've tested on
the CyberPro2000.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |            http://www.arm.linux.org.uk/            /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |