Subject: Re: Kernel Compile error

From: chakrapani krishnamoorthy <[email-masked]>
Date: Sun, 14 May 2000 02:19:48 -0700 (PDT)

--- Russell King - ARM Linux Admin
<[email-masked]> wrote:
> chakrapani krishnamoorthy writes:
> > Thanks a lot for your suggestion. I changed
> > "egcs" to "gcc" it was ok.I did not get the
> above
> > error. But now I get the following  error.
> > 
> > /linux/arch/arm/nwfpe/softfloat-macros:153:
> > undefined reference to '__ashldi3'
> > I donot really understand what it is any
> > suggestions please.
> 
> You should have a libgcc.a file which contains
> these, which should have
> been built during gcc's build.
> 
> If you type 'arm-linux-gcc
> --print-libgcc-file-name', it should tell you
> where it expects this file to be.  If its not
> there, then gcc didn't build
> or install properly.

I found the libgcc.a installed properly.I tired
repeating the process several times I get the
same error, could there be any other
reason.Anybody please help me out of this.

regards krishna. 

>    _____
>   |_____|
-------------------------------------------------
> ---+---+-
>   |   |        Russell King      
> [email-masked]      --- ---
>   | | | |           
> http://www.arm.linux.org.uk/            /  /  |
>   | +-+-+                                      
>               --- -+-
>   /   |               THE developer of ARM
> Linux              |+| /|\
>  /  | | |                                      
>               ---  |
>     +-+-+
>
-------------------------------------------------
>  /\\\  |

__________________________________________________
Do You Yahoo!?
Send instant messages & get email alerts with Yahoo! Messenger.
http://im.yahoo.com/

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Sun, 14 May 2000 10:29:59 +0100 (BST)

chakrapani krishnamoorthy writes:
> I found the libgcc.a installed properly.I tired repeating the process
> several times I get the same error, could there be any other reason.
> Anybody please help me out of this.

Maybe the symbols for some reason aren't defined in that libgcc.a as they
should be.  Try running a arm-linux-nm on the file and grepping for the
missing symbols.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |            http://www.arm.linux.org.uk/            /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |