Subject: RE: about ARM-assemble code

From: Lavu Sridhar <[email-masked]>
Date: Fri, 19 May 2000 13:05:48 +0530 (IST)

Hello, 

I want to create the boot image and a file system image for the Cirrus
Logic CL7500FE Platform. After that I would get the image in the ELF
format. Can i just download the image into the RAM using the ARM SDT
Debugger and the serial port connection on the Cirrus Logic Board?

Can I disassemble and see the code?

Thanks,
-Lavu Sridhar

On Fri, 19 May 2000, Jungjun Kim wrote:

>Date: Fri, 19 May 2000 11:01:11 +0900
>From: Jungjun Kim <[email-masked]>
>To: [email-masked]
>Subject: RE: about ARM-assemble code
>
>
>If you learn ARM assemble code,  it is helpful for you to read the book "ARM
>Architectual Reference Manual"
>You can find that book in bookstore like Amazon, etc.
>
>But if you just are not familliar with inline assmbler, please do as I did.
>First compile it, next disasemble its object file.
>
>	arm-linux-gcc -c -g test.c
>To disassemble,
>	arm-linux-objdump -S test.o
>
>Or simply,
>	arm-linux-gcc -S -c test.c
>
> 
>
>unsubscribe: body of `unsubscribe linux-arm' to [email-masked]
>++        Please use [email-masked] for           ++
>++                        kernel-related discussions.                      ++

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: Jungjun Kim <[email-masked]>
Date: Fri, 19 May 2000 16:46:29 +0900

Hello,

I think that you can easilly download image to the target board if you have
Muti-ICE or something like it. But in order to download serial port, you need
to have debugging agent running on the target board.
In case of ARM SDT, it uses ANGEL as a debugging agent.
ANGEL is can be found in ARM STD package, and maybe you need to port ANGEL for
your board.

Regards,
-Jungjun Kim

---

From: Lavu Sridhar <[email-masked]>
Date: Sun, 21 May 2000 22:50:06 +0530 (IST)

Hello,
	I have compiled the kernel files and have got the zImage and
vmlinux files. When I tried to load these files through the ARM Debugger,
it seems to time-out. I think the files are too big, or in the wrong
format. What file were you referring to in your previous mail.
	
Thanks,
-Lavu Sridhar

--------------------------------------------------------------------