Subject: Re: Kernel Compile error

From: Murphy Chen <[email-masked]>
Date: Thu, 11 May 2000 15:33:30 +0000 (Local time zone must be set--see zic manual page)

>        When I tried to compile the Kernel for ARM
> Platform I got the following Error
> 
> make: arm-linux-egcs:Command not found

	You need to make a compiler toolchain for ARM first.

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: chakrapani krishnamoorthy <[email-masked]>
Date: Fri, 12 May 2000 03:14:49 -0700 (PDT)

--- Russell King - ARM Linux Admin
<[email-masked]> wrote:
> chakrapani krishnamoorthy writes:
> > Thanks a lot for your suggestion. I changed
> > "egcs" to "gcc" it was ok.I did not get the
> above
> > error. But now I get the following  error.
> > 
> > /linux/arch/arm/nwfpe/softfloat-macros:153:
> > undefined reference to '__ashldi3'
> > I donot really understand what it is any
> > suggestions please.
> 
> You should have a libgcc.a file which contains
> these, which should have
> been built during gcc's build.
> 
> If you type 'arm-linux-gcc
> --print-libgcc-file-name', it should tell you
> where it expects this file to be.  If its not
> there, then gcc didn't build
> or install properly.

I typed the above command and found that libgcc.a
should be installed at
/usr/local/arm/lib/gcc-lib/arm-linux/2.95.2/libgcc.a

Then I found unfortunately it was installed in
that directory so there should be some other
problem.Kindly please help me out with some more
suggestions.

regards krishna.

>    _____
>   |_____|
-------------------------------------------------
> ---+---+-
>   |   |        Russell King      
> [email-masked]      --- ---
>   | | | |           
> http://www.arm.linux.org.uk/            /  /  |
>   | +-+-+                                      
>               --- -+-
>   /   |               THE developer of ARM
> Linux              |+| /|\
>  /  | | |                                      
>               ---  |
>     +-+-+
>
-------------------------------------------------
>  /\\\  |

__________________________________________________
Do You Yahoo!?
Send instant messages & get email alerts with Yahoo! Messenger.
http://im.yahoo.com/

---

From: chakrapani krishnamoorthy <[email-masked]>
Date: Fri, 12 May 2000 09:30:56 -0700 (PDT)

> there, then gcc didn't build

I checked up , libgcc.a file is present,

please advice