Subject: Warning: unable to open an initial console

From: Ken Chiu Kun Wu <[email-masked]>
Date: Mon, 1 May 2000 13:22:02 +1000 (EST)

Hi all,
	I kept getting this Kernel panic,
-----
SA1100 serial driver version 4.27 with no serial options enabled
ttyS00 at 0xf8050000 (irq = 17) is a SA1100 UART
ttyS01 at 0xf8010000 (irq = 15) is a SA1100 UART
pty: 256 Unix98 ptys configured
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
RAMDISK: ext2 filesystem found at block 0
RAMDISK: Loading 8192 blocks [1 disk] into ram disk... done.
Freeing initrd memory: 4096k freed
NetWinder Floating Point Emulator V0.95 (c) 1998-1999 Rebel.com
VFS: Mounted root (ext2 filesystem).
Freeing unused kernel memory: 8k init
Warning: unable to open an initial console.
Kernel panic: No init found.  Try passing init= option to kernel.
----
	The kernel I use is linux-2.3.35-rmk1 and it is patched with
diff-2.3.35-rmk1-np6 and patch-2.3.35-rmk1.  For ramdisk image, I
downloaded the one from LART website "ramdisk-lart-videolink.gz"
Also I am using /dev/ttyS0...
Thanks

Cheers
Ken

-----------------------------------------------
Ken Wu (Electrical/Biomedical Eng. UNSW Sydney)
E-Mail: [email-masked]
	[email-masked]
Homepage: www.progsoc.uts.edu.au/~kckwu
-----------------------------------------------

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: Erik Mouw <[email-masked]>
Date: Mon May 01 11:32:54 +0200 (MDT) 2000

> Warning: unable to open an initial console.

This is just a warning because the console device has device number 4,0
while it should be 5,1. It's not fatal.

> Kernel panic: No init found.  Try passing init= option to kernel.

Are you sure you used the correct configuration for PLEB?

> Also I am using /dev/ttyS0...

Can you try linux-2.3.99-pre3 + patch-2.3.99-pre3-rmk3 +
diff-2.3.99-pre3-rmk2-np2? As LART and PLEB are almost the same, you can
use:

  make lart_config
  make menuconfig, change "SA1100 implementation" to PLEB
  make dep clean zImage modules

This is a known to work configuration on the LART, and it should also work
for PLEB.

Erik

-- 
Yes, it works sometimes. If you need something that "works sometimes"
use Windows! -- Victor Khimenko on linux-kernel

---

From: Erik Mouw <[email-masked]>
Date: Mon May 01 11:42:17 +0200 (MDT) 2000

> diff-2.3.99-pre3-rmk2-np2? As LART and PLEB are almost the same, you can
                   ^^^^
Duh! This should be diff-2.3.99-pre3-rmk3-np2.
                                     ^^^^

Erik

-- 
There was a point to this story, but it has temporarily escaped the
croniclers mind. -- Douglas Adams, The Hitch Hikers Guide to the Galaxy