Subject: Problems with 2.3.99.pre3 on Brutus board

From: Harsha Sanjeewa <[email-masked]>
Date: Thu, 20 Apr 2000 15:34:00 +0600

Hi,
I tried kernel version 2.3.99.pre3 with patches for SA1100 Brutus board.
I was able to cross compile it. But once it loaded it, gave following
error messages and stucked. It seems that the problem is with Ramdisk.
But I used Nico's latest ram disk.

Uncompre.......................... done, Linux version
2.3.99-pre3-rmk2-np2 (roo
t@harsha) (gcc version 2.95.2 19991024 (release)) #2 Thu Apr 20 12:53:00
LKT 200
0
Architecture: Intel Brutus (SA1100 eval board)
On node 0 totalpages: 1024
zone(0): 1024 pages.
zone(1): 0 pages.
zone(2): 0 pages.
On node 1 totalpages: 1024
zone(0): 1024 pages.
zone(1): 0 pages.
zone(2): 0 pages.
On node 2 totalpages: 1024
zone(0): 1024 pages.
zone(1): 0 pages.
zone(2): 0 pages.
On node 3 totalpages: 1024
zone(0): 1024 pages.
zone(1): 0 pages.
zone(2): 0 pages.
Console: colour dummy device 80x30
Calibrating delay loop... 194.15 BogoMIPS
Memory: 4MB 4MB 4MB 4MB = 16MB total
Memory: 11748KB available (720K code, 463K data, 20K init)
Buffer-cache hash table entries: 1024 (order: 0, 4096 bytes)
Page-cache hash table entries: 4096 (order: 2, 16384 bytes)
POSIX conformance testing by UNIFIX
Linux NET4.0 for Linux 2.3
Based upon Swansea University Computer Society NET3.039
Starting kswapd v1.6
Console: switching to colour frame buffer device 40x30
Brutus keyboard driver v1.0
SA1100 serial driver version 1.2
ttyS0 on SA1100 UART1 (irq 15), using GPIO 14/15
ttyS1 on SA1100 UART3 (irq 17)
pty: 256 Unix98 ptys configured
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
RAMDISK: Compressed image found at block 0
NetWinder Floating Point Emulator V0.95 (c) 1998-1999 Rebel.com
VFS: Mounted root (ext2 filesystem).
Freeing unused kernel memory: 20k init

version 2.7kmem_alloc: Bad slab magic (corrupt) (name=inode_cache)
/etc/rc.d/rc.sysinit: /etc/rc.d/init.d/functions: Permission denied
kmem_alloc: Bad slab magic (corrupt) (name=inode_cache)
kmem_alloc: Bad slab magic (corrupt) (name=inode_cache)
kmem_alloc: Bad slab magic (corrupt) (name=inode_cache)
/etc/rc.d/rc.sysinit: hostname: command not found

...more error massages

kmem_alloc: Bad slab magic (corrupt) (name=inode_cache)
/etc/rc.d/rc.sysinit: /var/log/dmesg: Permission denied
Unable to handle kernel NULL pointer dereference at virtual address
00000010
pgd = c0004000
*pgd = c013e001, *pmd = c013e001, *pte = c013d08b, *ppte = c013d00a
Internal error: Oops: 0
CPU: 0
pc : [<c003348c>]    lr : [<c00519fc>]
sp : c0215ee0  ip : c0215f00  fp : c0215efc
r10: c0214354  r9 : c4132300  r8 : 00000001
r7 : a0000013  r6 : c0002be0  r5 : c2016860  r4 : c2016fe0
r3 : c22e4f60  r2 : 00000000  r1 : c2019fc0  r0 : c0002be0
Flags: nZCv  IRQs off  FIQs on  Mode SVC_32  Segment user
Control: C020117D  Table: C020117D  DAC: 00000015
Process initlog (pid: 6, stackpage=c0215000)
Stack:
c0215ec0:                                      c00519fc c003348c
60000093 ffffff
ff
c0215ee0: c2016860 00000000 00000001 c41321e0  c0215f18 c0215f00
c00519fc c00333
84
c0215f00: c40164e0 c2016860 c40164e0 c0215f30  c0215f1c c004f5f4
c0051778 c41333
e0
c0215f20: c2016860 c0215f4c c0215f34 c003b918  c004f4fc c41333e0
00000000 c40164
e0
c0215f40: c0215f60 c0215f50 c003b938 c003b8c0  c41333e0 c0215f80
c0215f64 c003a4
38
c0215f60: c003b928 0000003f c41321e0 00000004  c0214000 c0215f9c
c0215f84 c0022e
ec
c0215f80: c003a390 c0214338 c0214304 00000100  c0215fac c0215fa0
c0023148 c0022c
b4
c0215fa0: 00000000 c0215fb0 c000dea0 c002313c  40104f14 c0015728
00000001 000000
00
c0215fc0: fbad2088 00000008 40104f14 40104f14  00000001 000008e4
02000a00 020047
18
c0215fe0: 40104f28 bffffde0 4009b300 bffffdd4  40043bc8 4009b304
20000010 000000
01
Backtrace:
Function entered at [<c0033378>] from [<c00519fc>]
 r7 = C41321E0  r6 = 00000001  r5 = 00000000  r4 = C2016860
Function entered at [<c005176c>] from [<c004f5f4>]
 r6 = C40164E0  r5 = C2016860  r4 = C40164E0
Function entered at [<c004f4f0>] from [<c003b918>]
 r5 = C2016860  r4 = C41333E0
Function entered at [<c003b8b4>] from [<c003b938>]
 r6 = C40164E0  r5 = 00000000  r4 = C41333E0
Function entered at [<c003b91c>] from [<c003a438>]
 r4 = C41333E0
Function entered at [<c003a384>] from [<c0022eec>]
 r7 = C0214000  r6 = 00000004  r5 = C41321E0  r4 = 0000003F
Function entered at [<c0022ca8>] from [<c0023148>]
Function entered at [<c0023130>] from [<c000dea0>]
Code: e5834014 e5942014 (e5824010) e5864000 eaffffda

Any Help,
Regards,
Harsha

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: Nicolas Pitre <[email-masked]>
Date: Thu, 20 Apr 2000 11:56:13 -0400 (EDT)

> But I used Nico's latest ram disk.

There seem to have some problem with discontigous memory support lately.
Please try my latest 2.3.35 patch if you want Brutus support.

Nicolas