Subject: DEBUG_LL fix

From: David Friedman <[email-masked]>
Date: Fri, 28 Apr 2000 19:25:19 -0400

It looks like in the rewrite of head-armv.S in the 2.3 tree, DEBUG_LL was broken. The problem is that as of 2.3.99-pre5-rmk3, the IO virtual address is loaded from the machine description, but it seems that the code for DEBUG_LL still assumes that this value is the byte offset into the page tables for the IO virtual address.

I fixed this by adding a "mov     r7, r7, lsr #18" before the DEBUG_LL code runs in __create_page_tables.

David Friedman

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Sat, 29 Apr 2000 00:57:44 +0100 (BST)

David Friedman writes:
> It looks like in the rewrite of head-armv.S in the 2.3 tree, DEBUG_LL was broken. The problem
> is that as of 2.3.99-pre5-rmk3, the IO virtual address is loaded from the machine description,
> but it seems that the code for DEBUG_LL still assumes that this value is the byte offset into
> the page tables for the IO virtual address.

Correct.  It seems that the relevent instruction (that you have below) went missing
from __lookup_processor_type.

> I fixed this by adding a "mov     r7, r7, lsr #18" before the DEBUG_LL code runs in
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |            http://www.arm.linux.org.uk/            /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |