Subject: Configuration menus

From: George France <[email-masked]>
Date: Mon, 6 Mar 2000 16:04:32 -0500

In the kernel Configuration menus under:

      System and processor type:

There are two (2) ARM system types:

     EBSA-110
     FootBridge-based

Under both system types there is support for:
     EBSA-285
     CATS
     NetWinder
     Compaq Personal Server

Should there just be one system type for the SA-110, with the FootBridge as
an option underneath instead of its own section??

I would like to change the two(2) ARM systems types to one (1):

    SA-110

and then place the EBSA-110 and the FootBridge-based systems types under the
SA-110 system type.

Is there any reason why I should not modify the menus, to work this way??

Thank you in advance.

--George

George France,      [email-masked]
Cambridge Research Laboratory, Compaq Computer Corporation
One Kendall Square, Building 700     MS: CRL
Cambridge, MA 02139 USA

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Mon, 6 Mar 2000 21:50:10 +0000 (GMT)

> Is there any reason why I should not modify the menus, to work this way??

Yes.  SA-110 is not a system type.  There are clearly three different SA-110
systems out there, each with its own unique properties:

1. Acorn RiscPC
2. EBSA-110
3. Footbridge-based PCI

Don't forget that in some cases, machines may have a SA-110 in, or they may
have an ARM610 or ARM710.  Therefore, there is no such thing as a generic
"SA-110" machine.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.linux.org.uk/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |