Subject: Building arm toolchain problem

From: [email-masked]
Date: 22 Feb 2000 06:14:09 -0800

Dear All:

I have problem on building arm tool chain!!

I use the following source, kernel 2.2.14, gcc-2.95.2, 
glibc-2.1.2, binutils-2.9.5.0.27.

I followed the processed proposed by Chris Rutter (Thank you, Chris),
except that I can not find the suitable patch for gcc 2.95.2 and
binutils-2.9.5.0.27.

The gcc and binutils are normally built.
However, when I build the glibc, the make process is out with this error 
"/usr/local/arm/bin/ld: unrecognized emulation mode: elf32arm
Supported emulations: armelf_linux armelf_linux26 armelf"

Could anyone tell me why?

Thanks
 
kirk

_______________________________________________________________
http://www.SINA.com - #1 Destination Site for Chinese Worldwide

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: [email-masked]
Date: 22 Feb 2000 23:09:39 -0800

> George France from the cross-gcc mailing list sent me this hack after I
> stumbled onto this problem:
> 
> Use your favorite editor to modify the gcc file 'specs', to get the correct
> behaviour from gcc, amend the *link section of your specs file as follows:
> 
> *link:
> %{h*} %{version:-v}    %{b} %{Wl,*:%*}    %{static:-Bstatic}
> %{shared:-shared
> }    %{symbolic:-Bsymbolic}    %{rdynamic:-export-dynamic}
> %{!dynamic-linker:
> -dynamic-linker /lib/ld-linux.so.2}    -X    %{mbig-endian:-EB}
> %{mapcs-26:-m ar
> 2)	melf_linux26} %{!mapcs-26:-m armelf_linux} -p
 
  It works!! 
  Thanks a lot!
  However, now I encountered another error on building glibc.
  When it starts to build libdb1.so, arm-linux-gcc just lists
  many "multiple definition of __(variable name like __dummy
  , __gcc_bcmp ...etc)" messages.
  And says that these variables are first defined in libgcc.a !!

  What happened!!?? How shoud I do to avoid these errors??

  Thanks!

  kirk