Subject: memory violation problem in EBSA-285 like board

From: hmlee <[email-masked]>
Date: Fri, 14 Jan 2000 21:55:22 +0900

Hi!
We made a arm-linux system with sa-110 + dc21285 + via82C686(super i/o).

We are using a bios-1.05 version to loading the kernel in flash memory.
The flash memory contains bios-1.05+kernel.
The bios copies zImage to 0x8000 and jump there to running it.
I was compiled with CONFIG_EBSA285 options in kernel config time with
some patch in head-armv.S for debug.
The kernel was running and mounted to root filesystem in
harddisk(/dev/hda1).
We are using a dm-3.0-14beta.tar.gz for making filesystem in /dev/hda1.
The dm-3.0-14beta.tar.gz was untared in /dev/hda1 and connected to our
arm-linux system.
The harddisk has a
    /dev/hda1    linux(ext2 root filesystem)
    /dev/hda2    linux
    /dev/hda3    linux swap

But "memory violation" occured as follows:

Linux version 2.2.13-rmk2 ([email-masked]) (gcc version egcs-2.91.66
19990325/philb (egcs-1.1.2 release)) #104 Fri Jan 14 20:47:10 EST 2000
<4>NetWinder Floating Point Emulator V0.94.1 (c) 1998 Corel Computer
Corp.
PIC Installed Correctly !!
Console: colour VGA+ 80x25

Calibrating delay loop... 4.63 BogoMIPS                <=========  Why ?

Memory: 14848k/16M available (1092k code, 20k reserved, 408k data, 16k
init)
<5>VFS: Diskquotas version dquot_6.4.0 initialized
POSIX conformance testing by UNIFIX
SA110_Control = 0x84aac201
<7>PCI: DEC21285 revision 04
PCI: Probing PCI hardware
<7>PCI: master abort pc=[<C00152A8>]
<7>PCI: parity error data parity error pc=[<C0015328>]
<3>IRQ LOCK: IRQ31 is locking the system, disabled
<7>PCI: 00:38 [102c/00e0] on irq 21
<7>PCI: 00:40 [1106/0686] on irq 24
<7>PCI: 00:41 [1106/0571] on irq 14
<7>PCI: 00:42 [1106/3038] on irq 22
<7>PCI: 00:44 [1106/3057] on irq 22
<6>Linux NET4.0 for Linux 2.2
<6>Based upon Swansea University Computer Society NET3.039
<6>NET4: Unix domain sockets 1.0 for Linux NET4.0.
<6>NET4: Linux TCP/IP 1.0 for NET4.0
<6>IP Protocols: ICMP, UDP, TCP
Starting kswapd v 1.5
<6>parport0: PC-style at 0x3bc [SPP]
<6>parport1: PC-style at 0x378 [SPP]
<6>parport2: PC-style at 0x278 [SPP]
<6>Detected PS/2 Mouse Port.
<6>Serial driver version 4.27 with MANY_PORTS SHARE_IRQ DETECT_IRQ
enabled
Software Watchdog Timer: 0.05, timer margin: 60 sec
<6>Real Time Clock Driver v1.09
RAM disk driver initialized:  16 RAM disks of 4096K size
<6>loop: registered device at major 7
VP_IDE: IDE controller on PCI bus 00 dev 41
VP_IDE: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xe800-0xe807, BIOS settings: hda:pio, hdb:pio
ide0: VIA Bus-Master (U)DMA Timing Config Success
probing for hda: present=0, media=32, probetype=ATA
hda: FUJITSU MPD3084AT, ATA DISK drive
probing for hdb: present=0, media=32, probetype=ATA
probing for hdb: present=0, media=32, probetype=ATAPI
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
<6>hda: FUJITSU MPD3084AT, 8063MB w/512kB Cache, CHS=16383/16/63
<6>Floppy drive(s): fd0 is 1.44M, fd1 is 1.44M
floppy0: Unable to grab DMA2 for the floppy driver
md driver 0.36.6 MAX_MD_DEV=4, MAX_REAL=8
<6>3c59x.c:v0.99H 11/17/98 Donald Becker
http://cesdis.gsfc.nasa.gov/linux/drivers/vortex.html
<6>Partition check:
<6> hda: [PTBL] [1027/255/63] hda1 hda2 hda3
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 16k init
sh: memory violation at pc=0xe59cf000, lr=0x40004b9c (bad
address=0xe59cf000, code 3)
sh: memory violation at pc=0xe59cf000, lr=0x40004b9c (bad
address=0xe59cf000, code 3)
sh: memory violation at pc=0xe59cf000, lr=0x40004b9c (bad
address=0xe59cf000, code 3)
sh: memory violation at pc=0xe59cf000, lr=0x40004b9c (bad
address=0xe59cf000, code 3)
sh: memory violation at pc=0xe59cf000, lr=0x40004b9c (bad
address=0xe59cf000, code 3)
.....

Please help me!
If I could incorrectlly, tell me.

email : [email-masked]

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Fri, 14 Jan 2000 19:29:24 +0000 (GMT)

> unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.linux.org.uk/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Fri, 14 Jan 2000 19:33:11 +0000 (GMT)

I'll try again, this time remembering to answer elm 2.5 questions, rather
than elm 2.4 questions!

hmlee writes:
>...
>...

Sounds like the interrupt rate is too fast for some reason.  Can you check
you are only getting timer interrupts at 100Hz?

> <3>IRQ LOCK: IRQ31 is locking the system, disabled

Whoooops!  This is really really bad.  It appears that you are getting

> address=0xe59cf000, code 3)

this could well be a result of it as well.
   _____