Subject: "lost interrupt"

From: hmlee <[email-masked]>
Date: Thu, 16 Dec 1999 21:32:36 +0900

Hi all !
I have a problem to running  an armlinux.
We made a system as follows:
    - sa-110
    - DC21285 ( PCI Arbitor mode )
    - VIA82C686 ( South Bridge )
    - Keyboard, Mouse etc..
    - Linux-2.2.12 with rmk1
    - Chips 64550 (vga)
    - bios-1.05 with some change ( to start at 0x0000 address)

I had download image to rom emulator and run it.
Following messages shown.
Help me!
What is the mean of the "lost interrupt".
Please tell me what is occurred.

Uncompressing Linux...done.
Now booting the kernel
Linux version 2.2.12-rmk1 ([email-masked]) (gcc version egcs-2.91.66
19990325/philb (egcs-1.1.2 release)) #58 Thu Dec 16 21:07:16 EST 1999
<4>NetWinder Floating Point Emulator V0.94.1 (c) 1998 Corel Computer
Corp.
Console: colour VGA+ 80x25
Calibrating delay loop... 4.60 BogoMIPS
Memory: 14796k/16M available (1136k code, 20k reserved, 416k data, 16k
init)
POSIX conformance testing by UNIFIX
<7>PCI: DEC21285 revision 04
PCI: Probing PCI hardware
<7>PCI: master abort pc=[<C001587C>]
<7>PCI: [1106:0686] status = 2200
<3>IRQ LOCK: IRQ31 is locking the system, disabled
<7>PCI: 00:38 [102c/00e0] on irq 21
<7>PCI: 00:40 [1106/0686] on irq 24
<7>PCI: 00:41 [1106/0571] on irq 14
<7>PCI: 00:42 [1106/3038] on irq 22
<7>PCI: 00:43 [1106/3038] on irq 22
<7>PCI: 00:44 [1106/3057] on irq 22
<7>PCI: 00:48 [10b7/5950] on irq 22
<6>Linux NET4.0 for Linux 2.2
<6>Based upon Swansea University Computer Society NET3.039
<6>NET4: Unix domain sockets 1.0 for Linux NET4.0.
<6>NET4: Linux TCP/IP 1.0 for NET4.0
<6>IP Protocols: ICMP, UDP, TCP
Starting kswapd v 1.5
<6>parport0: PC-style at 0x3bc [SPP]
<6>parport1: PC-style at 0x378 [SPP]
<6>parport2: PC-style at 0x278 [SPP]
<6>Serial driver version 4.27 with MANY_PORTS SHARE_IRQ DETECT_IRQ
enabled
Software Watchdog Timer: 0.05, timer margin: 60 sec
<6>Real Time Clock Driver v1.09
RAM disk driver initialized:  16 RAM disks of 4096K size
<6>loop: registered device at major 7
VP_IDE: IDE controller on PCI bus 00 dev 41
VP_IDE: 100% native mode on irq 14
    ide0: BM-DMA at 0xe800-0xe807, BIOS settings: hda:pio, hdb:pio
ide0: VIA Bus-Master (U)DMA Timing Config Success
hda: UUIISS PP3388AA, ATA DISK drive        <---- Crashaed.(Fujitsu 8.4G
hard disk)
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
<6>hda: UUIISS PP3388AA, 32255MB w/0kB Cache, CHS=65535/16/63
<6>Floppy drive(s): fd0 is 1.44M, fd1 is 1.44M
floppy0: Unable to grab DMA2 for the floppy driver
<6>3c59x.c:v0.99H 11/17/98 Donald Becker
http://cesdis.gsfc.nasa.gov/linux/drivers/vortex.html
<6>eth0: 3Com 3c595 Vortex 100baseTx at 0x8000,  00:a0:24:71:d1:03, IRQ
22
<6>  8K byte-wide RAM 5:3 Rx:Tx split, 10baseT interface.
<6>eth0: Overriding PCI latency timer (CFLT) setting of 32, new value is
248.
<6>Partition check:
<6> hda:hda: lost interrupt
hda: lost interrupt            <---- What ?
hda: lost interrupt
hda: lost interrupt
hda: read_intr: status=0x50 { DriveReady SeekComplete }
hda: lost interrupt
 unknown partition table
VFS: Cannot open root device 00:00
<0>Kernel panic: VFS: Unable to mount root fs on 00:00

email : [email-masked]

tel : 822-402-6844
fax: 822-3432-6844

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: Benjamin Herrenschmidt <[email-masked]>
Date: Thu, 16 Dec 1999 15:52:23 +0100

><0>Kernel panic: VFS: Unable to mount root fs on 00:00

There are several possible causes to this problem:

 1- Incorrect configuration of the interrupts. Make sure you adapted the
VIA driver correctly to find the interrupt yu actually wired on your
board, or that you correctly filled the PCI config interrupt number.

 2- Make sure the interrupt code handles correctly the cascade (did you
actually use a cascaded interrupt controller ? I don't know if the VIA
contains one, most southbridges do)

 3- Do not use IDE DMA transfers (I mean WIN_DMAREAD/WIN_DMAWRITE
commands, not real bus mastering) unless you have done the appropriate
IDE SET_FEATURE to the hard disk and correctly programmed the VIA
timings. If you interrupt routing and PIC configuration is correct, this
error usually means that there is a mismatch between the drive IDE timing
configuration (PIO mode, DMA mode, ...) and the timings programmed in the
IDE controller. Usually, most recent drives cope quite well with weird
PIO timings but not with weird DMA timings.

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Thu, 16 Dec 1999 22:52:09 +0000 (GMT)

> Linux version 2.2.12-rmk1 ([email-masked]) (gcc version egcs-2.91.66

2.2.12 is rather old now - you should upgrade to 2.2.13.

> <3>IRQ LOCK: IRQ31 is locking the system, disabled

Oops, looks like the PCI error interrupt (assuming that it is still IRQ31)
is going permanently active.  Check PCI bus connections.

> hda: UUIISS PP3388AA, ATA DISK drive        <---- Crashaed.(Fujitsu 8.4G

The name looks wrong - check the PCI data bus, byte enables, and the IDE
interface connections.  It looks like the data on d0-d7 is being replicated

> hda: read_intr: status=0x50 { DriveReady SeekComplete }

I'd suggest an in-depth look at your hardware.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.linux.org.uk/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |