Subject: insmod wont

From: "Paul Robertson" <[email-masked]>
Date: Tue, 23 Nov 1999 12:31:02 -0000

I can't get insmod to insert a module into my ARM linux kernel.

The kernel is 2.2.13 built with CONFIG_MODULES and CONFIG_MODVERSIONS defined.
The module is a do-nothing "hello world" module which implements init_module and cleanup_module calling printk. (The printk version matches the kernel).
Insmod is version 2.0.0

Insmod reports "/lib/modules/misc/hello.o not an object file"
file /lib/modules/misc/hello.o reports ELF 32-bit LSB relocatable, ARM, version 1, not stripped

Can anyone help?

Thanks,

Paul Robertson
LocSoft Limited
"The key to your embedded solutions"
www.locsoft.com
Phone +44 (0) 1793 432557 
Fax     +44 (0) 1793 432727

---

From: Russell King - ARM Linux Admin <[email-masked]>
Date: Wed, 24 Nov 1999 10:02:01 +0000 (GMT)

Paul Robertson writes:
> The kernel is 2.2.13 built with CONFIG_MODULES and CONFIG_MODVERSIONS =
> defined.
> The module is a do-nothing "hello world" module which implements =
> init_module and cleanup_module calling printk. (The printk version =
> matches the kernel).
> Insmod is version 2.0.0
> 
> file /lib/modules/misc/hello.o reports ELF 32-bit LSB relocatable, ARM, =
> version 1, not stripped

Have you updated your module utilities to a version which supports ELF?
The original insmod utilities do not understand the ELF binary format.
   _____
  |_____| ------------------------------------------------- ---+---+-
  |   |        Russell King       [email-masked]      --- ---
  | | | |  http://www.arm.linux.org.uk/~rmk/armlinux.html    /  /  |
  | +-+-+                                                     --- -+-
  /   |               THE developer of ARM Linux              |+| /|\
 /  | | |                                                     ---  |
    +-+-+ -------------------------------------------------  /\\\  |

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]