Subject: Re: Adress of rd_start/initrd_start on EBSA285

From: Gaixia Zhang <[email-masked]>
Date: Sun, 21 Nov 1999 18:11:33 -0600

Maybe you can try this one: ftp://ftp.netwinder.org/users/n/nico/
But I didn't see big difference. Actually, the one you are using
works fine on my EBSA285 as a NFS root,

I am thnking about building my own ramdisk based on Netwinder's
2.2 disk image (huge one), but I am not sure I will have time,

Best wishes,
Gaixia

Paul Robertson wrote:

> Gaixia wrote:
>
> >Hi,
> >
> >I am trying to get a ramdisk for ARM-Linux on EBSA285. I ran into the
> >following
> >questions: What is the virtual address I should give to rd_start in the
> >param page?
> >and What is the physical address I should load the ramdisk image?
> >
> >How about initrd_start?
> >
> >I can only find 4200 0000 mapped to fe00 0000 and some others in
> >hardware.h,
> >Where could I get the related information for ramdisk?
>
> I have the same problem, plus some others...
>
> Where did you get your ramdisk image?
>
> I can't remember where I got mine, only that I tried
> ftp://ssdl-redstone.stanford.edu/pub/ramdisk.gz
> unsuccessfully
>
> My ARM-Linux kernel successfully mounts this ramdisk image as a NFS on
> another machine, but then crashes when it tries to execute /sbin/init
>
> Paul Robertson
> LocSoft Limited
> "The key to your embedded solutions"
> www.locsoft.com
> Phone +44 (0) 1793 432557
> Fax     +44 (0) 1793 432727

__________________________________________
NetZero - Defenders of the Free World
Get your FREE Internet Access and Email at
http://www.netzero.net/download/index.html

unsubscribe: body of `unsubscribe linux-arm-kernel' to [email-masked]

---

From: David Sean Friedman <[email-masked]>
Date: Wed, 24 Nov 1999 12:32:07 -0500 (EST)

Excerpts from arm-linux: 21-Nov-99 Re: Adress of rd_start/init.. by
Gaixia [email-masked] 
> 2.2 disk image (huge one), but I am not sure I will have time,
I built a ramdisk from the netwinder distro a few months ago. I planned
to use the full disk image, but I found a rescue image on the netwinder
site which had almost everything I needed. Try
http://www.netwinder.org/allmisc.html, and look for files named rescue
(I don't remember which one I used).

David Friedman
Carnegie Mellon